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Dear Reader

Thank you for choosing Mastering InDesign CS3 for Print Design and Production. This book is part of
a family of premium quality Sybex books, all written by outstanding authors who combine practi-
cal experience with a gift for teaching.

Sybex was founded in 1976. More than 30 years later, we're still committed to producing con-
sistently exceptional books. With each of our titles we’re working hard to set a new standard for
the industry. From the paper we print on to the authors we work with, our goal is to bring you the
best books available.

I'hope you see all that reflected in these pages. I'd be very interested to hear your comments
and get your feedback on how we’re doing. Feel free to let me know what you think about this or
any other Sybex book by sending me an email at nedde@wiley.com, or if you think you've found a
technical error in this book, please visit http: //sybex. custhelp.com. Customer feedback is critical
to our efforts at Sybex.

Best regards,

7 /D/%Z

Neil Edde
Vice President and Publisher
Sybex, an Imprint of Wiley
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Introduction

Creativity. It’s one of my favorite words of all time, a word I utter with reverence. Efficiency,
another of my favorite words. Combining the two—creative efficiency—describes what I consider
the single most venerated concept in the whole of professional creative industries. Creative effi-
ciency. It means freedom—freedom to be imaginative and experimental in your design as well as
freedom from as many of the time-consuming, distracting, unproductive mechanical steps you
need to take to achieve a design as possible. It’s a doctrine of sorts, one that I hold sacred, one that
I preach from pulpits of wood, metal, plastic, pixels, and, like this one, pulp. As an ideal, creative
efficiency is about making every task, every flick of the mouse or stroke of the keyboard, forward
movement in the progression toward a finished design. Its ultimate goal is directing every move-
ment and every thought toward the design, not toward the tools or processes we must employ to
construct a design.

We graphic designers and press and pre-press operators enjoyed creative efficiency once, not
too long ago, in a way our cousins on the sidewalks of public markets and beach boardwalks enjoy
still. A painter, working in oil, acrylic, gauche, pastel, or watercolor, has creative efficiency. Every
stroke of the brush, whether on the canvas or mixing a color on the palette, is active, forward
motion toward the completion of the art on the canvas. When illustrators” hands bore more cal-
luses induced by the smooth plastic pipes of Rapidographs and lacquered wood of Prismacolor
pencils than by mice and styluses, when pre-pressmen’s shoulders bent over X-Acto, Rubylithe,
and Zip-A-Tone instead of over QWERTY, Logitech, and Wacom, we enjoyed creative efficiency.
With a page before us, few of our motions and thoughts did not directly contribute to the final
design. Now, however, in the age of InDesign, Photoshop, and Illustrator, with creative horizons
wider than any even we of limitless imaginations had ever conceived possible, we have lost cre-
ative efficiency. Too much of our time is now spent thinking about the tools of our trade, about
how to use them to achieve a design. We still have our creativity, but we have been foiled in our
pursuit of creating productively and efficiently. Indeed, too often the creativity itself is handi-
capped by the increasing amount of time and thought devoted to divining the mysteries of the
tool, and often failing to find the means by which the tool wants us to do something, we compro-
mise the design.

This book is about helping you achieve creative efficiency within InDesign CS3. It is not for
the beginning InDesign user, although professional users proficient with previous versions of
InDesign will find in this book what they need to translate their prowess in InDesign 2, CS, or
CS2 into the new CS3. Ultimately, this book is for those who can already produce projects in
InDesign but who want to know how to increase their productivity, to produce those projects
faster, better, more easily, and most of all, more creatively. This book is about helping you
achieve—or regain—creative efficiency.

Hallelujah, brothers and sisters in the Fellowship of Ink on Paper. Hallelujah!



XVl

INTRODUCTION

What You Need

Naturally, you need your copy of InDesign CS3, but it would also be helpful to call on a colleague
who also has InDesign CS3 to look over the results of the self-test Master It exercises in this book.
Moreover, several of the exercises are built around collaboration techniques and teamwork, so if
you can work with someone else using InDesign, it would be a big help.

If you work with editorial personnel at all, get hold of InCopy CS3—even if it’s just the free
30-day trial version from Adobe.com. In Chapter 12, “Collaborating,” we'll talk quite a bit about
InCopy and how integrating it into your workflow takes the responsibility of copyediting and
those endless changes completely out of your hands and puts it back in the editorial department
where it belongs. With InCopy on your computer, you'll be able to gain a better understanding of
just how easy and important it is to return control of editorial content to the editorial department.

Once in a while over the following pages, we'll slip out of InDesign and into other tools of the
trade. Although not required, for some portions of the book it would be helpful if you had access
to recent versions of Acrobat, Photoshop, and Illustrator. Adobe offers fully functional 30-day trial
versions of those, too, if you need to download them.

You'll probably want to don your sense of humor, too. Some of my jokes will admittedly strike
you as lame. That’s OK because I believe in the philosophy that if you just keep shooting spitballs
toward the front of the class, you'll eventually hit the intended target (the teacher). There are enough
jokes, quips, and innuendos in this book that at least some of them will be funny—as long as you
start out with a sense of humor. If you just haven’t got one, well, interspersed between the humor
are a few tidbits of good information, case studies, and advice, too.

The Mastering Series

The Mastering series from Sybex provides outstanding instruction for readers with intermediate
and advanced skills in the form of top-notch training and development for those already working
in their field and clear, serious education for those aspiring to become pros. Every Mastering book
features:

¢ The Sybex “by professionals for professionals” commitment. Mastering authors are them-
selves practitioners, with plenty of credentials in their areas of specialty.

¢ A practical perspective for a reader who already knows the basics—someone who needs
solutions, not a primer.

¢ Real-World Scenarios, ranging from case studies to interviews, that show how the tool,
technique, or knowledge presented is applied in actual practice.

¢ Skill-based instruction, with chapters organized around real tasks rather than abstract con-
cepts or subjects.

¢ Self-review test “Master It” problems and questions, so you can be certain you're equipped
to do the job right.

What Is Covered in This Book

Mastering InDesign CS3 for Print Design and Production is organized a little differently than most
computer books. First, you'll notice that there are only 12 chapters. That'’s it. Twelve. A dozen. Effi-
ciency starts at home, they say.... Well, they don’t really say that, but they should. Each chapter
title is a single word, and the chapter is all about that word. Chapter 10, “Output,” for example, is
about printing, preflighting, packaging, soft proofing, color management (in the context of getting
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good color into and then out of InDesign), trapping, and mixed inks. And, those topics are covered
entirely in that chapter. You won't have to stick your pinky in the index and jump all around the
book reading a paragraph here, a page and a half there, another paragraph over here just to piece
together complete information about one topic. Go on. Compare this book’s index to any other
InDesign CS3 book on your shelf. How many page numbers are listed for a given topic in each
index? The more page numbers, the more you'll be flipping hither and yon to get what is, in large
part, the same information as this book puts in one place, in one contiguous discussion. Of course,
this book goes deeper into the topics and level experienced pros need. In this book, you also won't
have to weed through the beginner level, intro to InDesign stuff either—this is the first InDesign
book written by a print design and press professional for print design and press professionals.
Here’s a brief synopsis of what you'll find in each chapter:

Chapter 1: Customizing In order to have creative efficiency, you must minimize the impact
of your tools on the process of creating. That requires modification of tools: making InDesign
work as you do as much as possible. How you customize InDesign directly affects how effi-
ciently you use this page-layout application to learn and use anything else you might read in
this volume. Customizing InDesign shifts that dividing line between the software working for
you and you working for the software further toward the former.

Chapter 2: Text InDesign operates on a content-to-container premise. Everything within
InDesign is either content—text and imagery—or a container to hold text, imagery, or another
container. At the lowest level, the pasteboard is a container that holds everything you might
place in InDesign. Then there are pages and layers—more containers—and then the real content
enters the picture—text and imagery. In this chapter, you will learn to create and fill text frames,
format text frames, format paragraphs, compose paragraphs, and use paragraph rules for
organization and special effects.

Chapter 3: Characters InDesign is the world’s most advanced typesetting platform. In fact,
type set in InDesign is almost as good as type set on a letterpress. The few sacrifices you make
by setting type in InDesign instead of in lead tend to be balanced by the time savings—you can
set much faster than one page every four hours—and by the lack of ink perpetually embedded
under your nails. This chapter is a deep dive into working with characters. In this chapter, you
will learn to format characters, transform characters, insert special characters, work with Open-
Type font features, and use the Glyphs panel.

Chapter 4: Drawing InDesign is not Illustrator, and it never will be. Fortunately, however, the
Mustrator team happily shares its code with the InDesign team. Consequently, many of the
most common drawing tasks can be done directly within InDesign, without the need to load up
Mlustrator and then move artwork from it into InDesign. It’s a matter of efficient creativity—
those two words again! In this chapter, you will learn to draw precise paths with the pen tool,
freehand draw paths with the pencil tool, combine and subtract shapes and convert from

one shape to another, modify any vector artwork, and turn type into a container to hold
images or text.

Chapter 5: Images InDesign’s greatest strength is its type-handling and type-rendering fea-
tures. Fortunately, it’s just as good with imagery—especially in CS3—as you’ll learn when we
place image assets, import images without place, manage placed assets, and go native in your
workflow.

Chapter 6: Objects If there’s a “coolest subject” in this book, this chapter contains most sub-
jects that would fit the description—at least, from a standpoint of creativity and creative pro-
ductivity. As with drawing in InDesign, the name of the game when applying transparency
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and effects to objects is efficiency through doing as much as possible within InDesign; it’s about
resorting as infrequently as possible to creating objects in Photoshop or Illustrator. This chapter
will teach you to use attribute-level transparency and object effects, design custom stroke
styles, create mixed-ink swatches, manage and share swatches, work with anchored objects, set
type on a path, step and repeat, and transform again.

Chapter 7: Pages Pages are the foundation of every document in InDesign. How they’re created,
modified, and managed directly affects their ability to print, their fitness to purpose. InDesign has
always offered tremendous ease in working with pages, and the options and control over pages
has improved with each successive release. In InDesign CS3, a large portion of the new features
and refinements of existing features is centered around the Pages panel and controlling pages.
In this chapter, you will learn to create pages with bleed, slug, and live areas; manage pages in
and between InDesign documents; and master master pages.

Chapter 8: Stories Once you've mastered setting and styling type on a page, it’s time to think
about writing, editing, and flowing text across multiple pages. It’s time to think about stories.
In this chapter, you will learn to thread and unthread text frames and flow text; create bulleted
and numbered lists; write and word process in InDesign; and fix, find, and change text.

Chapter 9: Documents Working with documents involves knowing how to move around in
them, change viewing options, and compare views. Working with longer documents efficiently
means mastering InDesign’s unique long-document features such as indexing, creating tables
of contents, and working within the timesaving and collaboration-ready atmosphere of book
files. In this chapter, you will learn to interact with documents visually to change zoom level,
view modes, and display performance; build and manage grids and guides; create and manage
book files; index terms and create an index; and create a table of contents.

Chapter 10: Output At the end of the day;, it’s all about printing. Everything we do in InDesign
leads up to that defining moment when we watch, with breath held, as the job rolls off the
press. In this chapter, we get into what happens after design, into the ramp-up for and, ulti-
mately, the execution of outputting a job, including configuring color management on docu-
ments and images; soft proofing documents to screen; and preflighting, packaging, and
outputing to print with managed inks and trapping.

Chapter 11: Efficiency Professional creatives have deadlines, budgets, and (sometimes) even
personal lives to get to. In this chapter, the focus is on getting the job done expeditiously, pro-
ductively, and without sacrificing quality or creativity. You will learn to work efficiently with
text, tables, and objects.

Chapter 12: Collaborating Few InDesign users operate in a vacuum, creating documents start
to finish all on their own. The majority of modern workflows, even among freelancers, entails
some form of collaborative content creation. This chapter starts with the collaboration features
offered by InDesign CS3 and then moves into the when, why, and how of saving, reusing, and
sharing project consistency presets; collaborating with editorial personnel through the InDesign-
InCopy LiveEdit Workflow; and breaking the 1-document:1-designer and 1-page:1-designer lim-
itations to effect genuine production team collaboration with the Book File Collaboration
Workflow and the author’s original Placed Page Collaboration Workflow.

The Appendix gathers together all the Master It exercises from the chapters and provides a
solution and description for the expected results from each.
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Downloading Companion Files

The book’s download page is home to samples and resource files mentioned in the book. In addi-
tion, you'll also find the tryout version of the Page Control plug-in discussed in Chapter 7, “Pages.”
Both Windows and Mac OS X versions of the plug-in are included among the files available on the
book’s download page at http://www.sybex.com/go/MasteringInDesign.

How to Contact the Author

This book came about largely because people like you asked me for it. Most of my articles, e-seminars,
conference sessions, and other projects get started the same way—someone tells me about a need
or asks me a question. So, if you have a question or would like to see me cover another topic—in a
printed book, e-book, article, or somehow—please drop me a line. I can’t guarantee I'll write, record,
or speak about the topic you suggest, but I promise to consider doing so. At the very least I'll reply
to your email.

Even if you don’t have a question or book topic in mind, I'd sincerely love to hear about how
well my book worked (or didn’t) for you, about your experiences trying the techniques and advice
it contains, or any other feedback you may have about this book, whether unadulterated adulation
or scathing but constructive criticism. No threats of bodily harm or marriage proposals, though,
please.

Please feel free to drop me a line any time at MasteringInD@iampariah.com.

Want to go beyond this book and have me analyze and optimize your unique workflow and
train your team in person? Please visit www.WorkflowCreative.com.

To read more of my writing about InDesign and InCopy, please visit www.QuarkVSInDesign.com.

To read my articles (and those of others) about everything else in the wide world of design,
production, press, and this business of creating, please visit www.Designorati.com.

Sybex strives to keep you supplied with the latest tools and information you need for your
work. Please check its website at www. sybex . com, where we'll post additional content and updates
that supplement this book if the need arises. Enter the search terms “InDesign,” “Burke,” or the
book’s ISBN (9780470114568) and click Go to get to the book’s update page.
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Chapter 1
Customizing

“Creative efficiency.” If you read the refreshingly short introduction a few pages previous, you
know that I believe the phrase “creative efficiency” to be among the most important ideals of our
profession of designing for, or placing, ink on paper. To realize your creative potential, to enable
the creatives working under you to realize their creative potential, you must minimize the impact
of your tools on the process of creating. Accomplishing that requires modifying tools like InDesign,
making them emulate how you work as much as possible. Software—computers in general—are
far from the point where they will truly work the way humans work, the way humans think. We
are still forced to conform our methodologies and thinking processes to fit within the narrow
boxes sitting under our desks—to a point. Whenever possible—and, with InDesign CS3, much is

possible—customize the software to fit your work and preferences as closely as you can.

While the idea of rearranging palettes or modifying menus may seem superfluous compared
with other topics in this book, I've placed this chapter first because, ultimately, how you customize
InDesign directly affects how efficiently you use the page layout application to learn and use any-
thing else you might read in this volume.

Customizing InDesign shifts that dividing line between the software working for you and you
working for the software further toward the former.

In this chapter, you will learn to:

¢ Organize panels and use the new panel docks

Customize keyboard shortcuts

& Customize and color-code menus

¢ Remove parts of InDesign to create lean, workflow-specific installations

¢ Change the default font, colors, and more

¢ Carry your personalized InDesign work environment in your pocket or on your iPod
Panels

Ever since April 2005, when Adobe and Macromedia announced their intent to merge, users of
InDesign or any of either company’s products have speculated about the user interface that would
result from combining two of the most acclaimed user interface design teams in the business.
Creative Suite 3 is that result—the New Adobe Ul—and it’s highly customizable.
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No longer constricted by the settlement terms of lawsuits lost against one another in the late
Nineties and early Oughties, the newly joined Adobe and Macromedia are free to make use of the
best user interface innovations from both companies. The freedom of Adobe applications’ floating
palettes and Macromedia applications’ cleanly organized, nonfloating panel bars have converged
in Creative Suite 3 to create more choices in workspace arrangement than any application has ever
offered. To reflect the change, palettes are now called panels, and they can be free-floating, tabbed,
stacked, grouped together into vertical panel bars a la Macromedia applications, and condensed
into narrow icon and title tiles. Given the fact that InDesign CS3 has an unprecedented 41 panels,
you'll likely employ several panel arrangement forms concurrently.

Hands down, the most efficient way to organize the InDesign workspace is across dual moni-
tors—preferably monitors of the same size and resolution. Although the vast majority of users
don’t need all 41 panels opened at once, many panels—such as Layers, Pages, Swatches, Naviga-
tor, Index, Hyperlinks, Scripts, Links, and the five styles panels—tend to grow in utility and con-
venience according to their heights (or height and width in the case of the Navigator panel). The
more space you give such panels, the less scrolling you'll have to do, which means the faster you
can access the layer, page, swatch, style, or whatever it is you need. On my primary production
computer, I use two monitors, with the left containing the InDesign application itself and the Con-
trol and Tools panels and the right completely filled with all other panels. Of course, not even an
entire monitor can contain all 41 panels simultaneously—not expanded panels, anyway. Maybe if
you ran three monitors...

The point is, Adobe knows that InDesign is a forest of panels. The vast majority of the applica-
tion’s functions are contained on panels, which is a far more efficient way of doing it than in dia-
log boxes. Dialog boxes, while open, prohibit accessing the document; to do something to two
objects individually via a dialog box requires more steps than doing it through panels, which are
always onscreen. The downside to panels is, of course, panel bloat.

Below, we’ll go through the various ways Adobe has built into InDesign for organizing panels.
I'll also offer some advice on which ones you can safely keep off your screen.

The Panel Dock

The dock is InDesign’s attempt to organize panels on single-monitor systems where space is at a
premium.

Dragging panels to the side of the application window no longer creates a series of slender, ver-
tical bars as would occur in InDesign CS2 and InCopy CS2; now panels become labeled icons in
the panel dock, a top-to-bottom reserved area of the application window (see Figure 1.1). In some
programs, such as Photoshop and Illustrator, the icons are unlabeled, resulting in a much slimmer
dock (and consequently a wider document working area).

InDesign can have icon-only docks too; they just don’t appear that way in the default workspace.
To slim down an InDesign dock to icon-only mode and reclaim most of the horizontal space for
the working area, drag the triple bars at the top of a dock toward the screen edge (refer back to Fig-
ure 1.1). When you get to within 18 or so pixels of the edge, the dock will snap into icon-only mode.

With Creative Suite 3 and subsequent product releases, Adobe elected to remove the traditional
iconography of InDesign’s butterfly, Illustrator’s flowers, Photoshop’s feathers, and so on. Instead,
it branded nearly all its applications and technologies with color-coded, two-letter signifiers
strongly reminiscent of elements on the periodic table. Although your desktop, Start Menu, or OS
X Dock will be brighter but less visually interesting, the workspaces of Adobe applications them-
selves become a cool cornucopia of grayscale icons—every panel now has its own associated icon
displayed within the application dock. For easy reference, Table 1.1 pairs all the panels with their
associated icons.
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To use a panel in the dock, simply click on its collapsed icon or icon and title. It will expand out
to the side, revealing the entire panel. Collapse it back into the panel either by clicking the double
arrows pointed toward the dock or by clicking on the title tab of the panel.

Only one panel per dock may be extended at once, and by default, the last used panel will
remain extended until you collapse it. If you’d prefer that panels immediately collapse back to
their icon or tile states as soon as you finish with them, right-click on the dark gray dock title or
an empty area of the dock itself and choose Auto-Collapse Icon Panels (you'll also find the same
choice in the Preferences on the Interface pane).

Expand or contract the entire dock, inclusive of all the panels it contains, by clicking on the
double-arrow symbol at the very top of the panel. When the panel is in icon-only or collapsed tile
mode, arrows will point inward, toward the application workspace and away from the edge;
when the panel is collapsed, arrows will point outward toward the edge of the screen. You can
also double-click on the empty, dark title bar of the dock or Cmd-+click/Ctrl+click on it to toggle
between expanded or collapsed states.

Arranging Panels

To add a panel to the default dock, drag the panel’s title tab over the empty area of the dock
beneath the lowest panel. When your cursor is in position, a colored horizontal line will appear
across the dock. Release the mouse button to drop the panel into the dock at that point.

Remove panels from the dock by dragging the title or icon (not the gray bar above them)
out from the dock into the empty application area. When you release the mouse, the panel will
become free floating.

Some panels, you'll notice, are grouped—when you click the title of one to extend it, other
panels are tabbed behind it (see Figure 1.2). These are grouped panels. Collapsed, their grouped
arrangement is indicated by their icons or tiles contained within a light gray rectangle, with a com-
mon gray bar atop them. If you do drag the gray bar away from the dock, youll detach the entire
group of panels. Once detached, they will be a free-floating group of tabbed panels. Grouped pan-
els, both on the dock and free floating, are one-at-a-time views. In other words, if the Character
and Character Styles panels are grouped (as they are in the default workspace), you can view only
one or the other, not both simultaneously.

FIGURE 1.2 ~
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Rearrange panels in the dock by dragging their icons or tiles vertically. A horizontal line will
indicate the new location of the panel should you drop it. A rule between the panel groups, in the
dark area of the dock background, will reposition the panel or group to that point outside of other
groups. Dropping it within the area of a group of icons or tiles, however, will add the panel to the
group. Dragging the gray bar of a grouped set of panels will reposition the entire group or merge
it into an existing group.

InDesign can actually contain docks on both sides of the application window and can have mul-
tiple columns of panels arranged side by side in the dock. Just as with adding panels to the default
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right-side dock, creating and managing side-by-side docks is done by dragging. Begin by creating
the first dock, and then drag another panel (or panel group) to the screen edge. Bypass the horizontal
line indicating that the new panel will appear below the one already there, and keep going to the
screen edge, whereupon a vertical line will appear. When you let go, the previous dock area will be
pushed inward, with the new panel forming a column on the outside. You can keep going, adding
columns as you like, but only within the application window. If the dock expands so far that it
reaches the other side of the window, panels will begin to automatically collapse into their labeled
icon tiles.

Stacked Panels

Detached or free-floating panels have similar arrangement options. Drag the tab of one panel atop
another free-floating panel or group of panels to group them into tabs. When your cursor is in
position, a bold outline will appear all the way around the target panel. If you drag too close to
the bottom of another panel, you'll see a horizontal line appear only there, indicating that the
panels will stack rather than group (see Figure 1.3).
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Stacked panels work similarly to docked panels, but with several distinct advantages. You can
see and work with multiple panels at once just as you would free-floating panels, and they aren’t
limited to positioning at the screen edge. Like docked panels, stacked panels can be expanded or
contracted into just their tabs selectively, or an entire stack can be expanded or contracted with a
single click of the mouse.

At the top of a stack is a single minimize/maximize button. Clicking it contracts all panels in
the stack into their title tabs or expands them all. A single close button also hides the entire stack.
When you move a stack by dragging the very top, all the panels move with it.

Some panels—the Pages or Swatches panels, for instance—are resizable. Within a stack, they
can be resized by hovering the cursor along their bottom edges, at the point where they join the
next panel down, and dragging up or down. The cursor will become a double-headed arrow as a
visual cue.

Multi-State Panels

Many panels have expanded views with additional options, controls, or fields hidden by default.
Switch between the compact and expanded views by choosing Show Options or Hide Options
from the panel flyout menus. As we deal with each panel’s expanded controls throughout the rest
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of the book, I'll usually remind you to show the expanded view. However, since this book is writ-
ten as a focused manual for using InDesign in professional print workflows rather than as a soup-
to-nuts InDesign CS3 reference book, some panels won’t even be mentioned in later chapters.
Always check for the Show Options command on a panel’s flyout menu.

Another way to discern if a given panel has multiple states is the presence of double arrows
in the title tab (see Figure 1.4). Clicking on the arrows cycles through the states of any palette—
condensed, expanded, and minimized. Double-clicking the title tab of the panel itself accomplishes
the same state cycling as clicking the arrows.
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The Tools Panel

You'll use the Tools panel more than any other. All your tools are there, as are basic fill and stroke
color controls and preview modes. In Figure 1.5, I've identified each of the tool icons and different
parts in an exploded view of the Tools panel.
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Customization options for the Tools panel are limited to two choices: whether its docked or free
floating and how its tools are arranged—in the traditional two-column array, in one tall long col-
umn, or as a single row (see Figure 1.6).
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The first option, docked or floating, is set in the same manner as any other panel—drag it
toward or away from the screen edge. When docked, it uses the entire screen’s worth of vertical
space because other panels cannot be docked beneath or above the Tools panel. That’s the con. The
pro, of course, is that, when the Tools panel is docked, document windows automatically resize
around it, never over- or under-lapping it as they would do in previous versions of InDesign.

The second option, whether to display the Tools panel in single-column, double-column, or
single-row mode, is set in the Interface pane of InDesign’s preferences (InDesign > Preferences on the
Mac and Edit > Preferences on Windows). Easier than going that route, however, is to click the double
arrows at the top of the Tools panel. This will cycle it through the three states. Although the single-
column and single-row modes have the advantage of consuming less screen real estate, they have a
seeming drawback as well: fewer options. The three apply buttons near the bottom don't fit in the
slimmer modes, nor does the Normal view button at the very bottom. Fortunately, Adobe made up
for their absence with new keyboard shortcuts. If you opt to use one of the Tools panel’s slimmer
arrangements (or just like the efficiency of keyboard shortcuts), memorize the shortcuts in Table 1.2.

TABLE 1.2: Keyboard Shortcuts for Tools Panel Features Hidden by Single-Column and
Single-Row Modes

SHORTCUT FUNCTION

, (comma) Apply solid color to fill or stroke.
. (period) Apply gradient to fill or stroke.

/ (slash) Remove color from fill or stroke.

w Toggle between normal mode and the selected preview mode.
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The Control Panel

The Control panel, a favorite among users since its introduction in InDesign CS (1) PageMaker
Edition, is context sensitive to the tool and task at hand, offering a compact quick access point
for the most common features and options. While you're editing text, for instance, the Control
panel goes into Character or Paragraph mode, two transposable sets of fields and controls that
offer, among many other things, the ability to change the font family, style, and size as well as
paragraph alignments, spacing, and indents. When you're working with tables, though, the Con-
trol panel transforms to offer table-specific controls such as the number of rows and columns,
cell alignments, and insets. In all, there are four modes dependent upon what you're actually
doing in the document—working with objects, characters, paragraphs, or tables. Figure 1.7 shows

all four modes.
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The Control panel has been upgraded in InDesign CS3. It now contains more commands—
including some new ones like Apply Effect, which applies Photoshop-like object effects to selected
objects (see Chapter 6, “Objects”) and buttons for flip and rotate—and it’s customizable.

The very last object on the Control panel’s right end, a button that looks like three horizontal
lines, is the Control panel’s flyout menu. Like the face of the Control panel, the commands on the
flyout menu are context variable. At the bottom of the list, the Customize command is constant
and opens the Customize Control Panel dialog box (see Figure 1.8). Here, by unchecking the show
box in the expanding lists, you can selectively disable groups of controls or an entire mode. Maybe
you’d rather not have Adobe Bridge shoved down your...er...um...maybe you’d rather Bridge
not be so obvious in so many places (there are commands for it in the menus as well as the Go to
Bridge button and accompanying drop-down menu on the face of the Control panel). To dump the
Go to Bridge button, expand the Other section of the Customize Control Panel dialog and uncheck
Adobe Bridge. The same goes for anything else you’d rather not see on the Control panel.

Also at the bottom of the Control panel flyout menu are commands to dock the panel to the
top of the application window, its default location, dock it to the bottom, or float it free a la Page-
Maker’s Control palette and QuarkXPress’s Measurements palette. Once free floating, the Control
panel can be positioned anywhere you like onscreen, but always horizontal. In addition to using
the menu commands, dragging the gray bar on the left edge of the panel moves the panel around
as well attaching it to, or detaching it from, the top or bottom edge of the application. When you
drag a floating Control panel close enough to either the top or bottom, a thick horizontal line, simi-
lar to the one you see when docking other panels, will appear above or below the panel; release
the mouse button and the panel will snap into its docked position.
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If you're running a monitor with a horizontal resolution greater than 1024 pixels, you'll be able
to take advantage of a new dynamic in the Control panel. All the primary controls of each mode
are contained within the first 1024 pixels. With previous versions, that was it; if your screen was
wider, a docked Control palette left any extra pixels blank, wasted space. With the CS3 version,
however, Adobe uses much of that space. After the primary controls have been rendered, several
modes of the Control panel will present additional controls for your convenience. In Character
mode, for example, more paragraph-centric fields and options will fill the extra space after all
character-centric fields. In Paragraph mode, more of the character-centric controls slip in there.
The idea, of course, is that if you have the space to use, InDesign will use it to save you a few
times toggling between Character and Paragraph modes.

Panels You Don’t Need

So upgraded is the Control panel, in fact, that it negates the need to use some other panels almost
entirely. Conversely, you can elect to hide the Control panel, saving yourself some vertical screen
real estate. The main advantage to using the Control panel is its context-sensitive nature; depend-
ing on the task at hand, it contains the majority of controls, options, fields, and buttons from the
Transform, Align, Character, Paragraph, and Table panels, as well as some from the Stroke,
Text Wrap, Effects, Character Styles, Paragraph Styles, Object Styles, and other panels. All these
controls share the same space onscreen, which is far less real estate than the panels consume
individually—even with panel docking and other space-saving options.

Although the options on the Control panel are not comprehensive replicas of all the dedicated
panels mentioned in the previous paragraph, you may only need more on rare occasions. Con-
sider your unique workflow and examine what is and isn’t available on the Control panel to be
sure, but you can probably safely hide the following stand-alone panels and reclaim the space
they would occupy for other panels not duplicated on the Control panel:

Character
Paragraph
Table

Transform

* 6 o o

Align
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On the other hand, if you prefer using the individual panels (personally, I prefer using the
Character, Paragraph, and Table panels rather than the Control panel most of the time), drop the
Control panel and reclaim that space. With such a panel-laden application, where docking, group-
ing, and stacking panels and multiple monitors merely mitigate screen overcrowding and a claus-
trophobic document workspace rather than solve it, repossess any pixels you can.

Command Bar

Activated from Window > Object & Layout > Command Bar, this toolbar includes several com-
mon functions in an area even more compact than the Control panel or Tools panel. Like them, the
Command Bar can be left free floating or docked to the top or bottom edge of the application win-
dow. Figure 1.9 identifies all the buttons of the Command Bar.

FIGURE 1.9 New Document Decrease Left Indent Fit Spread in Window
The Command Bar Save Insert Pages
Find/Change Text Frame Options
Character Panel Update Link
Decrease Font Size (Open) Photoshop
Paragraph Panel Export Adobe PDF
Bulleted List Zoom QOut
ANEBE8RAB ATTRITHEIE-EEaSHEaRB@A2Aa’DO?
Numbered Actual Size
List
Tabs Zoom In
Swatches Panel (Open) lllustrator
Increase Font Size Place
Check Spelling Text Wrap
Print Remove Pages
Open Document Increase Left Indent Help

Keyboard Shortcuts

Somebody far back in time invented computer keyboard shortcuts, the ability to press a few keys
simultaneously to produce the same effect as, and in lieu of, reaching for the mouse and navigating
amenu. I don’t know who came up with the idea of keyboard shortcuts—I think it was Cro-Magnon
man, but it might have been Neandertal. Whomever it was should have a statue erected in his
honor. Maybe there already is; | haven’t visited the Smithsonian in a few years.

Keyboard shortcuts save tremendous time and effort and are, in my opinion, the greatest pro-
ductivity enhancing invention since instant coffee (circa 35,000 BCE). InDesign is loaded with
keyboard shortcuts to speed your work. And, at this point in the narrative, many software book
authors would launch into several pages of keyboard shortcuts or direct you to an index of the
same. Me? Well, I've got precious few pages in which to cram all the advanced InDesign info I can.
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I'm not going to waste 3 to 10 or so of those with something I can give you in a different medium
(see the sidebar “InDesign CS3 Keyboard Shortcuts”). More importantly, I can give you something
even better than a list of keyboard shortcuts: I can show you how to set your own keyboard short-
cuts for just about everything.

INDESIGN CS3 KEYBOARD SHORTCUTS

Even with the ability to customize every keyboard shortcut in InDesign, sometimes it’s nice to have a
list in front of you. So, I made one.

Visit http://QuarkVSInDesign.com/resources/downloads/ to download a free and printable PDF con-
taining every keyboard shortcut for InDesign CS3 and InCopy CS3 on both Windows and Mac.

If you’d prefer something preprinted, my friends David Blatner and Anne-Marie Concepcion sell a poster
with all the InDesign CS3 keyboard shortcuts—Mac on one side, Windows on the other. You’ll find that
here: http://indesignsecrets.com/indesign-poster-details/.

If you choose Edit > Keyboard Shortcuts (on Windows) or InDesign > Keyboard Shortcuts
(on Mac), you can assign a keyboard shortcut to any command in InDesign, change the shortcuts
already assigned, and create portable sets of shortcuts (more on portability later). In the Keyboard
Shortcuts dialog (see Figure 1.10) you'll see, by default, the commands and shortcuts of the
Edit menu.

FIGURE 1.10 T ——
Editing keyboard o
shortcuts [Default] - New Set...
Product: Area: Show Set...
Edit. Maru -

Curent Sharteits:

DefaulL: Clrl+X
New Shortcut: Contoxt:

ift+Otr+x Defaul - Assign
Curvently Assigned tat

Mormal horzontal test scale

Cance

Click on Cut in the Commands list. Its shortcut—Cmd+X/Ctrl+X—will appear in the Current
Shortcuts field beneath the list. Don’t like that shortcut? Click on Default: Cmd+X or Default:
Ctrl+X to highlight it, and then click the Remove button. InDesign will promptly notify you that
you cannot modify the Default set of keyboard shortcuts and ask whether to create a new set for
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your customizations. InDesign can contain multiple keyboard shortcut sets. In fact, if you look
toward the very top of the dialog, it already had three—Default, Shortcuts for PageMaker 7.0, and
Shortcuts for QuarkXPress 4.0. If you're migrating to InDesign from PageMaker or QuarkXPress,
using one of those sets can ease your transition. In the QuarkXPress set, for instance, object arrange
commands such as Bring Forward, Bring to Front, Send Backward, and Send to Back use XPress’s
familiar F5 commands instead of InDesign’s commands, which use the left and right brackets ([ ]).
Of course, InDesign isn’t PageMaker nor QuarkXPress, so not every command or keyboard short-
cut from one has a place in the other; the shortcut sets are not total conversions, but helping hands.

To create your own set, click the New Set button and name the set, or begin a change and
answer Yes when prompted. Go ahead and create a new set now, just to practice while you go
through the rest of this section. While working in your set, remember to save it from time to time
with the button at the top. If, after working through this chapter, you elect to eject the shortcut set,
simply choose it in the Set drop-down and click the Delete Set button.

Returning to modifying the Edit > Cut command, let’s stay that, instead of removing the
default shortcut, you'd like to add a second shortcut. You'd like both Cmd+X/Ctrl+X and
Cmd+Shift+X/Ctrl+ Shift+X to effect a cut. In that case, to add a shortcut, position your cursor
within the New Shortcut field at the bottom of the dialog and press the new shortcut. (Note to
Windows users: You cannot use the Windows key as a modifier within the application.) Beneath
the field you should see a warning that Cmd+Shift+X/Ctrl+ Shift+X is already assigned to the
Normal Horizontal Text Scale command. If you click the Assign button, you'll strip Normal Hori-
zontal Text Scale from the shortcut and assign it to Cut.

To the right of the New Shortcut field is Context. Every keyboard shortcut can be targeted to
certain types of tasks. You could, for example, bind Cmd+Shift+X/Ctrl+ Shift+X to Edit > Cut
only when working with tables. While working with text, with XML selections, within alert and
dialog boxes, and in all other circumstances, it will not invoke the Cut command. In fact, if you set
the Context field to Table now, you'll see that the Currently Assigned To notice no longer says
Normal Horizontal Text Scale. That’s because the shortcut is bound to that command only in the
context of working with text. The horizontal scale of text is irrelevant to XML code, dialogs, and
the structure of tables, and that command and shortcut combination has been assigned to function
only where it is relevant—when working directly with text. If you left Context set to Table and
assigned Cmd+Shift+X/Ctrl+ Shift+X to the Cut command, that would apply only when working
with tables. The same shortcut would still invoke Normal Horizontal Text Scale when working with
text. In other words, the same keyboard shortcut can be used five times over for different commands
in different contexts.

There are only so many keys on the QWERTY keyboard, only so many modifiers and combina-
tions of keys, so customizing keyboard shortcuts in InDesign often entails sacrificing keyboard
access to one command for another. By the same token, just as you can add multiple shortcuts to
Cut, other commands already have multiple shortcuts. Do they need two (or three)? Probably not,
which means their extras are fair game for commands that don’t have any. Other commands have
shortcuts you'll never use; put those key combinations to better use. If you use the Gradient
Feather effect often, give it a keyboard shortcut (it doesn’t have one by default, although the Drop
Shadow command does—Cmd+Shift+M /Ctrl+Shift+M).

The Product Area drop-down mirrors the structure of menus but includes a lot more, even
commands not found on the menu bar. Object Editing, for instance, includes all sorts of align, dis-
tribution, scale, and nudge commands that simply don’t have counterparts on any menu and
would normally require mouse work. Explore around the dialog, changing and testing shortcuts,
until you have all your most-used commands shortcutted and InDesign works your way.

The folks at Adobe did a great job in setting keyboard shortcuts on the commands most used
by the average InDesign user, but they had to leave it up to you to tailor the program to your
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unique workflow. Keyboard shortcuts, various panel arrangements and customizations, even
customizable menus are available to tailor the program to you. Use them.

Menus

Yes, you read me right: In InDesign CS3 you can customize menus. Photoshop CS2 (and its now-
retired protégé ImageReady CS2) introduced the idea of customizable menus. Odd as it may
sound, it’s a pretty cool idea. Do me a favor: Select Window > Workspace > Printing and Proof-
ing. You'll likely be prompted; answer in the affirmative. Now, return to the Window menu. Notice
anything? Check out the File menu. You should see quite a few commands and submenus high-
lighted in a pleasing green (see Figure 1.11). Try Window > Workspace > New and Improved in
CS3. Just about every menu will then show something highlighted in blue.

FIGURE 1.11
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Now, go to the blue-highlighted Menus command at the bottom of the Edit menu to open
Menu Customization (see Figure 1.12). Similar to customizing keyboard shortcuts, you have sets
to create and choose from and two categories of menus—Application Menus, those that appear
within the menu bar at the top of the InDesign window, and Context & Panel Menus, which are
the flyout menus on panels as well as those menus that appear when you right-click (Control-click
for you single-button Mac mouse users) on something. Every menu in InDesign can be customized.
Pick one. Click the arrow to the left to expand the menu, showing commands and submenus in the
order in which they appear on the menu itself.

If there’s a command that you never use, one you'd like out of your way, click its eyeball icon in
the Visibility column. The menu command or submenu will disappear from the application as if it
didn’t exist. To highlight a menu like those that turned blue in the New and Improved in CS3 work-
space, change the color in the third column. Sorry, no custom colors, just the basic rainbow red,
orange, yellow, green, blue, violet, and gray (for rain clouds, I assume).

Why would I want to remove some commands? you might ask. Well, the vast majority of InDesign
users never use everything in the application. Do you do any XML work? If not, you can hide the
XML-centric commands and unclutter the interface a little.

13
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FIGURE 1.12
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Next, I'd expect you to ask, Why would I want to color-code my menu commands? As you saw
Adobe do with its sets, color-coding menus is a great way to learn new features and commands. It
can also help in memory: Where do I set the options for an inline graphic so that it has vertical spacing?
Oh, duh! Here it is: Anchored Objects on the Objects menu. I colored it red last time I used it six months ago
so I'd remember where to find it again.

For you production managers, editors, and other team leaders, customizing menus presents a
new level of production control through customized workstation installs without messing with
installer scripts or disabling plug-ins. Check out the sidebar “Customizing InDesign to Easily Cre-
ate Workflow-Focused Workstations” to see how I helped the editor of one small newspaper keep
her staff focused and her layouts clean and press-ready.

@ Real World Scenario

CUSTOMIZING INDESIGN TO EASILY CREATE WORKFLOW-FOCUSED WORKSTATIONS

Very recently, 1 was asked to improve the workflow of a high school newspaper. The request came from
Pam, the editor in chief and a teacher at the school. Pam was exasperated with her paper’s workflow. She
had good reporters and editors, but none of them had had graphic design training despite the fact that
they laid out their own copy and photos and worked up advertisements for the paper’s local sponsors. Her
teenage staff probably knew more about technology than either Pam or I, but they’re prone to—let’s say—
experimenting with imagery and effects. They had a tendency to try to reproduce in their articles and ads
anything that caught their eye in any medium—other newspapers, magazines, printed advertisements,
broadcast media, the Web, and, most often, MySpace.com. All of this despite the fact that the paper was
one color (with thrice-annual special editions going to two or three colors). Before putting the paper to
bed every week, Pam lost a night of sleep fixing the staff’s experiments and converting too-similar color
pairings like RGB deep purple and dark red to colors that would contrast in 85 Ipi black on newsprint.
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When the school board delivered InDesign CS3 with its object effects, attribute-level transparency, and
other features, Pam foresaw her one night of cleanup and fix stretching into a night and a day. The stu-
dents’ designs, she said, will only get more wild. Because Pam had classes to teach, and because students’
class schedules varied, staffers often worked in the paper’s office without supervision. The teenagers,
who by their own admission know far more than we experienced old fogies, simply couldn’t resist engag-
ingin...experimental...design. New features of CS3 would improve the productivity and creativity of the
staff, but other features would make more work for Pam. This was the problem. The solution was to cus-
tomize the menus.

Armed with the character of the publication—B&W, 85 LPI, newspaper—the list-style presentation of
commands in the Menu Customization dialog made it easy to compile a list of what commands and pan-
els staffers needed and what they didn’t. Then, it was just a matter of turning off what they didn’t need.
Because the publication is printed only in black ink, we disabled Window > Color and removed the cor-
responding shortcut, preventing the Color panel from being accessed. The Swatches panel, preloaded
with tint swatches of process black and all other colors removed, we left available to the students, but we
disabled the Swatches panel menu commands for New Color Swatch, New Mixed Ink Swatch, and any
other command that would have enabled the creation or loading of colors other than those added to the
default palette by Pam. (We couldn’t do anything about the New Swatch button at the bottom of the panel,
though, so we disabled the Color Picker.aplnand other plug-ins.) For those thrice annual two- or three-
color special issues, Pam will create new InDesign INDT templates containing the same black tint
swatches and matching tint swatches for the chosen spot color(s). We turned off access to object effects,
transparency, HTML and XML export, and quite a few other commands and panels that the students
didn’t need in order to write and lay out their newspaper—disabling both in the main application menu
and in panel and context-sensitive menus. At the same time, we colored menu commands that were new
to CS3 or had moved since CS2 to help the students learn the new version.

To prevent the technology savvy teenagers from undoing everything, we assigned custom (and difficult-
to-guess) keyboard shortcuts to open the keyboard shortcut and menus customization dialogs and to
revert to the default workspace (thus restoring access to the Window > Workspace menu and everything
else so that Pam could later change the customizations if needed); changed the default shortcut for
InDesign’s Preferences, and then hid them all from appearing on the Edit and InDesign (Mac) menus.

As alast step, after making all the menu and keyboard shortcut changes and showing and arranging all the
required panels, we saved all the presets individually and created a new workspace that unified these
settings. The result was a lean InDesign installation completely customized to the needs of the school
newspaper and bereft of anything that didn’t have a place in the workflow. The final step was to copy
the shortcut set, menu set, and workspace from the build machine to the staff’s workstations and load the
preset workspace that mirrored the workstations to the build machine.

Pam tells her students it’s InDesign Elements CS3, a new product built specifically for black-and-white
newsletter publishing that Adobe is test-marketing among several schools and newspapers.

Of course, these changes couldn’t prevent a student from drawing something completely inappropriate in
Ilustrator or Photoshop and then placing it in InDesign. Both of those applications have similar customiza-
tion features, and we limited some of their functionality on the workstations, but by necessity, it couldn’t
be as thorough a streamlining as within InDesign. Still, last 1 heard, Pam’s per-issue cleanup had dropped
from a full night of work to less than two hours because of the limited InDesign installations.
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Plug-In Customization

Another level of application customization available to you is via the removal of plug-ins. (Indi-
vidual users, feel free to skip this section.)

InDesign, you see, is not so much an application in the traditional sense of computer program-
ming. It isn’t hundreds of thousands or millions of lines of code compiled into a single executable
like most other applications. InDesign.exe (Windows) and InDesign.app (Mac) is actually a plug-in
wrapper. All of InDesign’s functionality is added through plug-ins that are no different than a
third-party plug-in you may buy to give InDesign functionality Adobe didn’t. Don’t believe me?
Go look in your InDesign installation folder (AppTications/Adobe/Adobe InDesign CS3 on the Mac,
Program Files\Adobe\Adobe InDesign CS3 on Windows). The InDesign application itself is but a
few megabytes. Look inside the Plug-Ins folder on the Mac to find numerous . InDesignPlugin files
arranged in subfolders. On Windows, you’ll see the same subfolders beneath the Plug-Ins folder.
On either platform, you'll see mostly plain-English names for all your favorite InDesign panels
and features. The Eyedropper tool, for instance, is added to InDesign Windows by the inclusion of
the Eyedropper Tool.apln plug-in, for instance; the Print dialog is PrintUI.InDesignPlugin on the
Mac. The InDesign executable mostly acts as activator to run those plug-ins and glue to allow
them to work together. There’s also an extra layer of organization on Windows that isn’t on the
Mac. Windows users will note the Program Files\Adobe\Adobe InDesign CS3\Required folder,
which contains RPLN plug-in files. The . rpTn extension stands for Required PLug-iN. As the name
implies, everything in the Required folder is required for InDesign to fulfill its base purpose. In the
Plug-Ins folder are all the optional plug-ins, the ones InDesign can function without. Most you
wouldn’t want it to run without, though. For example, you could pull out the Page Setup
Dialog.apln, but then you wouldn’t be able to alter page sizes. On the Mac, plug-ins aren’t so eas-
ily differentiated as required, and nonrequired plug-ins all share the .InDesignPTugin extension.

InDesign can function, to one degree or another, absent any of the nonrequired plug-ins. There-
fore, if some or all of the people in your workgroup have no need of something like, say, hyper-
links and the Hyperlinks panel or type on a path, you can save (a little) system overhead and tidy
up the InDesign interface a bit by disabling the plug-ins that add those functions.

If you go to Help > Configure Plug-Ins (Windows) or InDesign > Configure Plug-Ins (Mac),
you'll see all the plug-ins installed in your copy of InDesign—required, optional, and any third-
party plug-ins you may have (see Figure 1.13). There are, by default, three sets of plug-ins defined:
All, which shows everything, Adobe Plug-Ins, both required and not, and Required Plug-Ins. In
any set, required plug-ins appear with a padlock icon to the left and are always active. Active non-
required plug-ins have a check mark in the first column. Where possible—and certainly with
Adobe-created plug-ins—a logo of the plug-in maker appears in the third column, and a cute little
plug icon shows in the fourth. At the bottom of the dialog, the Display section check boxes enable
further refinement of the view.

Anything without a padlock can be disabled by clicking the check mark icon. Like customizing
keyboard shortcuts, the first such change you make will prompt you to create a new plug-in set,
which is just a list of which plug-ins are active and which not. Any plug-ins neither you nor
InDesign need to do your job, disable them; you'll have a leaner InDesign with less demand on
your system RAM. If you're not entirely sure what a plug-in does, highlight it and click the Show
Info button. Although the resulting Plug-In Information dialog isn’t guaranteed to be illuminating,
I might offer some clues (see Figure 1.14). At the very least, the Dependencies area will note any
other plug-ins required for this one to run and, beneath that, which plug-ins can’t run if you dis-
able this one.
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When in doubt about what a plug-in does and whether you need it, try disabling it and look
for the absence of what you think it does. Fortunately, you can’t accidentally disable the Configure
Plug-Ins dialog itself as Plugin Manager.ap1n/Plugin Manager.InDesignPlugin is required (despite
the lack of an . rp1n file extension), so you can always simply reactivate a plug-in you want.

Why would I want to disable some plug-ins? For many of the same reasons you'd want to disable
some menus—a cleaner display, the aforementioned smaller RAM footprint, and to limit worksta-
tion installs to only what is required of the user’s workflow. If your team works in a strictly print
workflow, for instance, and never exports to HTML or to PDFs for distribution online, you can
remove commands, panels, and everything else to do with hyperlinks, form fields, sound and
video, HTML and SVG export, and so on. I can tell you from personal experience that using Con-
figure Plug-Ins to disable things like the Tools panel (Too1 Box.apTn) on someone else’s computer
is also an amusing practical joke. Just be kind enough to let the victim in on the joke before too
long (or leave this book nearby opened to this page and I'll take the blame).
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Workspaces

Now that you've got InDesign all customized to your personal work habits, with this panel
stacked over here, another dozen panels collapsed to icons in a dock, three more stacked, and
several panels hidden, menus color-coded and customized, and keyboard shortcuts totally cus-
tomized, it’s time to scare you: Everything you just did will evaporate the first time InDesign’s
preferences get corrupted. They get corrupted often—no more so than other applications, but
that’s too often.

All your customizations are saved into the application preferences, a flimsy little ASCII text
file with all the resiliency and tensile strength of wet newsprint. Sneezing too hard in the general
direction of your computer could tear and corrupt the preferences. Then where would you be?
That's right, trying to remember all the original keyboard shortcuts while stumbling all but blind
through the original configuration of panels. Of course, there’s a solution to prevent the loss of
your customizations. And, I'll explain that solution in detail in the sequel to this book, Mastering
InDesign CS3 for Print Design and Production Reloaded, due out from Sybex next year. Don’t let your
preferences get corrupted before then.

Just kidding. I was doing an impression of a typical local news anchor—tune into our six o’clock
broadcast to find out what’s killing area children and could be killing your child right now! (Yup, tune in at
least three hours after your child has been presumably slain to learn that children are being given
two desserts in the school cafeteria on Fridays.)

InDesign has, for several versions now, had the ability to save panel (previously palette, lest
we forget the tragedies of yesterday) arrangements as workspaces. With InDesign CS2, workspaces
saved custom keyboard shortcuts along with palette arrangements. In CS3, they now save menu
customizations, keyboard shortcuts, and panel arrangements. It’s the last part that’s the most
important because, while you can save and restore sets of keyboard shortcuts and menus, work-
spaces are the only way to record panel arrangements.

When we looked at menu color-coding a few pages ago, the New and Improved in CS3 and
Printing and Proofing options you chose were workspaces. You may have noticed that loading
them also rearranged your panels. If you missed that, load up Printing and Proofing again from
Window > Workspaces. Note the dock on the right wherein several panels have been hidden and
replaced by others not shown after first installing InDesign. The Default Workspace saved work-
space will return everything—shortcuts, menus, panels—to out-of-the-box InDesign.

Any time you customize InDesign, save your workspace by choosing Window > Workspaces >
Save Workspace. Supply a name and your workspace will be added to the Workspaces menu
ready for instant restoration in the event of a preferences corruption and subsequent reset or if you
change things around to fit a particular project.

That brings me to another key point: You can have many, many workspaces. Sometimes
you need these five panels showing, some projects require these six others, and yet other types
of projects require a dozen or more, all with options showing. Make workspaces for each of
your typical types of projects. Strictly print projects, for instance, aren’t likely to need the Hyper-
links panel, whereas creating a publication that will only be distributed on the client’s website
as a PDF does need Hyperlinks, and probably doesn’t need the Separations Preview and Trap
Presets panels. By employing multiple, project-specific workspaces, you can further reduce
panel clutter by limiting the application to only what the one type of project needs, without
the chore of having to manually open, close, and arrange panels every time you switch over
to a different project.
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InDesign in Your Pocket

Or, InDesign on a Stick—a USB stick /thumbnail drive/flash drive. Although you can fit InDesign
and all its component plug-ins on most portable USB flash drives, it won’t run from there. (Well,
I'm sure somebody could get it to run, but I think that would violate the EULA.) What I mean by
the title of this section is taking your InDesign in your pocket, your unique configuration and
work habits, and sitting down at any workstation and, in 30 seconds or less, making any copy of
InDesign CS3 work exactly like InDesign on your main computer—complete with panel arrange-
ments, keyboard shortcuts, menus, and even your own autocorrect settings and Find /Change
queries.

It's exceedingly simple, really. First, make sure you've created a new keyboard shortcut set, a
new set of menus, and a new workspace. Create and save them in their respective manners. Noth-
ing here is permanent, so please don’t feel pressured to create the perfect workspace or customize
everything right now. Just do something simple for each, save the set, and close InDesign.

Now, open a Finder or Explorer window and navigate to the InDesign folder:

Mac: [your user name]/Library/Preferences/Adobe/InDesign/Version 5.0/

Windows: Documents and Settings\[your user name]\Application Data\Adobe\InDesign\
Version 5.0\

Within those folders, you should see a subfolder for Workspaces. Open that, and you'll find an
XML file of the workspace you just created. Go back up to the Menu Sets folder to find your
recently created menu set. At the same level as both of those folders, you'll find others, called
InDesign Shortcut Sets, Autocorrect, Find-Change Queries, and Glyph Sets. All of these folders
store personal, per-user settings that are machine and even platform independent. You can pick
up these files by copying the entire Version 5.0 folder, carry them to any other installation of
InDesign CS3 on the same platform (Windows or Mac), copy them to the same locations on the
new machine, and have access to them at that workstation just as you would your own. When
you launch InDesign, your copied workspace will be on the Window > Workspaces menu, your
keyboard and menu sets in the Keyboard Shortcuts and Customize Menu dialogs’ Sets drop-
downs, and your Autocorrect, Find/Change, and Glyphs sets where they belong (I cover each
later in this book). In fact, if you're handy with scripting, you could probably write an Apple-
Script or VBScript or BAT file that, upon execution on a target workstation, copies the Version 5.0
folder from the USB drive to the hard drive.

You can even store your portable InDesign settings on your iPod, which, if you didn’t realize it,
can hold any type of data, not just music and videos. That would sell a few copies of this book! I
can see the cover line now: Run InDesign from Your iPod!

Customizing Application Defaults

Is there a way to change the default font/swatches/hyphenation options/whatever? Collectively, it's probably
the most common question I'm asked. Answer: Yes. If you can change the font family and style in the
Character panel, you can change the default font. Likewise with creating new default swatches and
removing the swatches with which InDesign ships. In fact, if you can do almost anything, you can
make it the new default. Just do it with all documents closed.

Open InDesign without a document and look at the panels. If an option is grayed out, you can’t
change its default. If it isnt grayed out, well...there you are. Do you want hyphenation turned off
by default instead of on? Uncheck the Hyphenate button on the Paragraph panel (show options if
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you don’t see it). To remove swatches you rarely use, open the Swatches panel and delete them.
Add new swatches you use regularly—like corporate colors—by adding them to the panel with all
documents closed. Every new document from that point forward will use only the swatches you
see there, or will leave hyphenate unchecked, or whatever change you want to make.

To change the default font, open the Character panel and change the font. Done. Well, not
entirely. You see, InDesign has a default paragraph style. When you change type options on the
Character or Paragraph panels, you are indeed setting new defaults. However, you aren’t chang-
ing the default styles, which can lead to problems later on if you reapply the default styles to text.
If you're sure of your new font (or other type styling defaults), make the changes in the Character
and/or Paragraph panels, and then open the Paragraph Styles panel. Highlight the Basic Para-
graph style, choose Style Options from the panel flyout menu, and then repeat your changes there,
making sure to save the style. Now your changes will survive a reapplication of the style.

Experiment with different controls and options. You can set new defaults for a great many
things when no documents are opened.

SHARING CUSTOMIZATIONS

Many of the customizations we’ve covered in this chapter can be easily shared with others in your work-
group. Things like workspaces, keyboard shortcuts, autocorrect pairs, find/change queries, and more can
be shared and standardized across your team. In Chapter 12, “Collaboration,” you’ll learn how; you’ll also
learn about the more powerful means of document and page collaboration available with InDesign CS3.

The Bottom Line

Organize Panels and Use the New Panel Docks New docks and other options make organiz-
ing panels in the workspace easier than ever before.

Master It Beginning with the default workspace, open all the panels you expect to use in
most projects and close those you won’t. Now, using grouping, stacking, docking, or just
free floating panels, arrange the panels to fit your work style and leave you as much room
to work on documents as possible.

Customize Keyboard Shortcuts Adobe couldn’t assign a keyboard shortcut to everything—
there just aren’t enough keys—so it did its best. Many of your favorite commands may not
have shortcuts or may have shortcuts you dislike. You can add or change keyboard shortcuts
for any command in InDesign.

Master It  Just for fun, create keyboard shortcuts for each of the object effects—Basic
Feather, Bevel and Emboss, and so on.
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Remove Parts of InDesign to Create Lean, Workflow-Specific Installations By customizing
menus and disabling plug-ins, you can now easily remove features and functions of InDesign
not required by your workflow. Doing so streamlines the interface, reduces errors, and ulti-
mately increases productivity among workflows that do not require the entirety of InDesign.

Master It To test your hand at removing features from InDesign, find all the features that
are new or improved in CS3 and hide their menu commands. Then, color green the first 10
still enabled menu commands about which you’d like to learn more. Finally, disable the
plug-ins that show panels you or your team aren’t likely to need.

Change the Default Font, Colors, and More Out of the box, InDesign uses Times New
Roman 12/14.4 pt as the default text style and includes swatches for process magenta, cyan,
and yellow and RGB red, green, and blue. These defaults are fine if your average document
uses 12/14.4 Times New Roman and only solid process or RGB colors. But, if the average
document you create requires another typeface, size, or leading or other colors, or virtually
any other option different from the defaults, change the defaults and save yourself some time.

Master It Think about the documents you create most often. What is the type style—font
family, font style, size, leading, and other formatting attributes—you use more than any
other? Make those your new defaults. Do the same with your swatches, eliminating any
colors you rarely use while adding those you use frequently.

Carry Your Personalized InDesign Work Environment in Your Pocket or on Your iPod
From freelancers brought into agency offices to assist with crunch time to students working
in school labs, from round-the-clock production teams where different shifts use the same
equipment to those dedicated enough to bring work home, seldom do creatives work solely
on a single machine anymore. Creative and production personnel who switch computers
waste a significant portion of their time customizing the InDesign environment of each com-
puter on which they work even for a few minutes. To save time, nearly everything customiz-
able about the InDesign CS3 working environment is portable. Customize one copy of
InDesign, and carry your unique environment with you, making you instantly productive
at any workstation.

Master It After arranging your panels and customizing your keyboard shortcuts and
menus, it’s time to take your InDesign workspace with you. If you have a USB flash drive,
an iPod, a PDA, or even just a floppy disk handy, copy the files containing your customized
environment to the storage device. Now, if a second computer is available with InDesign
CS3 installed, install those files to that computer and set up InDesign CS3 your way.
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Text

Like most layout applications, InDesign operates on a content-to-container premise. Everything
within InDesign is either content—text and imagery—or a container to hold text, imagery, or
another container. At the lowest level, the pasteboard is a container that holds everything you
might place in InDesign. Then there are pages and layers—more containers—and then the real

content enters the picture—text and imagery.
In this chapter, you will learn to:

& Create and fill text frames

Format text frames
¢ Format paragraphs
¢ Compose paragraphs
¢ Setup paragraph rules
Text Frame Basics

Whether imported from an external document or typed directly into InDesign, text is, by defini-
tion, content. Therefore it must be contained by a frame.

Creating Text Frames

The most basic text holder is a rectangular frame, and the easiest way to make one is to click and
drag with the Type tool. As soon as you let go of the mouse, your text frame will be fixed and an
I-beam cursor will be activated inside it, ready to accept your words of wisdom. You can then type
something into the new frame. Figure 2.1 shows my words of...well, not wisdom, surely. Let’s say
my words of satire.

FIGURE 2.1 The Getty Stone Address
Anewly created

text frame contain-

ing text Five versions and eight years

ago, Adobe brought forth on this
profession, a new application,
conceived in Liberty, and dedicated
to the proposition that all layouts
are created equal.
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Text frames can be created anywhere—on the page, on the pasteboard, overlapping both. Once
created, they can be moved by selecting them with the Selection tool (the black arrow) and dragging.
Resizing is just as easy: Once selected, a text frame will display its nine control corners—four at
the corners, four more at the centers of each side, and the last in the frame’s center. Dragging all
but the center point will resize the frame. Dragging the center point will simply move the frame.

Notice as you resize the frame with the Selection tool, the text wraps to accommodate but does
not resize. In a short while, we’ll get into the different ways to style and format text. For now, it’s
more important to cover the ways in which text makes it into InDesign.

Getting Text into Text Frames

On many occasions, you'll know exactly what to type into a newly created text frame. On others,
you won’t. While you're waiting on a client, editor, or copywriter to provide the text for a layout,
for example, you'll need to employ dummy text while you design. It's what we call greeking or For
Position Only (FPO) text; it enables you to work out the placement and style of type ahead of hav-
ing genuine content.

IMPORTING A TEXT FILE

Typing directly into InDesign is one way of getting text into your layout, and many people do it
just that way. Most of the time, for longer text anyway, you'll write copy outside of InDesign and
import it. If you work on a publication or in another collaborative environment, odds are good
that someone else will write the copy and you'll have to place and style it. Let’s use the old stand-
by Lorem Ipsum to simulate such tasks.

1. Create a new text frame with the Type tool. Just like last time, you'll immediately have an
I-beam cursor ready to type—don't.

2. Instead, choose File > Place (Cmd+D/Ctrl+D).

3. In the Place dialog, navigate to wherever you copied the Chap02 files from the book’s down-
load page. Inside that folder, highlight the file Torem. txt and click Open. Five-hundred-year-
old nonsense should fill your text frame (see Figure 2.2).

You've just imported an ASCII text file, and it doesn’t look too bad. Now repeat the process
with the bad-Torem. txt file. Not so nice, is it?

TEXT IMPORT OPTIONS

The text in bad-Torem. txt is roughly equivalent to what you might get from an email message or
something typed directly into Windows’s Notepad or Mac’s SimpleText. Lines are short and,
instead of wrapping dynamically, contain hard line breaks. Choose Type > Show Hidden Charac-
ters to see what I mean; it reveals all the nonprinting characters (what QuarkXPress calls “invisi-
bles,” if you're migrating to InDesign from that application). Figure 2.3 shows what you should be
seeing, although the width of your text frame may alter the view somewhat.

Email and plain-text editors have a tendency to break lines of type after a few words by
inserting a hard carriage return, as signified by the pilcrow, or paragraph mark (). They also don’t
like to use real tabs because tab characters are not always compatible with the ASCII text format.
Because email and plain-text editors lack paragraph spacing capabilities, vertical white space
between paragraphs is usually accomplished by using multiple carriage returns—a major typeset-
ting no-no.



FIGURE 2.2

The venerable
Lorem Ipsum filling
atext frame

FIGURE 2.3
Show Hidden
Characters reveals
just how bad
bad-Torem. txt
really is.
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orem 1psum dolor sif ameft, conscetetuer adipiseing clif, sed diam nonummy-

ibh cuismod tincidunt ut laoreet dolore magna-aliquam crat volutpat. Ut wisi-
enim-ad minim veniam, quis-nostrud exerci-tation ullamcorper suscipit lobortis
nisl ut-aliquip ex ca-commodo consequat.-Duis-autem vel cum irture dolor in
hendrerit in vulputate velit esse molestic consequat, vel illum- dolore cu feu=
giat nulla facilisis at vero eros et accumsan et iusto odio dignissim qui blandit.
praesent luptatum zzril delenit augue duis-dolore te feugait nulla facilisi
M
Ut wist enim ad minim veniam, quis -nostrud exerci tation ullamcorper suscipit:
lobortis nisl-ut-aliquip-ex-ea.commodo-consequat. Duis-autem vel eum iriure-
dolor in hendrerit in vulputate velit esse molestie consequat, vel illum dolore
eu feugiat nulla facilisis at vero eros et-accumsan et iusto-odio dignissim-qui-
blandit praesent luptatum zzril delenit augue duis dolore te feugait nulla facilisi.
Lorem-ipsum- dolor sit-amet, consectetuer adipiscing ¢lit, sed diam nonummy-
nibh euismod tincidunt ut-laoreet dolore magna aliquam erat-volutpat.
I
Duis-autem vel eum iriure-dolor in hendrerit-in vulputate velit-esse molestie-
consequat, vel illum dolore en fengiat nulla facilisis at vero eros et accumsan:
et iusto odio dignissim qui blandit praesent luptatum zzril delenit augue duis
dolore te feugait nulla facilisi. Lorem ipsum dolor sit amet, consectetuer adipi=
scing elit, sed diam nonummy nibh euismod tincidunt ut laoreet dolore magna

’:ﬂiqumn eral volutpal. T wisi enim ad minim veniam, quis nosinud exerei tation

ullamecorper suseipt loborhis msl ul ahqup ex ea commodo consequal.

- Lorem 1psum dolor sit-amet, conscetetuer
adipiscing elit, sed -diam nonummy- nibhy
cuismod- tincidunt ut-laoreet - dolore
magna-aliquam- crat volutpat. Ut wisi-cnim
jad minim veniam, quis nostrud exerei
tation ullamcorper suscipit lobortis nisl
ut-aliquip ex-ea.commodo consequat. Duis
fautem vel eum iriure dolor in hendrerity
i vulputate velit esse molestie consequat,
wvel.illum-dolore eu. feugiat nulla-facilisis 4

tvero eros et-accumsan et iusto.odio

Eigﬂissim qui -blandit praesent luptatum |
zzril delenit augue duis dolore te 4|
feugait nulla facilisij
i
I
I
il
- Ut-wisi enim ad minim veniam, quis nostrudj
exerci tation ullamcorper suscipit lobortis]
nislut aliquip ex ea commodo consequat._
s autem vel eurn irure dolor in hendrent]

m vilpulale veht esse molestie consequat, §
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As you might expect, all this makes for some very ugly copy and could be a lot of tedious cleanup
work for you, the InDesign user. Ten years ago, you would have had to go through the text manu-
ally deleting the extra carriage returns, replacing the faux tabs with a smack of the keyboard Tab
key, and, one line at a time, rejoining all the lines of a paragraph. Fortunately, InDesign was built
with an automated way to clean up most of this mess.

1. Create a new text frame with the Type tool.

2. Choose File > Place, and once again highlight bad-Torem. txt, but don’t press the Open
button yet.

3. Toward the bottom of the Place dialog is a check box labeled Show Import Options. Check
that, and then click Open. Up will pop the Text Import Options dialog (see Figure 2.4). What
does it all mean?

FIGURE 2.4 Text Import OpHons (bad-lorem.xt)
The Text Import }

Character Set: ANSI - UK
Options dialog box b iiE

Cancel

Sel Diclionary Loz Engleh: USA
[Extra Carraga Retums

+ femove at Lnd of Lyery Line
+ Remove Netween Parmgraphs

Formalling
~ Hephce |3 or More Spaces with a 1ab

¥ Use Typographer's Quotes

Character Set Every text file has a character set associated with it. Character sets are
dependent upon human-written language—such as Cyrillic, Turkish, Chinese, or Latin—
and machine-written language or the operating system. Because the character set is nearly
always encoded in the header of the text file, which InDesign reads, it’s usually best to stick
with InDesign’s suggestion unless you know for certain that the default choice is incorrect.

Platform Was the file created on Windows or Mac OS? This is important because the
default character sets of the two differ, and a wrong choice could lead to characters, or
glyphs, exchanging for something unexpected. If you get strange characters in your imported
text, try reimporting while switching the Platform setting. Again, though, InDesign usually
picks up on the correct platform.

Set Dictionary To For spell checking and hyphenation purposes, choose the language of
the text.

Remove (Extra Carriage Returns) at End of Every Line When dealing with a file like bad-
Torem. txt, this is the most important setting. Turning this on will strip out all the extrane-
ous carriage returns breaking lines within a paragraph. Manually removing them would be
the bulk of the tedious cleanup, so be sure to check this option when importing most ASCII
text files or content saved from text-only email.

Remove (Extra Carriage Returns) between Paragraphs Fairly self-explanatory, this option
will search out any instance of two or more consecutive hard returns and replace them with
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one return, readying the text for proper paragraph differentiation through paragraph spac-
ing above and/or below.

Replace X or More Spaces with a Tab In bad-Tlorem. txt, as is common with output from
plain-text editors, tabs are not tabs but consecutive spaces. This option will search out the

specified number of spaces and replace them with real tabs. In the bad-Torem. txt file itself,
I've set most paragraphs to begin with five consecutive tabs, but leaving the default value
of 3 in place will also do the trick.

“rr

Use Typographer’s Quotes Quotation marks look like (“”), while () are inch marks.
Plain-text files, with their extremely limited glyph set, rarely contain the former. Conse-
quently, quoted text is encased in inch marks. Turning on the Use Typographer’s Quotes
option will replace inch marks with real quotation marks. It will also replace foot marks (")
with genuine apostrophes (). It's on by default and should stay that way unless you're
importing a document containing measurements, time notations, or geographic coordinates.

4. Check all four of the check boxes in the Text Import Options dialog and click OK.
Bad-Torem. txt should import looking a lot less bad.

Once set, the text import options will remain in that state—they’re what we call sticky settings.
So next time you import a text file, you can uncheck Show Import Options in the Place dialog.
However, should you import a text file containing a list of items or structural dimensions, you'll
want to revisit the Text Import Options dialog and disable some of the options there to avoid man-

gling your copy.

WORD IMPORT OPTIONS

Importing plain-text ASCII is a once-in-a-while thing at best. Most InDesign users get the majority
of their copy from rich text word processors like Microsoft Word. Rich text is a far more robust file
format than plain text and rarely suffers from forced line breaks every 80 characters. In fact, Rich
Text Format, RTF for short, can support paragraph spacing, tabs, typographer’s quotes, text for-
matting like italic, bold, and underline, and even style sheets (more on those in Chapter 11, “Effi-
ciency”). Thus, RTF files have a different set of options for importing.

Word'’s native DOC files are based on RTF, and the two behave nearly identically with regard to
placement in InDesign. Thus, we’ll work with a Word DOC file. To get started, create a text frame.
Choose File > Place, and select the REVstory.doc document. Make sure Show Import Options is
checked before clicking Open. Up will pop the Microsoft Word Import Options dialog (see
Figure 2.5). Here’s what the options you'll see mean:

Preset Although your only current option here is likely [Custom], through the Save Preset
button on the right it’s possible to save the selection of options as a preset. Once saved, a set
of import options can be reactivated by choosing the preset from this drop-down menu. If you
import Word or RTF files and even occasionally require different options, it’s worth it to save a
preset or two.

(Include) Table of Contents Text Word can generate dynamic, hyperlinked tables of contents
based on headings or other styles used in a given document. InDesign can import the text of
those tables of contents, but it cannot import it as dynamic or hyperlinked. For instance, if in
Word the heading “Scumdot Tests on the Linotype 1500” appears on page 57 but upon import
into InDesign winds up on page 63, the TOC will still read 57 and will not automatically
update itself.
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FIGURE 2.5 Microsoft Word Import Options (REVstory.doc)
The Microsoft P v _ o
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Only new tables of contents created using InDesign’s built-in TOC generation can create refer-
ences relevant to text on InDesign pages.

(Include) Index Text As with a table of contents, Word and InDesign can both dynamically
generate hyperlinked indexes, but a Word-generated index will survive the import only as
unremarkable static text.

(Include) Footnotes and Endnotes Unlike its treatment of a table of contents or an index,
InDesign will preserve the dynamic nature of Word's footnotes and endnotes. Footnotes and
their references will be imported and, if they differ from the footnote settings in the InDesign
document, renumbered in accordance thereto. Endnotes will be inserted as formatted text at the
end of the imported story.

Use Typographer’s Quotes Just as with plain-text import, this option will convert inch and foot
marks into quotation marks and apostrophes, respectively. Again, this can be a gotcha if your
document contains legitimately used marks for measurements, time, or geographic coordinates.

Remove Styles and Formatting from Text and Tables Because Word documents are fully
rich text, the text in them can be emboldened, italicized, underlined, straelethrersh, and even
a eonbination thereof. If the author of the Word document knew what he was doing, you'll
probably want to leave this radio button set on Preserve Styles and Formatting from Text and
Tables. If, however, the Word document author went format-crazy, choosing to remove styles
and formatting (along with unchecking Preserve Local Overrides) will strip off all the format-
ting and styles, importing clean text ready for proper formatting in InDesign.

PLACE INTO MIDDLE

Need to place an external text document into the middle of the text already in a frame? Just put the cur-
sor in the right spot and import with Show Import Options checked. Remove styles and formatting and
the inserted text will automatically inherit the style and formatting of the text into which it’s inserted.
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Preserve Local Overrides When Remove Styles and Formatting from Text and Tables is
selected, this option becomes available. Off, it completely wipes all formatting from imported
text—bold text is unbolded, italicized type is returned to standard roman type, and so on.
Check it, however, and all the styles (aka style sheets) will be wiped away but individual text
formatting options like bold, italic, underline, and so on will survive the import.

Convert Tables To (Accessible only if Remove Styles and Formatting from Text and Tables is
selected.) If the imported text contains tables, how would you like them treated? Would you
prefer them imported as InDesign tables (Unformatted Tables), or would you rather convert
them to tab-separated text (Unformatted Tabbed Text), which can then either be formatted as
such or manually converted to an InDesign table?

Preserve Styles and Formatting from Text and Tables All text formatting and assigned styles
are preserved. On by default, and required for any of the following choices to be accessible.

Manual Page Breaks Word, InDesign, and most other word processor and page layout appli-
cations offer the ability to insert break characters that stop text anywhere on the page and jump
it to the next page before continuing. The three options in this drop-down offer the choice of
keeping page breaks as defined in Word, converting Word’s page breaks to InDesign column
breaks—instead of picking up on the next page, the text will start up again in the next column
of a multicolumn InDesign layout—or dumping Word'’s page breaks altogether.

Import Inline Graphics Generally a bad idea from a print professional’s perspective, Word has
the ability to embed graphics and imagery directly in the flow of text. Typically, graphics inserted
in this manner do not link to their original files; they’re contained entirely within the Word
document. Employing this feature is a very common practice among Word users inexperienced
in professional print workflows. Checking Import Inline Graphics will bring those embedded
images into InDesign as embedded, anchored objects (which are discussed in Chapter 6, “Objects”).
Unchecking it will flush those images out of the text as if they never existed.

Import Unused Styles Like InDesign, Word allows for reusable paragraph and character
styles. Below you’ll decide what to do with styles assigned to text in the Word document, but
this option applies to styles that are not used but are available to be used within the Word docu-
ment. In most cases you want this option unchecked to avoid cluttering your InDesign
document with Word’s numerous default and user-created styles.

Track Changes In InDesign this option does absolutely nothing. Check it or don’t; it makes
no difference. In InCopy, however, it does do something. If Track Changes was active in the
Word document, and if this option is checked here, basic Word change tracking is preserved.
Text deleted in Word will carry into InCopy as deleted (struck through), and inserted text will
be highlighted.

Convert Bullets and Numbers to Text Should the bullets and numbers in Word’s dynami-
cally created lists continue to be dynamic, updating as necessary (especially numbered lists),
or should they be converted to regular, editable text for selection and manual styling?

Style Name Conflicts A yellow caution sign appears if both the Word and InDesign docu-
ments contain styles with the same names. To the right of the caution sign the number and type
of conflicting styles are noted. The next few fields determine how those conflicts are resolved.

Paragraph and Character Style Conflicts Choose whether to use InDesign’s style definitions,
disregarding Word’s; redefine the InDesign styles to match those coming from Word; or add
the Word styles as new styles automatically named to nullify the conflict.
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@ Real World Scenario

POWER T1P: RAPID STYLE IMPORT

Although you generally want to leave the Import Unused Styles option off in the Microsoft Word Import
Options dialog, it does present an incredibly useful shortcut that can save hours or even days of work.

For instance, collaborative publishing workflows such as book, newspaper, and magazine teams usually
consist of one or more writers creating original content in a Word template and designers accepting writ-
ers’ Word files for placement into InDesign. The Word template from which writers create their chap-
ters, articles, ad copy, and other text invariably contains a set of styles they are required to use—headlines
must be assigned the “Head” style, kickers the “Kicker” style, bylines the “byline” style, and so forth.

Suppose your publication is in the middle of a redesign or migration and you need to rebuild your publi-
cation template(s) in InDesign. You can manually re-create all the styles needed to format stories, or you
could simply import the writers’ Word template while checking the Import Unused Styles option. That
would import all the styles from the Word document, even styles like “sub-sub-list” that are only occa-
sionally used. The styles will still need to be updated in InDesign to make them native, but that’s just a
simple matter of opening them and glancing through all the options. It’s much faster than creating all
those styles again from scratch.

Sometimes InCopy stands between Word and InDesign, with editors taking original content Word files
into InCopy and then furnishing revised InCopy stories to InDesign layout artists. InCopy, which is effec-
tively InDesign for editors and without frame creation tools, has the same Microsoft Word import options.
Thus, the same power tip applies if your editors are taking the Word files into InCopy instead of you tak-
ing them into InDesign.

Customize Style Import Checking this option and clicking the Style Mapping button opens
the Style Mapping dialog (see Figure 2.6), wherein all the styles in both documents are listed
side by side. An entry of [New Paragraph Style] or [New Character Style] denotes the lack of
conflict and that a new style will be created in the InDesign document to match the Word style.
Any conflicts—where both columns have a non-bracketed style entry—can be resolved by
clicking the style name in the InDesign Style column. A drop-down menu will appear present-
ing all styles present in the InDesign document, allowing a custom mapping from the Word
style, as well as conflict resolution options matching those from previous dialog’s drop-downs.
The button at the bottom of the Style Mapping dialog tells InDesign to create new, similarly
named styles based on the incoming, conflicting styles.

Save Preset (button) As you can see from the length of my walk-through, there are quite a
few decisions to be made when importing Word documents. The options you choose may be
the same for every subsequent Word document you ever import, or documents from different
sources or for different purposes might require alteration of these settings. If you anticipate
more than a single setup—or you merely wish to ensure you don’t lose your Word import
option customizations, save a preset by clicking this button, naming the preset, and clicking
OK. Thereafter, all your settings are ready for instant re-application from the Preset drop-down
menu at the top of the dialog.
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FIGURE 2.6 Style Mapping
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In this example, we want to select Preserve Styles and Formatting from Text and Tables and
Use Typographer’s Quotes. Everything else is irrelevant to this particular file—an article.

Click OK on the Microsoft Word Import Options dialog and the Word document will flow into
the text frame exactly as our prior documents did. Note that it’s already formatted with type and

paragraph styling.

TEXT COPY AND PASTE

You can also copy text from just about anywhere to paste into InDesign. As long as what you copy hits the
operating system’s clipboard as text (as opposed to outlined type or an image), InDesign will take it on
paste. Text can also be copied from InDesign into most other text-handling applications, although how
much of the styling survives the paste depends on the target application.

PLACING WITHOUT A FRAME

It happens all the time: You're working away, on a roll, and press Cmd+D/Ctrl+D, grab a text file,
and realize you forgot to first create a frame. Well, unlike in QuarkXPress, you need nof have a
frame in order to place content. True, all content must be within a container, but InDesign is savvy
enough to make the container while you place the content. Give it a try.

1. Deselect all objects by clicking an empty area of the page or pasteboard.

2. Choose File > Place, and select a textual file—one of the sample documents from this chap-
ter should suffice. Hit OK.

3. Back in the document, you should notice a new type of cursor—a loaded cursor (see
Figure 2.7). It even has a preview of the text you're about to place!

FIGURE 2.7
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4. With the loaded cursor, click and drag out a rectangular area. The story will place, giving
you both content and container in one swift action.

You can keep going like this, placing content without pre-created frames, throughout the entire
document.
Which textual file formats can InDesign place within text frames? Plenty! Table 2.1 shows you.

TABLE 2.1:  Textual File Formats Supported by InDesign

FILE EXTENSION DOCUMENT DESCRIPTION
.incd, .incx InCopy CS2—-CS3 documents
.incd InCopy CS stories

.doc Microsoft Word (versions 2—2007)
.x1s Microsoft Excel (versions 4—2007)
.rtf Rich Text Format

.txt Plain text

Ltxt Adobe InDesign Tagged Text

To place content from a WordPerfect file, use RTE. WordPerfect and all other word processors
can export to RTF with minimal loss of feature and formatting; many word processors even save
directly into RTF without the need for a second, proprietary format.

FILL WITH PLACEHOLDER TEXT

Now that you've got how to place text, there’s an even faster way to fill a frame if all you need is
FPO copy. Create a new text frame with the Type tool. With the I-beam cursor in the frame, go to
the Type menu and, second from the bottom, choose Fill with Placeholder Text. The text frame will
pack with gibberish FPO copy.

Fill with Placeholder Text automatically fills a text frame, however large. It also uses whatever
typeface, size, style, and paragraph settings are currently in effect. For instance, if 12/14.4 pt Myr-
iad Pro is the default type setup, Fill with Placeholder Text will fill the frame with 12 pt Myriad
Pro on 14.4 pt leading.

InDesign’s default placeholder text closely approximates real text with variable-length words,
lines, and paragraphs. It’s all still gibberish, but it could be real copy. If you’d rather it be some
other kind of gibberish, like Lorem Ipsum, the Declaration of Independence, or Elmer Fudd recit-
ing act IV scene I of Shakespeare’s Macbeth (“doubwe, doubwe, toiw and twoubwe”), changing
InDesign’s default placeholder text is a breeze. Place the text you’d like to use in a plain-text file
named Placeholder. txt, and save it into the InDesign folder. On Windows, you'll find the InDesign
program folder in the following path (if you chose the default location during installation):

C:\Program Files\Adobe\InDesign CS3
On Mag, it’s here:

Applications/InDesign CS3
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COUNTING WORDS IN A TEXT FRAME

Editors and writers with whom you work frequently measure text by word count. How many words
fit in this part of the page? Can you find a place to slap in this 700-word article? Of course, that means
designers have to build and style text frames to hold a specified number of words.

When you're dummying up a layout with FPO copy, how can you know how many words fit
in a given frame—and, thereby, how many frames are required per page, how many pages to carry
an article of set length, and so on? Don’t go running back to Word. InDesign actually has a pretty
good word counter. It’s called the Info panel (see Figure 2.8).

FIGURE 2.8 m— -
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Select the Type tool, and put the cursor anywhere within a text frame’s copy; don’t highlight
the text. The bottom of the Info panel will change to count characters, words, paragraphs, and
lines throughout the entire story. Any figures after a plus sign (+) are overset—mnot visible in any
text frame. The counts include text in any linked frame, on any page, and count everything in
the story regardless of style—headlines, kickers, bylines, run-in captions, and so forth—but not
text in other frames.

To find out how many characters, words, paragraphs, and lines fit within only a single text
frame or paragraph, highlight the text in question. Statistics on the Info panel will revise to reflect
only the highlighted text. In Figure 2.9, for instance, you can see the statistics for the first body
copy paragraph of REVstory.doc.
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If you'd like a somewhat more visual word counter, one that appears in the text itself and sur-
vives printing or export to PDF for the benefit of writers, editors, or clients, check the Chap02 folder
again. In addition to the files we’ve worked with so far, I've included Copyfit. txt, which contains
only 5-letter words and marks every 25th word with a running count up to a total of 1,000 words.

Text Frame Options

Creating and filling text frames is only half the job. You'll frequently need to set up multiple
columns, change insets, and once in a while, even muck with the vertical justification within the
frame. InDesign has these options organized in the Text Frame Options dialog, although some
appear elsewhere, too.
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With a text frame selected, press Cmd+B/Ctrl+B, or choose Text Frame Options from the Object
menu (see Figure 2.10).

FIGURE 2.10 Text Frame Options
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When creating a new document, you're offered the option of specifying a number of columns and
the width of the gutter, the space between text columns. Setting that in the New Document dialog
has one or two outcomes.

First, it creates for the columns guides that are evenly spaced between the margin guides. With
an 8.5X11-inch document and 1-inch margins all around, specifying two columns with the default
0.1667-inch gutter will create guides defining two columns of equal width—that being 3.1667 inches
per column. The center of the gutter rests in the center of the page, at 4.25 inches. If you also check
the Master Text Frame box, the second consequence kicks in, which is to create on the master page
and all document pages based thereupon a text frame containing two columns matching the
width and location of the guides.

That'’s all well and good if you want two equal columns perfectly aligned on, and filling, the
page inside the margins. But, setting column options in the New Document dialog becomes a
hindrance if you want something else—two separate stories flowing, a sidebar, or columns of dif-
ferent widths. If you need any of these, or decide on columns after beginning the document, use
Text Frame Options instead to set up and control your columns.

Check the Preview box at the bottom and you'll be able to watch how the text frame reacts to
column changes live.

The Number field is, obviously, the number of columns. Regardless of the number here, you're
dealing with only a single text frame. Because InDesign merely divides a single frame into internal
columns, you can resize the frame (outside the Text Frame Options dialog) and all columns will
contract or expand as needed.

And that’s a nice segue into...

What is the purpose of the Width field? Good question. Change the number of columns by clicking
the up/down arrow buttons while watching the Width field. Notice how the width changes?
Right: InDesign is maintaining the width of the frame and the width of the gutter and altering the
column width to account for the column count.
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Let’s say you didn’t want that. Let’s say you know for certain you need 1.75-inch-wide columns,
but you aren’t sure how many will fit in your layout. Check the Fixed Column Width box. Now,
instead of the column width being variable while the frame width is fixed, the opposite is true:
columns will always be 1.75 inches, and the text frame itself will expand or contract horizontally
to accommodate the specified number of columns.

If you manually resize the text frame on the page with Fixed Column Width checked, the frame
will resize only in whole column increments. This is a stellar way to build redesign templates for
multicolumn publications.

Most of us have heard the space between pages referred to as the gutter. InDesign tries to elimi-
nate confusion by stating that gutter is the distance between columns, and that the inside margins
and spine make up the area of binding or the space between pages in a spread.

When setting column gutters, more is more (within reason). A common mistake is to set gutters
that are too slender in an attempt to fit more copy on a page. Don’t fall into that trap.

Gutters separate columns of text. That separation—and thus gutters—is absolutely critical to
document readability. If a gutter is too narrow, the reader’s eye will jump across the gutter and
run together two disconnected sentences. Readers also have a difficult time coming back from
wayward excursions to other columns to find the beginning of the actual next line—it will be
twice as hard if they aren’t reading the leftmost column and have to contend with too-narrow
gutters on both sides of what they’re reading.

Want a rule of thumb? Column gutters should rnever be less than the point size of the typeface,
but even better is 150 to 200% of the type size. Anything more than 200 to 250% begins to discon-
nect columns.

INSET SPACING

Indents push text selectively—a paragraph pushed in here and there, but not everywhere—while
insets push everything in uniformly. If you want to indent a kicker paragraph or body copy, leaving
subheads out to the margin, employ paragraph indents (see later in this chapter). However, if
you've given your text frame a background color or stroke, you want to make sure no text bumps
up against the edge, so set an inset (aka internal margins, frame margins, frame/box padding, and
border spacing). You can see the difference between indent and inset results in Figure 2.11.

FIGURE 2.11 [
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nulla facilisis at vero cros et accumsan et iusto odio dignissim qui blandit praesent
luptatum zzril delenit augue duis dolore te feugait nulla facilisi. ¢
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The four fields can be set to push in from the four sides independently—say, to give only top or
bottom inset while leaving left and right sides flush—or, by checking the chain-link button, all
four can be made uniform. In the latter case, altering the value of one simultaneously changes the
other three.

Only a single inset field will be available if working with nonrectangular text frames.

It absolutely kills me when I see professionals not using insets, opting instead to layer a text
frame atop an empty colored or stroke frame—and I see it often. Why would someone do that?
Because that’s the way they’ve done it for years.

Text frames can be filled with color—CMYK, RGB, Lab, spots, tints, even gradients—they can
be stroked with any style or color, they can have drop shadows and other effects, and, now in CS3,
the frame fill and stroke opacity and blending modes can be set independently of text opacity and
blending mode. Most of these options have been available since InDesign 1.0. Creating two objects
to do the job one is capable of doing doubles the work necessary to create the same effect and dou-
bles the work of maintaining it. It’s half as much work to move or resize one frame than it is two.
Say it with me: Working efficiently gives me more time to be creative.

InDesign, unlike some other programs, does adjust column width (or column count if you're
using fixed column widths) to compensate for inset adjustments. So, no reason to go back to the
two-object-tango there.

VERTICAL JUSTIFICATION

When there isn’t enough copy to fill a column or frame, where do you want the text to be—the top
of the frame/column, the bottom, centered, or spread out and vertically justified? That’s the ques-
tion asked by this option. Figure 2.12 shows the four possible options.
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If you choose Justify from the Align list, the Paragraph Spacing Limit measurement field acti-
vates. When it’s set to 0 inches, anything is possible—a single line could appear at the top of the
frame and another single line at the bottom. To take more control over the situation, to tell InDesign
that you want no more than X inches inserted between paragraphs and lines within paragraphs,
set the measurement here. If there aren’t enough lines to fill the space without violating your spac-
ing limit, InDesign will align to the top and spread down as far as it can without violating the
limit you set.

FASTER COLUMNS & JUSTIFICATION

If all you need to do is change the number of columns or the vertical justification, you needn’t go
all the way into the Text Frame Options dialog. They’re probably on the Control panel in a very
simplified form. I say “probably” because it depends on your screen size. The number of columns is
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always accessible on the Control panel in Paragraph mode. Vertical alignment buttons only appear,
however, if your screen is set wider than 1024 pixels. All the default Control panel options are
included within the first 1024 pixels. After that, prior versions of InDesign left wasted space; CS3
makes better use of it by including additional options you might find useful from time to time.
Among those that appear when you have a text frame selected with the Selection tool are the Num-
ber of Columns field and buttons to change vertical justification modes, as shown in Figure 2.13.
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Paragraph Formatting

Now that you’ve got the hang of placing text and working with basic frames, let’s get down to
what can be done with it.

Most paragraph formatting is controlled via the Paragraph panel (Window > Type & Tables >
Paragraph). Figure 2.14 shows the complete Paragraph panel after choosing Show Options from
the panel’s flyout menu. If you're familiar with InDesign CS2, most of the CS3 version is identical,
although a few new gems like Define Lists and Restart/Continue Numbering are found here.
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Alignment

Along the top row are buttons for the nine types of paragraph alignment possible within InDesign:
Align Left, Align Right, Align Center; Justify with Last Line Aligned Left, Justify with Last Line
Aligned Centered, Justify with Last Line Aligned Right, Justify All Lines; Align Toward Spine, and
Align Away from Spine. Setting aside the last two for a moment, the first three are self-explanatory.
The middle four, the justify options, often cause confusion however.
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FLUSH, RAG, RAGGED, QUAD?

If you’re reading this book, you know at least one of those terms—probably a couple. Did you know they
all mean effectively the same thing? The first time [ heard quad right, 1 was a newly hired layout artist coor-
dinating a job with my firm’s service bureau for the first time. As is typical of print production, the new
guy was quizzed. 1 passed with flying process colors until the prepressman asked me if the copy was
quad left or quad right. That phrase tripped me up.

The flush edge, to which text aligns, is also known as the quad. Thus, left aligned is flush left is quad left;
right aligned is flush right is quad right. Opposite the flush edge is the ragged or just rag edge, referring to
the fact that it isn’t a clean, flush edge as it would be in full (both side) justification.

Fully justified text can be referred as such, or as flush left and right, just plain flush, forced, forced justified,
no rag, and, just once by a New Zealander, double-clean type.

Saying text is forced quad right is to say that the paragraph is fully justified—both left and right—but also
specifically qualifies the last line as aligned to the right.

The middle four alignment buttons, which justify entire paragraphs to both flush left and flush
right (full justification), differ only in their treatment of the last line of the paragraph. As you can
see in Figure 2.15, that can be a dramatic difference.
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Aligned Right
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Justify All Lines

If you choose Justify All Lines, watch the last line carefully. It will be spaced out to fill the
width of the column regardless of its content; if there’s only a single word on the last line, the
characters of that word will be pushed apart to fill the space. You can often see similar results in
newspapers, when a narrow, fully justified column contains a line wherein neither the previous
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nor the next words were able to squeeze into the line and only a single word is stretched to fill the
entire width of the column.

When the Paragraph Composer is active instead of the Single-Line Composer, InDesign will attempt
to compensate for short last lines in paragraphs set to Justify All Lines. Often, as in Figure 2.15,
word and character spacing throughout the rest of the paragraph will be adjusted to completely
absorb the last line, resulting in better last line appearance but with potentially tighter tracking
and word spacing throughout the entire paragraph.

ALIGNMENT RELATIVE TO SPINE

Introduced in CS2, the Align Toward Spine and Align Away from Spine options are phenomenal
inventions for anyone who deals with facing-page, bound documents. The first button aligns text
in the direction of the spine, the other aligns away from it. On a left-read page, text aligned toward
the spine will be flush right; move the same text frame over to the right page in the spread, how-
ever, and the text will automatically jump to be left-aligned.

Technical books, catalogs, magazines, reports, newspapers, and numerous other multi-page
publications often set heads, subheads, captions, photo credits, pull quotes, and, especially, header
and footer slugs to align toward or away from the spine. When pages get pushed around or text
reflows due to an addition, omission, or formatting changes, designers have typically had to go in
and swap alignments manually. No more. Just choose one of these two buttons and text will swap
its flush edge all by itself as it moves from a left- to a right-read page and vice versa.

Left and Right Indent

Indents push the entire paragraph inward from the frame edge. Use these for selectively control-
ling the width of paragraphs. Do not, however, use indents if you want to push all text in the frame
inward from the frame edge because you've filled or stroked the frame. Instead, use frame insets,
which we'll get to later in this chapter.

POWER TIP: CLICK ICONS TO SELECT FIELD CONTENTS

In many of InDesign’s measurement fields, including the indent fields on the Paragraph panel, you can
click and drag to highlight or select the contents and then type over the contents to change. But there’s a
faster way. Click once on the icon to the left of the field. For instance, in the Left Indent field, click the lit-
tle icon to the left of the up/down arrows. That will automatically select the content of the field without
the often hit-or-miss click-drag selection method.

Like most of InDesign’s fields, the Left and Right Indent fields can be controlled by typing in
values, by using the up/down arrows beside the field, or by using the keyboard arrows. With the
cursor in the field, pressing the up or down arrow on the keyboard will increase or decrease the
indent by predefined increments (by 0.625 inches each if your document is set to use inches as its
measurement, by one point if using points, and so forth). Holding Shift while pressing the up or
down arrow will adjust the indent by larger increments (0.25 inch or 10 pt).

Separating Paragraphs

When setting stories of more than a single paragraph, you must somehow signal to the reader that
one paragraph has ended and another begun. There are various ways to do that, including drop
caps, rules, and outdents (where the first line is farther left than the rest of the paragraph). Vastly
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more common are two other methods: vertical spacing between paragraphs and first line indents.
Which of the two you choose depends on your design—they can sometimes be combined success-
fully, too.

First line indents require less space typically, allowing a few extra lines of copy to fit on a page,
but the trade-off is less white space and fewer places for the reader’s eye to rest. Figure 2.16 shows
both first line indents and paragraph spacing. Notice where the same red-colored phrase appears
in both as well as the difference in visual density between the two sets of copy. In the example, the
first line indent is 2 ems (24 pts for 12 pt type) while the paragraph spacing in the second frame is

10 pts.
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Below the left and right indent fields in the Paragraph dialog (Figure 2.14) is the First Line Left
Indent field, which controls the indentation value of just the first line of selected paragraphs. This
field accepts positive measurements as well as negative measurements up to the inverse of the Left
Indent field. Negative values, of course, create hanging indents (see Figure 2.17).

As you can see in Figure 2.17, indenting the whole paragraph a certain amount and outdenting
the first line using a negative value in the First Line Left Indent field enables margin heads, resume-
style entries, and custom bulleted or numbered lists. InDesign includes a more automated way to
make bulleted and numbered lists, which we’ll get into later in this chapter; knowing how to do
it manually, however, is important for those times when the built-in Bullets and Numbering just
doesn’t cut the mustard (for example, when you want to adjust the baseline shift of a bullet or
number character).

If you're accustomed to doing hanging indents in Microsoft Word, we should go through it in
InDesign—it’s a whole different animal.
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In Word’s Paragraph dialog, on the Indents and Spacing tab, indentation is handled through
three fields. Left and Right work the same as in InDesign, but the Special field, a drop-down list,
determines whether the first line indent value (the measurement field to the right) is positive or
negative by the option chosen. Selecting First Line from the list creates a positive indent where the
first line pushes into the paragraph. Selecting Hanging pushes everything but the first line inward,
creating an outdent on the first line. InDesign simplifies the process (thus making it less obvious)
by eliminating the Special menu and allowing the First Line Left Indent field to accept either posi-
tive (indent) or negative (outdent/hanging) values.

Referring back to the resume example (Figure 2.17), the settings I used for the body paragraph
hang the employer name out to the left while indenting the rest of the paragraph. Between the
employer name and the job description is a tab whose stop was set to mirror the left indent value—
1.625 inches. Note that, in my resume entry, the left indent is 1.625 inches while the first line is only
-1.5 inches. The difference of 0.125 inches leaves enough room for the custom bullet, which is an
anchored graphic frame (indicated by the yen symbol [¥]).

The Left and Right Indent fields accept only positive values, while the First Line Left Indent field
will accept either. A negative value for the first line may be up to the value of the Left Indent field.
You can't, say, set a —2-inch first line when the left indent is only 1-inch. Nor can you pull the entire
paragraph beyond its frame’s (or column’s) borders by setting left or right indents to negative
values. Word will let you do that, but InDesign content can’t violate the boundaries of its container
(paragraph rules are an exception, as you'll see later in this chapter).

When setting positive indents on the first line of body copy paragraphs, the rule of thumb is
that the indents should usually be 1 to 2 ems, with an em being equal to the font size. Thus, the
indent on 10 pt type should be 10 or 20 points. Of course, this is only a best practice guideline, and
larger or even smaller indents may be dictated by style, column width, and typeface.

Book publishers tend to follow the 1 to 2 em rule for most of their titles but will deviate when a
template’s style warrants it. Magazine and newspaper publishers usually follow the same rule.
Copywriters tend to stick with the Tab key in Word, which inserts an indent on the default half-
inch tab stop. Indeed, largely because of Word, many people believe bigger is better, that any indent
less than one half inch is unprofessional and that one-inch indents are often preferable.

Instead of, or in addition to, indents, spacing between paragraphs creates breathing room. The
two fields in the next section of the Paragraph panel control the spacing above and below para-
graphs, with similar vertical measurement controls to the indents” horizontal controls.

InDesign suppresses spacing before paragraphs that appear at the top of a frame or column as
well as spacing after when paragraphs are at the bottom of a frame or column.
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Last Line Right Indent

The Last Line Right Indent field, which controls the indentation on the last line of a paragraph,

works identically to the First Line indent with positive values beginning at the right edge.
Depending on the work for which you employ InDesign, you may use this field constantly

or never.

It’s most often useful for catalogs, classifieds, directories, price lists, and other list-style copy

where paragraphs are fully justified and the last line ends with a particular type of information—an
SKU, phone number, accreditation acronym, price, or similar bit of information. I've used it in a
“magalog”—or “catazine”—style entry complete with Sky Mall-like hyperbolic copy (Figure 2.18).
There, the paragraph is justified with last line aligned right. A tab separates the end of the copy
from the SKU (no tab stop customization needed because of the alignment). Once tabbed out, the
SKU pushes 0.2 inches in from the flush edge with the Last Line Right Indent field. As small and
simple a trick as it is, that little bump of white space attracts the reader’s eye—even more so than

emboldening the SKU.

FIGURE 2.18 A.»REV.-Creativity Drink-24-Pack ($21.99)7
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matting a SKU . o .
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than messing last-minute - deadlines-and to-overcome-designer’s-block. . With.a-can. of
with tab stops REV.Creativity Drink-in-your-hand, you'll. never-be-left staring-uninspired
and creates white at.a.blank page-again! » Item #19720318¢#
space to attract
the reader’s eye.

Almost as important as signaling when a new paragraph begins is some kind of indicator
denoting the end of paragraphs. With full justification, every paragraph becomes a perfect block; a
last line right indent can restore the cue that the paragraph has ended while still maintaining a
(usually) more symmetrical result than left-aligning the last line.

Another use for this field is to add some variety to, and mitigate word and character gaps cre-
ated by, full justification.

Drop Caps

Not that long ago, the only way to create decent drop caps was by creating a separate text frame
containing only the enlarged cap, with a text wrap or runaround assigned to that frame. The initial
cap itself would have to be removed from the main story, tripping up spell check and making
more work for the layout artist if the copy reflowed or if an editor changed the opening word of
the story.

InDesign does drop caps a lot more elegantly via the last two measurement fields on the Para-
graph panel (see Figure 2.19).

Instead of specifying the size of the drop cap in points, you'll define its height only, and that in
the number of lines to drop in the Drop Cap Number of Lines field. Technically speaking, the
drop cap is therefore measured by multiples of the leading rather than the font size itself. A three-
line drop cap in 9/12 pt type, for instance, is 36 pts tall. InDesign will scale the horizontal dimen-
sion of the drop cap to match its height.

The dropped cap will be created and sized, and all other text wrapped around it, in one
simple step.
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The best part is that it’s totally dynamic because the drop cap is a paragraph styling attribute.
The drop cap is still part of the first word of the story, which means spell check continues to see
the complete word, and if the copy must change, you just change it. Type over it. InDesign will
take the new first character and convert it to a drop cap on-the-fly.

Drop caps of more than one character are also possible—just raise the Drop Cap One or More
Letters field value above one (see Figure 2.20).

FIGURE 2.20 there was-a gentleman who mammed. for Ius second wile
The first word drop- O n C e_the proudest-and-most-haughty- woman that-was.ever.
capped by setting seen.-She-had by-a: former - husband two-daughters-of her
the number of let- own-humor, who were, indeed, exactly like her m-all things. He had likewise, by

ters to four : :
another wife, a-young daughter, but of unparalleled goodness and sweetness ol
temper, which she took from her mother, who was the best creature in the world
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began to show herself in her true colors.. She could not bear the good qualities of
this pretty.girl,-and the less-because - they made -her own.daughters-appear-the more-
odious. She employed her in meanest work of the house: she scoured the dishes,
tables, ete.. -and scrubbed madam’s chamber and- those of misses, her daughters:

she lay up in a sorry garret, upon a wretched straw bed. while her sisters lay in fine
rooms, with floors all inlaid, -upon beds.of the-very newest fashion, and where-they-
had looking-glasses so large that they might see themselves at their full length
from head-to footy
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Because they're simply normal characters in the text flow, drop caps can be individually selected
and styled like any other letter. You can color them differently, assign a specific typeface, kern and
track, adjust their baselines, and even scale them horizontally or vertically (see Chapter 3, “Char-
acters”). When setting a drop cap in a different typeface from the text into which it drops, you're
much more likely to get disparate sizing and spacing. Manually tweaking scaling, baseline offset,
and kerning will become especially important in such cases.

When creating drop caps of one or more characters, watch the horizontal composition. If you
set too large a drop cap or a drop cap consisting of too many characters and InDesign can't fit the
rest of the copy beside it, the whole story could become overset until you either widen the column
or reduce the size or count of dropped cap letters.

HANGING DROP CAPS
If you want your drop cap to hang farther left than the text it’s a part of, there are two methods.

In the first, put a positive left indent on all text and a negative first line indent just on the paragraph with
the drop cap. This is the easier method to accomplish, but it requires more compromises.

The other method, which takes a little more initial effort, is more flexible and involves fewer long-term
consequences to worry about six pages later. Do this:

1. Before the drop cap, insert a hair space.

2. Set the Drop Cap One or More Characters to two characters to account for the space and the
actual cap.

3. Insertyour cursor between the hair space and the drop cap, and kern the two together with large
negative numbers. As you do, you’ll be pulling your drop cap out to the left and past the edge of
the text wrapping around the cap. The cap will overlap and eventually surpass the thin space.

We'll cover the last option in the Paragraph panel, baseline grid alignments, in Chapter 8,
“Stories,” where it will make more sense.

Paragraph Composition
The devil, as the saying goes, is in the details. Composition—putting text together—is about detail.
Whether you produce passable text or good type is a matter of composition.

You may have heard (even before I said it in this tome) that InDesign is the world’s most advanced
typesetting and text rendering platform. Of course, its unprecedented support for OpenType fonts
and their features, the ultra-fine control over every aspect of character appearance, and numerous
other features are part of InDesign’s claim to that title; what really earned it the title, what keeps it
head and shoulders above the competition, is InDesign’s next-generation composition engine.

Let’s talk about that, beginning with the first thing most cite as InDesign’s single greatest feature.

Paragraph vs. Single-Line Composer

What is a composer? In this context, a composer is the software engine that figures out how to fit
words and lines together in a paragraph to maximize readability and the flow of the reader’s eye
between words.
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In paragraph text, when lines of type must wrap, every text-handling application—InDesign,
QuarkXPress, Microsoft Publisher, Serif PagePlus, Microsoft Word, even your web browser and
email client—is making decisions. The application is fed too much text to fit on a single line within
the horizontal space allowed, and it must decide which words will fit and which won’t, when to
insert a soft line break and send subsequent words to the next line. This is the act of composing text.

Composers can be dumb—as in the case of web browsers and email clients—presenting mono-
spaced words until one simply won't fit, and then wrapping the line after the last word that does fit.

Other applications—QuarkXPress, Microsoft Publisher, Serif PagePlus, and Microsoft Word—
are of normal, everyday intelligence. They render words on a line until one won't fit, but then they
look for a way to break (hyphenate) the word that won't fit. They also go back and look across the
line for places where a slight expansion or contraction of the spaces between words might enable
the last word to fit better or where it might enable a better hyphenation choice. This—normal
intelligence composition—is single-line composition—the composer looks at the entire, but only,
current line of text to determine how to handle that last word of the line.

Finally, you have the genius composers—Mozart, Beethoven, Brahms, InDesign.

On the Paragraph panel’s flyout menu is the choice between Single-Line Composer and the default
Paragraph Composer. In Single-Line Composer mode, InDesign does what other single-line com-
posers do—evaluates its spacing and hyphenation and options one line at a time without regard
for the impact on subsequent lines or the effect on the paragraph overall. The Paragraph Com-
poser does the opposite. It looks at every line, every word, every character, and every space in the
paragraph. It goes far beyond just how to best end the one line; it asks itself the following questions:

How do I make this entire paragraph more readable?

How do I dam rivers?

*

How can I even out the ragged edge if the text isn’t fully justified?

How do I reduce the likelihood of runts?

*

*

If I'm hyphenating, how can I do it in such a way that all my other priorities are met with-
out hyphenating lines too close to one another?

Rivers are those threads of white that develop from the near-vertical alignment of spaces
between words. You see them often in just about any output from single-line composition soft-
ware, but especially when text is fully justified. Newspapers are the worst. The price of InDesign
would be worth it if the Paragraph Composer did nothing but eliminate rivers, which it does
almost entirely.

Figure 2.21 shows the difference between a passage of text set with single-line composition and
one set with paragraph composition. Both are set to full justification with first line indents and are
reminiscent of newspaper columns set with applications other than InDesign.

The first thing that should jump out at you is the big honking spaces in the upper set, particu-
larly in the last lines of paragraphs. Look at the first paragraph. That last line is two words, with
the column width the words don’t fill plunked between them. In the second column it gets even
worse with single word runts letter-spaced out to fill the column width. If you squint, you'll even
see several short but distinct rivers.

Compare the two paragraphs, noting the absence of big spaces in the set composed with the
Paragraph Composer. Even that set, with the size of text and column, isn’t great, but it’s a heck
of a lot better than the upper text frame. Notice how it isn’t just better word and letter spacing;
InDesign eliminated the problems the upper set has at the end of paragraphs by absorbing runts
into their host paragraphs through spacing adjustment throughout. The lower set even managed
to squeeze an extra line of text in there at the end.
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Because InDesign evaluates an entire paragraph in order to weigh its options and make decisions
about where and how to break lines, it happens on-the-fly, as you type. Fix a typo on line six and
the entire paragraph may recompose.

It’s not uncommon to be typing while lines above change, breaking differently, words spacing
differently, with every character you type.

In some cases you want total, manual control over how and where lines wrap. Often you sim-
ply need to adjust justification and/or hyphenation options or tell InDesign not to break certain
words or phrases. At other times, you really do want to break lines yourself with manual line
breaks (Shift+Return/Shift+Enter). Paragraph Composer will make that difficult, so toggle it
over to Single-Line Composer by selecting the frame or paragraph (or putting your Text tool
cursor in the paragraph in question) and selecting the Single-Line Composer on the Paragraph
panel flyout menu.
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Justification Options

This is not about left or right aligned. Justification options are about fine-tuning the limits of both
single-line and paragraph composition decisions regarding word and letter spacing and more (see
Figure 2.22). You'll find Justification on the Paragraph panel menu.

FIGURE 2.22
Justification options Minimum Dested  Maximuim ok
dialog Word Spacng: [0% [roow  fudsw
Letler Spacing: [D%— ,r [r Cancel
Ghph Seaing: [1ooe J1o0% oo v Proview

Autn Leading: [170%,
single Word Justification: Full Justfy -

Composar: Adobe Paragraph Composer -

If you open this dialog with text or a text frame selected, the preview option will tell InDesign
to recompose on-the-fly as you change options.

Presented with three columns of options are control over how InDesign adjusts the spacing of
words and individual letters and whether and by how much you’ll allow it to adjust character
horizontal spacing. The first column, Minimum, is the bare minimum amount of the whole you'll
allow InDesign to reduce spacing or scale. By default, for example, Word Spacing is set to 80%.
That means InDesign is allowed to squish the full space between words down to 80% of a space; if
composition requires a smaller space or a line will break, InDesign will break the line. Desired is
how much you want—typically 100% (a full space) for Word Spacing, 0% (no space) between let-
ters, and 100% of horizontal scale for Glyph Scaling. Maximum is the widest space you'll allow
InDesign to employ.

As you may have deduced from the fact that the default settings were in use in my single-line
composition example above, wherein a two-word line had a massive space between words and
several lines included single words with their letters spaced way out, what you set in here is a
guide, not a rule. InDesign tries to meet your guidelines, but given less savory choices, it will
violate the options in Justification.

Auto Leading, which is, in most programs, situated somewhere in the Preferences, is where
you set the default leading percentage for InDesign. We'll get into that in the next chapter.

Flip back to the composition examples in Figure 2.21, which we were looking at a couple of
minutes ago. Remember those single words spaced to fill the line? That happened because I had
the paragraph set to full justification (with last line justified as well). Single Word Justification
trumps the overall paragraph alignment in the case of singe-word lines. Changing this to any-
thing but Full Justify would have eliminated the lone word stretching.

Hyphenation

Also on the Paragraph panel menu is Justification’s cousin, Hyphenation Settings (see Figure 2.23).

If you're coming from proficiency in QuarkXPress, you're accustomed to having hyphenation
and justification (H&fJs) in a single dialog and being able to save them as a set. InDesign does it
differently, as you can see. True, it’s two dialogs, but that’s a small trade-off when you consider
that you don’t have to create an H&]J set just to apply it; you can apply selectively on-the-fly, save
them as part of paragraph styles, and even set the default for all future text simply by setting these
options with all documents closed.
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Here is fine control over the composition engine’s hyphenation choices. Check the box at the
top of the dialog (or at the bottom of the Paragraph panel itself) to enable hyphenation. First, you
can tell InDesign it’s allowed to hyphenate words with at least X number of characters but no less.
Typically, five letters is the minimum-—uwo-nt just looks funny, doesn’t it?

The next two fields determine where the first and last hyphens in a word are allowed to
appear.

After that is the maximum number of times InDesign is allowed to hyphenate a single word.
In most cases you'll never bump into that limit. You’d have to have a very long word and either
large type size and a narrow column (or both) for that for that to come into play. Realistically,
how often do you use let alone typeset words like onomatopoeia or supercalifragilisticexpialidocious?

Hyphenation Zone is a guideline (often overridden by InDesign) as to the minimum space after
a hyphenated word before InDesign is allowed to hyphenate another. You see, it’s poor form to
have too many words ending in hyphens and bad form to have consecutive lines both ending in
hyphens. The hyphenation zone, therefore, is a way to tell InDesign, I'd really like it if you waited for
half an inch or so following a line ending in a hyphenated word before doing it again. Sometimes InDesign
will agree; sometimes it’ll just come back with, I tried, dude. No can do. See, if I followed the hyphen-
ation zone thingee, it would throw the rest of the paragraph out of whack. Sorry.

What has always struck me as odd about the hyphenation zone is that it's defined by the docu-
ment measurement system, but what really matters is the leading, which is measured in points, not
inches, millimeters, or agates. A 0.5-inch zone may be great for 12/14.4 type, but with leading set
to 36 pts or higher, 0.5 inches is a zone of one line—in other words, hyphenate here, but don’t
hyphenate again until the next line. The zone won't increase based on type size or leading. Ideally,
it would be measured by number of lines, meaning the actual height of the zone would be relative
to, and keep up with, the type size and leading amount. Basing the hyphenation zone on the docu-
ment measurement system is not the wisest of choices on Adobe’s part.

Below the Hyphenation Zone field is the Hyphenation slider, which adjusts InDesign’s priority
toward either better spacing (and often more hyphens) or fewer hyphens (with potentially more
word and letter spacing).

The last three options give InDesign directives on what to hyphenate with special types of
words—capitalized words, the last word of a paragraph, and whether InDesign is allowed to
hyphenate the last word in a column (or page) so that it picks up again on the next column (or
page). My preference is to leave all three unchecked (off). If you deal with a lot of acronyms,
you'll definitely want the first option off—DARPA is a proper name, for example, and DAR-PA
is bad typesetting.
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Optical Margin Alignment
Optical margin alignment... You may have heard of that term. You also might be familiar with the
more traditional description of hanging punctuation.

The principal is simple: Punctuation and slant-sided characters don’t use up the vertical space
allotted to them, which creates small pockets of white space—optical bumps, if you will—in the
justified edge of text. Letting that punctuation hang a little outside the borders of the frame makes
the justified edge look more uniform and makes the text more readable (see Figure 2.24). Of course,
some clients don’t get that, so be prepared for push back.

FIGURE 2.24 “Yeah. So I says to Jack “Yeah. So-I says to Jack
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Whether Optical Margin Alignment is on or off, InDesign does a little bit of adjustment any-
way. Notice in Figure 2.24 how the Js and commas hang out a tiny bit even in the left paragraph,
which has the option off. On the right side of the figure, you can see greater adjustment where the
quotation mark, apostrophe, hyphen, and commas hang out into the margins. In short paragraphs
like these, hanging punctuation isn’t that big a benefit; in longer columns of copy, it can really
boost readability.

If you just don’t see any benefit.... Well, I used large type in the figure. Stand the book up
against something and take a few steps back until my figure is optically about 10 or 12 pt. The
hanging punctuation should trick your eye into perceiving a more uniform edge in the right para-
graph than in the left.

You'll find a check box to enable Optical Margin Alignment on the Story panel (Window >
Type & Tables > Story). It’s the only thing on the Story panel (see Figure 2.25), which is why most
people forget where to find it. Once Optical Margin Alignment is on, the Align Based on Size field
lights up. That defines how much space is allowed to be consumed by the left- or right-shifted let-
ters. Set this to be the same size as your type point size for best results most of the time; adjust as
needed for more control.

FIGURE 2.25 — — %
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Optical Margin Alignment is a story-level attribute—it applies to the entire story or frame, not
individual paragraphs. That creates a need to override the setting for certain paragraphs, which is
easy enough to do. With a paragraph selected, choose Ignore Optical Margin from the Paragraph
panel flyout menu.

Balance Ragged Lines

This simple little command stuck away on the Paragraph panel menu tries to even out the ragged
edge of type (see Figure 2.26) by telling InDesign to give higher priority to making text lines equal
in width than to filling the frame. It's yet another way to handle runts, as you can see in my example.
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Of course, Balance Ragged Lines only works if there are ragged lines. It has no effect on fully
justified text.

Keep Options

Although some paragraphs are single lines, they’re the minority. In most cases, paragraphs are
composed of multiple lines. How those lines split across columns (or pages) is almost as important
as the composition of a single paragraph.

We’ve talked about runts, a single word or syllable left all alone as the last line of a paragraph
(tip o’ the hat to David Blatner for coining the term). Runts are the penultimate sin of paragraph
composition. The ultimate sin is leaving a widow, the single last line of a paragraph surviving its
paragraph to stand all alone at the top of column, or an orphan, the first line of a paragraph
abandoned at the bottom of a column while the rest of the paragraph moves on to the next (see
Figure 2.27).

Both widows and orphans are equally bad things to let slip through in your publication.
Better is to leave a blank line at the bottom of a column; when possible, however, avoid
that, too.

Paragraph keeps is the term applied to gluing two or more lines of a paragraph together such
that they never leave widows or orphans—where one line goes, so must the next or the previous.
In InDesign, keeps rules are defined through the Keep Options dialog (see Figure 2.28) accessible
from the Paragraph panel flyout menu.
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Keep with Next is a numeric field that lets you even glue together lines not in the same para-
graph—say, headings and the paragraphs that follow—to avoid contextual widows and contextual
orphans (terms I coined, as far as I know). Keep with Next can be assigned to paragraphs ad hoc
and saved as part of paragraph styles. In order to avoid accidental contextual widows and contex-
tual orphans caused by last-minute formatting or copy changes, I always build a Keep with Next
value of at least 1, usually 2 or 3, into all my heading styles. I also add them into kickers and lead-
ing captions for tables, charts, figures, and so on.

If enabled, the next section, Keep Lines Together, defines how many lines of a paragraph
should bond. A minimum setting of two lines at the start and two at the end of a paragraph will
eliminate widows and orphans without causing overly large gaps at the bottom of columns. With
a setting of two lines in both, for example, if InDesign can't fit the first two lines of a paragraph at
the bottom of a column or page, or can't fit the last two lines of the paragraph, it will jump the

entire paragraph to the next column or page.

All Lines in Paragraph is available, but I caution you against using it indiscriminately. If you
know all your paragraphs will be short and must stay together, go ahead and use it. With variable-
length paragraphs and columns, however, you could be creating massive gaps at the bottoms of
columns or forcing InDesign into a corner from which it will have no choice but to fight back by
violating your keep directives.
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When creating short-listing-style documents like directories, catalogs, and classifieds, I always
activate All Lines in Paragraph and add Keep with Next to all styles making up a single listing.
That way, the entire entry stays together and never splits—perfect for doing such documents with-
out endlessly fiddling with column breaks or frame heights.

Finally. Start Paragraph defines where new paragraphs may begin—anywhere, only in the next
column, next frame (for threaded frames), on the next page, or on specifically the next odd or even
page. Why is this option useful? Headings. Tables. Charts. Figures. More.

For instance, perhaps you have a Chapter Heading style and every paragraph with that style,
every top-level heading, should begin a new chapter or section of the document, beginning with a
fresh, right-read (odd-numbered) page. Just set the Start Paragraph value to On Next Odd Page
and save it in the Chapter Heading style. Every chapter heading will then automatically jump to a
new right-read page, without you having to manually break the text flow or insert break symbols.
And, because you didn’t manually do anything, it can be overridden later from the Keep Options
dialog with minimal effort.

Efficiency and creative freedom at once. You gotta love it when those two come together.

Highlight Composition Violations

As noted previously, hyphenation, justification, and keep options are guidelines, not rules. InDesign
may have to violate those guidelines to adhere to higher-priority ones. Although you must place
your trust in the butterfly, there’s no need to do so blindly.

On the Composition pane of the Preferences (see Figure 2.29) are options to highlight instances
wherein InDesign had to ignore or violate hyphenation and justification and keep options,
instances of custom tracking or kerning, and any text defined as a font or glyph that you don’t
have installed.
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Text highlighted in yellow (see Figure 2.30) indicates an H&J or keep violation, with light,
medium, and deep yellow indicating the severity of the violation, from mild through severe. Cus-
tom kerned or tracked text highlights in a pleasing sea foam green, while instances of font and
glyph substitution, being the most troublesome, highlight in pink.
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Paragraph Rules

Paragraph rules are not for separating every paragraph in a story, but they can make headings and
other separations clearer and more creative. As you'll soon see, they also have tremendous decora-
tive value.

Rules (lines), like paragraph backgrounds, are another of those things people believe can only
be done with separate objects. Instead of assigning rules that flow with type automatically, sizing
and coloring to match as appropriate, many are stuck in the old days when their only option for
paragraph rules was to draw a rule or box as a separate object placed behind or near the text
frame. That just isn’t so. Virtually anything that can be done as a separate object rule can be done
as part of the text with paragraph rules.

The major benefits of using paragraph rules instead of Line or Rectangle tool objects are obvi-
ous: better alignment; adaptability to text color, size, and indentation changes; the ability to flow
with text; and of course. one object to move and resize instead of two.

Gateway to all this is the Paragraph Rules dialog (see Figure 2.31) on the Paragraph panel fly-
out menu. It creates rules (and boxes, dots, squiggles, and more) above and/or below—and even
behind or beside—paragraphs.

FIGURE 2.31 Paragraph Rules
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Rule Above/Below (drop-down) Choose whether to enable and edit rules above or below.
Both may be activated and customized independently.

Rule On (check box) Is the rule on or off?
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Weight The stroke weight of the rule. Choose a preset value from the drop-down, or enter a
custom value by typing over the contents of the field.

Type Matching the styles on the Stroke panel, these are the available rule stroke styles, includ-
ing solid, multiple lines, dots, dashes, hash marks, and more.

Color In addition to Text Color, which keeps the color of the rule in synch with the color of
the text to which it’s assigned, any swatches on the Swatches panel are available in this list.
Tints of swatches may be defined in the next field, but to assign a custom color, you'll need to
exit the dialog, mix the color, and create a swatch before returning to Paragraph Rules.

Tint A percentage of the Color field’s ink. Note that this is not transparency. A 0% tint is not
transparent; it’s paper color.

Overprint Stroke (check box) This option is available if the stroke color is set to anything
except Text Color, None, and Paper and chooses between knocking out any ink beneath the rule
or overprinting it. The latter option, with the box checked, could result in color mixing. For
instance, a cyan rule overprinted on a yellow background will mix the two inks, resulting in a
green rule when printed.

Gap Color, Tint, and Overprint The fields remain disabled until you choose a rule type inclu-
sive of gaps—dashed, dotted, hashed, diamond, multiple strokes, and so on. These fields con-
trol, respectively, the color of the spaces between the primary stroke color, the tint of that color,
and whether it overprints or knocks out background colors.

Width If Width is set to Column, the stroke will span the width of the column regardless

of the length of the text line—a single letter could have a stroke that spans the entire single-
column page. Conversely, setting the width to Text only rules over (or under) the text itself;
the rule will not continue across the column in the case of a short line of text or a single
letter.

Offset Rules above begin drawing upward from the baseline of the paragraph'’s first line of
text. Rules below grow downward from the baseline of the last line in the paragraph. Offset
is a vertical adjustment of the rules in the direction they normally grow. Thus, a positive offset
pushes a rule above higher and a rule below lower. Negative offsets pull rules toward and
potentially behind text. Both rules above and below are behind text and will not mask the type
to which they’re assigned.

Left & Right Indent Positive values will push rules inward from column or text edges
(depending on the Width setting). Unlike text indents, the rule indent fields can accept negative
values, allowing rules to be pushed beyond the borders of text frames, which opens numerous
creative possibilities.

Keep In Frame (check box) When a rule above is applied to the topmost paragraph in a
frame, the rule can sometimes bleed out of the top of the frame or escape it entirely. Checking
Keep In Frame puts a leash on the rule so it can’t leave the yard.

Paragraph rules make excellent section and content separators such as in Figure 2.32 where

level 1 headings carry a rule below (and paragraph spacing before) to signal a clear separation
from the rest of the copy; that is, to signal that a new section has begun.
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Create and fill text frames Setting type is InDesign’s primary function, and it performs that
function better than any other application. The fundamental building block of type in InDesign
is the text frame container and the text content.

Master It Create a new text frame, and then place the flawed text file, bad-Torem. txt, into
it. Clean up the resulting text to make it readable. When finished with that, place the docu-
ment REVstory.doc into the same text frame after the first imported document.
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Format text frames Correctly formatting and configuring text frames will save effort and time
not only now, but also every time a frame or its content changes.

Master It Using the text frame created above, convert it from a single column into three,
with a 0.25-inch gutter. At the same time, give the text some breathing room by setting top
and bottom insets of 0.1667 inches and no inset on the sides.

Format paragraphs Paragraphs must be separated and styled to enable legibility and facili-
tate readability. That can be accomplished through alignment, indents, paragraph spacing, and
drop caps.

Master It Continuing with the multicolumn frame of placed stories, let’s make them read-
able. In the first full paragraph of each story, add a drop cap of 2 to 3 lines. Separate the
same paragraphs from anything that may come before with a comfortably large paragraph
space before. Give the rest of the paragraphs a correct first line indent and, to control runts,
a last line right indent. Because we’ve got three probably narrow columns, let’s make clean,
rag-less paragraphs.

Compose paragraphs Paragraph composition is essential to good typography. A poorly
composed paragraph is one of those things that both trained and untrained eyes immediately
notice—even if unconsciously—and that marks the document as the product of an amateur.
From this book you should learn first that efficiency and economy of motion equate to more
creative time, second that coffee is your friend, and third that practicing good paragraph com-
position is very, very important to the quality of your documents, your clients and employers,
and the future marketability of you as represented by your portfolio.

Master It Undoubtedly by this point we have three columns of unsavory composition.
You may have widows and orphans, paragraphs may be split all over the place, hyphen-
ation may be off or run amok, and word and letter spacing could be just horrendous. Even
if it isn’t that bad, you’ve got some areas in your document that need work.

First, duplicate the text frame and work on the copy, keeping the original above or beside it
as a reference.

Begin the cleanup by asking InDesign to highlight problem areas and violations. Then,
working through the highlighted text and keeping an eye out for problems InDesign didn’t
notice, employ the skills you learned about paragraph composition to eliminate all runts,
widows, and orphans; then optically align hanging punctuation and tweak hyphenation
and word and letter spacing.
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Characters

InDesign is the world’s most advanced typesetting platform. The only other applications that even
come close are Illustrator and Photoshop, and only because they follow InDesign’s lead. In fact,
type set in InDesign is almost as good as type set on a letterpress. The few sacrifices you make by
setting type in InDesign instead of in lead tend to be balanced by the time savings—you can set
much faster than one page every four hours—and by the lack of ink perpetually embedded under

your nails.
In this chapter, you will learn to:

& Format characters

Transform characters
¢ Insert special characters
¢ Work with OpenType font features
¢ Use the Glyphs panel
Formatting Characters

Now that we know how to get text into InDesign, let’s talk about what the world’s greatest digital
text-handling platform can do with it.

The Character Panel

Let’s start the character-formatting discussion by walking through the Character panel, which
contains most character-level style options. Many of the Character panel’s options and fields are
replicated on the Control panel in Character mode—and a few are more easily accessible via the
Control panel—but we'll focus first on the Character panel and then cover the differences on
the Control panel.

If it isn’t showing, open the Character panel from Window > Type & Tables > Character, or
press Cmd+T/Ctrl+T. If you only see six fields in your Character panel, choose Show Options
from the panel’s flyout menu.

FONT FAMILY AND TYPE STYLE

Most fonts are actually families of typefaces that include a roman, normal, or regular typeface,
and other variations such as italic, oblique, bold, semi-bold, medium, light, condensed, and count-
less other possibilities. When styling type, the first option is going to be choosing the appropriate

type family.
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FIGURE 3.1
The Character panel.

|l # Character x ;
Font Family [Wyri=d Pro z
Type Style —— [5emibod Condansed =

FontSize — T EJ2= - @Ffoeses - Leading
Kerning L Av &M= - ay 5o + — Tracking
Vertical Scale — IT B - T - ___ Horizontal Scale
Baseline Shift a2 o T — Skew
Language Langusge: | Englishi USA v

Clicking the arrow will reveal a scrollable drop-down list of all font families installed on the
system (see Figure 3.2), including sample text set in the family’s default typeface, which is usually
the roman, normal, or regular style. Some sample text examples may be boxes, which indicate
that the font doesn’t include the letters S-a-m-p-I-¢; this is sometimes the case with symbol or ding-

bat typefaces.

Beneath the Font Family field is the Type Style field, showing all the individual typefaces in the

selected font.

FIGURE 3.2
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CONTROLLING TYPE SAMPLE PREVIEWS

Want larger (or smaller) sample previews of your fonts on the Font Family, Type Style, and Type menu’s
fonts lists? Open the Preferences with Cmd+K/Ctrl+K, and go to the Type pane. The last option in the
Type Options area is Front Preview Size.

Prefer larger or smaller font samples? The drop-down list offers three possible sizes: Small, Medium, and
Large, which would be better written as Where Are My Glasses, Squint Harder, and Mostly Readable. 1
keep hoping Adobe will bump up the size of all three, or at least add a fourth option, Good-Sized.

When changing type sample previews, InDesign must rebuild the previews. With a large number of
installed fonts or on slower computers, that may take a moment or two during which a “Building” notice
will appear.

Want to turn off the previews altogether? Uncheck the box. Although the previews use only a small
amount of RAM and system resources, they are rendering every font installed on your system simultane-
ously, which can be a drain on system resources.

In addition to choosing the font family and typeface style by selecting from the lists, you can
type directly into either field. If you already know the family you want, for example, begin typing
its name in the Font Family field. Through the magic of autocomplete, InDesign immediately
searches for matches beginning with the letters you've typed and fills in the rest. If InDesign’s
choice isn’t the correct one, keep typing until there’s enough of the name that InDesign gets it
right. Press Return/Enter to apply and return to your document or Tab to apply and move on to
the next field in the Character panel.

With the Font Family list shown, keyboard navigation keys Page Up, Page Down, Home, and
End and the Up and Down arrow keys shorten your search time by jumping through the list. In
the field, with the drop-down list closed, only the Up and Down arrow keys will change typefaces
one at a time.

At the bottom of the Font Family list, you may have some fonts segregated from the rest by
horizontal lines. Rather than intermingle non-Latin-character-set font families throughout the
main list, InDesign makes it easier to find them by placing them in groups sorted to the bottom of
the list. Families of Asian language fonts such as Chinese, Japanese, Korean (collectively referred
to as CJK fonts) as well as Russian Cyrillic, Hebrew, and other type families not using the Roman
character set of English, Spanish, French, Italian, and Portuguese will be listed at the bottom,
along with samples.

REMOVE UNUSED NON-LATIN FONTS

InDesign is fully capable of setting type in any known language using fonts from any language glyph set,
and Adobe likes to demonstrate this fact by including CJK fonts in the InDesign installation. As we all
know, fonts consume system resources—miniscule amounts per font, but it can add up. If you don’t
often (or ever) work with CJK text in InDesign, remove the fonts at the bottom of the Character panel’s
Font Family menu from your system to free up the resources consumed by them. With those nine type-
face families gone, you’ll have plenty of room to install yet another variation of Helvetica or even a few of
those wacky display faces you know you’ll never use but think are cool anyway.
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Not shown on the Font Family list on the Character panel or on the Control panel are previews
of families matched with their individual typefaces, which are the separate list in the Type Style
field. What does Myriad Pro SemiCondensed Italic look like? You can’t tell from either of those
panels until after you've applied the Myriad Pro family to your text and moved down to the Type
Style field. You can get a sample text preview from the Type > Font menu (see Figure 3.3). There,

each family is listed with a flyout displaying all the fonts and sample text—in one place.
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FONT SI1ZE AND LEADING

The Font Size and Leading fields are pretty straightforward—you’ve used ‘em umpteen times
before. InDesign provides drop-down lists of common point sizes, and both fields will accept
typed-in whole values (e.g., 12 pt) as well as values with decimal measurements up to the thou-
sandth of a point (e.g., 12.015 pt).

In the Leading field drop-down is a nonnumerical option, Auto. Choosing Auto sets the lead-
ing to automatically adjust in relation to the font size and will display the resulting value encased
in parentheses, which InDesign uses in several places to denote a calculated or default value. The
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default leading is 120% of the font size; thus 10 pt type defaults to sit on 12 pt leading. To change
the default leading value, use the Justification dialog accessible from the Paragraph panel menu
(see Chapter 8, “Stories,” for more on the Justification dialog); it isn’t in the Preferences as you've
been trained to expect.

POWER TiP: CHANGE FONT SHORTCUT

When you first show the Character panel, the Font Family field is selected, with its contents highlighted.
Thus, a rapid, mouse-free way of changing typefaces presents itself—press Cmd+T/Ctrl+T to show the
panel, and immediately type the name of the desired typeface or enough of it that InDesign can fill in the rest.
Hit Return/Enter, and get right back to work—without ever touching the mouse. Need to change the
style as well as the font? Press Tab after filling in the font family name to jump to the typeface style field,
and then type in your choice there before hitting Return/Enter. In fact, you can tab through all the fields
of the Character panel, changing size, leading, and more, without taking your hands off the keyboard.

Leading itself works a little differently in InDesign than what you’ve come to expect from other
applications. In InDesign, it’s a baseline-to-baseline measurement—the amount of space between
the current text’s baseline and the baseline of the line immediately above. Thus, increasing or decreas-
ing leading pushes it farther away from or pulls it closer to the line above.

Even more radical, leading is a character-level attribute—it applies to individual characters, not
entire paragraphs or lines. In certain other applications, it’s possible to double-click select a word,
increase the leading, and watch the entire paragraph loosen. Not so in InDesign. Instead, only the
one word will be changed. While it will, of course, push its entire line downward (or upward, if
you've decreased leading), your leading value has not been applied to the entire line; the line is
merely compensating for the character-level leading. Should the altered word wrap to the next
line, that line will push downward while the previous line resumes a leading consistent with the
rest of the paragraph.

Most people like this behavior, but if you don't, it’s easy to change. Open the Preferences with
Cmd+K/Ctrl+K, and go to the Type pane. In the middle of Type Options is a check box, Apply
Leading to Entire Paragraphs. Checking the option with a document opened sets it for the current
document only. To make it default for all future projects, close all documents and then check Apply
Leading to Entire Paragraphs.

There’s a gotcha I need to caution you about: When changing leading, it's common and familiar
to click at the beginning or end of the paragraph, drag down or up to select the entire paragraph,
and then change the leading value (or most other values). This creates the potential for big problems
because the paragraph marker () is a character too, albeit invisible. As a character, it can have its
own character-level attributes—typeface, style, leading, and more. If, when you select and change
a paragraph, you fail to select the paragraph marker as well, you create a situation wherein this
invisible character can cause the last line to have different leading than the rest of the paragraph
(as well as potentially different typefaces, point sizes, and more, which lead to their own sets of
problems).

Ensure that you're always selecting the whole paragraph, including the paragraph marker, by
training yourself to habitually work either with invisible markers turned on by choosing Type >
Show Hidden Characters, by triple- or quadruple-clicking to select an entire paragraph, or both. In
the Preferences Type pane is the option Triple Click to Select a Line. If checked, you must click four
times rapidly to select the entire paragraph.
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KERNING

Even if you're a kerning expert, InDesign’s unique take on the Kerning field begs explanation.
Kerning is defined as the distance between two glyphs (aka characters), and InDesign takes that
definition literally. Highlight a word in your document and hit the drop-down arrow on the Kern-
ing field. You're looking at the list on the left in Figure 3.4, aren’t you? Your options are limited to
Optical, Metrics, and 0, and everything else is grayed out. You also can’t type a specific numeric
value into the field. Position your cursor between two glyphs, without highlighting any text, and
everything gray will become available.
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InDesign enforces the literal definition of kerning: you can kern only one pair of glyphs at a
time except to set all selected glyphs to 0—no kerning whatsoever—or let InDesign handle it all
automatically by evaluating relational glyph positioning according to one of two criteria: metric or
optical kerning.

To understand the kerning options, it’s important to first understand the structure of a font. A
digital font—whether OpenType, TrueType, or PostScript (Type 1, Type 3, etc.)—is just a table or
grid. The type designer draws every character (glyph, to be politically correct) individually as a
simple vector shape comprised of paths and anchor points.

Most people tend to associate the mechanics of typeface design with the way we all learned to
draw the alphabet in first grade—one letter at a time, all in a line, on recycled or yellow newsprint.
Although that’s very close to how a typeface design begins, turning a design into a font requires
isolating letters, punctuation, and other glyphs off the line and into a table. For a computer to
understand that a given shape equals a glyph such as 4, a font must be divided into tabular cells,
with each cell having a specific purpose; whatever is placed in the cell defined as a lowercase a
will be spit out by the computer when you press the a key on your keyboard. And, that’s the only
way this whole idea of digital typesetting works—everyone agrees to put a in the cell in which
computers expect to find an a.

Font table cells are rectangular; every glyph is wholly contained within a rectangle. For glyphs
like M and N, which are rectangular letterforms anyway, that’s no big deal—they tend to fill or
almost fill their cells. However, with glyphs that aren’t easy rectangles, such as A, T, and Y, white
space is left in the table cell. Thus, when letters are put together in words, certain combinations
create too much white space that tends to disassociate the glyphs from one another. Kerning is the
system that compensates for white space by pushing certain glyphs toward one another, even vio-
lating the borders of individual table cells, to make them appear to be only as far apart as any other
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pair of glyphs. In some cases, kerning also pushes glyphs away from each other to create the same
illusion where glyph shapes fill their cells too completely and appear too close to other glyphs.

There are three means of kerning type, and Figure 3.5 shows their different results on the
same text.

FIGURE 3.5 AVAYA water comes in a tubular bottle]
(Top) Kerning

manually set to 0. AVAYA water comes in a tubular bottle[
(Middle) Metric

kerning. (Bottom) AVAYA water comes in a tubular bottle[
Optical kerning.

Metric Kerning Professional typeface designers usually include kerning pairs in text fonts
or include instructions to a typesetting application about how close together certain pairings
of glyphs should be placed. Take, for instance, VA. Because of the negative space created by
the letters” diagonal strokes, a large white space appears and can distract a reader’s eye (see
Figure 3.5). By including kerning pairs, the type designer is assisting the layout designer who
would otherwise have to kern such pairings manually.

Metric kerning is the default, and it informs InDesign to search for and use kerning pairs within
the font. It is usually the best choice for entire lines or paragraphs set in a single typeface and
when the typeface is a professionally created font—as opposed to 1,001 Fonts for a Buck CD-ROMs
or the vast majority of free fonts on the Web, which rarely include kerning pairs.

Optical Kerning Whereas Metric kerning uses the information created by the type designer
(if any), Optical kerning tells InDesign itself to fit glyphs together. To do that, InDesign actually
reads the text, evaluating the shape of each glyph, its positive and negative space, and then
seeks to create an even mix all the way through each word, line, and paragraph. It does that on
a pair-by-pair basis, individually kerning every glyph in relation to the next.

In Figure 3.5, for instance, on the line where Optical kerning was applied, InDesign applied a
-123 value between the AV in AVAYA but a value of —134 between the AY pair. Comparing the
same two sets in the line where Metric kerning was chosen, we get —130 and —110, respectively.
Which looks better? Which has a more even distribution of negative and positive space? You be
the judge. Look at the instances of the lowercase c and t as well. Which line looks better overall?

(If you said the top line, with zero kerning applied, please take this book back to the store and
exchange it for one on Microsoft Publisher.)

When a font lacks kerning pairs, thus disabling Metric, go for Optical. In many situations even
when Metric is available, Optical kerning is the better choice, but it isn’t perfect. Which, if
either, is better, is subjective and relative to the specific font, typeface, point size, and intended
use of your text. Try them both, but be prepared to manually kern here and there in either.

Manual Kerning In addition to choosing either Metric or Optical kerning, you can also set all
selected type or frames to 0, or no, kerning. If you're trying to set easily readable type, you'll
almost never choose 0 kerning.

With the cursor in the middle of a pair of glyphs to be kerned, the drop-down menu of presets
becomes fully active. You can choose a preset, click the up/down buttons on the field, use your
keyboard Up and Down arrows, or type a numeric value into the field. Kerning is entered in units
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of one one-thousandth (1,/1000th) of an em. An em is a relative unit of measure equal in width to
the height of the font (as measured by the capital M). For example, 12 pt type has a 12 pt em. To
put it more bluntly and dramatically: InDesign makes you master of kerning the verse.

KERNING CHARACTER STYLES

Among other things, character styles store and reuse kerning settings. If you often use the same kerned
pair of glyphs in the font and typeface and approximately the same size, save yourself the hassle of man-
ually kerning them every time. Highlight the character to the left and create a character style from it.
Next time you type in that pair, highlight the left character and apply your character style to instantly set
the correct kerning.

TRACKING

It’s amazing how much the Web has accelerated the spread and decline of design trends in all
media. Before 1995, it would take months or even years before a trendy typeface, illustration style,
or graphic design technique was mimicked around the world, and then even longer for the fad of
it to pass. Remember when the late "80s fad of hard-drop type appeared, with its iiber cool, hard-
line drop shadow that was more than a block-cut look yet still less than a real drop shadow? That
was still being cranked out well into the mid-"90s. The same is true of hollowed or outlined type
and wood or stone texture-filled type made popular by tutorials in catalog-magazine hybrids such
as the one from Image Club Graphics.

Nowadays, however, the Web has enabled print design trends to travel the globe in weeks
instead of years—and to fizzle just as quickly. To wit: Ultra loosened headlines and subheads like
the one in Figure 3.6. This type style began in the late 1990s and within a few years was everywhere
online and in print—and not just heads and subheads, but also taglines, captions, decks, naviga-
tion buttons, and even, when applied by the most aesthetically challenged, in paragraphs of text.

FIGURE 3.6 R EV DRINK M A KES HISTORY
A heading with char-

acters tracked out to

avalue of 900 (9/10

of an em)

Thankfully, the fad became passé not too long after it began and has since gone the way of out-
lined type headlines and mastheads. Despite the fact that a million websites and home-cranked
letterheads nearly ruined the style forever, tracking out text is still a viable design decision for the
correct project. More importantly, tracking is more than this one trick pony.

At first glance, the uninitiated often confuse kerning and tracking and fail to see much differ-
ence between them. They’ll use tracking to tighten up AV glyph pairs and kern out an entire
headline to give the characters breathing room.

Kerning is about controlling the interaction of the negative and positive space of two glyphs
when paired together. Tracking is the amount of relative space between any glyphs, regardless of
their actual shape. Kerning makes it look like the same amount of space exists between A and V as
between N and M. By contrast, tracking is about actually putting the same amount of space between
those glyphs.
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Very much like the Kerning field, the Tracking field measures in one one-thousandth of an em
from —1,000—theoretically, a complete overlap of one character upon another—out to 10,000—
theoretically the space of 10 characters occupied by one. I say theoretically because most fonts are
variable width—the width of the I is not equal to the width of M, and sometimes, even the M itself
is not equal to the width the font says it is. (Confused? Rushed designers don’t always re-create
every little setting specifically for each font they create; often they copy the settings from their last
finished font or from a master template, even if the current typeface has significantly larger,
smaller, or differently shaped glyphs.)

As with Kerning, Tracking offers a drop-down menu, buttons to increase or decrease the value
incrementally, and the ability to type a different value into the field. Unlike the Kerning field, Track-
ing requires text to be selected and has no effect when the cursor is merely blinking between two
glyphs. Negative values pull type closer together, while positive values push it apart.

The two types of horizontal space adjustment work hand in hand and are cumulative. For
instance, if you've applied a kerning of 200 to a pair of glyphs and then tracked them in -200, the
end result will be no space between them. Apply a positive 200 tracking and they’ll be 400 units
(4/10 of an em) apart. It's important to understand that concept because, even when tracking let-
ters far apart or close together, you still need kerning to ensure that they are not really exactly the
same distance apart and thus they look as if they are.

In Figure 3.7, the upper word has no kerning at all—it’s set to 0. The bottom uses Metric kern-
ing, so the relative spacing between these characters is adjusted to compensate for the negative
space created by their forms. Both words have been tracked out to a positive value of 600. Which
of the two looks like it has the more uniform spacing? Right: the lower one.

FIGURE 3.7 A V A L O N

Both words have
been tracked out to

600 (6/10ths of an A V A L O N

em), but the top uses
0 kerning while the
bottom uses Metric
kerning.

If, when tracked, text doesn’t look right, it might be one of those rare occasions for zero kern-
ing. The preceding sample was not such an occasion. You now know how to make ultra-loose
heads, but when else might you use tracking? When is it more than a special effect? Actually, it’s
used often but much more subtly.

Large type, such as might be used in headlines, often needs to be tracked together—sometimes
by a large degree—for maximum effect. Conversely, dark, shallow, or thick-stroked typefaces at
small sizes often need a little positive tracking to improve readability. The same is true of small cap
or all-cap type in any typeface within body copy.

Typefaces such as Americana have a lot of space built into their glyphs. They have tall x-heights
(the height of the lowercase x in relation to the height of the uppercase X), spindly strokes, and
wide, open counters (the holes in letters such as O, P, and C). All that extra space inside the glyphs
themselves can, at certain point sizes, render too much white space. Tightening the tracking
slightly in those cases can improve the overall readability.

Tracking can also eliminate orphans, a word or two left alone as the last line of a paragraph.
Tightening tracking on the entire paragraph by a tiny amount—say, a setting of -1 down to -5—
can often bring the orphans home. If not, try a positive value on the paragraph to push more words
down to join the orphan. Any more than +/- 5, however, and the tracking becomes noticeable and
is generally considered a bigger sin than leaving an orphan.

65
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FITTING MORE TEXT THAN WILL FIT

Stop me if you’ve heard this one. A man walks into a design studio with two pages of single-spaced, typed
copy for his one-page, one-sided flyer. He hands the pages to the designer and says, “Put these in my flyer
along with my logo, tagline, and pictures of my product. Oh! And don’t forget to put my website address
in really big type. And, 1 don’t want the flyer to be cluttered. 1 hate cluttered design.”

(What? You were seriously expecting a punch line?)

I’m asked all the time what’s the best way to squeeze text into a space too small to fit it. My first (and sec-
ond) answer is always, “Edit down the text and cut out the fat.”

When trying to squeeze more text into a space than would fit at an appropriate size and style, your first,
second, and third options should always be to cut copy. Get a real, edumacated editor involved to decide
if the copy communicates only the required points. If it overexplains. If it has any parts irrelevant to the
direct purpose of the layout.

Assuming you’ve cut every word you can, you have polished copy, and you still can’t fit it, there are a few
typesetting tricks you can try. Keep in mind: these are intended to help fit an extra line or two, not another
half page.

4 Reduce font size in fractional points. Must the type be 12 pt? Would 11.75 or 11.5 pt be just as legible?

& Look for a condensed or compressed version of the typeface. Many sans-serif typefaces—such as
Futura, Grotesque, and most flavors of Helvetica—have styles drawn to be legible and readable at
75% (or even less) the width of the full-sized, regular versions.

4 Swap paragraph spacing for indents. Paragraphs must be separated somehow, providing a visual
indicator where one ends and another begins. If the method you’ve chosen is vertical spacing before
or after a paragraph, try eliminating that and indenting the first line instead.

& Try tightening the tracking a slight amount. Of course, how effective it—or any of these tricks—is
depends entirely upon the font, point size, and amount of text being tracked and fit. However, | have
seen a tracking value of only —2 applied to a whole page of type allow another half dozen lines of text
to fit on the page. Just don’t go overboard trying to fit type; if the tracking is too tight, if there isn’t a
comfortable amount of horizontal white space, no one will read your text.

4 Reduce the horizontal scaling. As with tightening the tracking, a little goes a long way, and a little
more is terrible. In my experience, knocking horizontal scaling down 3% can create a lot of extra
space and is unnoticeable—as long as all text of the same typeface is scaled. Never scale just a couple
of words up or down because, beside unscaled text in the same typeface and size, it will be noticeable.
If you’re using a sans-serif font, you can scale even more—sometimes to only 80% of the original
width—without it looking like you were squeezing. Headlines and other large copy can also be scaled
more than body copy without significant impact on readability.

4 Tighten the leading. 1 want you to know that 1 sat here, staring at this sidebar for 10 minutes and
debating with myself if 1 should include this option. Reducing the amount of leading is the first thing
everyone thinks of when they want to squeeze more text into a space, and 1 don’t want to be con-
strued as an advocate of tightening the leading. In fact, I'm the opposite: 1 believe strongly in open
leading because, relative to text style, leading is the single greatest factor in a person’s decision to read
or not read a document.
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If the leading is too tight, it creates a dark, intimidating page that people resist reading. Writers or design-
ers who create to please their egos instead of their audience invariably disagree with my position, con-
vinced that their words or choice of fonts and pictures, respectively, will outshine and override any other
document characteristics and draw in the would-be reader. These are the people who set 12 pt type over
12 or 12.5 pt leading.

If you need a little space and nothing else will work, try dropping the leading down 1, 2, or 3%. Never set
body copy leading to less than 110%, and only go that low when the glyphs themselves have a lot of
white space built in and have a shallow x-height. Leading is like tipping a waitress or waiter: 15% of the
bill is not the most you should tip, it’s the least. And, 120% leading is not the most for body copy, it’s
the minimum.

Try combinations of these tricks if you still can’t fit all your copy. If you find yourself using more than two
of these techniques concurrently, don’t. Rethink your design and/or cut down the copy. If those are out of
the question, if you can’t redesign or cut copy, at least make sure your name is never associated with the
final design.

Be careful not to apply tracking to the last glyph in a word because tracking will push out
(or pull in) anything to the right of that last glyph (see Figure 3.8). In the passage shown, the
date was set in caps, and a positive tracking of 25 (1/500 of an em) was used to make the letters
a little more legible. In the upper example, the 5 was included in the tracking, which pushes the
single, standard-width space outward too far to look like an em space (a space the width of the
capital M). In the lower, the 5 was excluded from the Type tool selection and retains a 0 tracking,
allowing the space to reflect its actual width and fit more naturally. Be especially vigilant in
watching for unexpected tracking on the last glyph when incorporating tracking values into
character styles.

If you're adjusting tracking on an entire text frame, it isn’t that big a deal to apply tracking to
the last glyph. InDesign compensates for that extra space at the end of the tracked word when
aligning to center, right, or justified.

FIGURE 3.8 31 OCTOBER 1865 'Ourbattlements have
Top: Tracking is been overrun by the enemy, and we have retreated

. to the safety of the wood. My men lay scattered,
applied to all

battered, bleeding. Although the enemy has not yet

letters in the word, given chase, I believe it is only a matter of hours

causing a larger than until they finish us. By the sun hung low in the chill

normal gap to the azure sky, I estimate it to be nigh 7 o’clock, and I fear

right. Not tracking we shall not see another dawn.

the last letter (bot- 31 OCTOBER 1865 Ourbattlements have

tom) achieves the been overrun by the enemy, and we have retreated

desired effect with- to the safety of the wood. My men lay scattered,

out creating an battered, bleeding. Although the enemy has not yet
given chase, I believe it is only a matter of hours

overly large gap.

until they finish us. By the sun hung low in the chill
azure sky, I estimate it to be nigh 7 o’clock, and I fear
we shall not see another dawn.
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VERTICAL AND HORIZONTAL SCALE

The next leg of our journey down the Character panel includes the twin Vertical and Horizontal
Scale fields, which enable effects like those in Figure 3.9. Note that, except for the bottom row of
As, all the other type is exactly the same font size—90 pts.

Varius aftts Sqgqu at

achieved with type

IAAAAAAAAAAAAAAA

Type scaling opens a single typeface to the possibilities of numerous widths. Looking back to
Figure 3.9, for instance, the bottom row of As are all Grotesque MT Std Bold at 43 pts. Each letter’s
horizontal scale was adjusted by 10%, beginning with 10% on the left, progressing through 100%
(or normal, in red), and up to 190% on the right end. The Grotesque MT Std font family includes
only width-centric styles of Extra Condensed, Light Condensed, (Regular) Condensed, and Bold
Extended. There is no Bold Condensed, nor is there a Regular Extended, Super Condensed, and so
on. If your design requires a horizontal scale not available in the font family’s type styles, the scal-
ing fields can help.

TYPESETTING MASTER T1P: PROGRAMMING READERS’ BRAINS WITH VERTICAL SCALING

Want to call attention to something within paragraphs of text—maybe a figure reference or brand name?
One technique you can employ is to make the target text larger. If you increase the point size while lead-
ing is set to automatic, InDesign will push the entire line down to accommodate the larger word or two,
creating incongruous (and ugly) leading. If you checked the preference to Apply Leading to Entire Para-
graphs, InDesign will space out the entire paragraph—even uglier in a multi-paragraph document. How-
ever, if you leave the target text at the same point size and just bump the vertical scaling up a miniscule
amount, you can create a very subtle effect that calls attention to specific words in the passage. With a 1%
to 3% vertical scale increase, readers’ conscious minds will almost never pick up on the difference, but
their ever-alert subconscious minds will take note, recognizing that something is different about the text:
it somehow has more emphasis, and the subconscious will cognitively assign a higher priority to compre-
hending and remembering the emphasized text.

As an added benefit, a reader’s subconscious will also more easily latch onto and interpret such subtly
altered text while merely skimming over the text looking for keywords.

Think of this technique as a less-obvious, less-obtrusive means of assigning emphasis than would be pos-
sible with bold or italic.

Scaling fields accept percentage-based measurements from 1% up through 1,000%. While neither
extreme is realistically readable, each can make for interesting creative effects. More importantly,
the values between the extremes give you a more precise control over type styling and fitting. Look
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at the letters on either side of the red A. Each has been horizontally scaled by only 10%—10% down
to the left, 10% up to the right. Not a lot of apparent difference, is there? Distortion is almost imper-
ceptible, but +/-10% could determine whether a headline fits the designated space.

Scaling is used quite frequently (in small percentages) to better fit type into spaces—particularly
heads, subheads, and other small passages of type. A little nudge to horizontal scaling can fill that
awkward space at the end of a text frame or rescue an orphan. Tapping the vertical scaling up or
down can make capital letters more obvious in fonts with tall x-heights.

Compressing or extending letterforms this way is not the same as using genuine condensed or
extended versions of the fonts. Scaling down horizontally will reduce the weight of the vertical
strokes in proportion to the overall width reduction, whereas in a typeface version of the font cre-
ated by a type designer as condensed, the stroke weights are usually uniform or match the hori-
zontal strokes. Compressing vertically distorts the horizontal strokes while leaving the vertical
untouched, and so on. With serif or other delicate typefaces, the distortion can become obviously
horrific even at small percentages—as can the distortion to diagonal and curved strokes in any
typeface. Always look for a professionally designed condensed, compressed, extended, or expanded
style of the typeface before using large percentages in the Vertical and Horizontal Scale fields.

MAKING BETTER SMALL CAPS

If you have to fake small caps, try this: Instead of applying the Small Caps command from the Character
panel menu, use the same typeface and size in capital letters with a reduced vertical scaling. You’ll prob-
ably also want to loosen the tracking a bit. Although this doesn’t do it in every situation, with every type-
face, in many cases it gives you better results than the faux small caps option.

BASELINE SHIFT

The baseline is the ethereal horizontal line on which text vertically aligns. Descenders, or tails, on
lowercase letters such as j, g, and y typically extend below the baseline; most other capital and lower-
case letters stand directly on it (see Figure 3.10).

FIGURE 3.10 Mscendertine _ _ _ _ _ _ _ _ _ -
A diagram of the Cap peiant A I | I °°
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design, discuss,and ~ Descendertine o -0 0000 00T
set the size of type

The Baseline Shift field accepts positive or negative values as great as 5,000 points. Positive
values push glyphs upward, above the baseline, while negative values pull them down below the
baseline of surrounding text.

Figure 3.11 shows three uses of baseline shift to move the bottom of glyphs below or above
the baseline of surrounding text. The first, in “the Mighty Mighty Postscripts,” lowers the capital
M, P, and S so that their tops (cap height) align with the tops of the small-cap lowercase letters
(x-height) by using a negative baseline shift on the capitals. The second usage is the opposite, rais-
ing the “st” in the ordinal “1st” with a positive baseline shift. I should note that the proper way to
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set ordinals in OpenType fonts that include them is via the OpenType > Ordinals command on the
Character panel menu. In this case, because I used different fonts for the 1 (Zapfino Extra LT Four)
and the st (Garamond Premiere Pro, like the main title), the proper method didn’t align the two
correctly and it was necessary to use a manual baseline shift.

FIGURE 3.11 MIGHTY

Baseline shift effects

in the lowered caps THE MIGHTYBPOSTSCRIPTS

and the ordinal .
«Q'V(’ . (/7 7-(&/75*

Hmm. I did say there were three examples of baseline shift in that image, didn’t I? Where’s the
third? It's more subtle than the other two. Can you spot it? Proof your guess against Figure 3.12,
which shows the before and after.
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In Figure 3.12, you see the two versions of the word Live, as typed (top) and after a little touch-
up (bottom). I didn’t like the way the L joined the rest of the word, leaving such a large and dis-
tracting gap before the i. This being 70 pt Zapfino Extra LT Four, I shifted the L’s baseline by -7 pt,
lowering it so the tail would clear the ive. Then I used —150 kerning to pull the rest of the word into
the L. Doesn’t the second, adjusted version look much better than the first?

In addition to cleaning up type in general and creating special effects—which, with large shift
values, can yield very interesting and extreme results—baseline shift can compensate for defects in
a font. For instance, the trademark (™) or registered trademark (®) symbols included in a given
font are occasionally drawn too large or too small (often because they weren’t drawn specifically
for the given typeface, but copied from another). To correct such flaws, reduce or enlarge the point
size of the symbol in text, and then properly position the symbol with baseline shift. I often use
baseline shift to correct baseline alignment problems with many common symbols, including
copyright (©), pilcrow (1), middle dot or waisted bullet (¢) and euro (€). When you're supplying
custom in-line bullets or separator marks from symbol (aka dingbats, fleurons, or bullets) fonts,
rarely does the glyph not require baseline adjustment.

SKEW

Measured in degrees (-85° through +85°), the Skew field slants selected text in place and can be
used on anything from a single glyph to an entire thread-frame story—whatever is selected.
Positive values skew the top of text forward or right, while negative values slant back- or leftward.
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In Figure 3.13, I skewed the word skewed by a value of —24°, slanting it backward. The question
mark has a Skew value of positive 20° to angle it to the right.

FIGURE 3.13
Feeling skewed?

DESIGNS COMING OUT SY&WH”

Align your thinking with REV Creativity Drink™!

Skewing selected type in place is not the same

as skewing a text frame. As you can see in

Figure 3.14, type slanted with the Skew field on the Character panel still forms rectangular para-
graphs with flush alignment (set to Justify with Last Line Left), but the slanting serrates paragraph
edges. Conversely, skewing the text frame itself via the Transform panel changes the area into
which text flows and slants the type simultaneously. Both have been skewed by -15°.
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frame (right) Rat, quismolore delenim tureer Rat, quismolore delenim tareev!
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When will you use the Skew field? If you have any taste whatsoever, almost never. Like base-
line shift, extreme values here can create extreme effects—and one in a million projects will war-
rant such—but its primary use is for subtle correction. Sometimes the italic or oblique style of a
given typeface is too extreme and needs to be scaled back with a negative skew. Sometimes sym-
bols or dingbats need a little slanting this way or that.

Use Skew with caution. After I tell you about the Language field, I'll explain Skew’s most obvi-
ous purpose and why and when you should, and shouldn’t, use it.

LANGUAGE

Right up front, so you don’t get your hopes up: InDesign does not translate text from one language to

another. Every time I introduce the Language field in person, via webcast, or even in writing, some-
one always gets excited about the prospect of InDesign automatically translating the text. It doesn’t.
That’s not the purpose of this field.
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If not translation, what's the purpose of this field and why is it a character-level attribute? As always:
good questions.

InDesign is fully, wholly, unlimitedly multilingual. If it can be typed, InDesign will type it. And
not just languages based on the Roman alphabet. You can type Japanese, Korean, Vietnamese, Chi-
nese, Russian, Czech, Arabic, Sanskrit, and even Klingon (more about that strange idea later) as
long as you have a font with the appropriate character set. You don’t need to buy a regionalized
version of InDesign just to set type in a language other than English. In fact, the only substantive
difference between InDesign’s English, Eastern European, Japanese, and other regional versions is
their user interface—Russian designers get menus, keyboard shortcuts, and so on in Cyrillic, while
Americans, Brits, Mexicans, Italians, and so on get Roman characters in English, Spanish, or Italian.

Because any regionalized version of InDesign can hold text from any known (or future) human
written language and because even fastidious Italian writers sometimes make typos, InDesign
includes the ability to spell check and/or hyphenate the most common world languages. If, for
example, you're designing an anti-drug pamphlet to be distributed throughout Texas, you're
required to produce the same information in both English and Spanish. Assuming you're putting
the copy in both languages on the same pamphlet, a spell check run in your English copy of
InDesign will seize on just about every Spanish word. If you have dynamic spell checking enabled,
your pamphlet will become a sea of red squigglies. So, instead of dealing with that nightmare and
the added complication of no hyphenation or possibly wrong hyphenation, select the Spanish
portion and set the Language field on the Character panel to Spanish. Your red squigglies will
disappear, and words at the end of lines will correctly hyphenate.

You can tell InDesign to use any one of 39 different spelling and hyphenation dictionaries on
selected text, including separate dictionaries for U.S. English legal and medical terminology. Because
language is a character-level attribute instead of restricted to the frame or story as it is in other lay-
out applications, multiple languages or language variants (e.g., English: USA: Legal) can be con-
tained in the same frame and even the same paragraph. This is a huge benefit to anyone who
routinely sets those types of multilingual documents in which each English paragraph is immedi-
ately repeated in Spanish, French, Vietnamese, or another language. Instead of setting each language
in its own frame and having to adjust all the frames for every little formatting or copy change,
placing them in the same text frame causes the entire story to adapt automatically to changes.

Using the Language field is easy: Just highlight text, and choose the appropriate language from
the drop-down menu. Once that’s done, InDesign will automatically change dictionaries when
looking at hyphenation or when running a spell check on the text, paragraph, story, or document.
Text defined as English: USA (the default) will be compared against the English: USA dictionary, a
sentence in the middle of the same paragraph set to Norwegian: Nynorsk will be compared against
that dictionary, an English medical term among that against yet another dictionary. Tres bien, mes-
dames et messieurs.

Character Transformations

InDesign includes much more control over character attributes than the basic styling options on
the face of the Character panel, but they’re scattered about.

CHANGE CASE
Anyone who imports and sets text written by clients or other noneditorial personnel will under-
stand what I mean when I say that sometimes you need to change the case of text.

Largely because of single-font typewriters, but perpetuated by laziness in the early days of
computers and now by habits developed in Internet communications, a large percentage of
the business world believes all caps equals emphasis—and CONTINUE to type anything of
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REASONABLE IMPORTANCE in all caps despite the obvious Bold and Italic buttons in Word.
Professional type designers recognize that all caps is usually not the best way to convey emphasis,
and they’re often left retyping the all caps words in imported documents. A word here and there
isn’t bad, but when an entire line is set in all caps... Oh, the inhumanity!

If CS3 is the first version of InDesign you’ve used, rejoice; you needn’t retype any longer. If
you've been using InDesign for a couple of versions, you're already aware that it’s always had
commands to change the case of selected text, right? No? Oh. Well, now you are. Microsoft Word
has the same commands on its Tools menu, by the way.

Highlight any text in your document and go to Type > Change Case. There you will find four
options: Uppercase, Lowercase, Title Case, and Sentence Case. Respectively, they transform text
into all caps; all lowercase; title case, where the first letter of every word is capitalized; and sen-
tence case, where only the first letter of every new sentence is capitalized. With text selected, an
even faster way to get to the commands is to right-click (or, if you have one of those insipid single-
button Mac mice, Control-click) and select Change Case from the context sensitive menu.

Changing case is not an effect; the text is really changed. Fresh text typed into the middle of trans-
formed type won't inherit the transformation. These commands can be undone with Cmd+Z/Ctrl+Z,
by selecting another Change Case command, or by simply typing over the transformed text.

CLEANING UP AFTER CHANGE CASE

A common scenario: A designer is faced with a story containing multiple heading levels, all of which the
author set in all caps. The final design, however, will use other formatting and title case for headings.
Correcting the problem is not terribly difficult—select each heading one at a time and choose Change
Case > Title Case. However, what if there are acronyms in the headings? Maybe it’s a regional sales report
with headings like “Year End Spending, USA Offices,” “Year End Profit, UK Offices,” and so forth. Maybe
it’s a government or government contractor report that, like all such reports, speaks in acronyms more
often than complete titles. Changing the case will incorrectly change the case on all the words that should
be capitalized.

Simple: Change the case, then undo the damage by running Find/Change from the Edit menu. Enter in
the Find What field the incorrect case word now littered throughout the document (e.g., Nasa), and the
correct capitalization in the Change To field (NASA). Check the Case Sensitive and Whole Word options,
and then run the change operation. Repeat as necessary for other common erroneous capitalizations.

Although a great help, the change case commands are not perfect. Sentence case, for example,
doesn’t do proper names, acronyms, or initials. If the letters of acronyms or initials that begin a
sentence are not separated by periods (as in the case of, say, NASA), the Change Case > Sentence
Case command will convert all but the first letter to lower case (Nasa), which, of course, is a
major faux pas. Proper names that don’t start a sentence will be rendered in lowercase—an even
bigger faux pas. Fortunately, InDesign does understand that a stand-alone I should be capitalized.

These four simple case commands have saved many a typesetter hours of retyping work and
countless typos caused thereby.

CASE EFFECTS
Choosing Change Case > Uppercase will transform text to full uppercase. Any mixed case used
for proper names, acronyms, initials, prepositions, or whatever will be completely and forever
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Examples of super-

seriptand subscript — Writing 55 is the same as saying five to the fifth power.
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lost. Moreover, spell check will read the words as all uppercase, which may cause it to flag mis-
spellings. A less drastic, impermanent option to transforming type to all uppercase is to use the all
caps effect, which creates the appearance of all caps but doesn’t actually alter the text.

On the Character panel’s flyout menu are two case effects: All Caps and Small Caps. The
former will make text look all uppercase, but in the background it will keep it in whatever case it
was before the effect was applied. Editing the text in story editor will also reveal its real case.
Small Caps will leave all capital letters as such but convert all lowercase to smaller versions of
the capitals. If the typeface in use is an OpenType font with genuine small caps built in, those
will be used; otherwise InDesign will fake it by scaling capital letter versions down to 70% of
their cap-height.

As a general rule, the height of small caps should be identical to the height of the lowercase let-
ters in the same typeface (the x-height). Rarely does the default of 70% correctly hit that mark. In
fact, most designers change the default small cap height to from 80% to 85% of the cap-height
when first setting up InDesign. To do that, open InDesign’s Preferences and go to the Advanced
Type pane. There, beneath Superscript and Subscript, is the size of small caps relative to cap-
height. Up that to 85% and try it out. If the results aren’t perfect, come back and tweak it.

Like most other things in the Preferences, the Small Cap percentage is a document-level attrib-
ute. Setting it to 85% for the current document will not change it in the next document you create;
it will default to 70%. To effect the change for all future documents, set it with all documents closed.

Exporting or copying the text out of InDesign to another application such as Notepad or an
email client, for example, will result in a reversion to mixed case.

SUPERSCRIPT AND SUBSCRIPT

Super- is a prefix meaning above, beyond, on top. Sub-, the antonym of super, is a prefix meaning
below, a part of, or under. Superscript glyphs are printed aligned to or partly above the cap-height
of text, and subscript glyphs partly below the baseline.

Typically approximately two-thirds (58%—-67%) the size of the text’s cap-height, superscript
notations are raised up such that their baselines are between 33.3% and 67% higher than the base-
line of surrounding text. Subscript notations are the same size and usually rest on baselines offset
by the same amount in the negative (-33.3% to —67%). Super- and subscripts are often numbers or
letters, but either can also be a symbol. Figure 3.15 shows a few examples of both in use.

E=mc?

REV Creativity Drink>™
They graduated 1%, 4™, and 23" in their class, respectively.

Meet me at 4:30™
H,O can be expressed also as O H, or even HOH

Void where prohibited by law..
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Let’s walk through the figure line-by-line as we discuss superscript and subscript.

The first five lines of the figure include superscript characters. The first two are mathematic
examples, using superscript to denote power of, or multiply the preceding number by itself this
many times. Einstein’s most famous formula, energy equals mass multiplied by the square root
of the speed of light in a vacuum, is the first example.

Most text typefaces include the trademark symbol (™) drawn so that it’s proportional to the
rest of the typeface in its proper superscripted size and position. Most also include a registered
trademark symbol (®), but few include the symbol used when the text or artwork is a protected
mark denoting a service, the service mark (SM). When it’s required, and a font doesn’t have it, you'll
need to manually create it by using superscript.

Next in the figure are mixed alpha-numeric ordinals, those handy little notations that represent
ordinals like first as 1st. Stylistically, you can use either lowercase or uppercase ordinals.

Finally in the superscript category, for those not yet comfortable with the much more efficient
24-hour clock (I dig efficiency), are time notations. Grammatical and design style rules for setting
AM. and P.M. are pretty loose. Your organization may follow a style guide that dictates their usage
and style; if not, you have options. AM, from the Latin ante meridiem meaning before midday, may
be written with (A.M.) or without (AM) periods. The same applies to P.M., post meridiem, after mid-
day. Both A.M. and P.M. can be styled in a number of ways—as superscript, as lowercase, or as
small caps. Never should they be set in full caps.

My recommendation is to small cap if you don’t superscript. If you do superscript, capitalize
AM and PM. I also recommend dropping the periods and the space between the time and its nota-
tion in either case, but especially if you superscript. (Of course, if you simply abandon the whole
5,000-year-old A.M./P.M. thing and go with a simple 24-hour clock, all this mess clears up instantly.)

On the next three lines of the figure, we have subscript.

In the chemical formula for water, 2 denotes the number of hydrogen atoms required in the for-
mula and should be subscript. Placing it above, superscripting, would be mathematical instead of
chemical and would effectively say multiply hydrogen by hydrogen, which is just mind-boggling
to even consider.

InDesign has its own footnote system (see Chapter 8, “Stories”), and you shouldn’t have to
manually set their reference numbers. Regardless, footnotes are usually set as superscript, but can
occasionally be subscript as I showed with the dagger on the last line of Figure 3.15.

To apply either superscript or subscript, simply select the appropriate menu item from the
Character panel flyout menu. The selected text will then be scaled and its baseline offset by the
amounts specified in the Advanced Type pane of InDesign’s Preferences.

Never separate either superscript or subscript from the preceding glyph it modifies.

Grammar dictates that a sentence’s ending punctuation must always follow superscript, supe-
rior, or subscript notations, even though doing so may look odd. Mitigate unusual results with
kerning.

For more on superscript and subscript, especially how OpenType fonts can make them look a
lot better, see the section on OpenType later in this chapter.

NO BREAK
The last option on the Character panel flyout menu is No Break, a useful albeit oft-forgotten little
command. Highlighting a word and applying this command will prevent InDesign from hyphen-
ating that word if it appears near the end of a line—extremely handy to prevent accidental
hyphenation of a proper name.

Many large organizations and government contractors have style guides dictating that certain
phrases cannot be wrapped such that part of the phrase appears at the end of one line while the
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rest wraps to the next line. Others must deal with setting personal names with prefixes (e.g., Mrs.,
Dr., MSgt.), suffixes (e.g., ., III, DDS); grammatical style strongly favors keeping prefixes on the
same line with first names and suffixes with last. Applying the No Break command to multiple,
concurrently selected words will ensure that spaces and punctuation between them cannot be
interpreted as a breaking point to wrap the line.

Be careful with No Break, however, because it could create some rather large and ugly gaps at
the end of a line. If you're using forced justification, where both the left and right edges are flush,
instead of big gap at the end, you'll get horribly large gaps between words and possibly even
between characters in the same word.

Setting an entire paragraph to No Break will tell InDesign to never break a line anywhere.
InDesign will do as you tell it, too, oversetting the entire thing until such time as you resize the
text frame to accommodate the entire passage on a single line, which may not be possible. If you
accidentally do this, back out with Undo. If that’s not an option, click in the box with the Type
tool, press Cmd+A /Ctrl+A to select all (it will select even overset text you can’t see), and toggle
No Break off again.

UNDERLINE
Think you know all about underlining text, that there’s no reason to read this section? Well...Uh.
You could very well be right. But, skim it just in case. You can do much more with InDesign under-
lines than you might think.

In its most basic form, the Underline command from the Character panel flyout menu will
underline selected text with a thin stroke the same color as the type. Open the Underline Options
dialog from the same menu, however, and you get a lot more options (see Figure 3.16).

FIGURE 3.16
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What do they all mean?
Underline On (check box) Check this option to turn on the underline.

Weight Measured in points like any stroke, this is the thickness of the underline and may be
any size from 0 to 1,000 points, in whole or decimal numbers. A drop-down menu provides
several common weights. Because there are 72 points in an inch, a 1,000 pt stroke would be taller
than an 8.5X11-inch page. A value in parentheses indicates Auto or the default, which is a line
1 pt thick.

Both the Weight and Offset fields enable stepping values up or down incrementally by using the
arrow keys on your keyboard, by typing in values directly, by clicking the up and down arrow
buttons to the left of the fields, or by selecting a common preset from the drop-down menu.

Type Type provides a drop-down of numerous styles of stroke, which is the first step in rec-
ognizing underline as more than simple underscoring.
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Offset This field controls the vertical offset of the top of the underline from the text baseline.
A setting of 0 points offset makes the top of the underline flush with the text baseline, running
the text into its underline (not recommended). Valid measurements are positive 900 down to
negative 900 points of vertical offset, enabling you to push the underline above any text smaller
than 900 points tall, to create an overscore.

Also, because underlines underprint text—that is, when a negative offset causes overlap with
the text—the text will appear in front of the underline, which helps the visibility of descenders
on letters such as j, g, and y when the underline is a different color than the type. With a thick
underline, the underlap also enables creation of a highlighter or reversed type effect on text.
And that brings us to...

Color Listed here are all the swatches from the Swatches panel, but, as with InDesign CS2,
which introduced Underline and Strikethrough, there is still no means of mixing a custom color
from the Underline Options dialog. To a use a custom color, you'll need to OK or cancel out of
Underline Options, mix a new color on the Colors panel, create a swatch on the Swatches
panel, reselect your text, and then return to Underline Options.

The (Text Color) option on this list synchronizes the underline color with the text color—when
the latter changes, so will the former. Gradients may also be used for underline colors as long
as you've created swatches for them.

Tint Although you cannot create a custom color inside the dialog, you can choose a tint of the
swatch chosen in the Color field, from 0% (paper color) to 100% (full ink color). Note that Tint is
not transparency; 10% of a red stroke is opaque blush, not semitransparent red.

Overprint Stroke (check box) Ouverprinting is the process of printing one ink color atop another
ink color, possibly allowing the two to mix. For instance, a yellow underline overprinted on a
blue background will almost certainly come off a printing press greenish because the blue will
show through, and visually mix with, the yellow. When this option is unchecked, overprinting
only occurs when it should—when the underline color is a darker or more opaque ink than
the color beneath. Otherwise, it will knock out the ink below the underline. Checking this option,
however, forces the underline stroke to overprint regardless of its color or the ink colors
beneath.

Gap Color, Gap Tint, and Overprint Gap These options are inactive unless the underline
stroke type is set to a style that includes gaps—any style other than solid. These fields perform
the exact same function as their counterparts discussed previously, but they do so on the gap
color of a stroke instead of the main color. With a dashed line, for example, these three fields
control how, if at all, the space between dashes is colored. By using both colors, you can create
the illusion that multiple strokes are layered without the loss of control and object management
hassles of actually having separate, layered strokes.

STRIKETHROUGH
Strikethrough and the Strikethrough Options dialog (see Figure 3.17) are identical to Underline
and Underline Options in nearly every respect. There are really only two differences, but they're
important.

First, Strikethrough’s intended purpose is to strike out text, communicating that something has
been withdrawn, invalidated, or deleted without actually deleting text. Thus, whereas underlines
underlap or underprint text, strikethrough strokes overlap, or appear in front of, type.
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FIGURE 3.17 Strikethrough Options
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The second difference between Underline and Strikethrough is where Auto offset originates.
Both strokes begin calculating offset by aligning the top of the stroke to the baseline of scored
text, but, whereas Underline’s auto or default setting is a small percentage below the baseline,
Strikethrough’s is the middle of the text, targeting vertical alignment with the x-height.

Want a design that looks like something requested from the U.S. government under the Freedom
of Information Act—you know, a page wherein every word you want to read is blacked out?
That’s simple: Set the Strikethrough stroke weight to at least equal to the font size (usually a little
more to account for descenders), and adjust its offset with negative values until the stroke com-
pletely blots out the text you want redacted. You could even be cagier than Pentagon officials by
using one of the hashed stroke types with a different shade, but equally opaque, gap color.

@ Real World Scenario

UNDERLINE STYLES FOR HYPERLINKS

Let’s assume you’ve just landed a plum job as the creative director for your company’s newsletter. The
newsletter, which is distributed to employees, clients, and vendors, is 10 years out-of-date, and your first
task as creative director is to redesign it from scratch. To save money and make the newsletter more
digestible, the company also wants you to move it from paper to PDF.

PDF’s ability to contain live hyperlinks will definitely help you exploit the power of the newsletter, but
how much thought have you given to the types of hyperlinks you may employ? There are many different
types of hyperlinks a typical corporate e-newsletter may contain—links to pages within the same PDF,
links to the company website and documents thereon, as well as links to outside resources and partner
websites. How are your readers to know which link will do what?

Take a cue from better Web publishers and use different underline styles to instantly identify your pub-
lications different types of hyperlinks.

1. Place or type your text—including the hyperlink candidate.
2. With the Text tool, highlight the text to be linked and that will be underlined to show the link.

3. Open the Character panel, and from its panel flyout menu, select Underline Options toward the
bottom. This will open the Underline Options dialog box.

4. First, turn on Preview on the right, and then check Underline On. You should immediately see
your selected text underlined.
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If you’ve used paragraph rules or at least strokes, the controls in this dialog should be familiar. Weight is
the thickness of the underline, with a drop-down list of common sizes, or you may type in any value. Off-
set is how far below the baseline the underline should begin. Again, you may choose a common preset
value from the drop-down list or type in your own. Both the Weight and Offset value fields may also be
controlled with the up and down arrow keys. Type is InDesign’s stroke types—identical to the Stroke
panel. Any preexisting swatch may be used as the color of the underline, or it may be left at its default,
which is the same color as the text. Choosing any swatch but (Text Color) None and Paper will enable the
Tint field. Gap Color and Gap Tint activate only if the underline type is one that includes gaps of some
sort—anything but Solid, really. Gap colors take the place of having to layer multiple objects to achieve
a two-tone dotted stroke.

5. Setup your external hyperlink underline how you like. Most users are accustomed to a solid, single
underline that is the same color as the text (which you should change from black to a contrasting
color like blue, green, or red). When ready, hit OK. Don’t forget to actually assign the URL on
InDesign’s Hyperlinks panel.

Not so tough, is it? Well, it may not be tough, but it is tedious if you have more than a couple of external
hyperlink underlines to format. Save yourself some time and make a character style for this particular
underline. Thus, underlining more text is simply a matter of highlighting and then clicking on the style
entry in the Character Styles panel.

Set up your other underlines’ styles the same way, making character style sheets for each of them, too.
Make them all obviously hyperlinks by changing their text and underline colors from the color of the
surrounding copy, but don’t go overboard. Thin single, double, dashed, or dotted lines tend to serve
readers well.

In the passage from my favorite corporate newsletter, 1 used the following styles:

& Links to other pages and resources within the same PDF were done in blue, with a dashed
underline.

& URLs for company-owned resources such as intranet systems (the Acme Customer First Order
Center) and links to documents on the company’s public website (the newsletter’s 1Q2006 issue)
were colored green and given a double underline.

& External resources, such as those for the Albuquerque Gazette review and the partner’s site, which
take the reader away from company-controlled materials, are styled with a single, solid underline
and colored red to closely approximate familiar Web hyperlink formatting.

In Same Document

Intranet/Company Controlled

External Resource
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THE CONTROL PANEL CHARACTER MODE

Wouldn't it be great if there were an easier way to get to commands such as Superscript, Subscript,
All Caps, Small Caps, Underline, and Strikethrough? Buttons! That’s what would be really slick,
buttons to click for those commands, on or off. Wouldn’t that be cool? Adobe thought so, that’s
why they built it (Figure 3.18).
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FIGURE 3.18 App D e e S N
The Control panel in
Character mode

Everything you can do from the Character panel you can also do from the Control panel, with
the added benefit of a half dozen buttons for commands otherwise stuck two clicks away on the
Character panel flyout menu. New in CS3, even some of the Paragraph panel options are there,
such as paragraph alignment and left, right, first line, and last line indents.

Just select the Type tool and the Control panel automatically switches into Character or Para-
graph mode. To toggle between the two, click either the A button or the 1 button, respectively, at
the left edge of the panel. In Paragraph mode, some character-level settings are available as well:
for example, Font Family, Type Style, Font Size, Leading, and even buttons for Superscript, Sub-
script, All Caps, Small Caps, Underline, and Strikethrough.

All this raises the question, Do you really need the Character and Paragraph panels? If you asked me
the same question about InDesign CS1 or CS2, I would resoundingly say, “Yes, you need the indi-
vidual panels.” That’s because, in those versions, the Control panel wasn’t complete. Even with a
flyout menu that changed per mode, the Control panel simply lacked the full depth of settings and
commands the individual panels had. With CS3, however, the Control panel has matured and now
serves as a full replacement for those dedicated panels.

Whether you want to get rid of them and save some much needed screen real estate is up to
you. Use either or both.

Special Characters

On the Type menu are a couple of submenus that make insertion of symbols, marks, and numer-
ous sizes and types of spaces much easier than using difficult-to-remember keyboard shortcuts.

Insert Special Character

Skipping the Markers section, which we’ll cover in later chapters, here are the different symbols,
dashes, quotation marks, and other marks accessible from the Insert Special Character menu.
Table 3.1 is the first, the Symbols menu.

Special characters will insert using the type style in effect at the place of insertion. If your cur-
sor is resting among text styled as Myriad Pro Black Semi-Extended 12/15.5 when you choose
Type > Insert Special Character > Symbol > Copyright Symbol, InDesign will insert the Copy-
right symbol drawn into the Myriad Pro Black Semi-Extended font, at 12 pt on 15.5 pt leading. If
the requested symbol (or space, as below), wasn’t built into the typeface by the designer, nothing
will insert or, with low-quality fonts, you'll get an empty box. If either happens, style the symbol
as another font that does have the requested glyph.

The Hyphens and Dashes menu begins with Em Dash (—) and En Dash (=), which are
undoubtedly familiar. The latter pair, Discretionary Hyphen and Nonbreaking Hyphen, might
require a little more explanation, however.
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TABLE 3.1: Symbols

MENU COMMAND SYMBOL DESCRIPTION

Bullet Character . A bullet, middle-dot, or waisted dot character.
Copyright Symbol © The good old C-in-a-circle.

Ellipsis The ellipsis is not the same as three periods. It’s actually

three dots smaller than periods with thin spaces between.

Paragraph Symbol q More correctly called the pilcrow, the paragraph marker
denotes a hard return or enables references to specific
paragraphs.

Registered Trademark Symbol ~ ® Used when a trademark has been registered with the
USPTO.

Section Symbol § The double-S section symbol.

Trademark Symbol ™ The standard trademark symbol.

A discretionary hyphen is, at most times, an invisible character—a marker really. Placing a dis-
cretionary hyphen in a word not at the end of a wrapping line of text has no apparent effect. With
Show Hidden Characters active, you'll see it marked as invisible (see Figure 3.19), but the word
won't hyphenate—unless InDesign decides it needs to wrap the line somewhere around the word
containing the discretionary hyphen. When that happens, InDesign will hyphenate and wrap the
word where you specified, even ignoring whatever syllabic breakdown is included in the diction-
ary for the same word. In this way, you can tell InDesign, I know better than you, and I want this word
broken at this point if it must break. You can even put multiple discretionary hyphens in a single word,
which is useful for longer or ad hoc compound words whose syllables or parts you want broken a
certain way.

FIGURE 3.19

A discretionary A h ﬂ
hyphen, visible m a a m a e . e : a“
when hidden char-

acters are shown

Nonbreaking hyphens, as the name implies, are the opposite of discretionary hyphens. They do
show a hyphen, but InDesign will not wrap at the point of the hyphen.

Take a compound word like the partners” names in Auchman-Reynolds Holdings. It's a proper
name, and it’s extremely bad form to break the two constituent partner names apart across lines.
Generally speaking, leaving a larger than normal right-edge gap is preferable to breaking a com-
pound proper name (we already covered ways to tweak surrounding text and mitigate the damage).
Because, as typed, that’s a normal, visible hyphen in there and InDesign looks to hyphens as the
first obvious break point when Auchman-Reynolds won't fit on one line, InDesign will break it after
Auchman-. To prevent that, replace the normal hyphen with its nonbreaking variant and InDesign
will never break the two words apart. It may still try to break Auchman or Reynolds syllabically—
that’s where the No Break command on the Character panel comes in—but it won’t sever the two
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at the hyphen—well, almost never. If a column is too narrow to fit the entire Auchman-Reynolds on
a single line, leaving InDesign stuck between oversetting the text or breaking it at the hyphen,
InDesign will choose the latter option despite the nonbreaking hyphen.

Next on the Insert Special Character menu is the Quotation Marks submenu (see Table 3.2).

TABLE 3.2: Quotation Marks

MENU COMMAND SYMBOL DESCRIPTION

Double Left Quotation Marks “ Left or opening curly quotes or typographer’s quotes.

Double Right Quotation Marks ? Right or closing curly quotes or typographer’s quotes.

Single Left Quotation Mark ‘ Left or opening single quotation mark.

Single Right Quotation Mark ’ Right or closing single quotation mark. Also called an
apostrophe.

Straight Double Quotation Marks Inch or minute hash mark.

Straight Single Quotation Mark : Foot or second hash mark.

Finally, the Other menu includes additional special characters (see Table 3.3), which are each
covered in greater depth in later chapters in context.

TABLE 3.3: Other Special Characters

MENU COMMAND DESCRIPTION
Tab A standard tab, just like pressing the Tab key on the keyboard.
Right Indent Tab Used in conjunction with the Last Line Right Indent field on the Paragraph

panel to add a hanging indent to the right side of a paragraph’s last line.

Indent to Here Allows selective indentation of the left side of a paragraph independent
of the value of the Left Indent field on the Paragraph panel.

End Nested Style Here When nested styles are used, this marker ends the nested style up to,
and inclusive of, this marker in the text.

Non-Joiner A zero-width non-joiner character that keeps two glyphs that would
normally overlap as separate glyphs. This is most often used with script
typefaces to prevent their tails from merging and with certain non-Latin
written languages where two glyphs combine or partially combine.

White Space Characters

All spaces are not created equal. That horizontal bar on your keyboard creates a full space. Over
the centuries, typesetters have developed numerous other spaces to satisfy many more situations
than can a full space. In days not as distant as you might think, hot-lead typesetting fonts included
numerous strips of metal or wood at varying widths to afford precise spacing under any circum-
stances (a font was the complete boxed set of a given typeface’s glyph blocks).
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InDesign 1-CS2 brought in many of the most common spaces—em, en, flush, hair, thin, figure,
punctuation, and nonbreaking full spaces—but CS3 adds even more. If you're a converted
QuarkXPress user who misses 3-, 4-, or 6-per-Em-Space, rejoice; InDesign CS3 has expanded its
space offerings. Table 3.4 lists them; follow along in Figure 3.20, which shows all the spaces in use.

FIGURE 3.20
Examples of all the
spaces available in
InDesign CS3. The
same samples dis-
played with Show
Hidden Characters
off (left) and on
(right).
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None; no spaces

Full (keyboard) space

Em space

En space
Nonbreaking space
Nonbreaking space (fixed width)
Hair space

Thin space

Sixth space
Quarter space
Third space

Figure space
Punctuation space

Flush space

Like an em dash, this space is (theoretically) as wide as the typeface’s

The width of an en dash and approximately half the width of an em space.

TABLE 3.4: InDesign Space Types
SPACE DESCRIPTION
Em Space

capital M.
En Space
Nonbreaking Space

A standard (full) width space that will connect the words or glyphs on
either side, disallowing them from breaking across lines. Like a normal
space, the nonbreaking space may shrink or grow as needed during com-
position to evenly distribute words in a line.

continued
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TABLE 3.4: InDesign Space Types (continued)

SPACE DESCRIPTION

Nonbreaking Space (Fixed Width) Similar to a standard nonbreaking space except that it will remain at a
fixed size, resisting composition attempts to increase or decrease its width.

Hair Space The thinnest available space, used when only a tiny amount of extra white
space is required (e.g., on either end of an em dash, between initials in a
proper name or acronym, or to assist in fitting other punctuation, symbols,
or characters alternative to kerning or tracking).

Thin Space Slightly wider than a hair space and used for the same purposes.

Sixth Space % of the width of an em space.

Quarter Space % of the width of an em space.

Third Space % of the width of an em space.

Figure Space The width of the typeface’s lining numerals, often used to help align figures
and numbers.

Punctuation Space The width of the typeface’s period. This is often used in place of hair space

when the hair and thin spaces are too narrow.

Flush Space This is a very important type of space. It’s a variable-width space that
widens to fill the last line of a justified paragraph. Normal composition
would, in this case, either leave text flush to the left (possibly creating
orphans) or, when the last line is set to full justification, stretch the spaces
between all words until the line is filled. However, inserting a flush space
causes all other words’ spaces to remain constant while the flush space is
expanded to consume whatever emptiness remains. If you’ve ever tabbed
out the last line to flush-right alignment—say, to insert an endmark to
close a magazine article—the flush space can take the place of the tab.

OpenType

The final frontier of cross-platform, multilanguage, and advanced typography has been tamed.
OpenType fonts fix most of the woes of digital typography—and open entire worlds of typographic
freedom and control.

WHAT IS OPENTYPE?
OpenType was conceived and developed as, and is, a complete replacement for all other font
formats—for use with nearly all current and future written languages.

Earlier we talked about font glyph tables—how every letter, numeral, mark, and symbol has a
slot to hold it in the font table. TrueType and PostScript fonts have a limit of 256 unique glyphs—
256 slots in their font tables. With Latin-based languages having only 26 capital and 26 lowercase
letters, 10 numerals, and about 60 common punctuation marks and symbols, 256 works. Oh, wait.
That'’s just for English, which doesn’t have any accented characters in its normal written language.
We can’t forget about French, Spanish, Italian, and Portuguese. Then there are ligatures. There
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are more symbols, too, such as the Euro, which isn’t in either the Type 1 or TrueType specifications
because it didn’t exist when they were written. Hmm. A font table of 256 is starting to look cramped.

Even squeezing all those in, non-Latin character sets won't fit in there. Completely different
fonts will need to be designed and distributed for German, Swahili, Chinese, Japanese, Korean,
Vietnamese, Russian, and so on.

Even if non-Latin languages are of no consequence to your work, small caps, discretionary liga-
tures, swashes, alternative glyph versions, and several differently styled sets of numerals should
be. Oh! Then we’re going to need bold, italic, bold italic, and roman styles of the main typeface as
well as such styles of small caps, discretionary ligatures, swashes, alternative glyph versions, and
several differently styled sets of numerals. And those are just the basics; we haven’t even touched
on other weights like light, medium, semi-bold, heavy, extra bold, and black or different scales
such as condensed, semi-condensed, extended, semi-extended...

How many fonts does one designer have to manage these days? It’s starting to get complicated,
isn’t it?

Raise curtain. Cue OpenType.

Whereas a Type 1 or TrueType font can hold only 256 characters, OpenType’s Unicode font table
has 65,536 predefined slots. Allow me to put that in perspective. A single font can contain the com-
plete glyph sets from Arabic, Armenian, Bengali, Braille embossing patterns, Canadian Aboriginal
Syllabics, Cherokee, Coptic, Cyrillic, Devanagari, Ethiopic, Georgian, Greek, Gujarati, Gurmukhi
(Punjabi), Han (Kanji, Hanja, Hanzi), Hangul (Korean), Hebrew, Hiragana and Katakana (Japan-
ese), International Phonetic Alphabet (IPA), Khmer (Cambodian), Kannada, Lao, Latin, Malayalam,
Mongolian, Myanmar (Burmese), Oriya, Syriac, Tamil, Telugu, Thai, Tibetan, Tifinagh, Yi, and
Zhuyin (Bopomofo). Even after all those are added, there’s room for several languages yet to be
included (tibergeeks are seriously considering adding Star Trek’s Klingon and two Elven scripts
from J.R.R. Tolkien’s Lord of the Rings trilogy), thousands of variations of other characters, and a
“private use” area for approximately 130,000 nonstandard custom or regional characters.

Let’s scale the discussion down to a typical, English language document. One OpenType font
can contain the complete upper- and lowercase alphabet, plus several versions of each, including
sets drawn as small caps, swash caps, and other derivations. Maybe, in an invitation like Figure 3.21,
you’d rather something with a few more touches of style than the one for the example on the left.
The one on the right uses the same two OpenType fonts—Arcana GMM Std and Adobe Caslon
Pro—but with slight differences owing to alternate glyphs in those fonts.

FIGURE 3.21

The same typefaces,
using alternate
glyphs contained in
their OpenType
character sets

;%/fm wic dosslinlly inited 1o the
REV Creativity Drink

AI‘II’]L[’JI Shareh()ldt:r ]JLII'ICI'IE()H

at the Motel 6 on the Median lsland of [-95
(between exits 18 and 19)

f(;g;wf’ 2007 2 00— i75m
All guests are asked to eat fast and bring their
own doggy bag.

"l fon i -ﬂ{?f:l’)iﬁf%{ inpited) Jo the

C
REV Creativity Drink
Annual Shareholder Luncheon

at the Motel 6 on the Median Island of I-g5
(between exits 18 and 1)

A %ﬁmﬁ 2007

ALL GUESTS ARE ASKED TO EAT FAST AND BRING
THEIR OWN DOGGY BAG.

Z_ s 00—2 .;_‘.fﬁ PM

Subsequently we’ll get into how to apply different OpenType effects and to access all the glyphs
in a particular font. Before we do, there’s one other thing I'd like to note: OpenType fonts are com-
pletely cross-platform, unlike Type 1 or TrueType fonts (Mac OS X can use Windows TrueType
fonts, but not vice versa).
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CROSS-PLATFORM AT LAST
The same OTF file Dad uses on his iMac can go to cousin Charlie’s Windows Vista computer. Yeah,
s0? What does that mean to me?

It means no more empty boxes in place of copyright symbols. No more text reflow when a
Windows-based designer sends a document for touch-up and RIP (raster image processing) on
a Mac. No more having to whip out Fontographer or FontLab to violate your font license by con-
verting your Mac-based colleague’s fonts just so you can touch up a couple of text frames.

OpenType fonts are 100% cross-platform—the only place Windows or Mac matters any more is
your personal preference. InDesign documents are cross-platform. Images such as TIFF, JPEG, EPS,
and even PSD and Al have been reliably cross-platform compatible for years. The last impediment
to creative document operating system homogeny was platform-dependent fonts. OpenType
knocks down that barrier, allowing any creative person—Windows or Mac—to work with col-
leagues on either without fear that something in the document will change from one computer to
the next. In fact, OpenType even works on most Unix-based operating systems.

UPGRADING TO OPENTYPE FONTS

Adobe OpenType fonts are all identified on Font Family and other menus by either Pro or Std after
the family name, which differentiates them from Adobe Type 1 fonts. Pro OpenTypes are those that
take advantage of the larger OpenType font table, including a larger set of special characters, while
Std (standard) typefaces are merely those that Adobe converted directly from their earlier Type 1
incarnations without adding additional glyphs.

Unfortunately, Adobe’s lead has not been followed by every type foundry, some of whom
have not altered their font names at all from TrueType or Type 1 through OpenType versions.
TrueType and Type 1 are dying (not dead), so keep your eyes open for new OpenType versions
of old favorites. As soon as you replace a Type 1 or TrueType font with an OpenType version, pull
the other versions out of your active fonts and stash them away somewhere, only to be used for
older document compatibility.

USING OPENTYPE FEATURES

Support for OpenType fonts is built into Windows 2000, Millennium Edition, XP, and Vista and, on
the Mac, into OS 9 and X. Therefore every application that runs natively in those environments—
except FileMaker Pro!—recognizes and can use OpenType fonts without special add-ins.

InDesign 2.0, released in January 2002, was the first application in the world to use OpenType
fonts” extended features. Its brethren Illustrator and Photoshop quickly followed suit, and a couple
of years later, so did QuarkXPress.

On the Character panel’s flyout menu, the OpenType menu grants access to toggles that turn
on or off various OpenType features (see Figure 3.22). Highlight text on the page, navigate through
the Character panel flyout menu to the OpenType submenu, and click the appropriate command
to enable or disable its effect. Features encased in brackets ([]) are not present in the currently
selected font.

Discretionary Ligatures

Ligatures are special glyphs drawn to avoid awkward pairings of letters. For instance, in Figure 3.23,
pairings such as ff, fi, ft, and others awkwardly collide with each other. The upper teardrop of the f
in fi, for instance, collides with the dot in the i. Consequently, type designers long ago developed
special glyphs called ligatures that, like the lower set in the same figure, combine the two characters
into a single, more elegant shape. Standard ligatures are turned off or on via the Character panel
flyout menu’s Ligature command. It’s on by default, which is a good thing.
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Standard ligatures are nothing new—they’ve been in our fonts for decades. But, two aspects are
new to OpenType.

Aligature has traditionally been a single character; the ffi ligature, for example, ceased to be f-f-
i. Running a spell check on a document containing ligatures invariably flagged words containing
ligatures as misspelled. No longer. Not with OpenType.

It comes down to the difference between characters and glyphs. A character is, well, a character—
letter, number, punctuation, symbol. A glyph is any form a character or another mark might take.
In OpenType, the dot over the lowercase i is actually contained within a different table cell from
the stalk of the letter. Every time InDesign or another OpenType-aware application draws an i, it’s
actually combining two cells in the table to form a single character. When the i is part of an fi liga-
ture, the dot is simply left off. The ffi ligature is actually three separate cells—the f twice, or as in
the preceding example, two different versions of an f, depending on the typeface and usage, and the
i’s stalk—combined into a single glyph. (The examples in Figure 3.23 are set using the Adobe Caslon
Pro Regular typeface.)

While ligatures look like a single character, and in most ways act like one as well, they are not
(see Figure 3.24). Behind the scenes, the technology built into OpenType still understands that
ffiis f-f-i—and so does InDesign’s spell checker. You can even copy text containing ligatures
from an InDesign document and paste into applications that don’t comprehend ligatures, like
Windows Notepad or Mac’s SimpleText; upon pasting, the ligatures will disappear, revealing
the separate f-f-i characters. This is a function of OpenType itself, not InDesign, although a robust
OpenType interpretation engine is required for an application to correctly understand and use

glyphs.
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FIGURE 3.24
OpenType technol-
ogy forms the liga-
ture glyph from
three separate parts,
which always retain
their constituent
selectable forms.

Because of all the extra room afforded by OpenType’s Unicode font table, additional ligatures
beyond the most common appear in some OpenType fonts (see Figure 3.25). Pairings like ct and st,
for example, can be joined with what are called discretionary ligatures—ligatures that you may or
may not want to include. Other discretionary ligatures are variations on the default, obligatory
ligatures. They add a nice touch once in a while, but they aren’t for every document.

FIGURE 3.25
Discretionary liga- C t S t t
tures (bottom) styl-

ize the appearance

Fractions

How much can OpenType really improve fractions? For many years, most fonts have shipped
with common fractions built in—% % %. Yes, they have, and those are great until you need some-
thing like %, %o, or %x. At that point, what have you typically done? Right: You superscript the
numerator and subscript the denominator, adjust their baseline shifts, and then kern them together
with a standard slash (/). It’s a hack, but it’s served us well over the years. Predictably, OpenType
does it better without hacks (see Figure 3.26).

FIGURE 3.26 1/4 1/2 1/3 5/8 1/288 5/621

Typed numbers and

slashes before using
the OpenType > 1/4 1/ 2 1/3 5/8 1/ 288 5/621
Fractions command

(top) and after
(bottom).
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Assuming you're using an OpenType font that includes them (my examples use Adobe Myriad
Pro and Adobe Caslon Pro, both of which do), you may have two complete sets of numerals in
addition to the full-size set—0-9 as numerator, and 0-9 as denominator (see Figure 3.27). These
will be numerals located respectively in the upper-left or lower-right corners of the font table cell;
they are already in the right place for a fraction and don’t need to be super- or subscripted. More
importantly, they’ll be drawn with stroke weights that match full size numerals and other glyphs
in the font.

FIGURE 3.27 | |
Adobe Caslon’s dif- | 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9
|2 3 4 > 6 7 8 9

ferent numerals. 0 1
Top to bottom: stan-
dard full-size,
numerator, and
denominator, all
shown at 30 pt.

10 1 12 13 4 L5 6 17 '8 19

As you can see in Figure 3.28, creating fractions with the age-old superscript and subscript
workaround merely reduces the size of the numerals. Their stroke weights scale proportionately,
making the digits obviously scaled and looking rather spindly and out of place compared to sur-
rounding text. Additionally, the separator between them is a slash, not a solidus. Some would
argue as vehemently against that incorrect glyph usage as I do against using three periods instead
of a correct ellipsis.

e 28 3% Tbsp. 1% cups % inch

faked with super-
et 3% Tbsp. 1% cups % inch

kerning. (Bottom)
Proper fractions
using numerals
drawn to be numer-
ators and denomina-
tors, as well as
proper solidi.

Compare the two lines. Which set of fractions looks out of place? Which matches its surround-
ing text? Here’s a more pragmatic difference between them: For just three sets of fractions. it took
me almost four minutes to set all the numbers as superscript or subscript and adjust their baselines
and kerning—and I used keyboard shortcuts to speed up that work versus doing it via menus and
the Character panel fields. Even having to make three trips to the OpenType menu, creating the
proper fractions took me less than 10 seconds.

Not only do OpenType fractions yield better typography, they're faster and easier. Just type your
fractions, highlight all three parts—numerator, slash, and denominator—and select Fractions from
the OpenType menu. InDesign and the font take care of the rest.

As in ligatures, all the characters in a fraction remain individually editable. Did you mean to
type 5/8 instead of 5/9? No problem: Highlight the 9 and type over it.
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Ordinals

Ordinals, or ordinal numbers, denote a position in an ordered sequence—first, second, third, and so
on. In this usage, ordinals refer to shortened ordinals—1Ist, 2nd, 3rd, and so on—specifically the
textual portion that comes after the number. As with fractions, pre-OpenType era required super-
scripting the textual portion to produce stylish shortened ordinal numbers. And, as with fractions,
that’s no longer necessary with a typeface such as Adobe Caslon Pro that includes drawn-to-size
letters for ordinals (see Figure 3.29).

e Ist 2nd 3rd  59th

(bottom) choosing
Ordinal from the d d h
OpenType menu 1 St 2 n 3 r 5 9 t

What may not be immediately apparent is that InDesign is actually reading the text. If I had
typed ph instead of th in the last item, 59th, InDesign would not have swapped the full-size ph for
ordinal versions; they would have remained full-size because InDesign (and the OpenType font,
which does a lot of the thinking itself) is smart enough to know that ninth is an ordinal but ninph
is gibberish.

Swash

Swashes (see Figure 3.30) are those extra special touches we used to manually add from separate
fonts that included nothing but swashed variants of letters. With OpenType, InDesign can replace
appropriate glyphs with swashed versions just from this one menu command (again, as long as
there are swash glyphs in the font). Better, as with ligatures, spell check continues to work, which
wasn’t always so when we used swashes from alternate fonts.

FIGURE 3.30 T Todoire Ballot €2 aw;/z(uf / Drodeceteor

Bickham Script Pro
is an elegant type-
face on its own (top),

but a few swashes (( ) g//(\“/// / e sz /(A)d/ 4 W@P{ / /5(/ fecelroire

(bottom) can really
make it special.

Titling Alternates

Titling variants are designed to enhance readability when type is set at large sizes, such as in arti-
cle headlines. As a matter of necessity, titling typefaces used to be separate fonts. Now, as with
Dante MT Std (see Figure 3.31), they can coexist in the same typeface with uppercase, lowercase,
and small cap sets.

Contextual Alternates
Of all the cool features of OpenType, Contextual Alternates is...well, it's my second favorite, really,
after multiple numeral styles. But, man, it’s wicked cool.
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Titling Alternates
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Open Type menu.

OpenType fonts are not just font tables, not dumb code collecting a bunch of vector outlines.
They re intelligent software, and under the direction of an equally intelligent type rendering
engine such as InDesign’s, the results can be brilliant (see Figure 3.32).

FIGURES.32  The qm’ck brown fox /""W over the [a,z/,v grey do_g.

™ Thequick o fox jumpedlove the lazy grey dog

In my example, I used Adobe’s Caflisch Script Pro, the showcase typeface for OpenType con-
textual alternates. Look closely at the circled characters and parts of characters. Compare repeated
letters such as the lowercase o or e. Notice that specific instances of each letter are different from
other instances, how some are allowed to connect to the next letter while others are denied connec-
tion depending on their positions in words and on the shapes of surrounding glyphs. InDesign,
once again, reads the text and looks beyond the single glyph, analyzing the shapes of surrounding
glyphs and spaces to choose from among the available versions of a given letter for the best fit, the
best interaction, the best aesthetic. Take the lowercase d as shown in jumped and dog. In the former
instance, the d is given a stylized ascender that helps it connect through the preceding glyphs; in
the second, the ascender is straight and demure, confining the d to the short word.

This particular feature of OpenType introduces to the digital age one of the most important
aspects of typesetting not seen outside manual typesetting: subtlety.

Typing a line like the first in Figure 3.32, all instances of a single letter will be identical—one e
is identical to the next e. We’ve come to expect this because we’re asking a computer to grab a
shape from a table cell; we're not pulling lead blocks from a font case. If you turn on Contextual
Alternates and then begin typing, you can actually watch glyphs exchange on-the-fly, depending
on the characters that precede or succeed each, whether a given glyph starts or ends a word, if you
enter punctuation marks.

All Small Caps

You know all about small caps by now, and you know you can convert lowercase to small caps or
mixed-case type to uppercase and small caps from the appropriate command on the Character
panel flyout menu. The difference between that command and this is that the one on the Open
Type menu will convert all letters to small caps, even uppercase ones (see Figure 3.33).

As with all OpenType features, the OpenType > All Small Caps command only appears active
(without brackets) if the OpenType font contains genuine small caps—glyphs drawn at that size
with stroke weights matching normal sized glyphs. In a bit of fortuitous oddity, however, either
small caps command will use genuine small caps instead of scaling uppercase down (if they exist
in the font, of course).
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FIGURE 3.33 MARY HAD A LITTLE LAMB. IT WAS SALTY.

(Top) After using the

Smal Ceps o« MARY HAD A LITTLE LAMB. IT WAS SALTY.

mand on mixed case
text and (bottom)
the same text after
using the All Small
Caps command on
the OpenType menu

Slashed Zero

Sometimes the capital letter O and the numeral 0 (zero) are drawn so similarly that distinguishing
them can be difficult—especially when they’re close together such as in a phrase like “10:00 O’Clock”
or an SKU, serial, or other number such as the one in Figure 3.34. Other times, you just want a little
more style. Consequently, many OpenType fonts include a slashed zero as part of their glyph sets.
The singular function of this particular command is to replace standard zeros in the selected type
with their more obviously null, slashed counterparts.

warssner - 9 | QOCK NO. 000012A00603

many OpenType

fonts that include a

i STOCK NO. 900012A00603
can be used to differ- *

entiate between

the letter O and the

numeral 0. Before

applying Slashed

Zero (top) and after

(bottom).

Stylistic Sets

Stylistic sets are an expansion of contextual alternates, allowing up to 12 different sets of contex-
tual alternates. Moreover, they can be selectively applied to text. For example, you might use sev-
eral sets to ensure that no two instances of the letter e in a title or sentence are the same e. Available
sets (if any) are built by the type designer, which affords her more than one or two opportunities
to express type design ideas. All those variants that never made it into a font, that were left only in
the type designer’s sketchbook, can now be made available for our use (this is a good thing for
both type designers and graphic designers). Because stylistic sets are typically groups of stylistic
alternates rather than single glyphs, the type designer can apply a cohesive aesthetic, changing
several characters at once to match each other (see Figure 3.35).

To date, very few OpenType fonts include many stylistic sets; however, now that InDesign has
created a user interface to make use of them, look for more to appear, broadening the creative and
stylistic possibilities of fonts. Garamond Premier Pro is one family that does include stylistic sets—
three of them—with subtle differences primarily in accented characters.
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FIGURE 3.35
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Positional Forms

Glyphs that vary their shape depending on where in a word they appear are called positional
forms. For instance, a g at the beginning of a word may look different from a g at the end or in the
middle. Positional forms are most common in script fonts and non-Latin, script-style language
fonts such as Arabic. Table 3.5 defines the potentially available positional forms to which InDesign’s
Character panel OpenType > Positional Forms menu offers access.

TABLE 3.5: Positional Forms

POSITIONAL FORM DESCRIPTION

General The most common glyphs and variants

Automatic Automatic alteration of the positional form based on where in the word the
glyph appears

Initial A glyph at the beginning of a word

Medial A glyph in the middle of a word

Final A glyph at the end of a word

Isolated A glyph appearing alone, as a single character

Positional Numerals

If drawn into the typeface, the four commands here—Superscript/Superior, Subscript/Inferior,
Numerator, and Denominator—will intelligently replace figures in the selected text with the
appropriate, purpose-drawn numerals. Such numerals will have been drawn at the correct size for
each of these uses, with stroke weights matching surrounding glyphs and in the correct positions:
for example, numerator digits are drawn in the upper-left corner of the font table cell.

Generally, to create fractions, simply use the OpenType menu Fractions command. However,
under certain circumstances, such as with large-number or decimal number fractions, OpenType >
Fractions may fail to properly format the fraction or may leave out certain digits. In those cases,
manually select the numerator and denominator and apply the appropriate commands.
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If a font does not contain one or another feature, use the other, similar positional numeral set-
ting ahead of a faux effect. For instance, if your chosen OpenType font lists Superscript/Superior
bracketed, try selecting Numerator ahead of the Character panel menu Superscript command,
which is a faux superscript affected by scaling and shifting a full-size numeral.

Figure Styles

Undoubtedly my favorite of all OpenType powers is the ability to easily use different styles of
numerals appropriate to the situation. Please tell me you recognize that typewriter numbers—
0123456789—are not the only style we have. In fact, for most of us, those should be the least often
used. There are four styles, as you can see from Figure 3.36, which show off the sets available in

Adobe Caslon Pro Regular.

FIGURE 3.36
Figure styles avail-
able in Adobe Caslon
Pro Regular: (from
top to bottom) Tabu-
lar Lining, Propor-
tional Oldstyle,
Proportional Lining,
and Tabular Old-
style.

0123456789

0123456789
0123456789

0123456789

What are all these and when should I use each?

Tabular numerals, as you can see in the first and last lines, are numerals that align vertically.
Each numeral is set in an equal-width cell, monospaced, allowing the numerals to be aligned tabu-
larly, such as one might see in a list—prices, scores, statistics, and so on. Proportional numerals,
by contrast, are treated like letters; they have variable widths, and thus they have variable inter-
character spacing. You definitely don’t want to use a proportional style for vertical number lists
because they won't align properly and will make the reader’s eye work far too hard to compare

one line to the next (see Figure 3.37).

FIGURE 3.37
Tabular numerals
(right) work much
better for vertically
aligned numbers
than do proportional
numerals (left).

Bananas

Oranges

99 1b Bananas 99 1b
1.151b Oranges 1.151b
.671b Apples .67 1b
2.211b Peaches 2.211b

The contrast between lining and oldstyle is vertical rather than horizontal, as opposed to tabu-
lar and proportional. Lining numerals are cap height, which makes them great for tabular data but
lousy for putting in a paragraph of text. In Figure 3.38 you can see the difference between the two.
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Squint or just quickly slide your eyes over the two paragraphs. Which set of numbers immediately
jumps out at you? Right, the lining. The problem is, numbers shouldn’t jump out at you.

FIGURE 3.38 Alis delit vel ea acipiscilis ea auguer irit autat Alis delit vel ea acipiscilis ea auguer irit autat
Lining numerals ecte tie dolortisisci tisit, quissed tionsed tin vo- ecte tie dolortisisci tisit, quissed tionsed tin vo-
(left) stick out of the Ior_per.ll. ad eu feug_alt aliqui ea augiam inciliqui Ior_per.lt_ ad eu feug_all aliqui ea augiam inciliqui
estincilit enummodio od magna faci blan ullam- estincilit eummodio od magna faci blan ullam-
text abnormally, cor 1949 aliquamcon ut nissed magna adit nulla cor 1949 aliquamcon ut nissed magna adit nulla
while oldstyle feuguer sit prat. Ut prat illa adiat, vero od delit, feuguer sit prat. Ut prat illa adiat, vero od delit,

numerals (right)
blend, becoming

vent ing ex ex et nim iuscin ecte ex exero com-
my nosto 18 March 1972 conum volore eum vel

vent ing ex ex et nim iuscin ecte ex exero com-
my nosto 18 March 1972 conum volore eum vel

only important iure tate magna feugait at ipsum volent adigniat iure tate magna feugait at ipsum volent adigniat
where they should— lut iril ectem. ero oqo?or ipit eugiamcon ver alit lut iril ectem_ ero m?u.lor ipit eugiamcon ver alit
in context nulputat, velisci duipit ulla amcorpercip 1936- nulputat, velisci duipit ulla amcorpercip 1936

39 exerili ssequam alis nis amcoreet loreet lut-
pat. Faccumm olobore tate dit praessi smolobor
sed dipis dolor sim quis dolore commy nim ex
exercil iquismo dignism odolestrud modiame
onsequat, 15,000 vel utpat, quatem ercillam nit,
quis endrer sum ipsusci llaorpe riurerate mag-
nit acin ute exeraestrud dunt nullam zzriustrud
dolum venibh ero eu feuisis alit num inim ip et -

39 exerili ssequam alis nis amcoreet loreet lut-
pat. Faccumm olobore tate dit praessi smolobor
sed dipis dolor sim quis dolore commy nim ex
exercil iquismo dignism odolestrud modiamc
onsequat, 15,000 vel utpat, quatem ercillam nit,
quis endrer sum ipsusci llaorpe riurerate mag-
nit acin ute exeraestrud dunt nullam zzriustrud
dolum venibh ero eu feuisis alit num inim ip et

Within paragraph text, nothing should ever jump out at the reader by virtue of its mere existence.
See the word nothing in the preceding sentence? That should jump out at you because [ want it to. I
deliberately used italic. Thus, emphasis is under my control, not the font’s. I'm the content creator.
I'm in control of my content and its style. (Well, me and the graphic designer who laid out this
book...and my publisher, the editorial team who are going back and forth about whether my
rhetorical questions to you should be quoted or italicized...Sigh. You get my point.)

Numerals that appear within sentences and paragraphs must be considered of equal import

with the text that buoys them. That text is seesaw, up and down, with capitals and lowercase and
x-height-based letterforms that have ascenders and descenders. It's about shape. Capitals always
exact attention, even when they shouldn’t, as do lining numerals, even jerking a reader’s eye away
from reading and comprehending sentences above and below. They diminish the importance and
readability of surrounding text. Oldstyle numerals, however, don’t compete; they blend to become
important only in context. If you want emphasis, use italic, bold, underlining, color—something you
can control from instance to instance. When you set lining numerals among mixed-case text, you lose
control and elevate the numbers to a higher status than the text that describes them and gives
them context.

Of course, setting numbers among all caps type, use proportional lining rather than oldstyle.
The goal in all cases is to make the numerals a natural part of the text surrounding them, not the
central focus to the detriment, and partial exclusion, of that text.

Glyphs Panel
Now that you know all the automated ways of inserting special characters and accessing Open-
Type features and how to access various glyphs predefined by the type designer as alternates for
different situations, let’s talk about where you can access every glyph in an OpenType—or other—
font at a moment’s notice.

The Glyphs panel (see Figure 3.39), which can be opened via Window > Type & Tables >
Glyphs, is the window into a font’s table. Like Windows’s Character Map and Mac’s Character
panel, the Glyphs panel shows every glyph in a font in a scrollable, resizable, zoomable, filterable
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grid. (There are some excellent new features here for CS3, so even if you're familiar with the Glyphs
panel from previous versions, this section is worth a read.)

FIGURE 3.39 e ahmtarc] 7
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USING THE GLYPHS PANEL

By default, the panel shows the glyph set from the typeface currently selected in the Character
panel. If text is highlighted, it will be that text’s font displayed. At the bottom of the panel, the two
drop-down menus for Font Family and Type Style enable browsing and using any installed font.
You could, for example, be working in the middle of a line of text styled as Georgia Bold but,
through the Glyphs panel, quickly insert a Not Equal symbol (#) from Futura Std Book.

The main area of the panel is the current typeface’s glyph set. Any empty table cells—glyphs
not drawn into the font—are omitted, allowing you to scroll through only the existing glyphs, not
all 65,536 potentially filled cells.

If you have the Type tool selected, and if the cursor is within a text frame, double-clicking any
glyph in the panel will insert it into the text at that point. If the typeface in the Glyphs panel is the
same as the one in your text frame, the glyph will insert matching surrounding text. Choosing a
different typeface in the panel will insert the glyph in that typeface, which will inherit all other
formatting options in effect at the point of insertion—point size, leading, tracking, and so on.

Harkening back to options on the Tools panel, some glyphs in the panel will, at least with
OpenType fonts, have a little black arrow in their lower-right corners. As with the Tools panel,
clicking and holding on arrow-adorned glyphs will open a flyout. In this case, it will be all varia-
tions the font contains for the selected glyph. Figure 3.40 shows that flyout for, and five different
available versions of, the ampersand in Adobe’s Garamond Premier Pro Regular.

FIGURE 3.30 f;ﬁlmhsx‘ —.;_:i___
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| aramend pramier b N - NP




SPECIAL CHARACTERS 97

Prior to CS3, the drop-downs were incredibly important to using the Glyphs panel because
InDesign sorted the Glyphs panel by CID/GID (Character ID/Glyph ID) by default, scattering
alternate glyphs throughout the panel as they are distributed throughout the font table. That
meant selecting them individually was a matter of either using the drop-down function or scrolling
and visually scanning the entire glyph set. Thankfully, Adobe recognized that we spend enough
time staring at type specimens. Now, the Glyphs panel instead sorts automatically by Unicode,
which places all variations of the same character side by side. Every version of A appears side by
side, allowing you to easily scrutinize their differences and choose the perfect one for your design.
If you prefer the old sort method, select Sort Glyphs > By CID/GID from the Glyph panel flyout
menu in the upper right.

If you can’t see the glyphs well enough, zoom in. The buttons in the bottom-right corner of the
panel zoom out or in, respectively.

If you know you want to see only the swashes in a typeface, discretionary ligatures, or just
numerals of different types, filter the display with the Show menu. The options in this list vary
from font to font based on the OpenType features included in the font itself. If a font has no small
caps, for instance, you won't have the option to filter it down to only small caps. That makes the
Show list ideal for examining your OpenType fonts and learning which features each contains; it’s
a lot easier than checking the Character panel’s OpenType menu for brackets font by font.

GLYPH SETS

With options shown via the panel’s flyout menu, the top row includes recently used glyphs from
all typefaces, enabling quick access to something you previously inserted. The last-used glyph is
always appended to the left end of the list, pushing other recently used glyphs to the right. The list
grows horizontally with the width of the panel; the wider the panel, the more recently used glyphs
you can access. To be candid, I'm not sure of the limit of that list. I've sized the Glyphs panel so
that it completely covered dual 17-inch monitors (2560 pixels wide) and still not exhausted the
Recently Used list.

The Recently Used list is variable: Every glyph you manually select from the panel will add to
the list, pushing others to the right. When you need consistently quick access to a stable of com-
mon glyphs, use glyph sets.

Let’s say you lay out a magazine. As in most magazines, your feature articles are closed with a
custom bullet endmark—the publication logo or another brand-enforcement element. The most
efficient method of creating and managing endmarks has always been to make a font of it, which
means the mark is inserted and formatted like any other glyph—color, size, tabs. Now, let’s also
suppose that your periodical’s style guide requires that all intellectual property notations (trade-
mark, registered trademark, copyright, and so on) be set in Helvetica Neue Lt Std 57 Condensed
regardless of the style of surrounding text. Maybe you’ve even got some custom fleurons or bullet
characters your managing editor likes. Let’s suppose half of those are in the Zapf Dingbats type-
face and the other half in Monotype’s WebDings font.

How many fonts are we up to now, three? Throw a Euro symbol from another typeface in there
for an even four. Glyphs from four fonts. Every time you insert those you’ll be relying heavily on
the Recently Used list. But, if you're a good typesetter, you'll use a bunch of other glyphs in the
interim, blowing your ability to rely on the Recently Used list. So, should you manually select and
sift through four fonts to get your needed symbols? (Would I spend this long setting you up if that
were the correct procedure?)

You can define custom glyph sets from the Glyphs panel flyout menu, and then you can load
them up any time you need. As you can see in Figure 3.41, I created a rather whimsical glyph set
containing a few glyphs from different typefaces (Blackoak Std, Webdings, Adobe Caslon Pro, and
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Myriad Pro Semibold Semicondensed). Glyph sets may hold any glyph, from any font, even the
same character from multiple fonts.

FIGURE 3.41 o) o
A custom glyph set Show! | Masmarng 190 Cod = =

A®I ~NDCS 3
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Create a new glyph set from the New Glyph Set command on panel flyout menu. You'll be
prompted to name the new set (make it unique) and how new glyphs should be inserted. The
options are Insert at Front, Append at End, or Glyph Value Order, which orders the glyphs by
Unicode ordering—in other words, A before B, B before C—regardless of the order in which
glyphs are added to the set.

Once it’s created, start populating. Using the other functions of the Glyphs panel, browse through
your fonts looking for glyphs to add to the custom set. When you find them, click once on the
glyph to select it without inserting it into your document, then right-click/Control-click and
choose the appropriate destination set from the Add to Glyph Set menu. The glyph will instantly
be added, and you can move on to look for the next.

If you make a mistake, choose your custom set from the Edit Glyph Set menu on either the
right-click context menu or the Glyphs panel flyout menu. A new dialog (see Figure 3.42) will pop
up. Here you can change the name or insertion order of your set as well as manage the individual

glyphs.
FIGURE 3.42
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By default, InDesign will remember the specific font associated with a glyph. Thus, a copyright
symbol added from Futura Medium is a completely different entry than a copyright symbol added
from Futura Light; when either is double-clicked on the Glyphs panel, it will insert the symbol in
that font—Futura Medium or Light—heedless of the typestyle in effect at the point of insertion. If
this behavior doesn’t suit you, if you'd rather have in your set a copyright symbol that does pick
up the typeface in effect at the insertion point, uncheck Remember Font with Glyph. You can also
change the specific font and style from the drop-downs in case you want a glyph independent of
insertion point styles but inserted the glyph from Futura Light when you meant to insert the
Futura Medium copyright symbol.
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On a side note, since we’re here: You may recall I stated that every glyph has a predefined
place—an A must be in the A spot and no other glyph is allowed to occupy that even if, as with a
symbol typeface, the font doesn’t contain an A. You might even recall that I alluded to how the Pri-
vate Use area of OpenType fonts might be used. Look again at Figure 3.42, beneath the drop-down
lists. See where it says Name: <private use area-F059>? The heart glyph comes from Microsoft’s
Webdings font. Webdings is entirely a symbol font—there are no standard letters or numbers in it.
Thus, all the usual spots a typeface like Garamond or Caslon fills with characters are unused in
Webdings. If this were a TrueType or even Type 1 font, Microsoft would probably have put the heart
where another font would have its K or $. Not only would doing so be against the entire Uni-
code standard and indeed the purpose of OpenType, which Microsoft co-authored, there’s no rea-
son for it. With approximately 130,000 open and unrestricted slots, Microsoft could have fit the entire
glyph set of Webdings into the Private Use area more than a thousand times before even approach-
ing the point where it would have to consider breaking the rules. The Private Use area was created
specifically for this purpose—to make room in the rules for symbol fonts, fleurons in standard text
fonts, corporate logos and endmarks, and anything else one might want to put in a font.

Getting back to custom glyph sets, you can use them the same way you use the Glyphs panel in
general. Load your custom set from the top of the Show menu.

Still ho-hum about the idea of custom glyph sets? Maybe this will grab you: You can share them.
So, you put together your set of article endmark, bullets and fleurons, intellectual property marks,
and the Euro symbol, all from different fonts, and then upload the glyph set to the server from
which your entire workgroup can grab it. Instantly, the tedium of manually tracking down and
inserting those marks will be eliminated for your entire group, and the likelihood of mistakes
happening will be dramatically reduced. This is exciting (I've been campaigning for the ability to
share glyph sets since InDesign CS, which introduced glyph sets, was still in alpha.)

Each new glyph set you create is saved to your hard drive outside of InDesign (instead of into
the preferences as in past versions, waiting to be eradicated when you next reset the prefs). You'll
find it in the Adobe InDesign CS3\Presets\Glyph Sets folder saved as the name you set on the
Glyphs panel. To share it, simply copy the external glyph set file to someone else’s Adobe InDesign
CS3\Presets\Glyph Sets folder. As long as recipients have the same fonts, they can use the same
custom glyph set. Any time the set is updated, repost it to the server or push it through to client
systems using SMS or another automated update system; the entire workgroup will always have
the latest set of symbols and marks in accordance with your style guide.

The Bottom Line

Format Characters Formatting characters is more than just choosing a size and font.

Master It Build a single-page magazine article, using FPO copy if needed, and include
typical features of an article: headline, kicker, byline, subheads, body copy, and writer bio
block.
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Transform Characters InDesign includes much more control over character attributes than
the basic styling options on the face of the Character panel, but they’re scattered about.

Master It Creating a highlight (including reversed) effect on type is common enough that
designers have cobbled two means of doing it. The first and more common method, within
InDesign, is to place a colored rectangle behind text as a separate object. While it gets the
job done, it creates yet another object that must be moved and resized to reflect changes to
copy, text style, and reflow—and arduously at that because the text frame sits in front of the
colored box, making the latter difficult to select. Less common and infinitely more risky is
the Acrobat highlighting method. Within Acrobat is a commenting tool called the Highlighter.
Choose the tool and highlight color (from common colors such as yellow, pink, and blue),
and drag-select type. The highlight appears on screen and looks great. Unfortunately, it
doesn’t print unless the user deliberately changes a setting in the Acrobat Print dialog, the
existence of which most Acrobat users are totally unaware.

Using the same article, and using the skills learned in this chapter, highlight or reverse a
few words in the correct, printable, and flexible way. Then, insert at least two URLs in the
article and style them appropriately but distinctly from each other.

Insert Special Characters Not everything can be typed without phalangeal acrobatics worthy
of an Olympic gold medal.

Master It Continuing your work with the mockup article, find at least three places where
trademark and registered trademark symbols belong (use your imagination if you're using
gibberish FPO copy). Declare your work with a properly formatted copyright notice
beneath the article. Find a few proper name phrases that shouldn’t break across lines, and
ensure that they don’t. And, finally, insert em and en dashes where they belong, with slight
padding around the em dashes.

Work with OpenType Font Features OpenType fonts fix most of the woes of digital typogra-
phy—and open entire worlds of typographic freedom and control.

Master It Create pullquotes in separate frames, complete with quotation marks, unique
styling, and—because pullquotes garner much more attention than body copy and draw
the reader into a story—pull out all the stops by using OpenType features to style them
perfectly.
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Use the Glyphs Panel Every glyph in every font can be accessed by this one, elegant panel
and then inserted into the text.

Master It Concluding the work on the mockup article, cap the story with a custom end-
mark chosen from a symbol font and inserted into the last line of the article (ahead of the
writer bio block). Once done, build a new custom glyph set to make reuse of the endmark
easy for the next issue. Send the glyph set to a co-worker or friend so she may try inserting
the same endmark.

A new glyph set containing a single glyph should be created and made ready for sharing.
In a classroom or other multi-student environment, have the students title their custom
glyph sets with their own names, pair up, and then exchange their sets with partners for
installation and trial.






Chapter 4

Drawing

InDesign is not lllustrator, and it never will be. Illustrator is the pinnacle of modern vector drawing
tools, and neither InDesign nor Photoshop will ever replace or absorb it. Fortunately for us, how-
ever, the Illustrator team happily shares its code with the InDesign team (Illustrator is a nurturing
older sibling). Consequently, many of the most common drawing tasks can be done directly within
InDesign without the need to load up Illustrator and then move artwork from it into InDesign.

It’s a matter of efficient creativity—two of my favorite words combined in my favorite phrase.
In this chapter, you will learn to:

¢ Draw precise paths with the Pen tool

Freehand draw paths with the Pencil tool

¢ Combine and subtract shapes, and convert from one shape to another
¢ Modify any vector artwork
¢ Turn type into a container to hold images or text

The Essence of Vector

Before getting into the tools that create vector paths, let’s make sure we all understand the defini-
tion of vector.

Vector is the opposite of raster. Raster artwork comprises square pixels tightly packed into a
grid. Because that grid is a fixed size specific to each image, it means that raster images have a fixed
resolution. Increase the size of a raster image and you're expanding one pixel’s data into multiple
grid cells, usually in a way that combines or averages the data with surrounding pixels” data, which
blurs edges, merges colors, and lowers image fidelity overall. Shrinking a raster image down yields
sharper edges and overall better results, but you are still destroying image data. Each pixel can only
be filled with a single, solid color, so reducing the size, making room for fewer pixels, means some
are being thrown away.

With vector, however, no damage is ever done, no data sacrificed, during resizing operations.
For that matter, vector shapes are also infinitely editable without permanent data damage—some-
thing raster images are not. Vector artwork is not based on pixels or a grid. Instead, it’s simple
geometry based on planes.

Figure 4.1 should look familiar to you no matter how long you’ve been out of school. Our
three-dimensional world is divided into three dimensions, or planes: Left-to-right, horizontal posi-
tion, and object width is plotted on the x-axis; top-to-bottom, vertical position, and height on the
y-axis; and front-to-back, depth, relative distance, and what we often call stacking order, is plotted
on the z-axis. Describing the volume of a cube, for example (see Figure 4.2), entails asking three
questions: How wide is it along the x-axis, how tall along the y, and how deep along the z? This is
why, in places like the Transform and Control panels, you have positional fields for x and y.
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FIGURE 4.1 Y
All vector artwork
exists in three-
dimensional space,
along the x-, y-, and
Z-axes.

FIGURE 4.2
A cube exists along
on all three axes.

If you have a box handy, grab it. Each surface or face of a box is a plane: it exists solely along
one of the three axes. Stick six planes together—top, bottom, right side, left side, front, and back—
and you have a three-dimensional solid; and if the sides and planes are all equal, it’s a cube. The
place where each plane intersects with another is called a vertex.

When you're examining a real-world object like a box, planes and vertices are what define the
volume and shape of an object. Talking about vector drawing, however, is slightly different; it’s
not the faces and sides that matter but the corners. Consider Figure 4.3, the same cube drawn with
its faces unfilled. It still has planes; they just aren’t filled with color.

Even with this wireframe cube, the vertices, the lines connecting the corners, are secondary to
the importance of the corners themselves. It’s the corners that truly define and describe the shape
of the object.

Vector shapes are formed by the relationship of corners—anchor points—and the lines that con-
nect them—path segments. Together, anchor points and path segments form paths. Every path must
have at least two anchor points (i.e., to begin and end the path) and a path segment connecting the
two points. Closed paths are those that have no discernable start or end point—a complete circle
or square, for example—while open paths are incomplete, with obvious start and end points.
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FIGURE 4.3 Y
A cube without fills
reveals the corners

and vertices that X e
define its shape.

Because anchor points exist in three-dimensional space along the X, y, and z planes and not
within a fixed-resolution grid, the relative size of the planes—and anything on them—can be
scaled up or down infinitely without losing quality in the drawing. Although they appear to be
squares of a certain size onscreen, anchor points don’t have a size; zoom in or out and anchor
points remain the same size.

The cube we looked at earlier has volume because a computer draws a connection between the
coordinates. Like the coordinates themselves, the connections have no inherent volume, width,
height, or depth; they’re just lines drawn between points on the three planes. Volume is created by
the relationship between points on all three planes, and that relationship is relative. A square is a
square because four anchor points are equidistant from one another. Move all four the same dis-
tance downward and the object is still a square. Enlarge the square and it’s still a square, with
anchor points at the exact same relative distance from one another.

You see, resizing vector artwork isn’t really resizing. It's more like zooming in or out in three-
dimensional space. Shrinking an object down to half of its size is like zooming out to view a docu-
ment at 50%, like seeing the object from farther away. The object and all its detail are intact, even if
they aren’t discernable from that distance.

This is the essence of vector—total independence from any concept of resolution or image qual-
ity. If you’re new to vector, that can be a difficult notion to wrap your mind around—at first.

Drawing Paths

Drawing in InDesign is accomplished with a number of tools—many the same as in Illustrator,
Photoshop, and other applications—and any discussion of them must begin with the Pen tool.

The Pen Tool and Straight Paths

Let’s start exploring the Pen tool by drawing a simple path with two anchor points joined by a
straight path segment.

1. Using the Pen tool, click once and release somewhere on the paper—do not drag.

2. Move over a few inches and click again. A straight path segment should connect the two
anchor points.

105
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If you see only a faint blue line for the path segment, you don’t have a stroke color assigned;
press D to activate the default black stroke color. If that still doesn’t do it, check the Strokes panel
to ensure that it has a weight. In the end, you should have what I have (Figure 4.4).

FIGURE 4.4 =

A straight path,

consisting of two
anchor points joined
by a straight path

segment

Now, try making a perfectly level horizontal line.

1.
2.

3.
4.

5.

If your rulers are not showing, make them show with Cmd+R/Ctrl+R.

With the Selection tool, click the horizontal ruler and drag a guide down to an empty area
of the page or pasteboard.

Switch to the Pen tool and make the first anchor point by clicking directly on the guide.

Move over a few inches and, again, right on the guide, click to make your second anchor
point. As your cursor approaches the guide, you'll enter the snap zone, the area within a few
pixels of a guide that will cause the cursor to jump toward the guide. You'll know when
your cursor snaps to guide by the change in appearance from a nib with an X to a nib with
an empty arrowhead. If the snapping bothers you, turn it off by toggling off View > Grids
& Guides > Snap to Guides.

To fully appreciate your new path, hide guides with the Cmd+;/Ctrl+; keyboard shortcut.

Now, let’s try the next step and create a rectangular path.

1.

2.

Either on a new layer (with the last hidden) or a different area of the page or pasteboard,
drag two guides from the horizontal ruler, leaving a few inches between them.

Do the same from the vertical ruler, defining a roughly square shape with the four guide
lines.

Working counterclockwise from the bottom left with the Pen tool, click the bottom-left
intersection of guides, exactly where they cross, then click the bottom right, the top right,
and finally the top left.

At this stage you should have what appears to be a backward C. This is an open path
because it has a start and end point.

Let’s close the path: With the Pen tool still selected, click again on the bottom-left corner,
directly on the anchor point already there. As you get close to the anchor point, the cursor
will change from just a pen nib to a nib with a circle (see Figure 4.5).
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FIGURE 4.5

When closing a path, F
the Pen tool cursor

picks up a small circle

icon indicating a

change in function

from continuing a

path to closing a path.

Now, all on your own, try drawing a triangle. How about a six-sided polygon, like a stop sign?
Everywhere you want a path to change direction, insert an anchor point. Anchor points control the
direction of each subsequent path segment.

Let’s try one more exercise, this time using one of my sample files.

From the project files available on the book’s download web page, open pathtrace01.indd.
You'll see the single-page document in Figure 4.6. It contains two layers: the upper one, “Trace on
this Layer,” is for you to trace the content of the lower, locked layer, “Original.”

FIGURE 4.6 B pathtraced1.indd
Hey, if 1 didn’t think .
InDesign was cool,
would I write a book
about it? No, of = s g > |

course not. Instead, ] b w A b { ‘ |

I’d publish a website E i J g ) v :
comparing it to its ] : | > | - | '
leading competitor
(wink).

1. Using the Pen tool, trace the rectangle of the I until you have a closed path.

2. Once the I is finished, open the Swatches panel and fill it with a color other than orange so
you can see how close your tracing was to the original.

3. Begin tracing the N. Once it’s finished, give it a fill color, too, and move on to the D, the E,
and so on until you've traced every letter of both words. Be careful to simply click and
release to create a new anchor point; don’t click and drag. See how close you can approxi-
mate the curves of the D, Ss, G, R, and U using only straight path segments.

Getting a feel for the Pen tool and how to think about shapes by considering the placement of
their anchor points? Starting to feel confident drawing straight-segment paths with the Pen tool?
Good. Now, let’s move on to what straight lines can’t do.
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FLATTENING, CURVE OR TRANSPARENCY?

By drawing rounded edges using straight path segments, you performed rudimentary curve flattening.
When a document moves through a RIP (rastor image processor), all vector objects are converted to raster
pixels or dots so that a print output device can create halftones of the image. Because pixels and halftones
are fixed resolution and grid based (with a pixel or dot either being wholly on or wholly off), a curve,
which might only partially fill the pixel or dot, must be converted to a series of straight lines that are
more easily fit into a grid. They’re usually very tiny lines, but straight nonetheless. This is the process of
curve flattening.

Before alpha transparency made its way into PostScript 3, when a print professional used the word flatten-
ing, it was in reference to curve flattening. Now it’s generally used in reference to transparency flatten-
ing—another matter entirely. Although curve flattening is still as relevant, it’s stable and, after 20 years,
predictable. Transparency flattening in the print workflow, however, has more recently been the major
source of concern, innovative workarounds, expletives, and empty bottles of Pepto-Bismol.

The Pen Tool and Curves

Anchor points control the angle of path segments. Wherever a path must change its direction, it’s
the anchor point that actually does the work. The same is true of path segment curvature.

Every anchor point has the potential to curve the path segments on either or both sides of it.
Consider the S-curve in Figure 4.7. Note the two distinct curved parts in the S, one up, one down.
The divider line shows which curve is being generated by which anchor point.

FIGURE 4.7 |
In this simple S-curve,
the curve on the left
is created by the
anchor point on the |
left, and the curve I
on the right by the

other anchor point.

Introducing curvature is simple: Instead of clicking and releasing with the Pen tool, click and
drag. As soon as you begin to drag, the anchor point goes from being a corner anchor point to a
smooth anchor point and curve handles appear (see Figure 4.8). The angle and length of curve han-
dles control the direction and depth of path segment curvature. Drag a handle straight down and
the resulting curve will be symmetrically bowl-like; drag a handle down and at an angle and the
resulting curved path segment will be asymmetrically deepest in the direction of the curve handle
and shallow on the end farther from the curve handle.
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FIGURE 4.8

The same S-curve,
showing the curve
handles that define
its curvature

UNWIELDY TERMINOLOGY

Corner anchor points and smooth anchor points are unwieldy. No, not the points, the names themselves.
Those are the official names Adobe gave them, but they’re both just anchor points. Also, when anchor
points appear at the beginning or end of an open path, Adobe often refers to them as end points. Although
that makes sense, it’s yet another term for effectively the same thing: an anchor point, which is how I’11
usually refer to them all from here on.

Really, to understand this stuff, you have to do it. Let’s give it a shot with another sample file I
provided. From http://www. sybex.com/go/MasteringInDesign, open pathtrace02.indd. There’s the
S-curve. Let’s trace it.

1. With the Pen tool, click the first anchor point (marked with the faded number one) and
drag down toward the solid number one, trying to match your curve handle to mine.
When you release the mouse button, you should see just an unassuming little anchor point.
You've created curvature in the anchor point, but not yet a path segment to show it off.

Remember, although anchor points hold all the data, that data is invisible until a line is
drawn to display it.

2. Repeat the procedure with the second anchor point, clicking and dragging again following
the point near the number two. This time, as soon as you click the Pen tool onto the page,
you'll notice the path segment. Dragging the curve handle around a bit will enable you to
experiment with the depth and location of curve to fine-tune it.

Did you notice any difference on your second anchor point? As soon as you create the second
anchor point, defining that the path went to the right from the first point, only one curve handle
survives on the first anchor point. The reason for that is because, as the first point, it could only
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have one path segment emanating from it. With the second anchor point, however, you were con-
trolling not only the path segment to the left, but also a potential path segment to the right.

On a new layer, retrace the S-curve using the same procedure. Instead of deselecting the path
after the second point, click and release an inch or two away to create a third anchor point. Even
though you clicked and released instead of dragging, the resulting second path segment still has
curvature. Why? Because of the anchor point to the left.

Each anchor point may have up to two path segments attached to it—in this case, one to the left
and one to the right, though path segments can radiate off points at any angle. That path segment
receives a curve handle, but only one per anchor point. Because a path segment must exist between
two anchor points, the segment actually gets two curve handles—one for each anchor point.
Reflecting back on drawing the S-curve, it’s obvious the first curve is created by the anchor point
in position 1 on the left, the second by the anchor point in position 2 on the right.

Curve handles control the path segment on the same side of an anchor point, and when you
drag them, the segment curves toward the handle.

When you created the second anchor point, it had two curve handles. The handle you didn’t drag
controlled the path segment to the left—the incoming S-curve—and the other, the one you did
drag, was setting up for a possible path segment on the right. Creating the third anchor point—
completing the circuit—actualized the second segment. The second segment was a bowl instead of
an S because you didn’t drag the third anchor point and thus didn’t add any curvature emanating
from that point.

While drawing with the Pen tool, you are always dragging the curve handle corresponding to
the outgoing path segment.

Looking at the path of a perfect circle (Figure 4.9), you can see there are four anchor points posi-
tioned equally around the circle. This is the minimum number required to create a perfect circle in
Bézier curve-based vector illustration because the geometry involved limits the way curves attach
to anchor points.

FIGURE 4.9 . o .
Four equidistant

anchor points with

matching curve set-

tings form a circle.
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In the circle, each anchor point controls the curvature of the path segments attached to either
side. Creating a perfect circle requires that the curvature and angle of all four anchor points be
identical; a variance would distort the shape. Notice how the curve handles are either straight up
and down (90°) or flat (0° rotation). The handles align with the axes on which the anchor points
themselves sit—y or x, respectively—and create a perfect, uniform curvature thereby.

From the book’s download page, open pathtrace03.indd and see how closely you can trace the
circle diagram there using the Pen tool. Remember to end your path at the first point you drew to
close the circle.

How did it turn out? If it’s not exact, try it a few more times. Drawing circles is difficult and
takes practice. Mastering the Pen tool, anchor points, and path segments is essential to so many
other things in InDesign... Really, it's worth the time to try it out a few times. Once you've got the
tracing going pretty well, hide the “Trace This” layer and see if you can draw a perfect circle from
scratch. If not, practice some more. Rome wasn’t drawn in a day.

Forget to close a path or need to continue a previously drawn path? Move the Pen tool over the
last anchor point on the path—either the beginning or end point—click to activate the path, and
resume drawing. Using the same method you can even join two independent, open paths.

Pen Tool Aspects and Incarnations

Like the pantheons of ancient world gods and goddesses, many of the most powerful tools manifest
themselves in more than one aspect or incarnation. King of the vector drawing tools, almighty Pen
tool, like Zeus/Jupiter/Odin, has many aspects, each with remarkably similar powers if not faces.

CONVERTING ANCHOR POINTS BETWEEN CORNER AND SMOOTH
As you saw, path segments get their curvature from anchor points. Create curvature on the right
of an anchor point and it will be inherited by the path segment on the left and vice versa. What if
you don’t want curvature to inherit? How do you, for instance, follow a curved segment with a
straight one?

High atop Mount Olympus, the Pen tool’s Zeus incarnation makes converting anchor points
while drawing faster than hurling a lightning bolt.

1. With the Pen tool, start a curved path similar to the S-curve with which we’ve been work-
ing. Make your first and second anchor points, both with curvature.

2. Before making the third anchor point, hover the cursor back over the second and watch
what happens. Notice the little inverted V that appears in the corner of the Pen tool cursor?
That’s the convert anchor point cursor, and it will change the outgoing side of an anchor
point from a corner to a smooth. Click the second anchor point and watch as one of the
curve handles—the one corresponding to the path segment not yet created—disappears.

3. Now, click away from the second anchor point to create the third. You should wind up with
a straight path segment between them.

The same holds true if you start with a straight path and corner anchor point and need to make
the next segment curved—click the last point and drag to expose the curve handle.

In its full Zeus incarnation, the Pen tool may appear to many as the Convert Direction Point
tool, which is behind the Pen tool on the Tools panel. In this full manifestation, clicking a point
will convert both sides of it, stripping away or granting curvature to the path segments to both
sides simultaneously. As with the convert anchor point variant of the Pen tool, when going from
corner to smooth anchor point with the Convert Direction Point tool, click and drag out a bit to
reveal the curve handles. Later in this chapter we’ll get into manipulating those curve handles
after creation or initial conversion.
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ADDING AND REMOVING ANCHOR POINTS

Another common consideration in drawing vectors is whether a path has too many or too few
anchor points. To alter this, we have two more aspects of the Pen tool that render paths as mal-
leable as the clay from which Jupiter, king of the Roman gods, purportedly formed mortal men
and women.

Because each anchor point is plotted on the three-dimensional graph of x-, y-, and z-axes, and
because each anchor point contains angle and curvature data, paths require computer processors
to work out the math. Overly complicated paths and excessive anchor points cause slow screen
redraws when scrolling and longer print times. Unnecessary anchor points in a path can also cre-
ate an aesthetic issue: unwanted changes to the path directions or curvature.

If you still have the Pen tool selected, move your cursor over a path segment, maybe around
the middle between two anchor points. Notice the little plus sign added to the cursor? Click and a
new anchor point will be inserted at that point in the segment. The new anchor point can then be
manipulated with the Direct Selection tool (we're getting to that) to alter the path at that point. To
infuse curvature in the same action, click and drag.

Removing extraneous points is just as easy: Position the Pen tool cursor over an anchor point
instead of a path segment—presenting a nib with a minus sign—and click. With the anchor point
and its associated angle or curve control removed, the path segments on either side will merge and
adapt to account for the excised point. Consider the path smited.

If you need to add or delete more than a few points in a path, it’s often more efficient to use a
tool dedicated to the task. Once again behind the Pen tool on the Tools panel are other faces of the
god: the Add Anchor Point tool and the Delete Anchor Point tool. Like Jupiter in toga, in battle
armor, or in sandals and Golden Fleece, theyre still the same formidable Pen tool, with the same
powers.

PERFECTLY STRAIGHT PATH SEGMENTS

Few know that the Pen tool can make perfectly straight, level lines without using guides. Unlike
the other two incarnations of this same tool, the Pen tool in straight line mode doesn’t just pick up
slightly different cursors; it can do the job wearing its own face or a completely different one.

Beside and down from the Pen tool is the Line tool. When all you want is a straight line, here it
is. Click, drag, done. Click and drag while holding Shift to constrain the angle of the line to an
increment of 45°. If you need a specific length of line, draw it and then resize via the Control or
Transform panel.

The Line tool creates a simple, open path with two anchor points, which can be manipulated like
any other points (see later in this chapter). In fact, using the Pen tool, a path created by the Line tool
can be continued or incorporated into another open path. However, if you're already drawing with
the Pen tool and simply need a perfectly straight path segment, stick with the Pen tool.

Using the Pen tool, hold the Shift key while creating a new anchor point to force the new point
to line up with the last—exactly like drawing with the Line tool. Anchor points will align to the
nearest increment of 45°. So, if your cursor is close to the same x coordinate as the last anchor,
holding the Shift key while clicking will place the next anchor in perfect alignment along the x-
axis—0-degrees. Being close to the y-coordinate will put the next anchor point on a 90° angle with
the previous. Stray toward the middle of the x and y and you can get an anchor point and path
segment at an exact 45°, 135°, 225°, or 315° from the first point. This is a very handy trick for mak-
ing perfect lines because, well, sometimes you need perfect lines.

Try making a rectangle. Click and release to make the first anchor point; then, about an inch to
the right, Shift-click to place the second anchor point. An inch above that, Shift-click to make the
third, then fourth, and, finally, close the path.
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The Pencil Tool

More familiar in its operation and feel is the Pencil tool, which resides on the Tools panel just
below the Pen tool. With the Pen tool, you draw anchor points while path segments are filled in
automatically. Drawing with the Pencil tool is the polar opposite: you draw the path segments and
InDesign automatically adds an anchor point wherever you alter angles.

DRAWING WITH THE PENCIL TOOL
The Pencil tool has its uses, but its freehand drawing is not a substitute for the precision of the Pen
tool. Rather, it’s a complement to it, another tool in your belt.

If you need a path that feels more natural, more hand drawn or hand written, go for the Pencil
tool—especially if you have an electronic tablet whose stylus lets you draw with an honest-to-
goodness writing utensil. Mousing or trackballing with the Pencil tool is difficult and requires a
very steady hand. Every little stutter or hitch creates new anchor points—several of them—that
you'll probably want to clean up. There’s the chief minus to the Pencil tool’s pluses: Remember
when I said you want a path without extraneous anchor points? Swipe the Pencil tool across the
page and just try to count all those anchor points. Man, if you need to reshape that path...

Let’s try a tracing exercise with the Pencil tool. From this chapter’s folder on the download page,
please open penciltrace.indd. Grab the Pencil tool and, beginning with one path or one color area
(for example, the hair or one side of the green background box), do your best to trace over it with
the Pencil tool’s freehand path.

Hold Cmd/Ctrl and click in an empty area of the page to deselect your path. Now, try drawing
another path right up against to the first—start within a few pixels of the first, in fact, and let your
second path overlap the first one as in Figure 4.10. Whoa! Didn’t see that coming, did you?

FIGURE 4.10
Shown in gray is the
first path, with the
second in red. The
original image is
hidden in this figure
for clarity.
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MODIFYING PATHS WITH THE PENCIL TOOL

Another difference between the Pen and Pencil tools is in how each relates to preexisting paths.
The Pen will happily create independent path after independent path atop any previous paths
without altering previous paths. Conversely, the Pencil tool will alter paths to which it draws near.
Although jarring at first, this is actually a very cool feature because it allows you to modify paths
drawn with the Pen, Pencil, shape, and frame tools as well as type converted to paths (later in this
chapter), all with the speed and dexterity of the Pencil. (If you'd like to get your previous path
back, undo the Pencil action with Cmd+Z/Ctrl+Z.) Let’s try some intentional modifications.

1. Clear any paths you've already created in the penciltrace.indd document.

2. With the Pencil tool, trace the cartoon’s outer hair line as closely as possible, leaving the
face area open but completely ignoring the spike of bangs in the front—just draw right past
it as if it wasn’t there. Give the path a fill color. Figure 4.11 shows my result.

FIGURE 4.11

My Pencil tool-
traced hairpiece
(shown filled in red)

l:»

3. Zoom in to where the bangs meets the main hair line, and with the white Direct Selection
tool, select the path you just finished drawing.

4. Switch back to the Pencil tool and position its tip atop one of the anchor points in your path
around the intersection of the bangs with the rest of the hair. The small X in the Pencil tool
cursor will disappear when you're in the right spot.

5. Click the anchor point, and draw the spike of bang, coming back up and terminating that
path on a different anchor point in your first path (see Figure 4.12).
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FIGURE 4.12

The bangs piece
(filled in blue)
should merge with
the main hairpiece
inyour drawing.

The result will be that the bangs are added to the main hair path, with the two paths fully
merged. If you got differing results, undo and try again, ensuring that you both begin and end
your drawing on anchor points already in the path. Again, it takes a very steady hand as well as
good hand-eye coordination to work with the Pencil tool in this manner. You might find it helpful
to zoom in on areas of the drawing as you work, but note that it’s still extremely fine work even
zoomed far in.

Let’s try modifying the path shape instead of just adding to it by doing something my mother
has wanted to do for years: give me a haircut.

1. With the hair path still selected, find an anchor point around the length to which you’d like
to cut the hair.

2. Once again, click the Pencil tool on the anchor point. This time, however, drag across the
interior of the object to another anchor point on the other side instead of dragging outside
the path. When you let go, one of two things will happen: Either I'll have a haircut or I'll
have hair only on my shoulders (yuck!).

If it’s the latter case, undo, then repeat step 2 in the opposite direction. If you began with an
anchor point on the left and dragged left to right, start this time with an anchor point on the
right and drag back to the left. That should chop off my locks.

The reason you might have gotten either result is because paths have a direction. Depending on
whether you drew the original path clockwise or counterclockwise, the direction in which you
take the Pencil tool will reshape or chop one side or the other. Thankfully, Undo backs you out if
the result opposed what you expected.
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Drawing from a path segment instead of from an anchor point will terminate the path at that
point, allowing you to completely reshape a section. In such a case, the Pencil tool will create new
anchor points at the inception and termination locations—and everywhere in between—as
needed.

Just in case it’s not obvious, the Pencil tool can modify not only paths drawn with the Pencil,
but any unlocked, modifiable path, such as one you might create with the Pen or Rectangle tools.

So, what are you to do if you just want to draw one path near another without adding to, sub-
tracting from, or reshaping the first? Easy: Don’t start drawing directly on a preexisting anchor
point or path segment. Begin drawing outside (or inside) a path area and the Pencil tool ignores
what’s underneath and creates a new, completely independent path. The distinction is in the prox-
imity of existing paths to where you click to initiate drawing with the Pencil tool; begin within a
few pixels of an existing path to modify it, further out to ignore it. If your new, independent pencil
path must begin within the modification zone of an existing path, a useful trick is to begin the
new path on a new layer, locking the layer or layers containing lower paths.

CLEANING UP PENCIL PATHS
Getting back to the multiple incarnations of ancients gods analogy, Hera the Pencil tool, queen of
the gods, has two other aspects: Juno the Smooth tool and Frigga the Erase tool.

As noted previously, Pencil tool drawing creates many, many anchor points; the slightest twitch
in your wrist could create an unsightly bump or divot in an otherwise smooth path. If such is the
case with your path, or you simply want to clean up some of those extraneous anchor points, reach
for the Smooth tool, behind the face of the Pencil tool on the Tools panel. For little touch-ups here
and there, you can also just hold the Option/Alt key with the Pencil tool selected.

As you might guess, the Smooth tool irons wrinkles out of paths, eliminating anchor points that
are too close together or have too little difference in their coordinates—both very common when
drawing with the Pencil tool. Drag it along a section of Pencil-drawn path to watch unsightly bumps
just melt away. Unlike most late-night infomercial weight-loss shams, the Smooth tool doesn’t dump
the weight and leave the path a big sagging skin bag; as cottage cheese anchor points slough off,
other anchor points reveal themselves to make a smoother, more attractive path that retains curves in
all the right places.

Applications of the Smooth tool are cumulative—run it across a path to clean and smooth it,
run it again to clean it up more and make even more gentle curves.

Finally, what’s a pencil without an eraser? Flip the Pencil tool upside down and gaze upon the
goddess’s final face.

Whereas the Delete Anchor Point tool (and corresponding mode of the Pen tool) removes
anchor points without breaking the path, the Eraser tool does break the path. Drag the Eraser tool
along a length of path to erase everything it touches—anchor points and path segments.

Dragging the Eraser tool across a path segment will split the path, with new anchor points
developing on either side of the split, but it leaves a gap. Smudge out an anchor point directly and
the same occurs. To split a path without an unsightly gap, don’t use the Eraser tool. Read “Editing
Paths and Shapes” later in this chapter for the correct tools.

What might be a practical use of the Eraser tool? Opening up a closed path is a pretty common
one. Maybe you have a closed path and a new, disconnected open path that you’d like to merge
together. Erase a big enough opening in the former, and then connect them with the Pencil tool,
which is a nice segue into...
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MERGING PATHS WITH THE PENCIL TOOL

Let’s say you have two opened paths you’d like to merge together. Select both paths with the
Direct Selection tool, and then switch to the Pencil tool. Click the end point of one path and drag
toward an end point of the other path. After you’ve begun dragging, depress the Cmd/Ctrl key,
which initiates the Pencil’s merge mode, denoted by a tiny cursor symbol that looks very much
like an anchor point with path segments (see Figure 4.13). Keep dragging (and holding the modi-
fier key) until you're over the target anchor point. Release the mouse button and the paths will
merge. Repeat as necessary to merge the other ends of the paths or additional paths.

FIGURE 4.13
When merging two

paths with the Pencil

tool, holding Cmd on
the Mac or Ctrl on

4
Windows toggles the \
Pencil into path- . '

merge mode.

Shape Tools

You know how to draw rectangles and circles with the Pen tool, but you can also just use the tools
dedicated to creating these fundamental shapes.

Frames

Chapter 2, “Text,” should have given you a good feel for the basics of working with frames. You'll
get more of this in Chapter 5, “Images,” but so far, these frames have been four sided. Let’s go
beyond the rectangle.

ELLIPSE FRAME TOOL

Click and hold on the Rectangle Frame tool on the Tools panel and choose the Ellipse Frame
tool from the flyout. Drawing with the Ellipse Frame tool is just like drawing with the Rectangle
Frame tool—click, drag, done. The result will be some form of ellipse with four anchor points and
curved path segments between them. To create a perfect circle, click, and then hold the Shift key
while you drag, which will also create a perfect square if using the Rectangle Frame tool.

You'll notice that, though we’re working with an ellipse, InDesign still creates a rectangular
bounding box with control corners around it.

If you didn’t draw your ellipse in exactly the dimensions you require, it can easily be resized
via the Control or Transform panels like any other object. Or, if you know in advance the needed
dimensions of the elliptical frame, there’s a faster way. Instead of drawing and then resizing, grab
the Ellipse Frame tool and click and release on the page instead of clicking and dragging. Up will
pop a dialog with two simple options: the required width and height of the frame; set them and
click OK.

Now you can fill the elliptical frame with color, imagery, or text (try text with the Justify All
Lines alignment for an interesting effect).
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POLYGON FRAME TOOL
With elliptical frames behind us, let’s get into something more interesting: polygon frames
(Figure 4.14).
FIGURE 4.14 Lom
All of these objects e Al ki il e
were created by v el ot PP i e e
starting with the i ::a".;‘::&ﬁm: shm -
Polygon Frame tool. e e

As with the Ellipse Frame tool, selecting the Polygon Frame tool and clicking the page or paste-
board brings up an option box. This one has the same height and width fields, but also two others

(see Figure 4.15).
FIGURE 4.15
The Polygon Frame i o ]
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Palygon Settings

Humber of Sides: |:]6

star Inset: [=o%

The Number of Sides field should be self-explanatory. In the percentage-based Star Inset field,
though, you determine how deep those sides are set. A value of 0% means the polygon’s sides will
be flush with the outer diameter—a four-sided polygon would therefore be a perfect rectangle.

Want to make a classic five-pointed star? Use the Polygon Frame tool with five sides and Star
Inset of 50%. How about the foundation shape for an official seal? Pick a high number of sides—
maybe 25—and an inset of 5% to 10%. One of the most common uses I have for the Polygon Frame
tool is in creating equilateral triangles (three sides, 0% inset) that I'll often use as the starting point
for more complex shapes, patterns, or even bullet glyphs.

Any time a polygon has an inset, InDesign automatically creates a second set of anchor points—
the first for each apex, the second for each nadir. By starting with the Polygon Frame tool and
manipulating the anchor points with the Direct Selection tool, Convert Direction Point tool, or
other path modification tools, you can quickly create numerous complicated shapes.

SHAPE TOOLS

On the Tools panel next to the frame tools are the shape tools. They are the Rectangle, Ellipse, and
Polygon tools. They are exactly like their matching frame tools. They're so identical, in fact, that
they're superfluous—or the frame tools are. Six of one thing, half dozen of the other.

In InDesign, a frame is a frame is a frame. Shape objects are frames, and frames are shapes (and
they are all paths). The only visual difference between them is the diagonal, intersecting lines in
frames; they don’t mean a thing. Don’t believe me? Try it: Draw a frame using one of the frame
tools. Beside it, draw a shape with one of the shape tools. Now, select the Type tool (press T for
expediency). Click in the frame and start typing. OK. Now, with the Type tool still selected, click
in the shape and start typing. Any difference?
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Like most desktop layout programs, InDesign is built on the concept of the relationship between
container and content. Everything you can create or place in the application is either content or a con-
tainer to hold that content. Vector paths automatically form containers the instant the paths are
closed. Because both frames and shapes are paths, they are both containers. Moreover, either may
contain any of the following;: fill colors (solid or gradient), images, text, vector objects, and even
other containers.

So, you might ask, If frames and shapes, and their respective tools are identical, why do they both exist?
Why not just have one set of tools and be done with it?

The original intent of having both frame and shape tools was to distinguish between graphic
frames, text frames, and vector design elements that wouldn’t hold content. A noble intent, but it
was quickly defeated by practicality; it’s a lot faster to just select a frame and get to work than it is
to select a frame and make an inconvenient trip to the Object > Content menu before doing any-
thing worthwhile.

The reason these redundant tools persist is simple hand-holding. InDesign is still locked in mor-
tal combat with QuarkXPress, which does draw a distinction between frames (called boxes there)
and shapes. In that veteran layout application, picture boxes may hold only graphics; to put text
in them, you must first convert the container to a text box via menu commands. As you saw in
InDesign, however, the only action required to convert a graphic frame to a text frame is to click
in it with the Type tool. InDesign keeps the two sets of tools on hand as a learning aid for new
QuarkXPress converts. That’s it, plain and simple. Eventually, in some later version of InDesign,
the two sets of tools will merge, probably when Adobe wants to add another tool to the panel that
isn’t as easily relocated as the Measure tool.

FRAME-FIRST LAYOUT

Although there are still two sets of tools, they can be useful for frame-first (or box-first) layout work where
an entire page’s frames are created and placed ahead of their content. Because the frame tools have the big
X through them, they provide a visual differentiation from tools that create decorative vector shapes.
Having the obvious difference makes it easier and faster for others in the workflow to run through a page,
flowing in text or dropping in images with less likelihood of accidentally putting one where the other
should be.

If you draw one type of object—a shape to be a decorative vector object or a frame to hold text
or a graphic—and later change your mind, there’s no consequence to leaving them as they are.
However, should you wish to be precise, you can convert one into another. Just select the object
and choose one of the three types from the Object > Content menu. The only time you really must
do the conversion is if you've begun with a text frame but now wish to fill it with a placed graphic.

The Object > Content commands will work only if the frame or path is empty. If you already
have text or imagery in there, you'll need to delete them prior to converting the content type. To
wipe existing text or imagery out of a frame, switch to the Text or Direct Selection tool, respec-
tively, select the frame content, and press Delete or Backspace.
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Reshaping Shapes
Creating shapes is only half the deal. It also helps to know how to reshape them.

Having begun with a standard rectangle, you may realize you’d prefer to have a rectangle with
rounded corners. It can certainly be done with the Add Anchor Point tool, Delete Anchor Point
tool, Convert Anchor Point tool, a few guides, and some careful path editing. Or, you could save
yourself some work and simply use the menu command that does it automatically.

At the bottom of the Object menu is a submenu, Convert Shape, that offers instant conversion
of closed and open paths to any of nine shapes:

Rectangle Inverse Rounded Rectangle ~ Polygon
Rounded Rectangle Ellipse Line
Beveled Rectangle Triangle Orthogonal Line

Give ‘em a try. Draw a shape—rectangle, ellipse, or polygon—select that shape with the Selec-
tion tool if it isn’t already selected, and choose Object > Convert Shape > Triangle. Faster than
you can say it, you've got a triangle. With the same shape selected, choose Object > Convert
Shape > Orthogonal Line. (An orthogonal line is one that is perfectly aligned to either the x-axis or
y-axis, horizontal or vertical respectively.)

For real fun, grab the Pencil tool and draw a quick spiral in an empty area, then choose Object >
Convert Shape > Inverse Rounded Rectangle. Check that out, man! It doesn’t matter how many
anchor points were in your starting path or how many are required for the finished path, InDesign
adds or removes as part of the process. With these commands, the only thing InDesign cares about
is the overall size of the original object—more precisely, the bounding box area. If you start out
with a 1X1-inch square and convert it to a triangle, you'll get a 1X1-inch triangle. The same is true
when beginning with a 1-inch long line.

By now you should be asking, How do I change the number of sides and indention in the Object >
Convert Shape > Polygon or the radius of the rounded corners made by Object > Convert Shape >
Rounded Rectangle? And that would be a great question.

First, the number of sides resulting from a command to Object > Convert Shape > Polygon is
whatever the current settings are for the Polygon Frame tool or the redundant Polygon tool. On
the Tools panel, select the Polygon Frame tool from behind the Rectangle Frame tool and double-
click the Polygon Frame tool icon itself. Up will pop the Polygon Settings dialog where you can
set the number of sides and the star inset. Whatever options you set here are set for all future poly-
gons—those created with the Object > Convert Shape > Polygon command, the Polygon Frame
tool, and the Polygon tool.

Now, the way to determine the corner radius of rounded and inverse rounded rectangles is
not the same—there isn’t a rounded rectangle tool to double-click. Instead, those commands
take their settings from the current Corner Options settings. In fact, the Rounded Rectangle,
Beveled Rectangle, and Inverse Rounded Rectangle on the Object > Convert Shape submenu
are just shortcuts to the same features in Corner Options.

CORNER OPTIONS

About halfway up the Object menu from Convert Shape is Corner Options, which, in prior ver-
sions of InDesign, was Corner Effects. Select—or draw—a rectangle and select Object > Corner
Options. You'll see a dialog like Figure 4.16.
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FIGURE 4- 16 Corner Options

The Corner Options
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Corner Options are live vector effects, meaning no permanent damage is ever done to your
object. From the Effect drop-down menu you can choose Fancy, Bevel, Inset, Inverse Rounded,
Rounded, and, of course, None for no alteration of the shape’s corners—the last so you can
remove previously applied corner options.

A Corner Option size equal to or greater than half the length of an object’s side will completely
round (or concave, or bevel, or whatever) that entire side. For example, if you apply a 0.5-inch
rounded corner to a 1X1-inch square, you will convert the square into a circle. Putting the same
rounded corners on a 4X1-inch rectangle will round the short sides, creating a pill shape.

Corner Options is not limited to rectangles. It can be applied to any vector shape—triangles,
hexagons, 50-pointed stars, or whatever you like. Naturally, it has no effect on ellipses, lines, and
other objects devoid of corners. And, Corner Options cannot be used on placed images per se, but as
you probably recall, placed objects are content, not containers. When an image is placed in InDesign,
a container frame is automatically created, and that frame is a vector path and thus eligible for Cor-
ner Options. See Figure 4.17 for a few different things you can do with InDesign’s Corner Options.

FIGURE 4.17
Corner Options can
do some nifty
things.

WHEN INDESIGN CAN BE FASTER THAN ILLUSTRATOR

Interestingly, InDesign’s Corner Options and convert to shape commands are sometimes faster than
drawing the same object in Illustrator, which doesn’t have such automated commands. Because InDesign
and Illustrator are siblings, vector paths may be copied from one to the other, and worked on in either. So,
if you can’t remember how to make a rounded rectangle in Illustrator, or if you want a 50-pointed star
with beveled corners or a triangle with fancy corners, feel free to save yourself some forehead bruises by
doing it in InDesign and then copying and pasting into Illustrator.
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MERGING, DIVIDING, AND OTHER PATHFINDER FUNCTIONS

You can make basic shapes. You can draw any other shape you need with the Pen and Pencil
tools. You can even convert one shape into another and mess about with its corners. But can you
combine two separate shapes or knock one out of the other? That’s what we’re about to do.

1. Using one of the shape or frame tools, please draw a rectangle.

2. Beside it, please draw an ellipse.

3. Fill and stroke both shapes, but make sure to give them different colors.
4

. Now, drag the ellipse until it partially overlaps the rectangle—about halfway should do
nicely.

5. Select both shapes, and go to Object > Pathfinder > Add. You should get the result in Fig-
ure 4.18.

FIGURE 4.18
When two overlap-
ping paths (left) are
given the Pathfinder
command to add,
they merge into a
single, amalga-
mated path (right).

The Add command merges the two paths into a single, amalgamated shape. Click Undo and
try the next command on the Object > Pathfinder menu, Subtract. Where the ellipse overlapped,
the rectangle should now be bitten off. Undo again and try Object > Pathfinder > Intersect. You
should have left only where the two shapes overlapped, wiping away any overhang.

Exclude Overlap is the opposite. It will leave the overhang and cut out the area common to
both shapes.

Lastly, Minus Back is the inverse of Subtract: Instead of knocking the front object out of the
back, it punches the back shape out of the front. Figure 4.19 shows a few results from using
Pathfinder commands.

FIGURE 4.19
Shapes resulting
from using the

Pathfinder
commands Add Subtract Intersect Exclude Overlap Minus Back

As you try out the Pathfinder commands, notice what happens to the fill and stroke colors of
the resulting object, whether the front or rear object’s colors are retained by the new shape. In most
cases, the front object’s attributes are retained. It’s the opposite for Minus Back, though. And, it’s
not just fill and stroke colors that are assigned to this new compound shape. Object effects, drop
shadow, transparency, and so forth assigned to the dominant path will be retained by the resulting
compound shape.
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Also noteworthy is the fact that Pathfinder commands can be run on any ungrouped vector
object—even text frames. Give it a shot with the ellipse and rectangle. Choose Object > Pathfinder >
Intersect, grab the Text tool, and click inside the compound path; start typing. Want text that defines
a shape or flows through a shape more eye-catching than a rectangle (see Figure 4.20)? Well, then,
there you go.

FIGURE 4.20

Use Pathfinder com-
mands for creative,
eye-catching text
frame shapes.

COMPOUND PATHS

Any time a Pathfinder command results in a shape that is more than a single, continuous path,

you get what's called a compound path. Although compound shape is merely a descriptive term for

a shape that is more complex than a rectangle, ellipse, or polygon and, in the grand scheme of

things, hasn’t much of a meaning, compound path is a more important term because it refers to a

certain type of path. A compound path is a new, more complex type of path with different consid-

erations than those for a simple, continuous path. It’s multiple separate paths behaving as one.
Here’s another opportunity to understand by doing.

1. Draw a perfect circle (you know two ways to do that quickly), and fill it with a solid color
but without a stroke.

2. Atop the circle, create a five-pointed star that is larger than the circle (see Figure 4.21), and
give it, too, a solid color fill and no stroke color.

FIGURE 4.21
We’ll create a com-

pound path by
starting with a star
overlapping a circle.

v, ¢
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3.

Select both the star and circle and go to Object > Pathfinder > Exclude Overlap. Your
result should be similar to mine (Figure 4.22), with the overlapping area knocked out and
the resulting shape acquiring the star’s fill and stroke attributes.

FIGURE 4.22

After the

Pathfinder >
Exclude Overlap
command a
compound path

remains.

Look closely at this new object. If you select it with the Direct Selection tool, you'll notice all
the anchor points throughout. See all those different shapes in there? All the separate filled
areas? There’s no way that object is a single continuous path. It can’t be—it has 10 different
filled areas, 10 different closed paths. That, ladies, and gentlemen, is a compound path—
multiple paths behaving as one.

Try changing the object’s fill color—all areas will change simultaneously. In many cases,
you'll find that’s the desired result. When it isn’t, when you want to separately color the
shapes in this compound path, remember this crucial piece of information: move on to
step 4.

Although this will work however you've selected the compound path, let’s keep it selected
with the Direct Selection tool so we can more closely observe the changes to the object as
we...choose Object > Paths > Release Compound Path.

Do you see the difference? It’s subtle. Undo the last command and look at your compound
path star. Where’s the object center point? Right: In the center of the star. Now press
Cmd+Shift+Z/Ctrl+Shift+Z to redo the release compound path command. Where is the
center point now? Uh-huh. That’s right: There isn’t 1 but 10. All the shapes have been
released to individual paths, with their own centers and their own independent paths.
They can even be moved or edited independently if you wanted to do that (but not now).

Deselect all, then select one of the star points. Give it a fill color. Good. Now give the next star
point a different color. Keep going until you've filled all five. Figure 4.23 shows how my star
looks so far (it also shows the center points and paths, in case you need to see them).

For this particular project, we don’t want all the star points to be different colors, though.
We want them the same color. In fact, we want the remaining circle sections to also match
each other, but not with a solid color fill; we want them to have a radial gradient (see
Figure 4.24). See what you can do to match your circle sections to mine.
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FIGURE 4.23
After releasing the A
compound path,

each path is individ-
ually editable.

FIGURE 4.24
My star finished. A
Yours will look like

this, too, after a few
more steps.

P4

No luck on getting the circle parts to fill with a radial gradient like mine in Figure 4.24? Let
me guess: You got a separate radial gradient in all five sections, didn’t you? That’s because
we haven’t done step 7 yet.

4 %
|

Applying a gradient, object effects, and a few other things to multiple paths applies a new
instance to each path. To get the desired effect for this project, we can’t have separate paths.
We need a compound path—but only of the circle pieces, not the star points, too, or we’ll
end up back at the same problem we faced in step 3.

Select all five sections of the circle together and go to Object > Paths > Make Compound
Path. Now we’ve turned these separate paths back into a compound path, which means
they’ll once again behave as if they were one path. Try giving it a radial gradient fill now.
Better results, right?

Go ahead and deselect the circle parts compound path and select the individual star point
paths. Make a compound path of them as well, just for efficiency and expediency. Now
assign their fill color; I went with a solid red, but you're free to use any color or even
another gradient if you like.
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FIGURE 4.25
Before snipping with
the Scissors tool
(left), and after
(right)
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What else can you do with compound paths? You can use them as containers for placed images.
Select your circle sections compound path, choose File > Place, and import a photo. It will place
right into the compound path. Think about the possibilities that opens up for creative image frame
shapes and vector elements.

Compound paths can also hold text, although the shapes we have with this star would be bet-
ter suited to containing decorative text rather than copy you expect to be read. Click in it with the
Text tool and start typing to see what I mean.

Of course, being a container, a compound path can hold other containers. Experiment and
you'll find some really interesting ideas!

Editing Paths and Shapes

Creating paths? Check. Making shapes? Check. Reshaping them? Check. Now, what does an
InDesigner do to gain total control over paths?

SCISSORS TOOL

Remember the Erase tool? The Scissors tool is almost like it in a different form. It’s actually closer to

the Paths commands, which are next, and why I saved discussing the Scissors tool until now.
When you break a path by dragging the Erase tool across a path segment, a gap occurs. That’s

why the Erase tool is meant to be smudged along a path instead of across it. To precisely split or

cut a path without erasing parts of it, use the Scissors tool either on anchor points or on path seg-

ments. Clicking a path with the Scissors tool cuts it in that spot, creating two anchor points that

rest atop each other. To split a closed path into two separate objects, use the Scissors tool twice.

Try it out.

1. Draw asquare and give it a solid color fill and contrasting stroke color.

2. Select the Scissors tool from the Tools panel and then walk, don’t run, back to your square
and click the top-left corner. Apparently nothing should happen.

3. Again, move over to the bottom-right corner of the square and snip again with the Scissors.

4. Put the Scissors tool away and choose the Selection tool. With that implement, click the top-
right corner of the square and drag it away half an inch or so. If your scissor work was pre-
cise, your square should become two separate, but open, triangular paths like mine (see
Figure 4.25).
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SELECTIVE SIDE STROKING SCHEME

Observe the stroke on your pair of triangles. See how there’s no stroke on the long edge of either path?
That indicates that they’re open paths, and this becomes an ultra-slick trick for applying strokes only to
certain sides of an object!

The Scissors tool can split a path into two (or more) distinct paths, as you just did, but it can
also be used to merely open up a path, say to reshape with the Direct Selection tool or expand it
with the Pencil tool. Don’t think of this tool solely as a device to turn one object into multiple
objects. In fact, if you try to scissor a path containing text into two, it will fail. The first scissor will
work, opening the path, but the second just doesn’t—and with no warning from the otherwise
prolific alerter InDesign.

If the path you divide includes a placed image, all resulting paths will contain copies of the
same graphic, which can be a good thing or a bad thing. If the Links panel reports an external file
as persisting in the document despite all attempts to remove it, look for any shapes that might
have been split from others with the Scissors or Eraser tools or the Path commands.

PATHS COMMANDS
On the Object > Paths submenu are three commands you'll find useful from time to time: Open
Path, Close Path, and Reverse Path.

Open Path is like a single click from the Scissors tool. This command opens a path by splitting
it at the anchor point that closed the path. If you drew a square with the Pen tool, for example,
working clockwise and placing first the top-left anchor point, then the top-right, and around back
to the top-left again, Object > Paths > Open Path would split your path at the top-left anchor
point because that is where the clockwise path drawing ended to close the path. After you use this
command, the one anchor point is replaced with two, aligned atop each other and ready to be
manipulated.

The opposite function is Close Path, which takes split or otherwise open paths and closes them
by drawing a straight path segment to connect the last two anchor points (aka end points because
they end a path).

Reverse Path is an interesting command. Do you recall your work trimming my cartoon depic-
tion’s hair with the Pencil tool? Recall how I noted there were two possible outcomes due to the
direction in which you had originally drawn the path? Object > Paths > Reverse Path inverts that
result. Select the path, or an anchor point on the path, to reverse, and then use the menu command.

REVERSE ARROWS

If you have arrows or other start or end marks assigned to a path on the Strokes panel, Object > Paths >
Reverse Path flips the direction, turning a left-pointing arrow into a right-pointing one, and it’s faster
than rotating or flipping the path.
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PATHFINDER PANEL
Now that I've told you where to find the Convert Shape, Pathfinder, and Path commands on the
Object menu and you've gotten fairly comfortable with them, it’s time to tell you that they are
located elsewhere as well. Before I tell you where, you must understand that using the menus—
indeed, this entire chapter—is wax-on/wax-off training. It’s important that you learn things in a
certain order and that you learn the more difficult ways of doing things before the easy, Daniel-san.
On the Pathfinder panel (Window > Object & Layout > Pathfinder) are buttons to issue all the
pathfinder, path, and convert shape commands (see Figure 4.26).

FIGURE 4.26 (raiaen] -
The Pathfinder Pabdodr
panel a4 ne R

EDITING ANCHOR POINTS WITH THE DIRECT SELECTION TOOL

In Chapter 5, “Images,” you'll see how to use the Direct Selection tool to position placed graphics.
It’s the rough equivalent of QuarkXPress’s Content tool, but so much more. This humble little
white arrow is the way to select and manipulate anchor points after they’ve been created. With it
you can select, move, and delete one or more anchor points, as well as access and wrangle their
curve handles.

1. Draw an S-curve.

2. From the Tools panel, grab the Direct Selection tool and hover it over the second anchor
point in your S-curve. When you're directly over the anchor point, the Direct Selection tool
will display a solid square in its bottom-right corner. Click to select the anchor point.

3. Drag the anchor point around—maybe up a little ways, maybe down. Notice how the path
reshapes to accommodate the new position?

4. Release the anchor point, grab hold of the curve handle, and yank. (When your cursor is
close enough to the curve handle end to grab it by clicking, a small diamond will appear in
the bottom right of the cursor.) The curve will react accordingly, just as if you were still
drawing with the Pen tool and hadn’t yet let go of the mouse button. In this way, path seg-
ment curvature is perpetually editable.

Let’s try something else. I warn you in advance, the end result is a little corny. Regardless, it’s still
an excellent example of working with the Direct Selection and other tools to manipulate a path.

1. On anew layer, use the Ellipse or Ellipse Frame tool to create a circle just about 2 inches in
diameter.

2. With the Pen tool, add an anchor point about one-sixth of the way from the top around
the left side. Do the same on the right side (see Figure 4.27). Drag down a guide if it helps
to align them. Your circle should now have six anchor points initat 12,1, 3, 6, 9, and
11 o’clock.
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FIGURE 4.27

My circle so far,
with the two points
added (with no
anchor points
selected)

3. Zoom in until you have a good view of the circle. Grab the Direct Selection tool. Click an
empty area of the page to deselect all objects, and then, near the top anchor point, not on it,
click the Direct Selection tool and drag a selection rectangle where the anchor point should
be (see Figure 4.28). When you let go, the anchor point at the circle’s apex should be solid
(selected) while all other anchor points are empty (deselected). If any others are solid, click
away to deselect and try again.

FIGURE 4.28 [—
Dragging with the

Direct Selection
tool selects all
anchor points in
the drag area.

4. With the top anchor point selected, press Shift+Down Arrow on your keyboard until the
top anchor point is below the two you added. Notice how the curve handles remain fixed
at 0° while the path segments change in relation to the moving anchor point. See the curve
handles also coming off the points on either side of the active one? Figure 4.29 shows
approximately what you should be seeing now.

FIGURE 4.29
The circle, after &
moving the apex
anchor point
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5. On the Tools panel, behind the Pen tool, select the Convert Direction Point tool (the inverted
V as you may recall). With that tool, click the anchor point at the bottom of the now dented
circle. The bowl should snap to an angle, removing the curvature emanating off either side
of the anchor point and making it a corner anchor point (see Figure 4.30).

FIGURE 4.30 — L

. R e
Converting the bot- / . ol .
tom point to a cor-
ner anchor point
turns the curves it
previously held into
angles.

By now you must know what we’re creating.

6. With the Convert Direction Point tool still selected, press and hold the Cmd/Ctrl key to
temporarily change that tool into the Direct Selection arrow. Select the top anchor point
again—or what was the top anchor point. Once selected, release Cmd/Ctrl to return to the
Convert Direction Point tool.

7. You saw what happened when you used the Convert Direction Point tool on an anchor
point. Don’t click this point. Instead, click the little dot on the end of one curve handle.
Apparently nothing should happen, but what you’ve done is sever the dependency
between the two curve handles, enabling them—and their corresponding path segments—
to be individually manipulated.

8. Switch back—fully—to the Direct Selection tool. The anchor point should remain selected,
so now grab one of the curve handles and drag it upward and inward toward the point.
Keep dragging until you get a nice, smooth arc in the path segment on the same side of the
formerly top anchor point (see Figure 4.31).

FIGURE 4.31

So far, so good with ,/"' n | i
the disconnected / - \\

curves.

9. Do the same with the curve handle on the other side.
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10. Now, we need to do something about those anchor points on the sides. Let’s use the drag-
selection method again to grab both of them at once. Click your Direct Selection tool a little
ways off to the left, on the paper, and drag a selection rectangle rightward that covers both
side—but no other—anchor points. Those two should become solid and all other anchor
points hollow.

11. We'll get into scaling and transformations in a subsequent chapter, but let’s jump ahead any-
way. Up on the Control panel, the third column of measurement boxes is the scale percentage
fields. Just to their right is a tiny chain link icon. If that icon is a complete chain link, click it to
break the link between x and y scale percentages. Now, set the x, upper, percentage to 90%.
The shape will suddenly reduce its girth like cinching a belt (see Figure 4.32).

FIGURE 4.32
After we scale the
points, our shape is
alittle distorted.

12. You've got the basic shape now, so one at a time, select the side anchor points and adjust
their curve handles to restore smooth, full curves to our shape.

Yes, I had you draw a heart. I know how corny and cliché and almost useless it is for you to
know how to draw a heart in InDesign of all programs. We're far enough into the book that I hope
I've earned from you a little more patience, a little faith—at least enough to ask you to read a cou-
ple more paragraphs. This is important, and I beg of you, don’t put the book down just yet. We've
been through so much together, let’s not end it on this note.

You're still here. Thank you. Here’s what I need to tell you, and what I think you need to hear.
True, we drew a heart. But, what we drew is nowhere near as important as all the things you
learned from it. Specifically, you learned the following;:

¢ How to select anchor points by clicking them with the Direct Selection tool, and how that
tool’s cursor changes as it approaches anchor points and curve handles. You can also select
multiple, noncontiguous points by holding Shift as you click each one after the first.

¢ How to select one or more anchor points by dragging a selection area with the Direct Selec-
tion tool. That’s crucial because the need to select and work with more than a few anchor
points simultaneously is frequent.

¢ How to move anchor points with the keyboard—another crucial skill. They can also be
moved with the mouse, of course, and if you hold Shift while you move them, their motion
will be constrained to vertical (90°), horizontal (0°), or another increment of 45°, depending
upon the direction of movement.
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How to change the Convert Point Direction tool into the Direct Selection tool temporarily,
which saves trips back to the Tools panel.

How to adjust anchor point curvature for a desired result.

Reinforced skills you learned earlier, like adding anchor points to a path, converting anchor
points from smooth to corner, and converting an anchor point so that its curve handles
moved independently of one another instead of in tandem.

What most would consider an advanced power tip—that anchor points in a path can be
transformed with scale percentages the same way complete paths and objects can be trans-
formed. Here’s one better: It isn’t just scaling. You can rotate, shear, and precisely position
anchor points, too. We’ll dive deep into those features in a later chapter, though.

There, that’s my justification for the nearly unforgivable act of asking a professional such as
yourself to draw a heart. It was a heart, true, but a simple heart brought so much knowledge and
understanding. Can you forgive me?

TECHNIQUE: CONVERT TEXT TO IMAGE-FILLED FRAME

This final exercise is definitely the best part of the chapter. Well, it is if you like cool effects, and
who doesn’t like cool effects? Of course, I must give you the obligatory caution that what you're
about to learn has tremendous power—power to make your design outstanding, as well as power
to make it a hackneyed cliché. Like any cool technique, it can be abused. Use it only when the
design warrants it.

1.

FIGURE 4.33

text frame

Create a text frame and type your initials into it. We’re going to make a personal logo for
you, right in InDesign, without reaching for the orange “Ai” or blue “Ps” icons on your
Dock or Start Menu.

Style your initials, choosing an appropriate typeface(s) and setting the letters at a large
size—at least 100 pts. Resize the text frame if necessary to fit them. Figure 4.33 shows my
initials set in Adobe’s Blackoak Std OpenType typeface at 100 pts. The text color is irrele-
vant, as long as you can clearly make out the letters.

My initials set in a N S

3.

Using the Type tool, insert the cursor between the first pair of your initials (if you didn’t use
your middle initial, then there’s only one pair, but put the cursor there anyway). Kern the
letters tight—really tight—so they overlap but not so much that you can’t easily differenti-
ate them. Repeat for the second pair (if there is a second pair).
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4. Are you perfectly happy with the way the letters kern together? We're about to remove

your ability to edit their kerning, so be sure. I'll wait here while you experiment if you need

more time.

Ah. You're back. Ready to move on? Grab the Selection tool, which will automatically select

the text frame. Now, choose Type > Create Outlines. Kapow! It’s not type any longer—now
your initials are a compound path.

@ Real World Scenario

TO CONVERT TO OUTLINES OR NOT TO CONVERT TO OUTLINES: THAT IS THE QUESTION

Whether 'tis nobler in the RIP to suffer the slugs and bullets of outrageous fonts, or to take paths against a sea of
troubles...

A question I often hear: Should I convert all my type to outlines before making a PDF or sending it to press?

Many, many moons ago, the single greatest problem in print design and production, the thing that
stopped more RIPs and presses more often per day than anything else, was fonts—specifically, missing
fonts or the use of different versions of the same font by the designer and by the pre-press house. Design-
ers had to identify all the fonts they used in a document and then manually collect them for delivery
with a job to pre-press. This was arduous and error-prone work, and frequently (very frequently), a font
or two was left out.

During these dark ages it became commonplace to convert all type in short documents to outlines. Out-
lines are simple vector paths and no longer connect to, or require the presence of, a particular font. That, of
course, means the type is no longer editable if an eleventh hour change request comes down from the client.

Now, InDesign can, in nearly all circumstances, automatically collect all fonts for distribution with a doc-
ument. And jobs can be sent as PDFs, which can automatically embed fonts, too.

There is no reason to convert type to outlines simply for output to press or export to PDF. If you want to
turn the type into a container or massage the paths of type, sure, convert it to outlines and go to town.
Doing it “to be safe,” as I hear from time to time, will accomplish only three things:

Eliminate your ability to edit the text. Typos and client changes happen, and once type has been con-
verted and the document closed, there’s no way back to live text.

Make the document render engines in all display devices—InDesign, Acrobat, proof printers, the RIP—
work harder than necessary. True, type is vector paths, and converting to outlines merely exposes
those paths. However, operating systems have dedicated type rendering engines solely to handle the
math involved in drawing type quickly onscreen, on RIP, or on paper. When you convert to outlines,
you take the type engine out of the mix and unnecessarily put the load for every anchor point, every
path segment, in every glyph, on the shoulders of the math processor and the video card.

Finally, the worst thing you will accomplish is to royally tick off your print or pre-press service provider.
These people frequently need to access your document to resolve issues prior to going to press. Even
if they don’t need to edit your type—maybe they need to resolve a color conflict, adjust your docu-
ment bleed width, or change overprint and knockout settings—if they must open your document
and wait while their computers grind away to draw every page, they will not be happy.

Don’t convert type to outlines unless there’s a valid reason. Otherwise, you’re accomplishing little but
falling upon your own sword, Hamlet.
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5. We'll need to tweak a few things, so let’s release the compound path—remember how to do
that? Object > Paths > Release Compound Path.

6. When I released my compound path, I got a nasty surprise (see Figure 4.34). Fortunately,
the Pathfinder panel offers a quick fix.

FIGURE 4.34
Releasing com-
pound paths on my
initials left the coun-
ters (holes) of the P
and B as separate,
filled shapes.

If you have the same filled-counter problem I do, select the letter’s outer shape and the
counter. Do one counter at a time if, as with my B, there are more than one. Once selected,
subtract the front object (the counter) from the back (the main letterform). Repeat as neces-
sary to punch all the needed holes.

7. Take a close look at your in-progress logo. Are those paths exactly as you’d like them? Any-
thing you want to tweak in yours? There are a few things in mine that could be better.

For instance, I don’t like how the upper curve of the S intrudes on the counter of the P. I'll
fix that with the Add Anchor Point, Convert Direction Point, and Direct Selection tools.

The serifs on the P and S also don’t match up, which looks awkward. Fortunately, I can just
raise the top of the S serif a bit while lowering the top of the P’s and the B’s and then fix the
curves on their rounded corners to compensate for the move. My finished paths are in Fig-
ure 4.35.

FIGURE 4.35
After tweaking, my
personal logo paths
are finished.

8. Once you've tweaked the paths to your satisfaction, select all the initials with the Selection
tool and combine all three paths into a single path with the appropriate command on the
Pathfinder panel or the Object > Pathfinder menu.

9. With the permanently fused initials path selected, choose File > Place and import an
image, as I've done in Figure 4.36. Resize and move the placed image, if needed, with the
Direct Selection tool like the content of any other container. Finish off your logo with a
tagline, additional elements, or whatever else is needed.
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FIGURE 4.36
Letters have become
a graphic frame.

Maybe you don’t need a personal logo, maybe you've already got one and you're happy with
it. Where else might this technique prove useful? What about the masthead for a magazine or
newsletter? Cover art for a book or annual report? If you've got any symbol fonts like Zapf Ding-
bats, MiniPics, Wingdings, Webdings, or even Windows’s Marlett, you have ready-made clipart in
them that can be turned into truly unique graphic or even text frames in a snap. Figure 4.37 shows
a few things I've created with this technique.

FIGURE 4.37

A few other ideas for
type converted to
frames

e,
Customer Service.

The Bottom Line

Draw Precise Paths with the Pen Tool Precision drawing, the ability to create any shape,
requires mastery of the Pen tool.

Master It Re-open pathtrace0l.1indd from the files that you downloaded from the Web.
Instead of tracing it with merely straight path segments, use what you’ve learned about
corner anchor points and smooth anchor points to trace it faithfully—straight where needed,
curved where needed. Set the fill for your traced letters to contrast with the original orange
ones, and when you've finished tracing, zoom in to examine how closely you were able to
come to the original shapes.

Freehand Draw Paths with the Pencil Tool The Pen tool is synonymous with precision, and
the Pencil tool with freedom. Sometimes, quickly drawing something with a natural feel is
more important than precision.

Master It Open a new document and, using the Pencil tool, draw your own cartoonish self-
portrait. Get it all sketched out before worrying about the paths themselves. Once it’s done,
go back with the Smooth tool and, if needed, the Erase tool to clean it up.
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Combine and Subtract Shapes, and Convert from One Shape to Another Many complex paths
begin with simple geometric shapes. Indeed, most objects you create in InDesign will be simple
geometric shapes, alone or compounded with other shapes.

Master It
1. Draw three shapes—a circle, triangle, and a square—each exactly 2 inches in diameter.
2. Convert the triangle and square to circles.

3. Manually position the circles into a rough triangular formation. Each circle should over-
lap its neighbors, with all three overlapping in the center. Select all three.

4. Exclude the overlaps.

5. Release the compound path, and fill each resulting shape with color individually.

Modify Any Vector Artwork Precision drawing mastery requires precision path editing.

Master It Beginning with a pentagon, employ the Convert Direction Point tool and Direct

Selection tool to convert the straight segment shape into a five-pointed star with concave
sides like this:
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Turn Type into a Container to Hold Images or Text Strictly speaking, the technique of con-
verting readable type into frames should be used infrequently. When used on symbol font
glyphs, though, it’s a great way to make short work of creating complicated shapes for use as
frames or merely decorative elements.

Master It Using a font installed on your computer—preferably a symbol font—locate a
suitable glyph using the Glyphs panel. Set and style it on the page and convert it to frame.
Fill the frame with text—your own or InDesign’s placeholder text.
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Picture pages, picture pages, now it’s time for picture pages, time to grab your crayons and your
pencil...

— Bill Cosby, the Captain Kangaroo Show

InDesign’s greatest strength, the area in which it towers head and shoulders over all challengers,
is its type handling and rendering features. Fortunately, it’s just as good with imagery—especially

in CS3.
In this chapter, you will learn to:

¢ Place image assets

¢ Import images without the Place command
¢ Manage placed assets
*

Go native in your workflow

Placing Assets

Images, like text, are content and must be encapsulated within containers—frames. And as with
text, you have a choice as to when and how you create the frame: frames can be created manually
and later filled, or you can skip that step, letting InDesign create the frame automatically upon
placement of an image.

Frame-First Workflow

A frame-first workflow—also called forms-based, templated, box-first, or grid-first workflow (this
last is technically erroneous because all layouts should begin with a grid regardless of the way
assets are placed)—begins with the containers and fills them with content later. You already know
about working frame-first if you've ever used QuarkXPress, which only works frame-first.

Solo designers and graphic design studios with varied clients and projects won’t often employ
frame-first workflows simply because most of their client assignments begin after content had
been created; they're hired to lay out that content. Creatives working in publishing houses, corpo-
rate design departments, and other environments with a narrower focus are often required to
design templates and layouts at the same time other departments or agencies are creating the
content.

A product catalog, for example, is typically built on a rigid grid. The layout artist knows in
advance approximately how many products she must list and the target page count. From there,
she can extrapolate the number of products each page must contain and thus the amount of space
each product entry is allowed for copy and imagery. Until the photogs and copyeditors turn in all
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the material, the layout artist can’t place actual content, but she can build templates in preparation
for that moment. Figure 5.1 shows what one catalog page template might look like before content
is available.

FIGURE 5.1

A typical catalog REV Creativity Diink Catalea 2007 A
page built — = A== =
frame-first e B

Here, 11 product photos (the frames with diagonal crossbars through them) and their accompa-
nying textual descriptions (the empty frames surrounding the image frames) are arranged and
ready to receive content. In the lower-outside corner (lower-right on this right-read page), a fea-
tured product will benefit from a larger image and more copy atop a colored background. Thus,
each page can comfortably carry a dozen products. The designer has done the math—probably
with FPO images and text—and determined the appropriate size at which the average product
photo and its description should lay out. When photos are ready, they will be fit into the waiting
image frames; the same for copy in its frames. Until the product shots and copy arrive, this page is
finished.

That's frame-first page construction—building spaces ahead of content.
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Go ahead and build a quick frame-first layout similar to the one in Figure 5.1. Don’t get overly
concerned with the text frames. You'll need two or three at least, but don’t spend too much time
styling them.

Ready? Let’s go through the various ways to fill those image frames.

Image Import Options

The most common method of importing an image is via File > Place (or the Place shortcut of
Cmd+D/Ctrl+D)—just as with placing text documents. Basic asset placement you already know,
so we'll skip the beginner-level stuff and dive right into the various types of image assets InDesign
will import and the options available for each. So, go ahead and open the Place dialog. Which
types of images can InDesign place within frames? Plenty! Table 5.1 shows them.

TABLE 5.1: Graphic File Formats Supported by InDesign

FILEFORMAT DOCUMENT DESCRIPTION AND SUPPORTED CHARACTERISTICS

TIFF, TIF Tagged Image Format; supports single page, compressed or uncompressed
GIF Graphical Interchange Format; supports single frame
PNG Portable Network Graphics; supports single-frame, alpha transparency

JPG, JPEG, JPE  Joint Photographic Experts Group

PDF Portable Document Format; supports layers, multiple pages (one page per import), alpha
transparency

Al Adobe Illustrator document; supports layers, alpha transparency

PSD Photoshop document; supports layers, layer sets, alpha transparency

EPS Encapsulated PostScript

PICT Macintosh vector/raster hybrid

WMF Windows Meta File vector/raster hybrid

EMF Enhanced Windows Meta File vector/raster hybrid

MOV QuickTime Movie; nonanimated in InDesign (only first frame shows), but animates on
export to PDF

Because InDesign doesn’t draw as much of a distinction as other applications do between types
of content—text, imagery, even audio and video media—the Place dialog will automatically show
every importable file type. Even if you have a graphic frame selected, InDesign will present tex-
tual documents as place options. Remember, a container is a container, and content is content;
InDesign’s frames can hold any type of supported content.

At the bottom of the Place dialog is the same Show Import Options check box we examined
while working with ASCII and Word documents. The import options themselves, however, are
quite different.
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BASIC RASTER IMAGES

When you're importing basic raster or bitmap images like JPEGs, GIFs, and TIFFs, the Image
Import Options dialog contains two panes (see Figure 5.2). The first, Image, offers the option of
applying an embedded Photoshop clipping path (if included in the image) to crop the image con-
tent. If the image contains alpha channels, one may be chosen here as well.

FIGURE 5.2 Image Import Options {(13figl14.titt)
Image Import
Options

Image | color

7 Alplia Channet  None .

~ Show Praview

0K Cancel

Alpha channels are extra channels in the image to define transparency or a selection. Every
time you use Quick Mask mode to paint a selection, for example, Photoshop creates a special
alpha channel called Quick Mask (see Figure 5.3). Save a selection from Select > Save Selection
in Photoshop and you're really creating a new channel that, upon placement of the image into
InDesign, can be selected on the Image tab as the alpha channel—only the areas selected in the
original marquee will appear while the rest is hidden.

FIGURE 5.3 [E—

The Channels panel » [ ==
in Photoshop CS3 ;-'E! g i
displaying a saved ® [ ereen a2
selection channel E = e ain
(non-white area) B ronrwiite res  cuird
and the temporary

Quick Mask channel T
created while in

Quick Mask mode

The other tab available when you're importing basic bitmap images is Color, which enables
you to specify an ICC color profile and rendering intent specific to the image (see Figure 5.4). Oh, yes,
InDesign can manage the color of every placed image independently of one another and of the
entire document.

FIGURE 5.4 Image Import Options ((1fig014.titt)
Importing an image
offers individual

COlOr management Prafie: | [lse Document Defauk

Of the image inde- Rendesing Intent: Use Docurent Inage Intent -
pendent of the docu- -

ment or other
images.

Image  Calor

~ Show Praview
0K Cancel
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PNG

When you place a PNG in InDesign, you'll get the same Image Import Options dialog with
the same Image and Color tabs as with other raster formats, but you'll also get a third tab (see
Figure 5.5).

FIGURE 5.5 Image Import Options (logo.png)
Image Import
Options, PNG .
. w Uta Transparency Information
Settings = White dackground
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Because PNGs have alpha channel transparency—effectively, if you can create the transparency
effect in Photoshop, PNG will display it that way—your first option is what to do with the back-
ground. If you'd like to preserve the transparency, check Use Transparency Information. With that
on, InDesign needs to know how to mix semitransparent areas—on white or on the background
color defined in the image. For example, do you want this 50% opaque blue mixed with white
so it looks 50% opaque blue, or should it mix with yellow so the result is green? PNGs created by
Adobe software don’t have available background color definitions, and the only option is white.

Apply Gamma Correction allows you to compensate for the fact that PNGs are usually slightly
off in their gamma ranges. If you placed a PNG and a PSD of the same image side by side—indeed,
if the former was made from the latter—the PNG will look a few shades darker. It’s just a PNG
thing, homey. By adjusting the gamma correction here, you can compensate for the inherent dark-
ness of the PNG.

EPS
Let’s just run through the EPS Import Options (see Figure 5.6) and how InDesign handles placed
EPS files.

FIGURE 5.6 EPS Impart Ophions (Logo EXPORTING copy.eps)
The EPS Import
. A Read Embedded OPI Image Links oK
Options dialog Apply Photoshop Cioping Path B
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Use TIFF or PICT Preview
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EPS is a simplistic format, and it has few options on import.

It can contain a vector clipping path and an OPI link. OPI stands for Open Prepress Interface,
which is a process by which a low-resolution or FPO image is temporarily substituted for the high-
resolution, final image. For instance, if you're doing the layout on a magazine article while the real
photos are still out at the color correction house, you can use a picture of a Domokun as FPO and
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then embed in the EPS a statement that links to the predetermined path and filename of the final
image. At some point—conversion to PDF, print from InDesign, or in RIP—the final image will be
sucked in via the OPI link to replace the FPO image, but retaining the position, scale, and crop set-
tings of the FPO.

If yours is among those workflows using OPI, make sure to check the Read Embedded OPI
Image Links option. That will tell InDesign to maintain the link to final assets, which enables their
inclusion when you’re printing directly from InDesign and maintains the links when InDesign
content is exported or sent to RIP.

EPS files are pure PostScript code. Thus, in order to render them to screen, an application must
contain—or have access to—a PostScript interpreter. Without an interpreter, you get a gray box
with no idea of what’s actually in the image. Until the last couple of versions, that’s what you'd
get if you placed an EPS image into Microsoft Word.

Twenty years ago, when Adobe was still building support for PostScript, few applications
could render EPS files natively onscreen. They printed beautifully to PostScript printers, but
that wasted a lot of paper because creatives moved an EPS, printed a proof, moved it a little
more, printed another proof, and so on. To compensate, Adobe enabled EPS files to generate
and carry low-resolution raster preview images, first in the Mac-native PICT format and then
on Windows as well with TIFF-based previews. With the embedded raster previews, more
applications are able to display something other than a gray box without the need to pay
Adobe for a PostScript license.

When you create an EPS in Illustrator or Photoshop, for example, you're asked whether to
include a preview and, if so, whether it should be black and white (a 1-bit, no shades of gray
b&w) or color and whether any empty space between the EPS artwork and the rectangular
bounding box that contains it should be rendered as transparent or white. Pay particular atten-
tion to that last statement because it’s the cause of a lot of cranial injuries due to repetitive wall
and desk impacts.

Take a look at Figure 5.7, which is Illustrator CS3’s Save As EPS Options dialog. You can see
the Preview Format drop-down, which is where you choose color or black and white raster pre-
view images. Just below that are radio buttons to make the background transparent or opaque
(white). If the creator of the EPS chooses Opaque, when you place that EPS into InDesign, it will
have an opaque background. Former QuarkXPress users will immediately jump to the conclusion that
the frame containing the EPS is defaulting to filling with white (paper color in InDesign), which
XPress did until version 7. Naturally, they’ll click on the None color swatch to clear it. When that
doesn’t work, the forehead-to-desk percussion usually begins.

If you happen to find yourself unable to explain a white background on an imported EPS...
Well, there’s the explanation. Pull the EPS into Illustrator and resave it with a transparent preview
background.

Or, you could always just chuck the preview entirely and tell InDesign to build its own by
selecting Rasterize the PostScript. It won't really rasterize the image itself; you'll still get crisp
vector output. This option only creates a new preview proxy for onscreen viewing. Moreover,
InDesign’s proxy creation is usually better than the previews embedded in the EPS files them-
selves. I usually check Rasterize the PostScript for all my EPS imports.

If you infrequently work with EPS images and are prone to forget little details like how to over-
come a white background, I humbly suggest you dog-ear this page. A concussion is not a laughing
matter.
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PSD PHOTOSHOP DOCUMENTS

InDesign can place native Photoshop PSD documents and Illustrator Al documents (see the fol-
lowing section for the latter). You don’t need to save Photoshop documents to TIFF or Illustrator
artwork to EPS in order to place them into the page layout application anymore!

As with other image formats, the import options dialog for PSD files includes Image and Color
tabs to access alpha channel transparency and color management, respectively. It also includes a
Layers tab (see Figure 5.8). There have been some changes here since CS2, so don’t skip this sec-
tion if you're a CS2 guru.

FIGURE 5.8 Image Import Options (Orink Can_psd)
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Here you can see a multilingual product shot mocked up in Photoshop. In that application, I used
layers to set the label text in English, Spanish, French, Italian, and German without resorting to five
separate PSD documents that I'd have to tweak and touch up to match client change requests. All the
common image elements—the 3D can, the highlights and shadows, the logo—are contained on their
own layers used globally in all language versions; only the variable text is separated onto individual
layers.

In the top section, Show Layers, I can turn the PSD image’s layers on and off individually. If I
needed to place the version of the can en Espafiol, all I'd have to do is turn off the English layer
and turn on the Spanish. It even correctly interprets Photoshop’s layer groups, thus I can hide or
show an entire range of layers with a single toggle of the eyeball.

Controlling individual layer visibility is new to InDesign CS3. CS2 had only Layer Comp control,
which CS3 retains, but which often created more work for the InDesign users by making them go
back to Photoshop to set up layer comps.

@ Real World Scenario

CREATING LAYER COMPS IN PHOTOSHOP

What are layer comps? They’re snapshots of the state of layers in a Photoshop document—which are on,
which are off, their blending modes, and their positions. For instance, let’s say in Photoshop you have a
five-layered document. Everything looks good, but you’d like to experiment a little, maybe try a different
arrangement of objects, maybe see how changing Layer 3’s blending mode from Hard Light to Difference
would affect the overall design. You want to play around a bit, but not lose your way back. Undo will only
save you so many times. You could make a history state snapshot, but that’s a little risky. Duplicating
the image would work, but it would also leave you with multiple separate files if you decided to retain the
variants—maybe to show the client the customary (and often ill-advised) three versions of a design.
Instead of creating multiple copies of the same document, make a layer comp.

| 1Layee Comps N o]
Last Docisment Stale
| Engun
Spansh
Eranch
Tusian
German
- > al 3

Open the Layer Comps panel in Photoshop (Window > Layer Comps) and, with all the layers of the first
version on and set the way you want, create a new layer comp by clicking the button at the bottom of the
panel. Name it something like First Version. Then, start moving and changing things. When you’ve got
another design you like, create a second layer comp. Keep going until you’ve got all the designs and layer
comps you want.

Now, in the Layer Comps panel, you should note that only one layer comp is visible at a time. Click the
empty box to the left of First Version and that layer comp will become the active one, with only its con-
stituent layers active and set the way they were in the beginning. Turn on Second Version and the layers
will shift again. At the bottom of the panel are even left and right arrows to cycle up or down through all
the layer comps. Voila! Multiple designs and variants in the same Photoshop document.
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Layer comps track layers, not the image data on them. Layer visibility, position, blending mode, trans-
parency, and effects are tracked and managed via layer comps, but if you swipe a paintbrush across a
layer or fix a typo in a text layer, that change ripples through all comps. If you need to modify the actual
content of a layer, duplicate it and make the duplicate part of the next layer comp.

I’ve used layer comps on numerous projects, including the drink-can design, for multilingual work. More
often, I’ve used it for variations and managing multiple but closely related assets as a single entity—for
instance, color and grayscale versions of the same image in one PSD. In Photoshop, layer comps enable
efficiency by reducing the number of documents and thus the amount of duplicate layer-based data that
must be managed across all those documents. Carrying them through to InDesign offers the same advan-
tages—one asset to update instead of four or five, one file to package and send to press instead of four or
five. You get the point.

Upon placing a PSD with layer comps into InDesign you have access through the Image Import
Options dialog to those layer comps in the Layer Comp drop-down list. Just pick one and go.

The Last Document State option imports the image however it was last saved in Photoshop—
including which layer comp was chosen and which layers were on. Editing the image in Photo-
shop—even just changing the layer comp—will, upon updating the link in InDesign, reflect those
changes there. If you specifically want a particular layer comp regardless of how the layers may be
set the next time you save the file in Photoshop, don’t use Last Document State. Instead, choose a
specific layer comp.

In Photoshop, you can assign notes to your layer comps, which is a great way to tell the future
you what the current you was thinking while making all these different versions of the image. The
large area below the Layer Comp drop-down menu in InDesign’s Import Options dialog will dis-
play any notes associated with the currently selected layer comp. Thus, you can tell the future you
what you were thinking whether he’s using Photoshop or InDesign.

Jumping back one paragraph, When Updating Links is similar to the Last Document State
option. You have two options here: Keep Layer Visibility Overrides and Use Photoshop’s Layer
Visibility. The former keeps the options you choose in this dialog regardless of how layers were on
or off next time the image is saved from Photoshop. Conversely, the latter dumps all your options
and always updates the placed image from its next saved state.

To change layer and layer comp visibility on an image already in the layout, select the image
and open the Object Layer Options dialog (see Figure 5.9), which is on the Object menu.

In case it’s not obvious, the reason layer and layer comp support in InDesign is cool is because
you can have a single external asset to manage while still placing five, six, or a hundred different
images in the layout.

By keeping all five language versions in my product mockup in a single PSD file, I not only
made my creation and revision work on the image in Photoshop much easier and more efficient, I
also streamlined my InDesign and output work. I only have one asset image to worry about
instead of five—80% less likelihood of problems at RIP time.
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Adobe Illustrator Al files are PDFs, and have been for several versions now. The only thing that
truly separates your run-of-the-mill PDF from an Al file is an extra data layer to preserve native
Ilustrator object and document information—things like embedded swatch and symbol sets, the
pre-rendered 3D object data, and similar bits of information that Illustrator needs to edit artwork
but PDF doesn’t require in order to output to screen or RIP. Saving a PDF from Illustrator with the
Preserve Illustrator Editing Capabilities option checked results in saving a file identical in all the
ways that matter to a native Al file. So, PDF would, were it not PDF call’d, retain that dear perfec-
tion which it owes without that title. (My apologies to the Bard.)

Don’t believe me? Change the file extension from .ai to .pdf and double-click the file. Mac
users, that won’t work as well for you. You can Get Info and define Acrobat (or OS X Preview, for
that matter) to open the PDF or just drop the file on your Acrobat or Adobe Reader icon. Close the
file, then drop it into Illustrator.

The fact that Als and PDFs are the same file format means two things. First, it’s a great trou-
bleshooting step. If someone tells you they can’t open your Al file or that it’s corrupted, ask if they
can read it in their copy of Acrobat or Adobe Reader. If so, they should be able to do a quick Save
As from Acrobat, forcing a rewrite of the file code to clear out corruption without throwing away
Mustrator editing data. Note that that’s only for Acrobat; saving it out of OS X Preview or another
PDF reader will probably destroy the Illustrator editing data layer.

The other thing it means, germane to the topic at hand, is that choosing to place either a PDF or
an Al results in the same import options dialog, that being Place PDF.

PDF files placed into InDesign don’t have the Image and Color tabs—that’s all managed from
within the original application or the PDF itself. InDesign will preserve colors and color profiles
embedded in a PDF even if InDesign itself doesn’t understand the colors. Moreover, trapping data
in the PDF is also preserved. To change either, edit the PDF directly. Placing a PDF has other
options relevant to the particular nature of PDFs. The Layers tab is, except for the absence of layer
comp controls (neither Illustrator nor Acrobat has such facilities), identical in appearance and
function to the Layers tab in the Image Import Options for Photoshop PSDs. What is unique to Al
and PDF placement is the General tab (see Figure 5.10).

Because PDFs can be multipage documents (but Illustrator documents cannot) and InDesign
can only fill a single frame with one page at a time, the first option to choose is which page you
want. The controls beneath the Preview section will let you cycle through the pages one at a time,
jump to a specific page, or, with the buttons on either end, jump to the first or last page of the doc-
ument quickly. Multipage PDFs can be placed, but only one page at a time (sort of; bear with me a
moment, and we’ll get to that).
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Jumping down to the Options section on the right, Transparent Background asks, a la EPS,
whether the image should be placed with a transparent or white background. When you look at a
PDF in Acrobat or other applications, you see a white page. That’s just a device to make the PDF
easier to read onscreen, just like pages in InDesign; there is not a white box there. Thus, by default,
you'll place a PDF with an empty background, which is typically what you want. If for some rea-
son you don’t, uncheck the box (or fill the resulting frame with white).

Crop To provides several options: Bounding Box, Art, Crop, Trim, Bleed, and Media. There’s a
lot of confusion over what they all mean, complicated by the fact that, in many cases, there’s no
discernable difference between them. Let me see if I can sort it out.

Bounding Box The document bounding box is the total area of all objects and image data in
the document. Choosing this option imports everything in there, including, if defined, crop
marks, data in the bleed area, and data in the slug area (beyond the bleed).

Art In applications like Illustrator, you can define an area smaller than the bounding box as
that containing the art—the art box. If you’ve done that, cropping to the art will toss out every-
thing outside the art box. In many cases, such as with InDesign-created PDFs, the art box is the
trim area.

Crop If the document has a crop area defined—with or without crop marks—this option will
crop to the, er, crop area. For example, in Illustrator, you can begin with an 8.5X11-inch docu-
ment and then create a crop area that is much smaller than the page simply by drawing a rec-
tangle and choosing Object > Crop Area > Make.

Trim Crop to a defined trim area. The trim is the final, deliverable dimensions of a document
and omits the bleed area.

Bleed The bleed area is outside the trim and holds “overflow” image data. In the event paper
shifts on a cutting machine and the blade doesn’t perfectly align with the trim edge, extending
imagery out beyond the trim guide (usually % inch) ensures that ink continues to bleed off the
page. If the PDF includes a bleed area, this option will include it in the image.

Media Crop to the original paper size defined in the PDF—regardless of the options above in
the dialog as well as other factors like visually cropping the PDF within Acrobat.
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PDFS DO PRINT

Contrary to a popular misconception prevalent even among recent design program graduates and veteran
creative and production professionals, PDFs are capable of high resolution. Raster images in PDF can be
as good as images in Photoshop, and the fully realized vector paths on par with those in Illustrator. They
can hold transparency as well as can Photoshop, and they are ready for press. All of this assumes they
were created correctly, of course, but the same is true of any document. PDFs are no more or less likely to
be botched than an EPS, a PSD, or even an INDD.

To speed display onscreen, InDesign automatically generates a raster preview of placed PDF
pages. If the PDF contains transparency, the preview uses TIFF; if not, it uses JPEG. Neither of
these will print. They're just to speed screen drawing while working, using plain raster images as
proxies instead of rereading the potentially much more complex native PDF every time you scroll,
zoom, change pages, or manipulate the placed object.

PLACING MULTIPAGE PDFs

Getting back to the Pages section and that whole “placing one page at a time” thing, it’s sort of
not true. True, you can place only one page of a PDF in one frame, but new to InDesign CS3 is
the ability to place multiple pages in rapid succession without going back through the whole
process.

For instance, let’s assume we have a 10-page PDF and we want to insert all the pages in sepa-
rate image frames—maybe we’re doing the old QuarkXPress-as-imposition-tool trick in InDesign
instead of buying a dedicated imposer. Up until now, every page of the PDF had to be placed sep-
arately, one page at a time, with a trip to the Place and Place PDF dialogs each time. In a stroke of
genius, Adobe has now enabled multiple images to be preloaded onto the place cursor, and they’ve
opened that feature to multipage PDFs.

Let’s give it a try in our mock catalog page.

1. Go to File > Place (or use the much quicker Cmd+D/Ctrl+D shortcut), and navigate to a
multipage PDE. Any one will do. They’re so common, I'm so confident that you have them
littering your hard drive, that I didn’t even bother to include one in the project files avail-
able on the book’s download web page.

2. Select that PDF, check Show Import Options, and click OK.

3. On the General tab, select All if your PDF has 10 or fewer pages; if it contains more than 10
pages, select Range and enter a range of page numbers in the format X-Y. Click OK.

4. You should see a loaded cursor with the brand-new thumbnail preview of what’s on deck
to be placed. Click in one of the image frames to place the first page, and look again at your
cursor. It still shows the on-deck preview, doesn’t it? Well, that’s the next page. Click in the
next waiting image frame to place that and load up the third page. Keep going until you've
run out of image frames.

Wicked cool, isn’t it? And that brings me to...
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INDESIGN INDD
Yup, you can now place one InDesign file into another. That’s not the same as merging two
InDesign documents, which we’ll cover in Chapter 7, “Pages.”

A common practice, especially among QuarkXPress-based publishing workflows, is to export a
layout page as EPS and then place the EPS inside the same or another layout—a picture of a page
within a page. It’s the way to do, for example, cover shots in magazine “Letters to the Editor” or
“In the next issue” department pages.

While the QuarkXPress method of saving/exporting a single page to EPS and then replacing
has worked for many, many years, and despite the fact that InDesign can do it the same way
(File > Export, choose EPS, JPEG, SVG, or PDF format), there are significant drawbacks to that
method. Specifically these:

¢ It’s one page at a time export. If you need images of every page of a 32-page publication,
you have to repeat the process—go to the page, ensure it’s the current page, select File >
Export or File > Save Page as EPS, name the file, click Save—32 times.

It’s one page at a time import. To place those 32 pages, you'll have to do it 32 times.

Exporting pages creates a whole new file—more assets to manage, more likelihood of miss-
ing or corrupted files, and more potential RIP problems.

¢ Exported pages are copies, not the original pages. If the actual layout of the page design
changes—say, at the last minute, the cover shot for the next issue changes—you must
rebuild and replace the EPS of pages, again, one at a time.

¢ Exported images are EPS, an obsolete format. Although InDesign does a great job with EPS
previews, as do recent versions of QuarkXPress. Even QuarkXPress, the application that
pioneered the methodology, didn’t, prior to version 6.5, include a screen preview that could
be considered reliable relevant to the print output.

Most of us have learned as a matter of necessity to work around the drawbacks, but now, why
bother? InDesign CS3 solves all these drawbacks and problems:

¢ Problem: It's one page at a time export. Solution: There is no export; just save the source
INDD document.

¢ Problem: It's one page at a time import. Solution: Importing InDesign INDD documents is
exactly like importing PDFs, with an identical dialog and the ability to import one, all, or a
range of pages, which will place sequentially from the on-deck place queue just as with
multipage PDFs.

¢ Problem: Exporting pages creates a whole new file. Solution: There is no export and no addi-
tional assets to manage.

¢ Problem: Exported pages are copies, not the original pages. Solution: There is no export.
When the source INDD changes, update linked assets to reflect those changes in the placed
instance(s) within the current layout.

¢ Problem: Exported images are EPS, an obsolete format. Solution: There is no spoon, Neo.

You can place one InDesign document inside another, although you cannot do a “hydra import,”
an asexual import wherein the same InDesign document is placed back into ifself as an asset. If
that’s what you need, consider your options. Longer documents can, for other reasons as well,
often benefit from splitting into multiple files coupled by an InDesign Book. With a Book tying
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them together, styles and swatches can remain synchronized, as can page and section numbers,
and all documents in the publication can be printed, packaged, and exported to PDF simultane-
ously, just as can a single document. If a Book doesn’t makes sense for your document yet you
still need to place a page from the current document as an asset on another page, save the asset
version as a separate, complete copy of the document. Then, if the source page changes in the
final deliverable, just make a new copy of the master document, overwriting the asset version,
and update links. That is still more reliable and faster than taking the route of export to EPS, JPEG,
SVG, or PDF; it does result in a larger package for print, though.

Multiple Asset Place

Surely the new CS3 feature destined to be used most often, to save the most time, is the multiple
concurrent asset placement option. It works not just with multiple pages of one PDF or INDD, but
a whole set of images—you can even mix imagery and text!

Let’s jump right into a hands-on exercise.

1. Ready a folder of images and textual documents. You're welcome to use the resource files
found in other chapter folders on this book’s download files. The key is that they must be
copied to the same folder.

2. Press Cmd+D/Ctrl+D to open the Place dialog, and navigate to the folder of images
and/or textual documents. Select up to 10 of the files in the list (you can use more than
10 files; I just don’t want you bogged down trying this hands-on exercise by having to place
40 or 50 images).

On both Windows and Mac, select sequential files in a list by clicking on the first and then,
while holding Shift, clicking on the last. All those between will be added to the selection. To
highlight nonsequential files, or to selectively remove certain files from the group, hold Ctrl
(Windows) or Option (Mac) while clicking on the undesirables.

3. Got your files selected? Good. Let’s speed this up by unchecking Show Import Options, and
then click OK. You'll be deposited back into your document with a loaded cursor and pre-
view image. Just to the right of the cursor itself, within the thumbnail, will be a number in
parenthesis. This is the number of on-deck files waiting to be placed.

4. Click once inside the first image frame on the page—it will fill with the image you just saw
thumbnailed, and the next image in the stack will appear in thumbnail. Click the next
frame to fill it, too.

If you encounter a text document, which will be obvious by the first few words appearing
as its thumbnail, click on a text frame instead.

5. Before placing the third image, look at it. It’s not the one you want to place third, is it?
(Humor me.) The order in which a file system sorts the list in the Place dialog does not
always match the order in which we’d like to place the images. In some cases, you know
which goes where, but sometimes it’s just easier to change the order of the images to be
placed and queue up a different one.

How? The up and down arrows on your keyboard. Try them out to cycle forward and back,
respectively, in the stack of on-deck assets to be placed. The thumbnail preview will show
what’s in front, what would be deposited in the layout upon the next click.

Go ahead and fill the rest of the frames until you’ve emptied the place queue.
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There are a few other things you should know about this new multiple asset place. When it
was just one asset placed at a time, pressing Esc would clear the place cursor and return you to an
unloaded cursor. Now, Esc clears only the frontmost (displayed) asset; the rest of the stack remains.
If you want to clear out of a loaded queue of 20 pictures, switch tools by choosing one on the Tools
panel.

When you turn off Show Import Options, the last selected options for a given file type are used.
For instance, if, when placing a single PDF, you choose to import all pages and then, on a subse-
quent place operation, disable Show Import Options and place multiple assets including a multi-
page PDF, you'll place each page of that PDF in turn. The on-deck count does not add in the number
of PDF pages; instead it counts the PDF itself as one asset regardless of its page count. For example,
if you place a 100-page PDF and a PSD, the on-deck count will list only 2 even though it will place
101 individual images.

Drag and Drop

Everyone uses File > Place (or Cmd+D/Ctrl+D), which is the least efficient of the methods in ver-

sions prior to CS3. Now, with the ability to place multiple assets concurrently, the Place command

has suddenly become extremely useful again—more so in some scenarios than this next method.

Still, drag and drop asset placement has its own significant advantages, especially when you need

only a few images from a folder of assets or if you need several assets across multiple folders.
Have you heard of Adobe Bridge (see Figure 5.11)?

FIGURE5.11
Adobe Bridge digital
asset manager

Adobe Bridge is a mid-level desktop digital asset manager (DAM) included as part of Creative
Suite 3 and with any stand-alone CS3-version application. I'm not going to devote a lot of time to
discussing it because (a) I've got limited page count in this book, and (b) I can probably talk my
publisher into letting me write a separate Adobe Bridge book in which I'll have several hundred
pages to really go into all its cool, efficiency building features. Suffice it to say, Bridge is pretty
darn cool, with a lot of hidden features and nuances that can really speed up your work and take
some of the focus off the tools and put it where your attention belongs—on your designs.
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What I do want to talk about here is that Bridge is a visual DAM, allowing you to manage your
assets by actually seeing them instead of trying to remember in the Place dialog the differences
between photographs labeled prodshoot070419-0067. jpg and prodshoot070419-0068. jpg. With
Bridge and other DAM software (like iPhoto, Extensis’s Portfolio, Cerious Software’s ThumbsPlus,
and others), you can view thumbnails of your images, zooming in or out as needed, and manage
them visually—move, delete, duplicate, reorganize, and so on.

(Incidentally, Adobe Bridge CS3 was integral to the creation of this book by managing all my
screen shots in various versions and states, the sample files destined for the download web page,
all my make-readies for the screen shots, and pictures of my kids, to which I liked to look every so
often while working.)

One advantage Bridge has over the competition is that it will thumbnail not just graphics files,
it also shows previews of Photoshop, Illustrator, Acrobat, Microsoft Office, and even InDesign
documents. (Note that in order for Bridge to display thumbnails of Adobe application files, they
must have an embedded preview image, which is an option in the Save As dialog or Preferences
for each application.) Thus, if you're using Version Cue document versioning and revision control
on your InDesign document, you can see the differences between what you did yesterday and this
morning.

Although ThumbsPlus won’t do InDesign documents, PDFs, and Office files, it will show
thumbnail-sized previews of fonts—TrueType and OpenType, but not PostScript. Bridge won’t
do fonts at all, leaving you to the horrid little preview windows of modern font managers.

Getting back to the main point of placing images, you can drag and drop directly from Bridge
into InDesign. Choose the picture you want to place, not the filename.

Position the Bridge window such that you can see your InDesign layout simultaneously
(multiple monitors help), then drag an image from Bridge and drop it atop a frame in InDesign.
Voila! Placed image.

Working content-first, you can even place multiple images simultaneously, though not into pre-
existing frames. Select the images in Bridge using Shift (sequential) and /or Cmd/Ctrl (nonse-
quential); then, in one motion, click on an already selected image and drag it out of Bridge and
over an empty area of the InDesign document. All the images selected in Bridge will place as links
in InDesign, each in its own frame and cascaded for (usually) easy selection. Note that it will use
the previously chosen or default import options for each file type; you wont” see an Import
Options dialog.

Because Bridge can also manage textual files—PDFs, Word documents, TXT, RTF, InCopy
INCD documents, and even other InDesign INDD documents—they can also be imported via
drag and drop.

Any other DAM application that affords the user drag and drop file management capability can
also be used in the same manner, as just described. iPhoto on Mac OS X is great for that, as is Adobe’s
Lightroom and Photoshop Album (professional photography and consumer DAMs, respectively), the
aforementioned ThumbsPlus and Portfolio, and numerous other DAM applications.

When you do find yourself managing files in the file system—an OS X Finder window, a Win-
dows Explorer window,, or either platform’s desktop—you can place via drag and drop from there
as well with the same behavior.

One last area for drag and drop is from another application to InDesign.

You can drag Photoshop and Illustrator layers, and Illustrator objects, and drop them directly
into the existing frames in the InDesign layout or on a blank area to create their own frames. Text
and other special layers from Photoshop will not survive drag and drop into InDesign, though.
You can also drag text from InCopy, Word, and various other applications into InDesign. Like
imagery, the text can be dropped onto pre-existing frames or onto empty areas.
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Copy and Paste

Naturally, you can copy frames and their content, together or separately, from within InDesign
and paste elsewhere within InDesign. You can copy type from the middle of a story and paste it,
too. I won’t waste your time talking about something as academic as that. I would like to spend a
few paragraphs discussing what can and can’t be copied into InDesign from other applications
and some of the things to watch out for when doing that.

InDesign’s drawing tools are perfect for most common drawing tasks. When you need some-
thing a little more robust, however, haul out Illustrator. When you do that, you have a choice: Save
the Illustrator file and place it into InDesign as an asset, or simply copy the artwork from Illustra-
tor and paste into InDesign. Either method works, and each has its pros and cons.

InDesign understands vector paths and basic shapes about as well as Illustrator, and, more
importantly, InDesign is wise enough to recognize when something—in this case, Illustrator—is
more knowledgeable than itself. Take, for instance, live effect 3D objects created in Illustrator.
InDesign is a page layout application; it has no concept of 3D space beyond x and y coordinates
and basic stacking order.

Draw a path in Illustrator, apply a 3D Revolve effect to spin the path into a vase or ashtray, and
the path remains infinitely editable (because it’s a nondestructive effect in Illustrator). InDesign,
however, doesn’t have a 3D Revolve effect, has no concept of lighting—three-dimensional or
otherwise—and just doesn’t get it. Consequently, you might expect that copying the 3D object
from Illustrator and pasting into InDesign would result in just the original path, sans 3D, in
InDesign. Fortunately, if that’s what you expected, you'd be wrong.

In Figure 5.12, you can see three versions of an urn. In Illustrator, I drew a relatively simple
path (highlighted on the left) and revolved it into a 3D urn. This is a live effect—I can change
the path at any time and the 3D Revolve effect will update the three-dimensional shape to match
my changes. The center version is the same object copied from Illustrator and pasted into InDesign.
Notice how it looks identical? What really happened is that the 3D effect was converted to flat
paths, maintaining the object’s appearance by sacrificing the reality. If I ungrouped the paths in
InDesign, I'd be left with hundreds of little slivers, which you can see as individual paths in the
picture on the right. That one is the object copied in InDesign and pasted back into Illustrator. The
ability to edit the 3D shape easily is gone; if I needed to change the shape or color of the urn, I'd
have to spend hours doing it.

In this case, Id re-create the object from scratch, hoping I remembered or could re-create the
exact 3D Revolve settings, light source positions, and so on. Odds are, it would take me less than
five minutes to re-create the urn; with something complicated, though, I could be looking at hours
or days worth of redrawing time just because I thought copy and paste would be faster initially.

FIGURE5.12

The same 3D shape
as drawn in Illustra-
tor (left), as pasted
into InDesign (cen-
ter), and then copied
from InDesign and
pasted back into
Illustrator (right)
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There’s the pro and the con: You can copy native objects from Illustrator and have them
become native objects in InDesign—no rasterization. Draw a couple of rectangles or stars in
lustrator, paste them into InDesign, and you can edit their paths further there. You can also
change their colors and transparency, move around the constituent objects in a group pasted
in, and so on. However, if you get something InDesign doesn’t understand—Iike the 3D urn—
InDesign will make it understandable and could thereby reduce or eliminate your ability to later
edit the object.

TROUBLESHOOTING: PASTE FROM ILLUSTRATOR CREATES A FLAT IMAGE

If, when you copy something from Illustrator and paste it into InDesign, you get only a flat image with-
out individually editable paths, the problem is not within InDesign, although it would be a logical
assumption. In Illustrator, on the File Handling & Clipboard pane of that application’s Preferences, are
options for how data is copied to the system clipboard: as PDF (flat with transparency support) or AICB
(individual paths, but no transparency). If, when you paste from Illustrator, the result is flat artwork
without editable paths, you’re dealing with PDF-format clipboard contents when you want AICB (Adobe
Illustrator Clip Board).

If you change the setting in Illustrator and the problem persists, check that you haven’t overridden
InDesign’s default pasting format. In the Preferences, on the Clipboard Handling pane, the top option,
Prefer PDF When Pasting, should be unchecked.

I1deally, leave both copy as PDF and AICB options checked. What occurs then is that Illustrator copies to
the clipboard as both, allowing the destination—the paste into—application to select which format it
supports. InDesign will choose AICB, thus accepting paths and individual objects, while applications
that don’t understand AICB will take the PDF-format content.

My rule of thumb is, if it takes more than 1 minute to draw in Illustrator, I'll save the Al file and
place it rather than copy and paste to InDesign. (I'm fast with Illustrator; if you aren’t, maybe try
5 minutes as a rule.) I would much rather retain editability of a drawing than worry about manag-
ing one more external asset.

The same is true of Photoshop images. While you can copy and paste from Photoshop to
InDesign, and it’s great for little bits here and there, you lose a lot. The first to go is transparency;
pasted images are flattened onto a white background. Not even InDesign’s Object > Clipping
Path > Option command will get rid of the white. The same is true if you drag one or more layers
from Photoshop and drop them into InDesign.

Other things to watch out for include transparency—Illustrator transparency flattens upon
paste or drag into InDesign—and color. Both Illustrator and Photoshop support color models
InDesign does not, like Web-Safe RGB, HSL, and Grayscale. The latter will become tints of process
black (the K in CMYK), while the former two will convert to the RGB color space. Spot colors sur-
vive unless they’re from a library InDesign doesn’t have, such as Visibone2, in which case they're
converted to the nearest match CMYK process values. Simple Illustrator gradients—linear, radial—
will convert to InDesign gradients and may be edited after paste, but more complicated ones or
gradient meshes become individual vector paths in InDesign (think of the urn). Illustrator patterns
become embedded EPS images and are no longer editable.
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Objects or elements coming into InDesign via paste or drag and drop will be permanently con-
verted, whereas placed assets only appear within InDesign using that application’s supported color
models; the actual colors and spaces will survive unchanged inside the external assets and thus
through to output. This can also be a gotcha: An image saved in HSL (Hue, Saturation, Luminosity)
will look RGB in the layout, enticing you to forget that the asset is not RGB, and may later cause
problems with a RIP that doesn’t know how to convert from HSL. Preflight and Package for Print
will pick up on the color space and alert you, though, so keep an eye on those.

Text from nearly any application—including Photoshop and Illustrator—can be pasted into (or
from) InDesign, though, by default, text will lose its formatting upon paste. Back on the Clipboard
Handling pane of InDesign’s Preferences, you can change that behavior by toggling the setting for
When Pasting Text and Tables from Other Applications to All Information instead of the default
Text Only.

Other Flavors of Paste

No, I don’t mean to discuss the chunky white bottled paste we found so delicious as pre-nap
snack in kindergarten. I mean Paste without Formatting, Paste Into, and Paste in Place. They
aren’t strictly for getting assets into InDesign, but at this point in the discussion, they are relevant.

When the Clipboard Handling preference is changed to preserve formatting, swatches, styles,
and so forth on pasted text, there is a way to override it and paste unformatted text per instance.
This same method is very helpful for copying and pasting from one place or document in
InDesign to another.

On the Edit menu is the Paste without Formatting command. Instead of using Cmd+V /Ctrl+V
to execute a normal paste, use Cmd+Shift+V /Ctrl+Shift+V to paste text without any formatting.
Pasted text will then take on the attributes assigned to the frame or surrounding text, including
style, formatting, color, and so on.

Just below that command is Paste Into, which is a nifty command to know when you want to
accomplish one of these tasks:

¢ Paste one container (with or without content) inside another container

¢ Move or copy an image (or text) from one frame to another without having to go through a
fresh place routine

¢ Clip or mask a group of objects by pasting into a frame in the shape of the desired mask

Next is Paste in Place. Copy an object, then choose Paste in Place to put a duplicate directly
above, and perfectly aligned with, the original (there is no Paste Behind as in Illustrator). Also, less
obvious, is that Paste in Place doesn’t so much paste one copy atop the original as it does paste the
copy in the exact same place as the original. Huh? Six of one thing, half dozen of the other. No, it’s not
the same thing.

Copy an object. Now, go to the next page. Paste with a standard Cmd+V /Ctrl+V. What hap-
pens? The pasted object shows up dead center of the document window. Change your view—
scroll around, zoom—and paste once more; again, the object is dead center of the document
window. Now, paste in place instead. The copy is pasted at the exact same coordinates as its
original, the source from which the copy was made.

The advantage to using Paste in Place instead of a standard Paste (or Edit > Duplicate for that
matter) is that it does almost the same thing, but there’s no need to also manually position the
copy. You can run through an entire document, blindly using the paste in place keyboard shortcut,
and know that the object is inserted in the exact same position on every page.
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Content-First Workflow

In contrast to the frame-first workflow is a more freeform way of working: content-first. As inti-
mated earlier, this is an entirely alien concept to recent QuarkXPress converts.

Instead of making frames to hold everything, a content-first workflow brings all or most of
the assets into the layout first. Once everything is there, you can then see how many text frames
you need to fit and how many images have to be accommodated and play around with various
arrangements.

Highly structured documents like catalogs and the templates for regular magazine feature
and department pages almost always must begin frame-first because the content just isn’t known
ahead of time. More to the point, the frames often dictate the length and dimensions of content.
Solo designers and graphic design studios with varied clients and projects, however, usually do
(or should) begin content-first because, by the time they’re brought in, most of the content is usu-
ally finished. The layout must therefore change to accommodate the content, not the other way
around.

How do you accomplish a content-first workflow? Simple: Don’t make frames before import-
ing content.

You see, InDesign must have containers for content, but you aren’t required to create them.
InDesign will create them for you. If your work is always of the nature where the content is pro-
vided before you begin layout, you might never have to make an empty frame again.

Start with a blank page or a basic grid, and then go to File > Place, press Cmd+D/Ctrl+D,
paste, or drag and drop your content. When you click (or click and drag) to place the content,
InDesign will make the frames to hold the content in the same action.

Click and release to place the content at full size, in a frame sized to fit the entire content (or
within the limits of the pasteboard, whichever is smaller). Click and drag to define the area for the
frame. InDesign will still place the asset at full size (in the case of an image), but nondestructively
crop it to fit within the frame you drew. Text inserted this way will wrap to the area and overset
any lines that don’t fit.

Whenever I can, I work content-first. Even when doing a fixed-content layout like a catalog
page, I'll bring in FPO content from a previous issue or a less than final edit to help me more accu-
rately size up frames (afterward I'll flush the frames of the FPO content). Both with my own work
and that of nearly everyone I've converted from the QuarkXPress Way, content-first results in
faster, more accurate work—you don’t forget to include a tagline or photo credit when it’s already
sitting on the page or just beside it on the pasteboard. Additionally, content-first workflows tend
to be more creative overall than frame-first because designers are visual; we're ultimately working
toward communicating via content, not boxes.

Managing Placed Assets

Getting content in is only half the considerations. You also need to know how to manage it.

The Basics

Here’s a quick recap of the stuff you probably already know or have figured out by now by read-
ing the chapter thus far.

I assume you've already noticed the Replace Selected Item check box in the Place dialog.
Check that and, if you had a frame selected, InDesign will flush its content with the newly
imported asset.
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Images inserted via place or file/thumbnail drag and drop methods are by default linked and
not contained within the InDesign document itself. Those pasted or dragged and dropped from
another file are embedded, without a link to external assets, as is text by default.

When opening a document containing linked assets, InDesign automatically compares them
to its record of their last state (location, date, time, and so on). If anything has changed, you'll be
prompted to update or relink to the assets.

Links Panel

Most content is managed on the Links panel (see Figure 5.13). This includes linked assets of all
types as well as embedded images. Embedded text is not referenced on the Links panel, nor is
imagery pasted or dragged in from another application.
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Every instance of a linked asset is listed on the Links panel with its location in the layout on
the right. Possible locations are page numbers (1, 2, 3, and so on); PB for pasteboard, denoting
that the asset is not within a page and will not print; and a master page prefix (e.g., A, BB, CCC,
DDDD) indicating that the asset is on that master page and thus shows on any body pages to
which that master page is assigned. Multipage assets like PDF or INDD files will include not only
the filename but also the asset page in use. For example, bio_RaiMagnor.pdf:2 denotes that I've
placed page 2 of that PDF asset.

Double-clicking an entry in the list will bring up the Link Information dialog (see Figure 5.14),
which lists valuable data about an asset, including basics such as filename, size, type of asset, and
date of last modification as well as some whose purpose may be less obvious:

Link Needed A Boolean field. Specifies whether the link to an external asset is required to
print the document. The value is yes or N/A. Embedded images are a part of the InDesign doc-
ument itself and a link to an external resource is not required in order to print the layout; the
value of Link Needed would therefore be N/A.

Color Space The color model of the selected asset—RGB, CMYK, and so on.
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Content Status This is a comparison indicator. Is the displayed image in synch with the actual
linked asset, or has the latter changed?

Layer Overrides Relevant only to layered PSD, PDF, INDD, and Al files, this field states
whether you’ve shown or hidden any layers or layer comps to make the placed image differ
from the state of the external file.

Adobe Stock Photos This new field denotes whether the selected asset is stock imagery
obtained through Adobe Stock Photos via Adobe Bridge.

Version Cue Status Identifies whether the asset is managed by Version Cue.

Location A handy little field, here is the full path to the asset. You can highlight and copy the
path and filename, ready to paste into another application’s Open dialog.
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The Prev and Next buttons along the right edge of the dialog allow you to move through the
list of assets without having to close the dialog and double-click on the next entry to see its link
information. Go To Link will jump the document window to display the selected asset, which is
extremely handy for figuring out just what the previous designer (or you) was thinking placing a
particular image. Finally, Relink opens a browse dialog to fix a broken link or replace this asset
with another, automatically replacing the one with the other within the frame and preserving
frame attributes such as scaling and crop data.

Select multiple Links panel entries the same as files in a list—by holding Shift for contiguous
selection and Cmd/Ctrl for noncontiguous. To quickly select all entries in the list, hold Cmd/Ctrl
and double-click on any one.

Opt+Shift+double-click / Alt+Shift+double-click on a Links panel entry to execute an immedi-
ate Go To Link, jumping the document window to the location of the asset on the page, paste-
board, or master page.

The Links panel flyout menu (see Figure 5.15) provides numerous commands that are also
worth running through:

Edit Original Also available as the last button on the bottom of the Links panel, Edit Original
is an incredibly useful, time-saving command. Very simply, it opens the linked asset in the
application that created it. To touch up a PSD, for instance, you needn’t launch Photoshop, go
to File > Open in that application, and then browse for the correct image. Edit Original does all
that in one step, from within InDesign. Once you've completed editing in Photoshop (or Illus-
trator, or another InDesign document, or...), simply save the asset and close the editing appli-
cation. Edit Original listens for that to occur and automatically updates the link inside the
InDesign document to reflect your new changes.
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Copy Link(s) To Often, especially within workgroups, InDesign layouts employ assets that

are scattered throughout numerous folders and local or network hard drives. Keeping track of
them can be confusing, tedious, and nigh impossible. Copy Link(s) To is a very cool command
that offers order from chaos (at the expense of duplicating files). Select assets in the Links panel,
run the Copy Link(s) To command, and InDesign will ask to which location and folder you
would like it to collect the selected assets. Choose a place, and InDesign will both copy the
assets there and update the document’s link information to point to the new location.

Save Link Version If you are using a versioned workflow managed by Version Cue, this com-
mand will create a new version of the linked file as it exists within the InDesign document. For
example, this is useful for layered assets whose layers or layer comps you've overridden.

Versions Displays Version Cue-managed versions of the selected asset.

Purchase This Image With Adobe Stock Photos, you're able to download low-resolution
comps of images and place them into InDesign via Bridge. This command will let you purchase
the actual license to use the royalty-free stock photo and download high-resolution or other
available versions. Upon purchase, InDesign’s tight integration with Adobe Stock Photos
results in the comp automatically being replaced by the purchased image.

Reveal in Finder/Explorer Opens a Finder (Mac) or Explorer (Windows) window to view the
file system folder containing the selected asset.

Reveal in Bridge Similar to Reveal in Finder/Explorer, except an Adobe Bridge window is
opened on the folder instead, enabling visual management of assets.
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Embed File Breaks the link to the external asset and makes the item part of the InDesign docu-
ment itself. Employed rarely for imagery, Embed File is most often used to embed textual assets
(Word and Excel files, for example) and for final stage embedding of InCopy stories.

Link File Info Opens the asset’s XMP metadata dialog.
Link Information Opens the Link Information dialog discussed earlier.

Along the bottom of the Links panel four buttons provide single-click access to Relink, Go to
Link, Update Link, and Edit Original.
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Linking vs. Embedding
When you embed assets in a layout, you put all your eggs in one basket, as my grandmother says.
If one file gets corrupted, all your work is gone.

Embedding assets is tempting, and I see many new creatives opting for it. They’re tempted by
the fact that embedding means fewer—or no—external assets. They like the idea of having just
one file to move around, never having to worry about network paths remapping or forgetting to
copy PSD from this other folder onto their USB drives to work on the layout at home.

Sure, a layout with all or a significant portion of its imagery and copy embedded is easier to
deal with, easier to manage, and easier to send to a thumb drive or DVD-ROM, but it’s not worth
the risk. Eggs. Basket. Splat. Weeks of work oozing out all over the linoleum.

I like being right as much as the next guy, but I hate being proven right on the linking versus
embedding debate. It truly saddens me when somebody comes up to me long-faced at a confer-
ence and begs me to help him fix a corrupted document wherein he has embedded all his images.
Sure, I know a few tricks I can try (most are somewhere in this tome), but it’s a rare occasion
when they work; if all the safeguards have failed, there just isn’t much to be done to resurrect a
truly corrupt INDD. At that point, it’s a matter of re-creating the document. If all the assets are
external, the work is lot less than if they were all embedded and must also be re-created from
scratch.

If that doesn’t dissuade you from embedding assets, maybe this will: Remember the urn? If you
embed, you potentially lose the ability to quickly and easily edit original artwork. Images placed
as links and then embedded can often be extracted back to an editable state, but artwork brought
in via paste or drag and drop from an application are instantly frozen into EPS or TIFF formats—
good-bye live effects, good-bye layers, good-bye to a lot of stuff.

Opinions differ on the linking versus embedding debate. Some—including a few gurus whom I
admire—say embedding is fine, that there are enough safeguards in place with InDesign’s Saved-
Data and extremely stable file format. In my experience, having done page layout and compositing
for all these years, having looked into the faces of misty-eyed owners of unopenable documents,
and having researched enough technical support cases wherein months” worth of work was lost
due to a simple power surge or mistimed network backup, embedding anything that will take
longer than 5 minutes to re-create—cumulatively—is, in my opinion, a bad idea.

Fitting
Relating content to its container is accomplished through a process called fitting.

Is the entire image displayed at 1:1 scale, or is it cropped? Is the frame larger than the content to
provide a colored border? When you place an asset, are you working frame-first or content-first,
and is the frame already the needed size? All these questions—and more—are a matter of fitting.
InDesign naturally contains features and commands for fitting that have been standard in layout
applications for years, but it also introduces some new ones.

FITTING COMMANDS

InDesign’s fitting commands are found in not one, not two, but three locations—the first two are
the Object > Fitting menu and the Fitting submenu on the context sensitive menu available when
you right-click on a frame with content. In past versions of InDesign, these two menus differed.
The context sensitive version was a subset of Object > Fitting, containing only the most common
fitting commands. To much rejoicing, the context sensitive menu now offers rapid access to all
the fitting commands (see Figure 5.16).
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In addition to finding them on the menus, you'll find them as convenient buttons on the Con-
trol panel (see Figure 5.17); they appear on the far right any time a frame is selected.
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A fourth means of access, keyboard shortcuts, also exists for all the fitting commands, but
because they tend to be three- or four-key commands, it usually takes less brain power and finger
acrobatics to use the Control panel buttons or right-click to access those fitting commands you use
infrequently.

Let’s quickly run through the fitting commands.

Fit Content to Frame Stretches or shrinks imagery to fill in the full area of the frame. This com-
mand may result in distortion of the image to accommodate the frame dimensions.

Fit Frame to Content Resizes the frame up (decrop) or down (crop) to match the dimensions of
the content (either imagery or text). Use this when you want 100% of your content showing but
without excess or empty frame area around it.

Center Content Aligns the content to both the horizontal and vertical centers of the frame
without resizing either frame or content. Center Content is a quick way to begin a framed pic-
ture effect wherein a color-filled frame is larger than its content image.

Fit Content Proportionally Uniformly scales the content in an attempt to fill the frame. Scaling
stops when it fills either the horizontal or vertical dimension of the frame, thus the image is not
distorted but empty frame space usually endures along the other axis.

Fill Frame Proportionally Uniformly scales the content to completely fill the frame without
stopping at the smaller of the frame’s horizontal or vertical dimension. Instead, scaling contin-
ues until both dimensions are filled, stopping at the larger second dimensions and often crop-
ping the image. For instance: Placing a 1X2-inch image inside a 2X2-inch frame and choosing
Fill Frame Proportionally will scale the image up 200% (resulting in a 2X4-inch image), filling
the horizontal 2-inch dimension and cropping the vertical by 50% (2 inches).
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It’s important to remember that fitting occurs relative to the actual frame dimensions. By
default, strokes assigned to frames straddle the frame path. For example, a 4-point stroke puts 2
points inside the frame and 2 points outside. In that scenario, the 2 points of stroke inside the
frame will cover 2 points of the content all the way around.

While you may be tempted to resize the frame to account for stroke weight, don’t. It will throw
off your measurements and scaling, something you'll have to wrestle with every time you resize,
alter fitting, or scale the frame and content. Instead, use the Stroke panel to move the stroke to the
outside of the frame instead of the default middle (straddle) alignment.

FRAME FITTING OPTIONS

The last option on the Fitting menu is Frame Fitting Options (see Figure 5.18). It's new to CS3 and,
obviously, extremely useful. However, please do not skip this section assuming you already know
about this dialog or can intuit it simply from the screen shot or trying it yourself. While that may
be the case, the most powerfully productive use of Frame Fitting Options is hidden. I don’t want
you to miss that.

FIGURE 5.18
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Prior to CS3, it took a lot of work to do something as simple as using the frame to crop out a
border embedded in an image. You had to either measure the width of the border and then sub-
tract twice that width from the frame’s width and/or height or zoom way in, turn on high-quality
display, and manually reshape the frame and refit the content over several steps. Either way, if
either the frame or the content had to later change size, you were forced to do it all over again.
Anyone who has arranged a series of photos from various sources knows this toilsome process.

Thankfully, it’s no longer necessary.

Frame Fitting Options has crop boxes with a live preview. They work just like other measure-
ment fields in that you can type in a value, and use the increase/decrease arrow buttons or, with
the cursor in the field, even the up and down arrow keys on your keyboard. The chain link button
between the Top and Bottom and Left and Right crop fields links all four together—changing the
value in one alters all four to match. (Good-bye image border.)

In the middle of the dialog, the Alignment Reference Point alters the alignment of the image
within the frame. This can operate alone, simply altering where an image falls within its frame,
but it also affects how the image reacts to cropping operations.

Positive cropping values pull the content foward the selected reference point, while negative
cropping values push the content away. In Figure 5.19, for example, you can see the different
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alignment and cropping result of the same image and frame using positive (left) and negative (right)
cropping values. In both of these, the content is aligned to the top left; changing the reference
point dramatically alters the cropping results (see Figure 5.20).

FIGURE 5.19

At left, a frame and
image cropped to
positive 0.75 inches
all the way around;
atright, the same
frame and image
with negative crop-
ping of the same
amount. Both are
aligned to the top-
left reference point.

FIGURE 5.20
Using a positive
0.75-inch cropping
value, different
alignment reference
points dramatically
alter cropping
results. From left to
right: Aligned to bot-
tom right, center,
and middle top.
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Fitting on Empty Frame asks, If, on its own or as a result of cropping, the frame is larger in at least
one dimension than the content, thus displaying empty space, how should the image be fitted within the
frame? Your four options are None (don’t alter the image at all), Fit Content to Frame, Fit Content
Proportionally, and Fill Frame Proportionally, which are identical to the individual fitting com-
mands discussed above except that, in Frame Fitting Options, they account for crop values and
alignment options.

Now, I promised you a hidden feature. A man of my word, here it is, in a hands-on exercise.

1. Still got your catalog template with the empty frames? If not, go ahead and create about a
half dozen empty picture frames.

2. Select all those empty frames and go to Object > Fitting > Frame Fitting Options. Break the
Make All Settings the Same chain link, and set top and left crops to —0.25 inches.

3. Set the reference point to the top-left corner and fitting to Fit Content to Frame. Hit OK.

4. Deselect the frames, and go to File > Place. Select a number of images roughly equal to the
number of frames and import them.

5. Once you have a loaded cursor, place the images one at a time into the frames you just
modified. You should immediately notice the fitting effects.
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Let’s assume you have a series of product shots all from the same manufacturer or photog.
They were all taken amid a sea of white backdrop and drape, with the products always the same
distance from dead center.

Your first option is that you could take them into Photoshop, crop or trim them, and then save a
new set of images. The drawbacks to that are as follows: It’s more work for you—you'll probably
have to do at least some fitting and cropping in InDesign regardless; it creates another set of digi-
tal files to track and manage; and should substitution of products occur or new versions of the
photos be delivered to you, you have to do both the Photoshop and InDesign work again. Your
second option is to place the unaltered photos into InDesign and, through fitting and cropping,
get them just right.

By presetting your frame fitting options—fitting and /or cropping—you can prep for the most
common tasks required by your series of product shots, making the cropping, fitting, and align-
ment all part of the placement process instead of an extra step you must do to each afterward.
They won't all be perfect (unless you're incredibly lucky), but performing a few touch-ups here
and there is much more efficient than repeating the same settings for the majority of your photos
each in turn.

Even without alterations to the cropping or alignment, the ability to preset fitting is a huge
time-saver. You can fill an entire frame-first catalog layout with images all fit proportionally
within their frames in seconds!

The Bottom Line

Place Image Assets Focusing on efficiency with this version of InDesign, Adobe seeded
numerous tiny improvements in the task of placing image assets and three big overhauls—
increased support for Photoshop PSD layers, frame-fitting options, and simultaneous multiple
asset import.

Master It Create a frame-first layout containing 6 to 10 image frames. Preset the blank
frame fitting options to Fit Content Proportionately, and then, using any folder of images
available, import and place, in one operation, all the images needed to fill the frames.

Import Images without Place Drag and drop enables visual selection and import of image
assets while copy and paste, under the right conditions, offers a more natural way of mov-
ing assets from one place to another in the same document or between InDesign and other
applications.

Master It Create another empty frame layout similar to the previous one, and then, using
Adobe Bridge and ensuring that both Bridge and the InDesign layout are visible onscreen,
visually choose and place image assets from within Bridge to fill the empty frames.
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Manage Placed Assets Getting image assets into the layout is only half the job; you must also
know how to manage—and even replace—assets once they’re on the page.

Master It Use one of the two documents created in the preceding Master It exercises, and,
without using File > Place, drag and drop, or even copy and paste, replace three of the
images (in the same frames) with other assets. If you have Photoshop and/or Illustrator
installed, choose another image already placed on the page and edit the image itself in Pho-
toshop or Illustrator without opening the application from the Dock or Start menu.
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Objects

If there’s a “coolest subject” in this book, this is the chapter most likely to contain it. In fact, many
of the topics covered in this chapter could fit that description—at least, from a standpoint of cre-
ativity and creative productivity. If production efficiency or collaboration is the coolest subject to

you, well, I've got whole chapters about those, too.

As with drawing in InDesign, the name of the game when applying transparency and effects to
objects is efficiency through doing as much as possible within InDesign, resorting as infrequently
as possible to creating objects in Photoshop. If you’ve been in the layout game for any length of
time, you know how often it was necessary to design whole pages in Photoshop just to enable
object interaction, and if you know that, you know how problematic late changes became. Each
release of InDesign empowers you to do more in the layout itself, retaining all the freedom of
InDesign objects, and without rasterizing. InDesign CS3, in fact, now has many Photoshop-like
effects built in.

In this chapter, you will learn to:

¢ Use attribute-level transparency and object effects
Design custom stroke styles

Create mixed ink swatches

Manage and share swatches

Work with anchored objects

Set type on a path

Step and repeat

® 6 6 O o o

Transform again

Transparency and Effects

InDesign 2.0 introduced transparency to desktop publishing applications in 2002. Finally, two
objects blend together without having to rasterize them in Photoshop. Objects—text, paths, even
placed image assets—could be rendered less than opaque, and they could be blended together
using familiar Photoshop blending modes such as Multiply, Screen, Exclusion, and others. A new
world of creative freedom and efficiency exploded.

In 2003, version CS gave us drop shadows natively in InDesign, and they were pretty cool (if
overused), not only for their shadows, but also because drop shadows could be used to create an
outer glow effect as well.

InDesign CS3 proves Adobe was just teasing us all along, whetting our appetites. Now, trans-
parency and effects are really cool.
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Attribute-Level Transparency

Object-level transparency is when an entire object—simultaneously and equally the object’s con-
tents, fill color, and frame and stroke color—may be blended with its background by changing
opacity and blending mode. With an image in a frame, for example, setting a 50% opacity made
the frame, its stroke, fill color, and the image inside the frame semitransparent all at once. If you
wanted a fully opaque frame stroke over a semitransparent image in InDesign CS2 or earlier, you
had to stack two objects—the first, the stroke-less image frame, and above it, an empty, stroked
frame. That was object-level transparency.

InDesign CS3, like Illustrator before it, now has attribute-level transparency—the opacity and
blending mode of the fill, stroke, and contents can all be set independently of one another. To her-
ald the change, the Transparency palette has become the Effects panel (see Figure 6.1). Open the
Effects panel by choosing Window > Effects.
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You still have the same Blending Modes drop-down menu and the same Opacity field, which
accepts input via typed-in values or adjustments to the Opacity slider by clicking the arrow button
to the right. Now, though, the middle section of the panel asks the tantalizing question, Which
attribute do you want to blend, to render semitransparent?

By default, Object is selected, meaning opacity or blending mode changes will apply to the entire
object a la CS2. To change just one attribute—the stroke, fill, or text—select that attribute beneath
Object prior to altering the blending mode or opacity percentage. Each attribute may have its own
settings, and all may be modified within the same object if so desired. Thus, as you can see in Fig-
ure 6.2, with its opaque text, 50% opaque stroke, and Color Dodge blending mode fill, each attrib-
ute may be blended independently within the same object instead of stacking multiple objects that
must be individually (and often laboriously) altered for a change request.
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You might notice that the attribute-level options mention nothing about changing the opacity
of images inside a graphic frame. That’s because the option isn’t there. That function is a hidden,
secret trick. (You might want to either dog-ear this page or write the trick on a sticky note affixed
to your monitor.) To change opacity settings or effects on an image independently of its containing
frame’s fill and /or stroke, you must select the image itself with the Direct Selection tool, the white
arrow. It’s then that the Effects panel will reveal control over the placed image (see Figure 6.3).
Using the black arrow Selection tool accesses only the container, not its content. It makes sense,
logically, that Adobe would divide the scope of the Effects panel along the line drawn by the
Gemini-like Selection and Direct Selection tools—logical, but far from obvious.

FIGURE 6.3 [ra—
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Isolate Blending, a check box at the bottom of the panel, allows you to specify that objects with
transparency only blend within their group, appearing opaque in relation to objects below that.
Electing to enable Knockout Group (the other check box) knocks the selected object out of the ink
of objects below, thus preventing blending and overprinting that might cause, through the non-
opaque nature of printing ink, a blending regardless of the Isolate Blending choice. If you don’t see
either of these check boxes, choose Show Options from the Effects panel flyout menu to reveal the
lower portion of the panel.

Effects

Attribute-level transparency is only one-half of the transparency effect overhaul on CS3. As cool as
that is, it’s the new attribute-level Photoshop-like effects that really widen one’s eyes and tug up
the corners of one’s lips.

Start by creating an object; then, on the Effects panel, click the middle fx button at the bottom,
which pops up a menu. Choose Drop Shadow to begin. If you're familiar with Photoshop’s layer
style effects, the basic controls of InDesign’s Effects dialog will be instantly familiar (see Fig-
ure 6.4). Even if you aren’t a Photoshopper, you should find the controls and options intuitive.

FIGURE 6.4
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The first thing to note is the drop-down menu in the top-left corner. As with the Effects panel,
the Effects dialog effects (man, I wish Adobe had created more distinction in the names) are attrib-
ute level, meaning that the entire object as well as just its stroke, fill, and text can have their own
individual effects. Text inside a frame, for instance, can have a drop shadow and bevel while its
frame has an inner glow and is 75% opaque, and the stroke... The number of possible permuta-
tions of 9 effects, 15 blending modes for many of the individual effects, and all those effects and
blending modes applied separately across the four object attributes is a dizzying venture into
mathematical probabilities. And, they all interact to create a gestalt potentially as visually rich (or
garish) as anything that could be created in Illustrator with the Appearance panel.

So broad and varied are the possibilities of the Effects dialog that the only way to really come
to understand them is to experiment on your own. Therefore, I'll explain some of the options and
discuss the effects themselves just a little, leaving you to explore on your own after that. Make sure
the Effects dialog is open to follow along.

DROP SHADOW
Drop Shadow isn’t new, but it has been rebuilt.

You still have the familiar CS2 x and y Offset distance fields, but Drop Shadow now has a much
more intuitive Angle spinner to accomplish the same thing. No longer do you have to estimate the
conversion between the angle of the light source and horizontal- and vertical-axis-oriented coordi-
nates. Just drag the rotating spinner or type in the angle degree in the field to the right. Even bet-
ter, all effects can be oriented according to the same light source with the Use Global Light check
box (more on Global Light in a few pages).

Also new are the check boxes Object Knocks Out Shadow and Shadow Honors Other Effects.

When InDesign draws a drop shadow, it does so behind the object as well as whatever portion
of the shadow is visible beyond the area of the object. If the object fill or stroke is less than opaque,
you'll see the drop shadow through it. More importantly, even if the object itself is opaque, even
if you can’t see the shadow through it onscreen, you could find the reverse is true upon printing.
As you know, printing ink isn’t truly opaque; black ink is close, as are several types of spot inks,
but cyan, magenta, and yellow especially tend to allow ink beneath to shine through. Thus, apply-
ing a black drop shadow to a yellow-filled object, for instance, will often result in a yellow-tinged
black object or a messy near-black green. Checking Object Knocks Out Shadow prevents drop
shadows from showing through both onscreen and in print by knocking the shape of the object
out of the shadow. The shadow itself will therefore only be around the edges of the object, not
behind as well. Figure 6.5 shows the difference between Object Knocks Out Shadow on and off.

FIGURE 6.5

The same object (set
to 50% opacity for
clarity) with the
same drop shadow.
At left, Object
Knocks Out Shadow
is on, and at right
it’s off.
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Shadow Honors Other Effects is a choice between adapting the shadow to reflect shape and
transparency changes introduced by other effects (option checked) and ignoring them, drawing
the shadow solely based on the real object or attribute shape (option unchecked). For instance, say
you've added an outer glow effect as well as the drop shadow to a simple square. With Shadow
Honors Other Effects unchecked, the shadow draws only in the shape of the path, the square.
Conversely, with Shadow Honors Other Effects checked, the shadow will expand to incorporate
the shape of the outer glow as well as the original square.

When InDesign draws a drop shadow, it begins feathering from the start to the end of the
shadow—from the original object shape out to the end of the shadow. This creates a soft, feath-
ered shadow, but you don’t always want a soft, feathered shadow. Optically, the sharper a drop
shadow, the harsher the light and the closer the object is to its background. To affect sharpness,
use the Spread percentage field, which pushes the opaque area of the object shape out farther into
the shadow area to reduce feathering in the edges.

Noise adds digital, random noise to a shadow, making it appear less smooth. Why on earth
would you want to do that? For realism, of course. Other than glass and Mr. Clean’s head, few
things in nature are perfectly smooth. Adding a little noise—say, 1 to 3%—makes a shadow more
believable usually without being consciously noticeable to the viewer. Continue increasing the
noise percentage to roughen the shadow—try 90 to 100% for an interesting mezzotint effect.

To change the color of the drop shadow, click on the color swatch between the Blending Mode
and Opacity fields. Black is the default, but other colors offer tremendous creative opportunity.
Don'’t be afraid to experiment. These are all nondestructive, live effects, meaning they can be
changed or even turned off at any time without consequence.

INNER SHADOW

Inner Shadow has options similar to those of the Drop Shadow effect but places a shadow within
the object or attribute rather than without. It has the effect of making objects and text appear cut
out of, or sunken into, the background. Like the Drop Shadow effect, Inner Shadow has a noise
percentage. It substitutes choke for spread, however, but the effect is the same, with opaque
shadow pushing inward to reduce the feathering in shadow edges.

OUTER GLOW

Prior to InDesign CS3, an outer glow effect had to be faked by using a colored drop shadow with
no offset and a generous blur and spread. Now there’s a dedicated outer glow effect. Blending
mode, opacity, color, size, noise, and spread work like they do in Drop Shadow and Inner Shadow
effects. The Technique field offers two options: Softer and Precise.

A softer outer glow spreads outward smoothly from the sides of a shape. Color does not
emanate from corners, which results in corner softening; the farther outward the glow is pushed
via the Size field, the softer the corners. Selecting the Precise option does use the corners, radiating
the glow outward equally from the total area of the shape. Thus, though the corners would neces-
sarily be somewhat rounded, even an extremely large outer glow on a square would look like a
square.

INNER GLOW

The Inner Glow effect pane is very much like the Outer Glow pane, with all the same options plus
one extra: Source. The glow is placed inside the object or attribute, and the Source field chooses
whether the glow shines inward from the edges or outward from the center.
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Note that Technique has the same Precise and Softer options it has with Outer Glow, but they
work a little differently. With Softer, the glow radiates evenly from (or to, depending on the Source
option) all sides and corners, leading to a soft, rounded glow deeper in the corners. Electing Pre-
cise, however, draws the glow from (or to) the sides without overlapping at the corners thus creat-
ing distinct rays of color (see Figure 6.6).

FIGURE 6.6

Both objects have
the same Inner Glow
effect, including a
source of Edge. On
the left, Technique
is set to Softer; on
the right, it’s set to
Precise.

BEVEL AND EMBOSS

Add depth to text and objects with bevel and emboss effects. Angle and Altitude control the
apparent depth of the three-dimensional effect, while Highlight and Shadow set the colors, opaci-
ties, and blending modes of the colors that reveal the dimensionality. Style choices are as follows
(refer to Figure 6.7):

¢ Inner Bevel to place the bevel within the confines of the shape or attribute

¢ Outer Bevel to grow the bevel outward without impinging upon the fill of the object or
attribute

¢ Emboss, which colors part of the object itself as well as the area outside the object to create
the effect of the shape rising up from, or sinking into, the page

¢ Pillow Emboss, which, as the name implies, re-creates the effect of stitching a pattern into a
satin pillow, where the stitch sinks into the page but the area within and without is raised

FIGURE 6.7

Styles, from left to

right: Inner Bevel,

Outer Bevel,

Emboss, and Pillow : i V—
Emboss.

The Direction drop-down menu determines whether the shape rises up in relief from or, like
intaglio, sinks down into the page.

SATIN
Satin creates a satiny sheen effect by infusing color into the shape from opposing corners and sides.

BASIC FEATHER

Replacing the rudimentary InDesign CS2 Feather effect are three new effects, with Basic Feather
being the first. This effect softens and fades out the edges of the object or attribute, allowing it to



TRANSPARENCY AND EFFECTS

taper into background objects. The options here are simple and sparse because the feather grows
inward uniformly from all edges softly. Choke, as in other effects, controls the spread of the non-
feathered area and its balance with the feathered edges.

DIRECTIONAL FEATHER

To sharpen the feather or to feather edges to different degrees, use the Directional Feather effect.
Feathering from the top, bottom, left, and right may be controlled together or individually by
depressing or releasing, respectively, the Make All Settings the Same chainlink icon between them.
The angle twirler sets the direction into which the feather radiates—the direction of fade between
the object and its background—and should be used in conjunction with the widths.

GRADIENT FEATHER

From the perspective of both creativity and, especially, productivity, the new Gradient Feather
effect is worth more than all the rest put together. Graduating a solid color into no color is a very,
very common task for many designers and layout artists. Prior to InDesign CS3, the only way to
create a solid- to no-color gradient was to fake it with a color-to-white blend. The white, of course,
was still fully opaque, making it impossible to allow background objects to shine through and
blend with the gradient. Blending modes could make some gradients mix well with some back-
grounds, but it was hit or miss. Most of the time, to get a gradient or any object to blend gradually
with objects behind required doing it in Photoshop with layer styles or in Illustrator with opacity
masks. No longer (see Figure 6.8).

FIGURE 6.8
Examples created
with the Gradient
Feather effect

The Gradient Feather works exactly like the Gradient panel. Instead of working with color
stops that blend one into the other, you're working with gradient stops, levels of opacity, that
blend into one another. A black stop is 100% opaque, a white 0% opaque. Click on a gradient
stop—or click on an empty area beneath the gradient ramp to add a new gradient stop—and then
set the opacity in the Opacity field. The object or attribute will respond by becoming more or less
opaque in the corresponding area.

Both linear and radial gradients are supported, with angles on the former just like a normal
color-to-color gradient. Additionally, the same manual control given to color-to-color gradients
via the Gradient tool on the Tools panel is offered through the new Gradient Feather tool accessed
by clicking and holding the Gradient tool in the Tools panel. Just like its counterpart, the Gradient
Feather tool determines the placement, compression, and angle of a gradient feather defined
through the Effects dialog. Where you click with the Gradient Feather tool is the start of the
feather, and after dragging, where you stop is the end of the feather.

More about Effects

When an object or one of its attributes has one or more effects applied, a special fx icon appears
beside the object or attribute on the Effects panel (see Figure 6.9).
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MOVING AND REPLICATING EFFECTS

Given the fact that effects are attribute level, it’s a common mistake to apply an effect to, say, the
fill when you meant to apply it to the entire object as a whole. Rather than undoing all your work
in the Effects dialog and trying to re-create it for the correct target, simply change the target of the
effect. Click on the fx icon beside the attribute in the Effects panel, and drag it atop a different
attribute. For example, if you applied effects to the fill but they were intended for, or you'd like
to them applied to, the whole object, drag the fx from beside Fill, and drop it beside Object. Done.
The effects will move from one to the other.

To copy the effect to another attribute without removing it from the first, hold Cmd+Opt+Shift/
Ctrl+Alt+Shift before selecting the fx icon. Then, upon dragging, you'll see a hand cursor with a plus
sign in it indicating that the effects will be copied and not moved.

Now, to copy the same effect to a completely different object, it’s very much the same. Select the
object with the effects—the source object—and drag the fx icon from beside that object’s attribute
entry on the Effects panel. Drop the icon directly atop the target object. It will apply the same effect,
to the same attribute, meaning that if you drag a Stroke effect from the source object, it will be a
Stroke effect in the target object. This is for ad hoc effects replication or for use between objects
whose other characteristics vary. The easiest way to apply the same effects to multiple objects is
to create an object style, which we’ll discuss in the Chapter 11, “Efficiency.”

Effects can be removed in several ways, the easiest two of which are to drag the fx icon to the
trashcan icon at the bottom of the panel and to select the attribute on the Effects panel and choose
Clear Effects from that panel flyout menu.

GLOBAL LIGHT

Effects like shadows, glows, beveling and embossing, and so on are lighting effects. They’re meant
to bring the illusion of three-dimensionality to a two-dimensional medium by faking the effects of
light cast on volumetric objects floating in 3D space. The illusion only works if the effects follow
the basic logic of consistent light sources. In other words, if your drop and inner shadows are
being cast about in different directions, if they don’t line up with the highlighted and shadowed
surfaces of your bevels, you can’t sell the illusion. The viewer will be yanked out of the perception
of 3D space into the reality of flat ink on flat paper.

If your design has—or should have—multiple light-directed effects, determine where the light
source is relative to the document and the objects. Decide in your mind where you are placing the
imaginary light bulb that illuminates your objects and casts those shadows and reflects in those
highlights. Once you see in your mind’s eye the light bulb dangling in place near the document,
tell InDesign where you've hung it by selecting Global Light from the Effects panel’s flyout menu
(see Figure 6.10).

The Global Light dialog has but two options—Angle and Altitude—with one informing the
document lighting effects’ direction and the other the intensity of the light. It’s always the same
wattage bulb, but its effect on the document becomes more intense as the altitude decreases. Both
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fields accept typed-in numeric values in degrees, but a more intuitive way to alter both is to drag
the light source crosshair in the dial. Dragging it around the dial changes the angle, and drag-
ging the crosshair toward or away from the center dot alters the altitude, descending or ascending
respectively. If you've already created effects on objects, and if, in the individual options for those
effects, you checked the Use Global Light option, then changes made in the Global Light dialog
will alter effects while you watch (turn on Preview, of course).

FIGURE 6.10
The Global Light Angle: [27° |
dialog

Using effects with a global light has a slight drawback: uniformity. True, uniformity is key to
maintaining the illusion of dimensionality, but being too uniform will ruin it just as quickly as not
being uniform enough. It’s a delicate balance. The problem with global light is that it sets all light-
directed effects to use exactly the same angle and altitude.

Let’s say you've got a row of blocks. (I don’t know why you’d have a row of blocks. It’s just an
example.) Let’s also say that you’ve decided your light source hangs just a little lower than the
top-left corner of the first block at around 35 to 45 degrees altitude. In reality, the closer an object is
to a light source shining on it, the more severe the highlighting and the sharper and shallower the
shadows cast by the object. As objects move away from the light source, highlighting becomes less
intense and shadows lengthen while their edges diffuse. This is true whether the light is pointed
straight down to form a circular light area or angled to form conical light. Unfortunately, InDesign’s
understanding of lighting is very simple—and I mean beyond the facts that there’s only one possi-
ble light source and no way to way to shape the light. Distance from the light source is not among

the factors considered by InDesign when it’s creating light-directed effects. In fact, InDesign con-
siders every object to have its own companion light source; the global light is just aligning all the
objects” individual light sources to the same location relative to each object. The object farthest
from the light source you imagine will be influenced exactly the same by the global light source,
with identical effect angles and intensities, as the object closest to your imagined light source. Take
a gander at Figure 6.11 to see what I mean. Notice how the highlights and shadows of the objects
on the left are identical despite logic dictating that they should all vary dependent upon their dis-
tance from, and angle in relation to, the light source on the left. Which of the two sets looks more

realistic?

FIGURE6.11
InDesign’s Global
Light creates light-
directed effects that
are unrealistically
uniform. An
InDesign-created set
of drop shadows
(left) versus a set
manually tweaked
to reflect real-world
perceptions (right).
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The advantage to using the document’s global light settings to inform effects is simple to grasp:
every such effect, on every object or attribute to which it has been applied, can be altered document-
wide from the single location of the Global Light dialog. With global light, efficiency and produc-
tivity are a trade-off with realism and accuracy. Efficiency is a powerful motivator, and I'm not
implying otherwise—you know how much I value creative efficiency—but if you want realism, if
you really want to sell the illusion of dimensionality, don’t rely on the document global light. Use
it, certainly, but deviate when logic or the laws of physics dictate.

As you saw in the right image in Figure 6.11, realism dictates that light-directed effects adjust
their angle, length, and depth in correspondence with the objects” position and distance in relation
to the light source. With objects closer to the top-left page light source, I shortened and sharpened
their shadows, gradually lengthening and softening the edges on other object shadows as they
moved away from the light. Moreover, objects that were not directly in line with the light source—
such as the bottom-left and top-right corners—required that the shadows rotate. How? Simple: I
drew imaginary lines (light rays) from the light source to the corners of the objects. Shadows don’t
cast toward a light source, so if the light struck a particular side, I pushed the shadow away from
that edge, casting it off the opposing side.

I started with a global light but tweaked the settings per block to create a realistic environment.
The rest was basic geometry and a lifetime of familiarity with Thomas Edison’s invention. I'd use
the same method to determine the location of highlights and shadows on beveled or embossed
objects.

Creating realism is time-consuming, of course. Anyone who has ever watched a “Making Of”
DVD featurette knows that. When you're making changes to objects with realistic characteristics, it
can take even longer to maintain or adapt the reality to the changes, so quality becomes a trade-off
with speed. I won’t presume to tell you where to draw that line, when to set a document global
light and be done with it and when to start tweaking angle spinners and Spread fields. Some jobs
demand speed and “good enough” quality, others the extra mile even with the extra time it will
take to run that far.

Strokes

“If you're in the game, then the stroke’s the word.” If you've used InDesign or any layout or illus-
tration application for more than a few minutes, you’ve got the basics of strokes and the Stroke
panel. Let’s talk about those things that you may not have heard, the things about which I often
get questions from experienced InDesign users. Figure 6.12 is the Stroke panel with options shown
(from the flyout menu). With a tip of the hat to Billy Squier, let’s briefly go through each section.
Don’t take no rhythm; don’t take no style.

Weight The stroke thickness, expressed in whole or partial points (e.g., 1 pt or .333 pt).

Cap When open paths terminate (as opposed to a closed path like a circle that has neither a
start nor an end), how should their ends look? That’s the question posed by these three unas-
suming buttons. Your options are Butt Cap, Round Cap, and Projecting Cap, and their resulting
effects on paths are exactly what the buttons depict.
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Miter Limit When a path makes a corner, InDesign has to decide what to do with the stroke on
the outside of the turn. It must consider whether the stroke color should keep going in the same
direction until it reaches a point, even if that’s a great distance off, or if the stroke should be
clipped somewhere before it reaches a point. The Miter Limit field sets the clipping boundary;
when a stroke reaches that limit, InDesign will cut down the path (see Figure 6.13).

FIGURE 6.13

A sharp corner
results inalong
spike in the stroke
(left), and a miter
limit clips the stroke
(right).

Many people think the Miter Limit field is measured in points. It’s not. It’s in multiples of the
stroke weight. Thus the default miter limit of 4 is four times the stroke weight; a 1 pt stroke
weight begets a 4 pt miter limit. Using defaults, InDesign will clip the stroke with the join type
option if the stroke reaches or extends beyond 4 pts long. If you're getting too many mitered
corners when you want sharp, up the miter limit.

Join Join is the shape of corners in paths, either Miter Join (sharp, single angle), Round Join, or
Beveled Join.

Align Stroke These three buttons determine where the stroke falls relative to the path. Paths
themselves have no thickness—they’re just the connections drawn between to points plotted
on the x and y axes. Because they have no thickness, the stroke must align somehow to the
path. As you can see in Figure 6.14, where that is has a great effect on the results. You can choose
Align Stroke to Center, straddling the path such that a 20 pt stroke puts 10 pts inside and 10 pts
outside the path; Align Stroke to Outside, putting the entire stroke outside the path and thus
keeping the fill color, image, or text unimpinged upon; or Align Stroke to Inside, putting the
entire stroke inside the path to encroach upon and perhaps obscure part of the shape fill.

FIGURE 6.14

Left to right: stroke
aligned to center,
outside, and inside
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Type The Type menu contains the different styles of stroke available, including a single solid
stroke, picture-frame-like multiple-line strokes, and several varieties of broken strokes—these
last will get more interesting in three more paragraphs.

Start and End Need an arrowhead or other stroke adornment? Although not as robust as Illus-
trator or other drawing and flowcharting software, InDesign can do basic flowcharting and
diagramming arrows. The start is the first anchor point you created in drawing your path, and
the end the last. A little-known feature is the ability to reverse the direction of arrows without a
return to the Stroke panel—to do it, if you choose, with a keyboard command.

Let’s say you have a straight line path drawn left to right to which you've applied a start of an
arrow and an end of a circle. The arrow, therefore, is on the left and the circle the right. If you
need it the opposite way, you can go back to the Stroke panel; you can also flip the path or
rotate it, but that becomes problematic if the path is already at an angle. Instead, select Object >
Paths > Reverse Path. The direction of the path will be reversed, just as if you drew it right to
left, and the start and end will transpose without altering the position or rotation of the path
itself. If you need to do that frequently, assign a keyboard shortcut to the Reverse Path com-
mand in Edit > Keyboard Shortcuts.

Gap Color and Gap Tint When you choose any stroke type other than Solid, Gap Color lights
up. The gap is the space between multiline, dashed, dotted, slashed, or other broken stroke
types. In addition to coloring the positive parts of the stroke, the Gap Color drop-down allows
you to select a swatch to color the negative spaces between. Once a gap color is chosen, Gap
Tint activates to fine-tune the gap color. In other words, if you want effects like those in Fig-
ure 6.15, you don’t have to overlay multiple objects.
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Custom Stroke Styles

When you select Dashed, the last option in the Type menu, additional fields appear at the bottom
of the Stroke panel (see Figure 6.16) to define a custom dashed stroke. Using points or any meas-
urement system InDesign understands, enter dash and/or gap widths (as many as three pair) for
exactly the dashed stroke you need. Above the Dash and Gap fields, choose how the dashed stroke
handles corners to (try to) avoid weird bunching of, or gapping in, dashes.
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When the Dash and Gap fields don’t offer enough control, or to create a stroke comprising
something other than rectangular dashes, select Stroke Styles from the panel flyout menu. You'll
see listed there the multiline stroke styles. Click the New button to open the New Stroke Style dia-
log and build your own stroke style (see Figure 6.17).

FIGURE 6.17 New Stroke Style
The Neyv Stroke oot [T
Style dialog
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Praview

Preview Weight: E 5 .

Changing the Type field sets the tone for the stroke and the rest of the options.

Dash Figure 6.17 shows the version of the New Stroke Style dialog that occurs when you
choose the Dash type. Within the horizontal ruler you draw the dashes as black block; negative
spaces between the blocks are gaps that will appear in the stroke. At the bottom of the dialog,
the preview keeps your stroke in perspective, at the weight you choose in the bottom field.

To draw a new dash segment, simply click in an empty space in the ruler section—either within
the ruler itself or in the drawing area below it. Once a dash segment is begun, the arrows above
it, within the ruler, can be dragged to resize the dash. You can also use the Start and Length
fields for precision sizing. If the pattern is too short or long at its default one-third inch, change
the Pattern Length field. Even if the pattern is a good length at its default, you may want to

adjust it to take up any excess empty space at the end of the pattern, which will become a gap
before the pattern repeats.

Note the presence of Cap and Corners adjustments to precisely control the ends of dashed
strokes and how dashes behavior at angles.
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A custom stroke must begin with a dash (or dot or stripe); it cannot begin with a gap. Addition-
ally, each stroke is limited to five dash segments. If you genuinely need something more com-
plicated than five dash segments, use Illustrator to create and apply the custom stroke as a new
brush style, and then copy the stroked object into InDesign as a vector path.

When you're happy with your new custom stroke style, give it a name at the top, and then click
either OK, to save the style and close the New Stroke Style dialog, or Add, which also saves the
style but leaves the dialog open and ready to create additional styles.

Dotted Of the two default dotted stroke styles—Dotted and Japanese Dots—many designers
prefer to use the latter because of its narrower gaps between dots (see Figure 6.18). Tightly
spaced dots are more aesthetically pleasing when used as, for example, text separators in hori-
zontal paragraph rules and vertical drop rules and cell borders in tables.

FIGURE 6.18 ® & & & ¢ o & o o o o 0o 0o o 0o o
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(lower)

Personally, I often find even the Japanese Dots style a little loose for my tastes—particularly
when using a 25 to 50% black dotted stroke close to text. Other times, say, with a custom two-
color frame border, Dotted is spaced too tight. Choosing the Dotted style from the Type menu
opens a horizontal ruler similar to the one offered for new Dash type strokes, but there are no
lengths; just click within the ruler to place a dot, and click and drag on a dot to reposition it.
The Center field aligns the center point of the dot to a place on the ruler.

Stripes Multiple line strokes like Thick-Thick, Thick-Thin-Thick, and so on are Stripe types.
Choosing Stripe from the Type menu activates unique fields and a vertical ruler (see Figure 6.19).
Click and drag to draw a stripe. Rather than absolute placements within a fixed-width pattern,
stripes are set in the style based on percentage of height. For example, a stripe of 10% will be

1 ptin a 10 pt stroke or 10 pt in a 100 pt stroke.

FIGURE 6.19 New Stroke Style
Drawing a Stripe
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Your new stroke styles will be available from the Type menu on the Stroke panel and also
from anywhere stroke styles are selected—paragraph rules dialogs, underline and strikethrough
options, and more. Through the Stroke Styles dialog, they can also be saved to, and loaded from,
disk for sharing with colleagues.

Swatches

Wait! Don’t skip ahead! I'm not going to waste your time with a Swatches panel walk-through or
by explaining how to use and create swatches. Plenty of InDesign 101-style books will tell you
about that, and if you're reading this book, you’ve long since graduated from InDesign 101. This
section isn’t about the basics of working with swatches. In the first half of this course we’ll discuss
advanced swatch work like mixed ink swatches and mixed ink groups, and then we’ll talk about
sharing and working efficiently with swatches—some of which is new to InDesign CS3.

I expect everyone to be prepared at the start of each section with a sharpened No. 2 pencil, a
three-ring binder, and InDesign CS3 opened on your computer.

Mixed Inks

Mixed ink colors are the result of mixing one or more spot colors with process inks or of mixing
two spot colors. You may know of them under another name: tint build or multi-ink colors; the
latter is what QuarkXPress calls them. Mixing inks allows you to coax a larger selection of colors
and tints from a minimum of inks (read more creativity, lower production cost).

CREATING MIXED INK SWATCHES

If, after reading the preceding paragraph, you're feeling as confused as a Bush administration
Supreme Court nominee, don’t throw in the towel just yet. The best way to understand mixed inks
is to make a mixed ink, so let’s do that.

1. Mixed inks must contain at least one spot color, and that spot color must already be on the
Swatches panel. The first step, therefore, is to make a spot color swatch.

From the Swatches panel flyout menu, select New Color Swatch. In the resulting dialog, set
Color Type to Spot, and from Color Mode, choose any spot color library like PANTONE
Solid Coated. When the colors load, pick one and click OK.

2. Now that you have a spot color swatch created, the New Mixed Ink Swatch command will
be selectable from the Swatches panel menu. Choose it and up will pop the New Mixed Ink
Swatch dialog (see Figure 6.20).

FIGURE 6.20 New Mixed Ink Swatch
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3. Click in the empty box to the left of the spot color you just created to start, and then choose
one of the process inks to mix in. Beside each ink name is the ink’s tint ramp and a tint per-
centage field. Try dragging the tint sliders while watching the preview swatch on the left.
Notice the new colors created by combining the two inks? Depending on the spot you
chose, chances are good that some of the colors you can mix up with only two inks would
have otherwise required additional spots to print. That would be more plates (read addi-
tional RIP time and film charges) and more inks (read more cycles through the press and additional
per-ink setup charges).

4. Once you have a new color you like (keeping in mind that what you see on screen may not
be accurate), give it a name more explanatory than the default Mixed Ink 1; then click OK to
save the swatch and close the dialog or Add to save the swatch and leave the dialog open
ready to create more mixed ink swatches. Of course, you can use more than two inks as
long as at least one is a spot color.

CREATING MIXED INK GROUPS

The only real drawback to creating a mixed ink according to the above procedure is the tedium of
it, the need to manually comming]le the inks to create a new mixed ink swatch. If you wanted to,
say, get all possible combinations of two inks in 10% increments of both tints, you’d have to manu-
ally create all those new swatches by changing percentages and then clicking Add. That isn’t par-
ticularly difficult, just tedious. Wouldn't it be great if InDesign found all the possible combinations
for you? That’s exactly what mixed ink groups do.

Select New Mixed Ink Group from the Swatches panel flyout menu to open the dialog shown
in Figure 6.21. As with the New Mixed Ink Swatch dialog, add an ink to the mix by clicking in the
blank space at the left. Now, instead of specifying a tint percentage to make the mix, set a range of
tint percentages and let InDesign create each individual mix and swatch. Let’s do it, starting from
an opened New Mixed Ink Group dialog.

1. In the Initial column, set the starting tint percentage for each ink. For this exercise we want
to add varying stages of black to the spot color, so set the initial tint of the spot to 100% and
Process Black to 5%, the lowest desired mix value. The first mixed ink swatch will have
these initial tints and will grow from there toward greater tint percentages. Because the spot
begins at 100%, only black’s contribution will increase while the spot remains constant at
full ink density.

2. Repeat is the number of color steps, the number of swatches to create, starting at the initial
value. Because we want to add black in 5% increments up to 100% black plus 100% spot, set
the Increment field to 5% and the Repeat field to 19 (100% divided by 5% equals 20 steps
minus the initial 5% step). The spot will stay constant at 100%, thus its Repeat field should
be 0, disabling the Increment field as well.

3. Notice that below the ink selection area is a running count of the number of swatches to be
created. Each ink you add, each repeat value, increases that number exponentially. Always
check the count before hitting OK to make sure a typo or incorrect value hasn’t set you up
to generate too many swatches.
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4. Click the Preview Swatches button to see the results of the mixed ink group without com-
mitting them to the document’s Swatches panel. Swatch names are determined by the
Name field at the top of the dialog, with Swatch X appended. If the swatches meet with
your approval, click OK and watch the Swatches panel populate.

In addition to the various Swatch X mixed ink swatches (identified by the double ink droplet
icons), you'll have a mixed ink group swatch (see Figure 6.22). You see, all those swatches you just
made are still a dynamic part of the mixed ink group—change the group, change all the swatches.

FIGURE 6.22
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You can change individual swatches, to adjust the mix percentages for example, or to convert
the group swatch into a standard spot or process swatch. But, to change the colors in all the
swatches in the group—for instance, to replace one spot or process color with another across all
the grouped mixed inks—edit the group, not the swatch. Instead of editing the swatch, double-
click the mixed ink group swatch itself (hold Cmd+Opt+Shift/Ctrl+Alt+Shift while double-
clicking to edit without applying the swatch to the selected object and without making it the
default for new objects). That will get you to the Mixed Ink Group Options dialog (see Fig-
ure 6.23), where you can rename the group, convert mixed ink swatches to process colors (note
that this is irreversible), and disable or replace one or more inks in the mix (note that you must
always have at least two colors in the mix, and at least one must be a spot). When you click OK,
all the swatches in the group will update to reflect the changes.

185
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FIGURE 6.23 Mixed Ink Group Options
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If all you want to do is replace a color in a mixed ink group, there’s an even faster way. When, on
the Swatches panel, you delete a normal spot or process swatch used in a mixed ink or mixed ink
group, InDesign will ask you to choose a color with which to replace the one you're deleting. Your
choice will update all mixed ink and mixed ink group swatches that included the replaced color.

Managing Swatches

I'm sure you already know that you can drag and drop swatches in the Swatches panel list to
reorder them, just as I'm sure you're perfectly aware that you can rename swatches by editing
them (Cmd+Opt+Shift+double-click / Ctrl+Alt+Shift+double-click). There are some other things—
particularly things new to CS3—that you may not know, however.

SELECT ALL UNUSED

This command on the Swatches panel flyout menu selects all swatches that aren’t currently used
by some object in the document. Once theyre selected, just click the trashcan icon at the bottom

of the panel to delete all unused swatches in fell swoop. Leaving unused swatches in a document
has no practical effect—you won't, for instance, get extra plates during separation just for having
swatches in the panel. It is a usability issue and productivity issue, however. It’s just easier to work
with a Swatches panel uncluttered by the extraneous results of past experiments.

ADD UNNAMED SWATCHES

Add Unnamed Swatches is kind of the opposite of Select All Unused. In the course of designing,
we don’t always create swatches for every color we mix on the Colors panel and elsewhere. Often,
colors are created on page 2 and forgotten about by page 6; when page 8 rolls around again, the
color is created again ad hoc with hopefully the same mix as other instances. Selecting Add Unnamed
Swatches from the Swatches panel flyout menu creates swatches for all in-use colors in the docu-
ment that don’t already have swatches. It also associates the source objects with the swatches,
making color replacement as easy as deleting the swatch and choosing a substitute.

MERGE SWATCHES

In the Swatches panel, select any two or more swatches, and then choose Merge Swatches from the
panel menu. What happens is not really a merge—you won't get green by using the command on
blue and yellow swatches. Instead, it's more of a replacement.

Let’s say you have three color swatches—red, blue, and yellow—all in use as the fill colors for
different objects. Selecting them in the Swatches panel in order—clicking first on red, then blue,
and finally on yellow—and executing the Merge Swatches command will simultaneously delete
the blue and yellow swatches and fill all blue and yellow objects with red. The first swatch you
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click on, regardless of its actual order in the list, becomes the surviving replacement color. Merge
Swatches is a handy way to replace colors with a minimum of fuss—particularly for those of you
who are cleaning up someone else’s document in preflight.

UNDELETABLE SWATCHES

A very common frustration is ending up with swatches that you can’t find in use anywhere and
can’t be deleted no matter what you try. This problem is nearly always caused by a color embed-
ded in a placed asset—particularly vector assets. See the sidebar “Finding the Unfindable Swatch,
Deleting the Undeletable Swatch” for a real-world strategy to deal with this problem.

@ Real World Scenario

FINDING THE UNFINDABLE SWATCH, DELETING THE UNDELETABLE SWATCH

Most often, a swatch that cannot be deleted in InDesign is actually contained within a placed EPS, PDF,
Al or otherimage asset. InDesign can place and modify such assets within the context of the instance on
the page, but it cannot edit the asset itself, cannot change the EPS, PDF, Al or what have you. Therefore,
InDesign can’t delete or alter swatches that may be in the asset. Worse, you often can’t even find where
the color is used. Often this happens because the path carrying the offending color is hidden behind other
paths and, even more common, there is no path, just a single anchor point.

In vector drawing, a single anchor point is considered an object just as surely as a complex path. As an
object, the anchor point may have a fill and/ or stroke color assigned to it even though there isn’t a path
to make either fill or stroke visible. One errant click of the mouse in Illustrator or another program can cre-
ate an orphaned anchor point, and thus an orphaned color instance, resulting in an undeletable color
swatch in InDesign. Because these orphaned anchor points are invisible, they’re also often impossible to
find—unless you know to look for them and how to look.

FIND THE IMAGE
First, in InDesign, identify the image that is the source of the undeletable color swatch.
1. Save a copy of the document—never perform troubleshooting on the original.

2. Remove all unused swatches from the Swatches panel to narrow the possibilities and make
cleanup easier.

3. Go back to the first page of your document containing placed assets, and select and delete all
placed assets. Select all unused swatches again with the appropriate Swatches panel command.
Is the ostensibly undeletable swatch among those highlighted as unused? If not, move on to page
2, deleting all placed assets and then selecting all unused swatches. Keep repeating this seek-and-
destroy process until the swatch does get selected by the Select All Unused command, and then
move on to step 4.

4. Whenremoving all objects and then selecting unused swatches causes the undeletable swatch to
be flagged as not in use, you will have found the page containing the swatch. The next step is
to narrow that down to the exact image. So, press Cmd+Z/Ctrl+Z to undo the deletion of all of
the page’s objects, and then, one at a time, delete each placed asset object and choose Select All
Unused from the Swatches panel flyout menu. Eventually, the undeletable swatch will be among
the selected, identifying the exact image that contains it.
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5.
6.

Press Cmd+Z/Ctrl+Z again to restore the image you just deleted, and keep it selected.

On the Links panel (Window > Links), the asset will also be highlighted. Click the Edit Original
button at the bottom of the Links panel, the button that looks like a pencil, which will open the
application registered on your system to edit such imagery—Illustrator for vector or Photoshop for
raster, for example.

Note: If the undeletable swatch is not contained within a linked asset, if it’s instead within objects or
imagery that were pasted into InDesign, the Links panel will not help you. Instead, copy the asset and
paste it back into the application that created it. Make the necessary changes, and then copy and paste
backinto InDesign.

IF THE EDIT ORIGINAL COMMAND OPENS PHOTOSHOP...

1.

Open the Channels panel in Photoshop (Window > Channels). RGB, Lab, and process colors cre-
ated in Photoshop do not generate swatches upon import of the image to InDesign. Only spot col-
ors, created on separate channels, create InDesign swatches. Therefore, your undeletable swatch
will be a separate channel beneath the Red, Green, and Blue channels or Cyan, Magenta, Yellow,
and Black channels. That channel’s name will be the same as the title of the InDesign swatch.

Turn off all channels except the offending spot color channel by clicking the eyeball icon beside
each of the other channels. When only the spot color channel is visible, its contents will render
onscreen in black rather than in the actual color.

Examine the image data there. Do you need it? Should it remain a spot color, generating a new
plate upon separation output from InDesign or the RIP? If your answer is yes, close everything
and go back to your original InDesign document to keep working. If no, if you don’t want the spot
color, decide whether you want that image data at all.

To keep the image data but convert the spot color into the nearest equivalent mix of process
inks (or RGB), highlight the spot channel and choose Merge Spot Channel from the Channels
panel flyout menu. The image data on the spot channel will become part of the CMYK or RGB
channels, approximating the original spot color as closely as those color models allow. Note
that Merge Spot Channel is not available for images in Lab mode. If your image is in Lab mode,
you’ll need to first convert it to RGB or CMYK with the appropriate command on the Image >
Image Mode menu.

If you decide you don’t want the spot color or the image data on the channel, select the spot chan-
nel and drag and drop it atop the trashcan icon at the bottom of the Channels panel.

Save the document and close Photoshop. Because you used InDesign’s Edit Original command,
InDesign will automatically update the placed asset without further action required. When you re-
open your original document, of course, you’ll be prompted to update the image with a single
button click. In both the original and temporary troubleshooting copy, the formerly undeletable
swatch should now be deletable.
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IF THE EDIT ORIGINAL COMMAND OPENS ILLUSTRATOR...

1. Illustrator is much more like InDesign than like Photoshop in terms of color handling and
swatches. You won’t find a Channels panel, for instance. Instead, you’ll need to locate the path or
anchor point containing the unwanted spot color swatch.

On Illustrator’s Swatches panel you’ll find the offending swatch (hint: spot color swatches appear with a
black dot inside a white triangle in their lower-right corners). With no objects selected, choose from the
Swatches panel the spot color swatch of which you want to rid yourself.

2. Go to Select > Same > Fill Color. Illustrator will then select any and all paths (and orphaned
anchor points) filled with that color. If nothing was selected, move on to step 3; otherwise, skip
down to step 4.

3. Iftrying to select objects with the offending swatch as their fill produced no results, then it isn’t
being used as a fill color. Try looking for it as a stroke color with Select > Same > Stroke Color.

4. Examine what was selected and decide whether to delete or recolor it.

& Ifyoudecide that you don’t need the selected items, press the Delete key on your keyboard. Poof!
Problem solved.

& However, if you decide you do want the selected paths, you just don’t want them to use a spot
color ink, convert the spot color to CMYK or RGB. Double-click the swatch in the Swatches panel
and, in the Swatch Options dialog, change Color Mode to CMYK or RGB and then the Color Type
field to Process Color.

Note: Even if you did get hits on the fill color, it’s a good idea to go back and look for any paths with that
stroke color as well.

5. Save the document and close Illustrator. Because you used InDesign’s Edit Original command,
InDesign will automatically update the placed asset without further action required. When you re-
open your original document, of course, you’ll be prompted to update the image with a single
button click. In both the original and temporary troubleshooting copy, the formerly undeletable
swatch should now be deletable.

Note: Illustrator artwork can contain both embedded and linked raster images and even other vector art
files. It’s entirely possible to have a Russian doll of images—one image placed into another, which is
placed into another, and another, and so on. If you determine that the unwanted swatch is within a linked
asset rather than the Illustrator document itself, use the Edit Original command on Illustrator’s identical
Links panel, and then follow the same procedures above for whichever application opens.

IF THE EDIT ORIGINAL COMMAND OPENS ANOTHER APPLICATION...

Most raster image editors will conform at least loosely to the Photoshop directions, and most vector draw-
ing applications to the Illustrator. Use those as guides within the unique environments and user interfaces
of whichever applications you employ to edit raster and vector artwork.
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Other times, swatches are rendered undeletable because of file corruption, which is regret-
tably very common with documents converted from QuarkXPress, PageMaker, or even earlier
versions of InDesign. The best way to counter file corruption is to force a complete rewrite of
the document code.

1. Choose File > Export and save a copy of the document as an InDesign Interchange INX
file—a special, pure XML copy of the document.

2. Close the original INDD document, and open the INX version.

3. Choose File > Save As and save the document back to a normal INDD InDesign
Document.

4. Try deleting the offending swatch.

Of course, the four magic swatches whose names are bracketed—None, Paper, Black, and
Registration—can never be deleted by design.
Speaking of swatch issues upon converting documents from QuarkXPress...

SWATCHES FROM QUARKXPRESS

When opening a QuarkXPress version 3.3 to 4.1 document in InDesign, swatches convert faith-
fully, with a few notable exceptions.

White QuarkXPress doesn’t have a swatch named Paper. Instead, it has White. Upon convert-
ing the XPress document to InDesign, you'll often have both Paper and White. In theory, leaving
the White swatch in use shouldn’t hurt; in practice, though, it has been known to confuse some
RIPs. The solution is simple: Delete the White swatch. If it’s in use as a fill or stroke color,
InDesign will prompt for a swatch with which to replace it. Choose Paper.

Multi-Ink Colors to Mixed Ink Colors The two are nearly identical with one difference:
QuarkXPress allows multi-ink colors without the inclusion of a spot color while InDesign’s
mixed ink color require a spot. Multi-inks with a spot will convert just fine into mixed inks.
Multi-inks without a spot will become standard process color swatches.

Color Library Colors Colors from QuarkXPress’s color library are converted to process
swatches based on their CMYK values.

HSB and Lab Colors QuarkXPress HSB and Lab colors are converted to RGB colors in
InDesign.

Sharing Swatches

The ability to share swatches—between documents, between applications—makes for fewer trees
sacrificed to scribbling down color formulas. Whether it was eco-conscience or a desire to shave
just a little more time and effort off designers’ project work, Adobe has made accessing and shar-
ing color swatches between applications easier and more accurate with each new release of the
Creative Suite. CS3 is no exception.

IMPORTING SWATCHES FROM OTHER DOCUMENTS

On the flyout menu of the Swatches panel, the Load Swatches command enables importing
swatches from any preexisting InDesign document or template. Just choose the command, select
the document, and click Open; all that document’s color swatches will import to the current
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document. You can import swatches from InDesign INDD documents and INDT templates, Illus-
trator AI and EPS files, and Adobe Swatch Exchange ASE files.

If you want to import swatches from other documents selectively instead of all at once, follow
this procedure:

1. Choose New Color Swatch from the Swatches panel flyout menu.

2. In the New Color Swatch dialog, select the last option in the Color Mode drop-down, Other
Library. A file dialog will appear.

3. Choose from the Open a File dialog any of the file types InDesign supports for swatch
import—INDD, INDT, Al, EPS, or ASE—and click OK. The swatches in the chosen docu-
ment will appear in the swatch list of the New Color Swatch dialog.

4. Choose the swatch to import, and click OK or Add.

MAKING NEW DEFAULT SWATCHES

If you work in an in-house design, production, or press services department, or if for some other
reason you find yourself regularly working with the same colors, the Load Swatches command
can make your brand identity colors the defaults for all new documents. Open InDesign without
opening documents, and load up swatches from a previous document. They will populate the
Swatches panel (delete any you don’t regularly need). Close InDesign to commit the changes, and
then, in every future session of InDesign, every new document you create will automatically have
your corporate colors ready and waiting on the Swatches panel.

SHARING SWATCHES WITH OTHER APPLICATIONS

In Creative Suite 2, Illustrator CS2 was able to generate a new type of swatch file, an Adobe
Swatch Exchange file. The ASE file could be imported by Photoshop, GoLive, and InDesign, but
only Illustrator could create it. Creative Suite 3 corrects this horrendous inequity by allowing any
of the quartet to export its native swatches to Adobe Swatch Exchange, the swatches can then be
brought into the others with the Load Swatches or New Color Swatch (and counterpart) com-
mand. Just choose Save Swatches from the Swatches panel flyout menu and save the ASE file
somewhere where the rest of the Creative Suite applications can find it.

Using ASE files is a great way to ensure consistency between original art—from raster to vector,
print layout to Web layout—and even for the future. What I mean by that is this: I recommend to
my freelance and agency clients that deal with multiple clients (and multiple brand color sets) that
they create an ASE file for every client and multiple-document project as part of the initial job
setup. Either the production manager or one assigned creative generates the necessary swatches
from the client specs, creates the ASE, and makes it part of the core project files alongside other
core files like the client’s logo, signature fonts, and so on. After the initial work is completed,
when follow-up jobs come in for the same client, any member of the design team can import the
swatches from the ASE and get right to work without having to dig through other document
Swatches palettes to identify which are the brand identity colors and which are only specific to a
particular document or project.

VIEWING SWATCHES—WITHOUT OPENING OR IMPORTING
I have to say, as simple a thing as it is, the ability to view a document’s colors in Adobe Bridge—
without opening the document—struck me as among the best new features of Creative Suite 3.
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If all you want to do is see which colors a document uses or grab a couple of color formulas,
there’s no longer any need to load the creating application and open the document, or even import
swatches.

You're probably managing your digital assets in Bridge anyway, so just select the desired docu-
ment and look to the Metadata panel on the left (see Figure 6.24). Among the expandable sections
are Plates (not for INDD files), which shows all the process and spot inks in use, and Document
Swatches, which displays all swatches saved in the document—including unused swatches, so be
sure to clean those up before closing the document. Because the default name of custom swatches
is the formula (e.g., C=66 M=69 Y=0 K=0), you don’t have to open the document to obtain a cus-
tom color formula. Nice, huh?

FIGURE 6.24

The vastly improved
Metadata panel in
Adobe Bridge shows
the selected docu-
ment ink plates and
document color
swatches.

Anchored Objects

Adobe calls graphics and other objects that maintain their position relative to a place in the text
regardless of where that text flows anchored objects. I call them tethered objects. After all, anchoring
something is to stop it from moving. Anchored objects move—they follow the text describing
them, jumping pages all by themselves if the text to which they’re attached jumps to other pages.
That's the behavior of a tethered object, not an anchored. Regardless of the semantics, anchored
objects, introduced in InDesign CS2 (lifted, incidentally, from FrameMaker), is one of the most
timesaving features ever added to a layout application.

Here’s a scenario: Imagine a typical business report—Ilet’s say an annual shareholder’s report.
The majority of the document is a single story, flowing from page to page to page. At various
points in the main narrative, copious photographs, charts, graphs, and maybe some pullquotes are
required to support the main text. In the typical workflow, these supportive materials (for simplic-
ity’s sake let’s refer to them collectively as images) are placed into the document independent of
the text frame, maybe floating out in the margins, maybe over the text itself and with a text wrap.
Somewhere in the text are references to most images—e.g., See Chart 16—to give them context. If
editorial or style changes force text to reflow, moving image references to different pages, the lay-
out artist must manually go back and, one at a time, move the images as well. If a major reflow
change occurs early in the document—say, page 5 of 350 pages—that artist is looking at days of
doing nothing but repositioning images to follow their references.
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That’s a huge commitment of valuable creative and production time. Anchored objects reclaims
that time, turning the act of repositioning 345 pages of images from days of tedious work into min-
utes of minor cleanup.

You see, instead of letting images float free in frames disconnected from the main story, images
can be tethered to a specific place in the text with an invisible marker character called an anchor.
That anchor is fixed in the text after this word or before that character, and it behaves like any other
character albeit invisibly. When text reflows, the anchor marker flows with it, dragging the image
frame (or additional text frame) along. Anchored objects will always appear on the same page as
the text that describes them (if you choose; you can also make them appear on the opposite page).
InDesign will move them for you as the text moves. You can even force them to jump from the left
to the right page and vice versa, changing position relative to the spine and page edge, if the
anchor marker flows to the other side of the spread.

Anchoring Your First Object
Let’s go hands-on, anchoring an object to text together.

If you're already comfortable with threading text frames, something we’ll get into in Chapter 8,
“Stories,” go ahead and set up your own facing pages document with three to five pages and a
single story running between them in a series of two- or three-column frames. If you prefer,
I've already created such a document in this chapter’s folder at http:/ /www.sybex.com/go/
MasteringInDesign, and you're welcome to use it. Just open Anchored Objects Text.indd and
turn to page 2 in that document.

1. With your text ready to go, find a place on the first page of the story about midway down
the first column. Highlight two words, and give them an obvious and contrasting color like
blue, green, red, or orange. The color isn’t necessary to create anchored objects, of course;
we’re just doing it as part of this exercise solely so we can easily pick out the location of the
object anchor we’ll insert momentarily.

2. Deselect the text and text frame, and place an image, any image, into the document. I'm
going to use the infamous Photoshop sample file Ducky. tiff, found in the Samples folder
under the installation folder of any recent version of Photoshop. If you chose a large image,
scale it down to about the width of a single column of the text.

3. On the Text Wrap panel (Window > Text Wrap), choose Wrap Around Bounding Box to
push text out of the way of the image. Again, although you may elect to use a text wrap on
a real project, we're doing it now just to simplify this exercise—it’s easier to watch the col-
ored tracking text if it isn’t hidden behind the image.

4. With the image still selected, cut it with Cmd+X/Ctrl+X, and switch to the Type tool by
pressing T.

5. Insert your cursor between the two words you recolored and paste with Cmd+V /Ctrl+V.
You should see something like what I have in Figure 6.25.

Wait, you might say. That’s just a simple inline graphic. Correct, we’ve just inserted an inline
graphic, which is nothing revolutionary. What is different, however, is how InDesign has
redefined the role of inline graphic.
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6. After pasting, your image frame should still be selected. If it isn’t, grab it with the black
arrow Selection tool, which will select the image and its frame (the Direct Selection tool
will select just the image inside). The frame is the key part of this. Now, choose Object >
Anchored Object > Options to open the initial, deceptively simple view of the Anchored
Object Options dialog (see Figure 6.26).
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With Position set to its initial value of Inline or Above Line, examine the Anchored Object
Options dialog for a moment and its functions should be easily gleaned. If not, don’t sweat
it; after this initial exercise, we’ll go through what everything means.

7. For now, check the Preview box at the bottom, and arrange the dialog onscreen such that
you can clearly see it and the image we’re working with. Now, set the Position field to its
other option, Custom. Your image should jump similar to mine (see Figure 6.27).

8. Check the Relative to Spine option at the top, but leave everything else at its defaults. Hit OK.
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9. With the Type tool, return to the story a paragraph or so above the colored text. Begin typ-
ing. It can be anything you want, just as long as you add a few lines or a new paragraph.
We don’t want so much new copy that the colored text goes into the next column, not yet.
As you insert new text, as the colored tracking text is forced to move down the column, you
should see the image move down to follow.

Congratulations, you've just made your first anchored object, an image that will follow a
specific place in the text without ever needing to be manually repositioned.

10. Zoom to the point where you can see the entire spread onscreen. Insert a lot more text,
enough to push the colored tracking words to the next page across the spread (copying
and pasting paragraphs will be much faster than typing).

Where did your image go? Right: it not only followed the text, it swapped sides of the page.
That was the effect of the Relative to Spine option I had you check a moment ago. The
anchored object alignment was relative to the spine—in this case, using defaults, it was
positioned away from the spine. Thus, when the text jumped from a left-read to a right-read
page, the anchored object swapped sides of the paper to stay in the outside margin away
from the spine.

Now that you've got the basic how-to of anchored objects down, pick your jaw up off the floor,
and let’s dive a little deeper into this tremendous time-saver.

Anchored Object Anatomy

As I noted before, anchored objects are thus called because they’re poorly named—er, I mean,
because they anchor to an invisible marker character within the text. If you look at hidden charac-
ters by choosing Show Hidden Characters from the bottom of the Type menu and zoom in on the
words we colored, you'll see a yen symbol (¥) between the words, at the spot we pasted the image
frame (see Figure 6.28).

FIGURE 6.28
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The anchor marker won't print, of course, and doesn’t cause any additional spacing. Otherwise
it’s treated like any other character. You can select it, delete it (which deletes the anchored object,
too), copy it (which copies the anchored object, too), and paste it (which, you guessed it, pastes the
anchored object, too). Wherever that marker goes, so too goes the anchored object.

Because the anchor marker is treated like text, once it’s highlighted, you can adjust its kerning,
leading, or baseline offset, changing the anchored object in the process.

How can you distinguish an anchored object from a stand-alone object? Simple: look for the
anchor at the top of the object frame (see Figure 6.29). It's important to note that you can anchor
any type of object. It can be a filled image frame like the one we just inserted, a filled text frame
(for pullquotes, for example), an empty frame, a set of grouped objects (very useful for anchoring
a photo and its caption or photo credit), or even a vector path you drew in InDesign.

FIGURE 6.29 <4 —
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To convert an anchored object into a stand-alone, select the object and choose Object >
Anchored Object > Release. The object will remain but will no longer be tethered to the text.

Inline Anchored Object Options

Let’s go back to the Anchored Object Options dialog (select the object and choose Object >
Anchored Object > Options), and go through first the Inline or Above Line options. Figure 6.30
is that view again.

FIGURE 6.30 Anchored Object Options
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Inline Y Offset When you choose Inline, you're telling InDesign that the image should remain
on the same line as its marker, at the same horizontal place as the marker, be that the first char-
acter in the paragraph, the last, or in the middle of a sentence three lines deep (see Figure 6.31).
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Therefore, your only option here is how far vertically to move it—think of the Y Offset field as
baseline adjustment for the anchored object. Positive values move the object’s baseline (bottom
edge) up from the baseline of surrounding text (up to a maximum of the text’s leading height),
and negative values push it down below the text baseline.
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If you need more vertical offset than the leading allows, switch to Above Line, which puts the
anchored object above the leading of the line of text in which the marker appears (see Figure 6.32).
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Above Line Alignment Because the Above Line option moves the anchored object up and out
of the line of text containing the anchor marker, it has horizontal alignment options including
the ability to align it to the left, right, or center of the column. It can also inherit the text align-
ment such that left-aligned text begets a left-aligned anchored object. This is significant because
it means that the alignment of anchored objects becomes dependent on the paragraph style.
Various text headings, for example, often change their alignment throughout the course of doc-
ument development as different aesthetics are considered. Choosing Text Alignment from the
drop-down ensures that objects anchored inside headings maintain their relative alignment to
the text. The last two options, Away from Spine and Towards Spine, make the anchored object
switch its position relative to the side of the spread on which it falls. If, for instance, Alignment
is set to Away from Spine, the anchored object will become left aligned on a left-read page and
right aligned on a right-read page. The same spine alignment options are available with text
(on the Paragraph panel), so you can still use the Text Alignment option to predicate the align-
ment of the object upon the text containing its marker and still use spine-based alignments.

Note: Disable text wrap on Above Line anchored objects. Otherwise, text will be pushed away
from the anchor marker, with some weird results.

Space Before and After Both of these fields operate exactly like the paragraph Space Before
and After fields on the Paragraph panel—they provide vertical padding before or after the
anchored object. This is highly useful for giving a little extra white space to anchored object
instances without overriding paragraph spacing.
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Prevent Manual Positioning Anchored objects can still be manually moved around with the
Selection tool, potentially overriding the settings in Anchored Object Options. Checking Pre-
vent Manual Positioning prohibits such manual (and possibly accidental) movements, requir-
ing alterations be done through Anchored Object Options, which also helps maintain
consistency across the document’s anchored objects.

Custom Anchored Object Options

Inline and above line anchored objects are, for most workflows, once-in-a-while things. In the vast
majority of cases, objects anchored to text will not be inline but out in the margins, in—or as—a
sidebar, tacked to the top or bottom of pages, or floating between or across columns. And that’s
where the Custom Anchored Object Options come in.

With your anchored frame selected, reopen the Anchored Object Options dialog and set the
Position field to Custom (see Figure 6.33). Check Preview so you can see the changes to the object
as you change settings. You already know what the Relative to Spine check box does, so let’s go
through the rest of the dialog.
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ANCHORED OBJECT REFERENCE POINT

Confusing as the Anchored Object Reference Point section may appear, it’s actually very simple:
It's the anchored object’s reference point proxy. Select the top-left box in the grid of nine boxes to
position the anchored object’s top-left corner in a specific place on the page; select the bottom-right
reference point to make all positioning options throughout the rest of the dialog relative to the
anchored object frame’s lower-right corner. It works just like choosing the reference point in the
Transform panel for precision X and Y positioning.

With Relative to Spine unchecked, there is but a single reference point proxy. Checked, Relative to
Spine causes two to appear inside page icons (as shown in Figure 6.33). The reason there are two, and
the reason they re mirrored, is because spine-based alignment swaps sides from left- to right-read
pages, just like margins. And, just like margins, you're not dealing with right and left reference points
anymore, you're dealing with inside (toward the spine) and outside (away from the spine). Select the
reference point on either page to automatically select the corresponding point on the other.
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ANCHORED POSITION

Half of positioning an anchored object is choosing which part of the object you're positioning
through the Anchored Object Reference Point. The other half is choosing where on the page to put
that reference point. All the options in this section are predicated on each other; changing one set-
ting filters the options of the others based on relevancy.

The Reference Point proxies here are reference points for the page, text frame, column, or line
of text in which the anchor marker appears. In the simplest terms, you're aligning the object refer-
ence point to the position anchor point, putting the selected corner (or side or center point) of the
object on the selected position reference point. Figure 6.34 shows a couple of examples of how the
two relate.

FIGURE 6.34
Two examples of
basic anchored
object settings and
their results
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The position Reference Point setting also changes depending on whether Relative to Spine is
checked, but it also changes based on the values of the Y Relative To field. If the Y Relative To field
is set to any of the three Line options, thus restricting the anchored object to align vertically with
the line of text in which its marker is placed, the position Reference Point proxy will be limited to
three horizontal options: outside (or left), center, and inside (or right). Changing the Y Relative To
field to any other option lights up the full nine points of the proxy. For instance, setting Y Relative
To to Page Edge allows you to choose the top-left corner of the proxy—thus aligning the anchored
object to the top-left corner of the page.

Before we get too far ahead, let’s look at the x-axis—horizontal—alignment options.

Anchor Marker This option tells the object to follow the marker, similar to an inline anchored
object. If text edits make the marker move an inch into the line of text, the image frame tethered
to the marker will move an inch in the same direction. Selecting Anchor Marker creates the
tightest association between marker position and object, but it also offers the least predictability
and control over object location.
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Column Edge Choosing Column Edge makes the horizontal alignment relative to the left or
right edge of the text column. It doesn’t necessarily mean the anchored object will be inside the
column. It can be inside, partially inside, immediately outside, or far outside—the same with
any of the X Relative To choices. Column Edge merely means that the position becomes relative
to the width and location of the column, but it’s best used for objects that will appear inside the
column—at the top, bottom, or somewhere between.

In single-column layouts, there is no effective difference between selecting Column Edge and
Text Frame.

Text Frame I recommend using the Text Frame setting when you want to align objects to side-
bars, when you want to align them to the top or bottom of the frame, and when placing objects
that span multiple columns. It bases positioning on the width of the text frame regardless of
number or width of columns and their gutters.

Page Margin Page Margin makes positions relative to the page margins, which, in many cases,
are the same as the text frame dimensions.

Page Edge Based on the document feature that changes least often—the size of the page—the
Page Edge choice offers both absolute positioning and the most reliable positioning heedless of
margins, frames, and columns. This type of alignment is ideal for placing content that must
appear close to an edge, such as a nameplate, title illustration, or sidebar content.

The X Offset field accepts both positive and negative measurements to fine-tune horizontal
object placement. For example, to position a pullquote text frame 0.25 inches to the outside (away
from spine) of the frame containing the marker, set options like those shown in Figure 6.35. Natu-
rally, measurements in the X Offset field may be entered as inches, millimeters, centimeters, pica,
points, ciceros, or agates.

FIGURE 6.35 Anchored Object Options
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Y Relative To sets the vertical object position. Among the drop-down menu’s seven choices,
four are vertical equivalents to those described above: Column Edge, Text Frame, Page Margin,
and Page Edge. The other three options set vertical alignment relative to the features of the text
surrounding the marker. Line (Baseline) aligns relative to the baseline of the text, Line (Cap Height)
to the top of capital letters in the text, and Line (Top of Leading) to the height of the leading on
which the text sits. A'Y Offset field also allows fine-tuning of vertical positioning.

Depending on all the settings in the Anchored Object Options dialog as well as the position
of the marker and the size of the anchored object itself, objects sometimes expand out of the areas
in which you want them. The Keep Within Top/Bottom Column Boundaries hedges against
such unexpected jumps by forcing anchored objects to remain within the vertical confines of the
text column containing the marker. Thus, even if an image would otherwise spill out the top
of the column, this option will override other choices in the dialog to force the object to stay within
the column. It won't alter the horizontal placement or size, just the vertical alignment. Of course,
checking Keep Within Top /Bottom Column Boundaries works against vertical alignments of Page
Margin and Page Edge and is better used with any other Y Relative To choice.

Is your head spinning yet? Between InDesign CS2 and CS3, I've explained anchored objects in
writing four or five times now and verbally in front of a class or seminar nearly a hundred times.
It doesn’t get any easier; it’s a difficult topic to explain, made more so by the long and confusingly
similar terminology at work. If you're feeling lost, trust me, it isn’t you.

Anchored objects can save you quite literally days and even weeks of work on longer docu-
ments, and it’s well worth the investment of your time, brainpower, and a six-pack of Red Bull to
learn it. The best way to do so is to go hands-on, using this book as a reference while you try out
different combinations of anchored object options. To get you started, Figures 6.36 through 6.39 are

a few recipes.

FIGURE 6.36
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FIGURE 6.37 Anchored Object Options
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You don’t have to begin creating anchored objects by pasting an image into text. You can simply
place the Type tool cursor at the desired marker point and, without pasting, choose Object >
Anchored Object > Insert, which creates an empty anchored object at the location. Why would
you do that? On very, very rare occasions I've found it useful when working in a frame-first lay-
out, but usually it’s more trouble than it's worth. If you need empty frames, draw, cut, paste, and
set up empty frame-anchored objects.



FIGURE 6.39
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Not only can text bet set in frames of any shape, it can also be set around frames of any shape, on
any open or closed path. Figure 6.40 shows a few different examples of type on a path. The con-
cept of Type on a Path isn’t new—illustration applications and many page layout programs have
had the ability for decades now. InDesign does it as well as any other application, and it has a few
features you might be surprised to see in a page layout application.

Dow,

FIGURE 6.40
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Setting Type on a Path

Let’s start with a little hands-on.

S
oW

Fontaholics

N5

@]

E

@ )

H JUE
O

puepiod

1. With the Pen tool, draw a meandering open path. I'm going to use a gentle S curve (see Fig-

ure 6.41), but any shape will do.
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FIGURE 6.41
My starting path

2. On the Tools panel, click and hold on the Type tool to reveal the Type on a Path tool behind
it. The Type on a Path tool looks rather like a T sliding down a log flume ride.

3. Position the Type on a Path tool cursor near the beginning of the path. When you're close
enough, a little plus sign will appear in the upper-right quadrant of the cursor. Click.

4. You should now see a flashing I-beam cursor on the path itself. Type something and watch
as your type follows the flow of the path (see Figure 6.42).

FIGURE 6.42
My type on a path

One of the differences between the way InDesign and other applications do type on a path is
the fact that InDesign does not automatically strip the fill or stroke color from the path. Notice the
line stroke is still visible. This can be a good thing or a bad thing. To hide the path stroke, just
remove it on the Swatches panel.

Editing Type on a Path

The text in the type on a path object is just standard text. You can style it however you like, includ-
ing applying paragraph and character styles. Spell check, Find/Change, Autocorrect, and all the
other text features of InDesign work on, and apply equally to, text in type on a path objects as
framed type. They can even contain (or be) anchored objects.

If your typing went too far, placing more text than will fit on the path, the text will overset just
like a text frame. You can see in Figure 6.43 the little red plus sign indicating overset text after I
increased the size of the type but not the size of the path on which it rides. The overset indicator
appears in the oufport of the type on a path object. If you look toward the other end of the path,
you’ll also see a matching inport. Yes, you can thread multiple type on a path objects together, run-
ning text from one to the other just like you can with text frames (see Chapter 8, “Stories,” for
more on threading text).
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FIGURE 6.43
Overset type on
apath

You can change text alignment by using the alignment buttons on the Paragraph panel (left,
right, center, justified, and so on). On the same panel, the left and right paragraph indentation
fields are also available, enabling you to build some padding into the beginning or end of the
path. Alignment occurs within the total length of the path less any indentations you've set.
There’s another way to control the indentation of type on a path, which, conveniently, is similar
to the way you alter the center point and flip type from the top to the bottom of the path and
vice versa.

Type on a path objects have three special indicators—the start point, the center point, and the
end point indicators. With the black arrow Selection tool, select the type on a path object and posi-
tion the cursor over any of the three indicators. When you're close enough, the cursor will change
to the one in Figure 6.44. Once you see that, click and drag the indicator. Dragging the start or end
point indicators inward will create padding on that end, enabling the path to continue but limiting
the text to the position of the indicator. The center point indicator can go either way and will alter the
horizontal center of the line of text. It can also flip text from one side of the path to the other—just
drag the center point indicator across the path and the text will follow. Note that the text changes
direction as well; if you just want to push the text below the path without changing direction, use
the Align and To Path fields in Type on a Path Options (see below).

FIGURE 6.44 A e =
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End point indicator.

The path remains completely editable at all times, incidentally. Just grab the Direct Selection
or any other path editing tool and change the path shape; the text will reflow to follow.

If you've changed your mind and want to remove type from the path, that’s easy. To keep the
type, select it with the Type or Type on a Path tool and cut; paste the text elsewhere. If you’d also
(or instead) like to preserve the path without text, select the type on a path object and choose
Type > Type on a Path > Delete Type from Path.
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Type on a Path Options
If you choose Type > Type on a Path > Options, you'll see that the shape and direction possibili-
ties of type on a path don’t rely entirely on your skill with the Pen tool (see Figure 6.45).

FIGURE 6.45 Type an a Path Optians
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The Effect field controls how the glyphs of your text are affected by path direction changes (see
Figure 6.46). There are five options: Rainbow, Skew, 3D Ribbon, Stair Step, and Gravity.
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Rainbow Like a rainbow, this, the default option, keeps glyphs’ baselines aligned with the
path—where the path turns, so does the type. When curves and corners happen in the direction
of the text, glyphs are often compressed together; outward angles expand the spacing between
glyphs.

Skew The Skew option creates faux depth by assuming that path curvature equals z-axis,
front-to-back perspective. It does this by not rotating glyphs as the path wends and winds,
keeping text perfectly vertical. Try this effect on a large elliptical or loose spiral path for dra-
matic effect.

3D Ribbon 3D Ribbon is the opposite of Skew. It maintains glyph horizontal level while alter-
ing the y-axis alignment to follow the path.

Stair Step Choosing Stair Step as the effect will keep glyphs vertical, aligning the beginning or
left edge of their individual baselines to the path.

Gravity As the name implies, this choice simulates the effect of gravity on the glyphs. It does
so by aligning text vertically to the path’s centerpoint while keeping the center of the glyphs
horizontally on the path.
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The Spacing field controls the spacing between glyphs on the curves and corners of a path,
which can be used to compensate for bunching that occurs with several of the Effect choices.

Fine-tune the alignment created by Effect with the options in the Align and To Path fields. You
can choose to orient the text ascenders (top of the text), descenders (the bottoms of characters like
y or g), vertical center, or baseline to the path. And, you choose whether they align to the path’s
top, bottom, or center. If your path has no stroke, you won’t see much difference with the three To
Path field options. However, if your path does have a stroke, Center puts the text on the path itself,
potentially commingling with the stroke, while Top or Bottom takes into account the weight of the
path’s stroke, moving text beyond the stroke.

Flip has the same result as dragging the center point indicator across the path. It’s like rotating
the text 180° on the path without altering the path. It throws text to the other side and other end
of the path. It has the same effect as choosing Object > Paths > Reverse Path, though that com-
mand is not available for text on a path objects.

Step and Repeat

When you need several copies of an object—especially if you need them arrayed—don’t use copy
and paste or Edit > Duplicate (Duplicate duplicates the object without copying it to the system
clipboard, thus leaving intact whatever you may have waiting there). Step and Repeat, also a com-
mand on the Edit menu, makes copies of an object while aligning them.

Let’s say you're building a template for a sheet of pre-cut laser printer labels. First, you draw
and place the rectangle or rounded-corner rectangle defining the area of the first label. You set the
rectangle frame itself not to print by checking the Nonprinting option on the Attributes panel
(Window > Attributes); you want to be able to see the area of your label, not print a border that
will likely misregister. Next, you arrange inside the label the company logo, return address, and
maybe a rule or two, leaving space for the recipient address (these do print, of course). Once your
first label design is finalized, you group all the objects including the rectangular frame to both pro-
tect the individual elements from accidental repositioning and make duplication and placement of
the label easier. Now what are you going to do? Copy and paste 7, 9, or 29 times, each time
tediously positioning the new copies via the Transform panel? No, of course not. You're going to
select the first label and choose Edit > Step and Repeat (see Figure 6.47).

FIGURE 6.47 T
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First, decide how many copies you need. To lay out a sheet of labels arranged five deep in two
columns, you'll need to use Step and Repeat twice. The first time, set Repeat Count to 4 (the first
label you created is the fifth), a 0-inch Horizontal Offset, and a Vertical Offset equal to the height
of the label rectangle. Use the new Preview check box to see what will happen. That is, your label
will duplicate downward four times, creating a single column of five perfectly aligned labels. Hit
OK to commit the preview to reality. The second time through Step and Repeat, with the entire
column of five labels selected, you'll make one repetition with no vertical offset and a horizontal
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offset equal to the width of the label. That will create your second column of five labels, again, all
perfectly aligned.

If you were laying out something else—say, a photo directory page—and wanted spacing
between the repeated objects, just oversize the offset. For example, if your object is 1.5 inches wide
and should have a 0.25-inch gutter between each instance, set the Horizontal Offset field to 1.75
inches. If you enter values in both the Horizontal and Vertical Offset fields, your replicated objects
will stair-step, moving both horizontally and vertically.

Transform Again

I'm sure you know all about the Object > Transform menu, about using Move to numerically
move a selected object, Scale to scale the container and its contents, Rotate to precisely revolve the
selected object, and Shear to skew it. The Rotate and Flip commands you know are there as well.
You know about those, but I'm curious if you know about the Object > Transform Again menu
and all the time it can save you.

Introduced in InDesign CS2, the Transform Again menu (see Figure 6.48) is like a mini macro
system. Imagine this: You've placed an image in the document, then immediately scaled it 50% in
both directions, rotated it 90°, and flipped it horizontally. Maybe you spent 30 seconds or as much
as 2 minutes doing all that. Satisfied with the image, you now look across the rest of the catalog, at
the other 23 images on the page, at the other 399 pages of the catalog with their 24 product photos
per page, all waiting to be scaled, rotated, and flipped. I can’t imagine how the prospect of 30 to
120 seconds per image and all that clicking and field entry typing wouldn't elicit at least a moan if
not a fleeting fantasy of paying the neighbor kid 10 bucks to do it for you.

FIGURE 6.48 Y bl view Window Heio
The Transform s
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Faced with that exact same scenario, on a similar catalog, it took me an average of less than
1 second per image to effect all the same transformations. I was done in an afternoon. (To be truly
efficient, I would have done much of the transformations via a Photoshop batch action and written
an InDesign script to do the rest of the work for me, but that’s not the point I'm trying to make.)
Try it yourself:

1. Create two identical objects on the page. They can be as complicated or as elementary as
you like; a pair of simple square frames filled with color will work nicely.

2. Transform one of them—scale, rotate, shear, or flip, one type of transformation please—
from the Object > Transform menu, with a dedicated tool from the Tools panel, using the
Transform panel, or however you would normally transform an object. You can even drag
one of the control corners on its bounding box with the Selection tool and resize it horizon-
tally, vertically, or both (at once). Just make sure that you use a single transformation and
that its result creates an obvious contrast with the second object.
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3. Select the second object and choose Object > Transform Again > Transform Again. Your
second object should instantly change to mimic the transformation action you manually
effected on the first.

4. Draw a third object, similar or disparate, it’s your choice. Hit the same command—Object >
Transform Again > Transform Again.

5. Now, if you would, return to the first object and apply multiple transformations to it—
scale, rotate, shear, and flip.

6. Select object number two, and choose Object > Transform Again > Transform Sequence
Again. Your second object should now be scaled, rotated, sheared, and flipped identically to
the first.

InDesign remembers and, through the Transform Again commands, replays the last transfor-
mations you perform. Just about anything you do to one object can be applied over and over to
additional objects—even to whole spreads of objects individually—as quickly as you can select
them and execute the menu command or keyboard shortcut. As long as the transformation you
want is the last action or actions you've performed in InDesign, you can replay them to alter
another selected object.

Transform Again Transform Again replays the last single transformation to the selected
object(s). If you have more than one object selected, they will be transformed as a unit, just as
if they were grouped. For example, you've rotated an object 45° and then selected four other
objects. When ysou run Transform Again, the entire group of four objects will be rotated 45° en
masse. Depending on their arrangement, they will each likely be rotated to some other angle
than 45°.

Transform Again Individually This command will transform each of the selected objects with
the last single transformation individually, just as if you went through and did them one at a
time. Thus, you can select an entire page of objects and know that, after executing a Transform
Again Individually, they will each be at 45°.

Transform Sequence Again As you saw above, Transform Sequence Again replays all of the
transformations to new objects. Whatever your last sequence of transformations, they will be
applied to the selected single object or to multiple objects as if they were a group.

Transform Sequence Again Individually Using this command transforms all selected objects
separately with the previously recorded transformations.

Going back to the original scenario, transforming 24 images on each of 400 pages doesn’t seem
as daunting a task anymore, does it?

InDesign records the last transformations and only the last transformations. As soon as
you do something else—insert a page, type something, whatever—you’ll dump the cache of
remembered transformations. After that, the Transform Again commands have no effect.
Therefore, if you're running through a document transforming again, stay focused and resist
the urge to fix that typo you spot in the middle of the document until after you're done trans-
forming again.
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The Bottom Line

When we began this chapter I postulated that it held the “coolest subject” in this book. I'll assume
you're nodding.

Some subjects such as object effects and type on a path are extremely quick to grasp and use.
I've tried to ease the learning curve on other subjects like anchored objects, which are not as easily
grasped due in large part to the (regrettably necessarily) confusing user interface. Those need to be
explored in actual working documents to fully comprehend their nuances and coolness factor. Spend
some time with each of the subjects in this chapter, trying them out on your own and clients’ projects
and I think you might change your opinion of which subject is the coolest in the book.

Use Attribute-Level Transparency and Object Effects InDesign CS3’s new attribute-level
transparency and transparency-based object effects allow more to be done inside InDesign with
live object effects than ever before.

Master It Place an image onto the page. Above that image, create a text frame and fill it
with placeholder type. Fill and stroke the frame. Using the new attribute-level transparency
and effects...

*

Give the frame an inner glow and blend it back with the photo such that the frame tints
the photo.

Make the type gradually disappear into its background as it moves from the top down.

Give the stroke a drop shadow and blending mode that alters the background image
just in the area of the stroke.

Master It Solution Results will vary widely with the images, colors, and blending modes
chosen, but learners should all do each of the following:

*

*

Select in the Effects dialog Settings for Fill, add an inner glow, and either alter overall
transparency of the fill or change its blending mode.

Select in the Effects dialog Settings for Text and apply the default gradient feather with
either a -90° angle or 90° and reversed.

Select in the Effects dialog Settings for Stroke, change its blending mode, and apply a
drop shadow.

Design Custom Stroke Styles Although the stroke styles that come with InDesign are perfect
for many occasions, they fall short of perfect in others. That’s why InDesign lets you create
your own.

Master It Create a new Dash type stroke style that looks like the graphic below—dot-dot-
dash-dot-dot—which is Morse code for ID, InDesign’s identifier among the Creative Suite 3
icons.

Proview

Preview Weight: |5 v
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Mixed Ink Swatches and Sharing Swatches Between creating mixed inks swatches and mixed
ink swatch groups and sharing swatches across applications and documents, InDesign CS3
makes color fidelity and productivity easy.

Master It Pick a new spot color and create shades of that spot by mixing black into a mixed
ink group. Generate 10% tint swatches in the group. Save the document and exchange it
with a partner. Both you and the partner should then add the mixed ink group swatches
you both created into InDesign’s default Swatches panel. If you're working alone, you can
still do this portion of the exercise with the single document you created.

Work with Anchored Objects Anchored objects replace the old-style inline graphics that had
limited options. They also completely eliminate the need to manually reposition text-supported
figures, illustrations, charts, pullquotes, tip boxes, sidebars, and other objects when document
text reflows.

Master It Beginning with several pages of text linked into a single story (again, use this
chapter’s sample file if you like), insert at least one above line graphic and at least two
objects (images, nonthreaded text frames, natively drawn objects, or a group of objects) as
anchored objects that float outside the text. Make the above line image appear on a line by
itself, with at least 0.25 inches of vertical padding above it, and make the floating objects
align to the outside margin of whichever page they fall on. Check your work by inserting
text above the marker points to push the marker points and anchored images to subsequent

pages.
Set Type on a Path Type on a Path allows text to go anywhere paths can go, in any shape a
path may take, which is anywhere, any shape.

Master It Let’s combine a few of the things we’ve learned in this chapter to create a cool
type on a path creative technique. Begin by drawing a broad arc open path. Add type to the
path—whatever you’d like to say, perhaps a line from a favorite poem—and give it faux
depth. Make the stroke disappear such that the text floats free. Then, using object effects,
make the text gradually fade out from opaque at one end of the arc to completely transpar-
ent at the other end.
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Chapter 7
Pages

Pages are the foundation of every document in InDesign. How they’re created, modified, and
managed directly affects their ability to print, their fitness to purpose. InDesign has always offered
tremendous ease in working with pages, and, perhaps more so than any other area of the applica-
tion, the options and control over pages improve with each successive release. In InDesign CS3, a
large portion of the new features and refinements of existing features are centered around the

Pages panel and controlling pages.
In this chapter, you will learn to:

¢ Create pages with bleed, slug, and live areas
¢ Manage pages in and between InDesign documents

¢ Master master pages

Creating Pages

I'won’t waste your time by explaining what a page is, that these magenta guides inside the page
are your margins, or that the pasteboard is (mostly) a non-printing workspace where you can stick
work product items you don’t want on the final print. All that stuff you already know. What I will
do, however, is take you on a quick run through of the areas in which I've seen even seasoned pros
get confused. Along the way, you'll discover a few lesser-known features and tricks.

Document Setup

The first place to define document dimensions, number of pages, and the features of pages is the
New Document dialog (see Figure 7.1). We'll jump around the New Document dialog a bit instead
of going through it top to bottom.

If you know in advance how many pages you need, it’s often easier to create them all at docu-
ment inception with the Number of Pages field than to add them later. They can be added later,
however, so don’t stress if you're in the habit of pressing Cmd+N/Ctrl+N and then Return/Enter
immediately thereafter.

Down in the Columns section, you can set up a number of equal-width columns and the gutter
space between them. This will insert column guides on all pages and, if Master Text Frame is
checked, will also match the columns and gutters in the text frame options. Without it checked,
you'll need to manually insert text frames and, if they're to be multicolumn frames, manually con-
figure them with Object > Text Frame Options.
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FIGURE 7.1
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The Master Text Frame option creates a text frame on the document’s initial master page. The
frame will span margin to margin horizontally and vertically and will be placed on every page,
ready to be overridden (see later in this chapter for overriding master page items) and filled with
text. For documents like books, reports, proposals, and certain catalogs and other publications that
require only a single text frame on most pages (with one or more columns), Master Text Frame
should be checked. However, for shorter or multistory documents (e.g., newspaper, magazine,
most catalogs, and so on), it’s usually better to leave this option unchecked, opting to create text
frames manually as needed.

The Margin field accepts any measurement system InDesign understands—points, picas, inches,
inches decimal, millimeters, centimeters, ciceros, or agates. When you create a new document,
InDesign uses the measurement system and notations from its default preferences; fresh out of
the box, that’s pica and points. If you don’t do pica, feel free to type the margin sizes in inches or
any other recognized measurement system—just as with page size above it and most of the other
measurement fields throughout InDesign.

If you're tired of having to manually override the pica measurements in the New Document
dialog and you’d like it to automatically show you inches decimal, ciceros, or another system,
cancel creating a new document. Close all other documents, and then go to Edit > Preferences >
Units & Increments (Windows) or InDesign > Preferences > Units & Increments (Mac). Change
Ruler Units Horizontal and Vertical to the desired system and click OK. Doing this with all docu-
ments closed forces the new measurement system to be the default for all future documents—dur-
ing the current session and, unless you crash before successfully exiting InDesign, for all future
sessions as well. Note that if you reset your preferences, this is among those preferences that go
bye-bye.

The chain link icon between the four margin fields links them together such that changing one
alters the other three to match. Click the Make All Settings the Same chain link to break the inter-
dependency when you want different margins for top, bottom, and inside and outside or left and
right.

FACING VS. NONFACING PAGES

If you've got the concept of facing and nonfacing pages down cold, skip this section. Many, many
people—including experienced InDesign users—have questions about the distinction and reper-
cussions between checking that box beside the Number of Pages field. It’s to them that this section
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speaks. Facing pages are any bound document that will have left-read and right-read pages; there’s
a spine between the pages, and they face one another (see Figure 7.2). If you're duplexing, printing
on both sides of a page, you probably want to check the Facing Pages option at the top of the New
Document dialog. Because facing pages swap edges—odd-numbered pages in English texts are
always right-read (pages are to the right of the spine or binding edge) and even-numbered pages
are left-read, their margins also swap. Page 1’s right margin becomes page 2’s left margin and
vice versa. Therefore, calling the margins left or right is only accurate half the time. Instead, left
and right become inside and outside. Inside margin measurements control the distance from the
spine (the bind edge) while outside margins specify how far content appears from the trim edge.
InDesign will automatically flip the margins between odd- and even-numbered pages—swapping
left for right, right for left—between pages.

FIGURE 7.2

Facing pages (left)
are for bound docu-
ments, while non-
facing (right) are for
single pages or docu-
ments that will all
have a common
bind edge.

When Facing Pages is checked in the New Document dialog, the Margins section shows Inside
and Outside fields. Uncheck it and you'll see the field labels change to Left and Right.

You'll want nonfacing pages for any document in which all pages will have a common
bind edge. For instance, you might be creating a report where only the right-read pages will
be printed upon, leaving their backs blank. That’s a common scenario for velo-, GBC-, spiral-,
three-ring-, or even staple-bound documents and reports around an office or courtroom. Deposi-
tion transcripts and other evidentiary documents, for instance, are typically one-sided, nonfac-
ing pages.

How do you know if the person before you created the document with facing or nonfacing
pages? Simple: Look to the Pages panel. A document created with facing pages will have page
icons set 2-up on the spine (see Figure 7.3) instead of spineless singles. Even a one-page document
displays the difference—page one of a facing pages document will be to the right of the spine. Also
note the position of the A master page identifier. It's positioned on the outside edge of facing pages
but centered on nonfacing.

If you (or the client) decide to change the layout of a document from facing to non or vice versa
after you've already begun working, fret not. File > Document Setup contains that and most of
the other options from the New Document dialog. You might probably also need to adjust the
margins, which can be done through Layout > Margins and Columns.

215
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Ruler orientation is also affected by choice of facing or nonfacing pages. Although you can over-
ride this in Edit > Preferences > Units & Increments, by default InDesign orients the horizontal
ruler’s zero-point to the top-left corner of the spread. Thus, in an 8.5X11-inch document of nonfac-
ing pages, the right edge of every page is at 8.5 inches. With facing pages, though, only even pages
and page one end at 8.5 inches. Page three and all odd pages (except page one) begin at 8.5 inches
(the spine) and end at 17. Positioning an object onto the right page of a spread using the Control or
Transform panels, for instance, requires X positions greater than 8.5 inches.

The Origin field in the Units & Increments preferences can change the horizontal ruler behavior
(see Figure 7.4). Spread is the default and works as described previously, beginning at the top left
of the left page and growing across the entire spread. Page restarts the numbering for each page—
at the spine, the right-read page starts over again at 0 inches. Finally, setting the Ruler Units Origin
to Spine orients the ruler zero-point on the spine itself; pages to the right of the spine get positive
measurements while pages to the left of the spine have negative measurements emanating from
the spine.

PAGE LAYOUT

If you graphic designer readers are considering skipping this section because you believe bleeds
and slugs are in your print service providers’ sphere of concern rather than yours, don’t. Failure
to create proper bleeds is among the most common reasons designers’ printed output is flawed
and service providers charge for cleanup time and simply kick the job back as unacceptable.

You print providers shouldn’t skip this section either. While I doubt I'll teach you anything you
don’t already know about bleed, live area, and slugs and why they’re important, you might learn
a different way to explain these concepts to designers so they get it. (Feel free to distribute copies of
this book to your designer clients. Sybex has very attractive volume discounts. <wink>)

Bleed is when artwork or text runs to the page trim edge. The cover of this book is a good
example. Notice how the ink bleeds off all four edges of the cover leaf. The bleed area is how far
beyond the page ink must extend in order to safely ensure against slivers of paper appearing in the
finished piece should pages misalign on the cutter.
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Let’s define the terms we’re talking about visually. In Figure 7.5 you can see a trifold brochure
I once designed for a client as well as different marks and guides (I've removed some marks to
make my point easier to discern). On the very outside, the blue guide box is the slug area. Inside
that, with the artwork running right up to them, are the red bleed area guides. Next, the paper
edges—turned green in the figure for easy identification—are the trim, the expected final paper
size post-print, post-trim, post-finishing. Finally, within the page are the magenta margin guides
that form the document live area (sort of). The white area beyond is, of course, the pasteboard.

FIGURE 7.5
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SLUG

Slug is a nebulous term that can be applied to a lot of different things. In my travels and two
decades in the business I've noted its usage change regionally and by specialization within each of
the print, prepress, and design industries. Quite a few people use the term slug to reference head-
ers and footers or parts of them, like the page number. (The page number is properly called a folio,
not to be confused with folio referencing a folded sheet of paper comprising two leafs or spreads.)
In this context, slug refers to any information that must accompany a design through prepress and
print but that will be trimmed off during finishing.

What should you put in the slug area? Whatever the designer or print service provider may need.
Job name, job number, document title, InDesign filename, client name and contact info, date,
designer’s name and contact info, color bars, short knock-knock jokes for your service provider’s
amusement—anything can go in there. What should go in there is whatever is needed by the
designer, the prepress bureau, the printer, the finishing and bindery service, and whoever will
retain the film or plates generated from the artwork (if there are film or plates). It's a great place to
put special instructions to providers down the line, too. For instance, if your job contains a spot
color intended to be a varnish, in addition to setting up the ink properly in Ink Manager, note in
both the job ticket and the slug area which ink is the varnish. Even if the prepress and press opera-
tors miss the note on the job ticket, they’ll see it in the slug because the slug will output to every
piece of film and every printed page. If you're running film for the job, include enough informa-
tion that, a year or five down the road, you'll be able to immediately identify the job, client,
designer, and corresponding digital document. Many a wasted hour has been spent at swapping
sheets of film on a light table trying to figure out which page 14 cyan plate goes with which yel-
low, magenta, and black plates.

Before sending a job to press, I typically add one small table into the slug area above the page
and another table below. In the top, I include the job name as given to my print and finishing
providers, the page number, the date, my account number(s) at the service provider (for proper
billing and tracking), my name and contact information (so I can be called or emailed about some-
thing without a trip to the customer database), and any special instructions echoed from the job
ticket. Within the lower table is information for my reference, including internal job name and
number, client name, digital document title and filename, and authoring application and version. I
often send PDFs to press, so I want to know on the film if I should be searching archive DVD-ROMs
for an InDesign, QuarkXPress, [llustrator, or some other type of document and what version of
that software I used in case whatever version I'm currently using has trouble translating from
older ones (InDesign had that problem with version 1.0 and 1.5 documents). Knowing the author-
ing application and version can also help my prepress provider understand the document and any
unique RIP considerations (once in a while it’s a factor, even with properly made PDFs). Of course,
I put all this information on the master page rather than doing it manually page by page.

Marks and symbols like crop marks, bleed marks, and registration marks vital to the proper
output of your job will, by definition, wind up in the slug area.

Setting up a slug area is simple. When you're creating a new document (or later in Document
Setup), clicking the More Options button reveals the Bleed and Slug area (see Figure 7.6). The
chain link button on the right will mirror all four sides’ measurements, which is usually not neces-
sary. In most cases, you want to put all your slug information on one or, at most, two sides of the
output. Your service providers will often add additional marks and symbols or their own tracking
information, and you want to leave them space in which to do so. Additionally, because the slug
will print on film and paper, too generous a slug area can unnecessarily enlarge the required
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substrates, potentially increasing the cost of the job. Slug areas should only be large enough to
hold the required information comfortably.

FIGURE 7.6 Blead and Skug
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When exporting a PDF for press, you'll want to ensure that the PDF includes the slug area. As
you can see in Figure 7.7, the Marks and Bleeds pane of the Export Adobe PDF dialog has a check
box at the bottom to Include Slug Area. Check that for press output, but uncheck it when publish-
ing a PDF to your website or intranet for digital distribution.
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The Print dialog’s Marks and Bleed pane has the same box (see Figure 7.8) if you're outputting
straight from InDesign or printing to PostScript. When printing to a desktop printer, you typically
only want to print the trim size, so uncheck it. However, if you'd like to scale the entire design to
include the slug, bleed, and any marks, check the appropriate options, and then, on the Setup
pane, activate the Scale to Fit option. Note that the entire output will shrink down to fit within the
chosen paper size (and respect any rebates), including the slug and so forth.

In both locations you can also add needed marks and symbols via the Printer’s Marks check
boxes as well as control type, weight, and offset (distance from artwork) of the crop, bleed, and
registration marks.
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BLEED

Bleeding designs are run on sheets larger than the intended deliverable page size and then trimmed
in very large stacks on a guillotine or other type of cutter. Cutter operators are punctilious (they have
to be; they have 10 fingers relying on their attention to detail). Still, they’re human (as evidenced
by the number of cutter operators at annual conventions answering to the nickname of “Lefty”).
Moreover, sheets of paper have a tendency to shift ever so slightly as a blade is rammed down
through a stack. Even a one one-thousandth of an inch shift can leave an ugly white strip down
one or more sides of an edge-to-edge print piece that didn’t account for such possibilities. That
would ruin an otherwise beautiful design. Hedge against this common problem by drawing beyond
the trim. Don’t stop image frames or filled objects at the page edge; keep them going out % inch.
Look at Figure 7.9, the same document with and without bleeds. See the difference? The one that
extends the art to fill the bleed area can’t be marred by paper slivers; if the cutter is off enough to
cause slivers with an %-inch bleed, the operator will send the job for a print rerun anyway:.

FIGURE 7.9

The same full-bleed
design without the
safety net of extend-
ing artwork out to
the bleed area (left)
and with (right)
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Create a bleed guide around any side that will run ink up to the trim edge—it’s usually easier
to just set up a four-sided bleed guide even if fewer edges will bleed. When sending a bleeding
document to press, always bleed the artwork. Get the desired bleed area size from your print serv-
ice provider; when in doubt, use the industry standard % inch or 0.125 inch. Then, as you design,
account for the bleed area by extending objects and colors out to the red bleed guide. If you use a
background image, crop it at the bleed guide, not at the trim. Depending on the image, that may
require you to enlarge it in InDesign or even go back to Photoshop or Illustrator and add more
space around the focal point of the picture. As you get in the habit of using bleeds and bleed guides
in InDesign, you'll learn to plan for the bleed when prepping artwork.

As you noticed in the preceding text, adding, resizing, and outputting bleed to print or PDF is
controlled in the same place as whether to include the slug area. You've got additional control over
bleed, however (see Figure 7.10). You can use the document bleed settings as defined in New Doc-
ument or Document Properties, or you can override them (or correct for their absence) by specify-
ing new bleed values in the Bleed and Slug section of the Print or Export to PDF Marks and Bleed
panes.

FIGURE 7.10 Bleed and Skug
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LIVE AREA

Similar to bleed, live area compensates for paper shifts on a cutter, but on the inside of the trim. If
pages or the blade slip during a cut and a bleeding print shows paper along one edge, it therefore
follows that the opposite edge of the page will lose some of its artwork. It's even more important
that the design elements critical to communicating the message of a design be inset from the trim
edges than it is that background colors extend out beyond. You don't, for instance, want the last
digit of an ad’s sales phone number chopped off. (I've seen that exact thing, actually, within an ad
in a major, one million plus circulation magazine; the client showed it to me when my agency was
hired to take over from the firm that had created and placed that ad.)

The buffer space of the live area is, like the bleed bulffer, typically % inch or 0.125 inches. It can
vary, though. Product packaging labels and low linescreen boxes, for example, often need 0.25 or
even more distance between trim and live area (and trim and bleed). Consult your print service
provider.

I'wish I could show you a dialog where you can create a live area guide (orange would be a
nice choice in guides), but I can’t. InDesign doesn’t have such a feature, although I keep lobbying
for one. Instead, Adobe considers the margin guides to define the live area despite the fact that
they default to half an inch around all four sides instead of an eighth of an inch. Margins can be
used to represent the live area—it makes sense in some respects given the way Adobe built
InDesign’s margins feature—but there are some drawbacks to it as well.

InDesign allows you to put anything you want within, outside, or crossing the margins—so
does every other professional layout application and most consumer-grade layout tools as well.
Margin guides, in fact, matter very little in InDesign. The only place they really have an effect is in
automated text frame creation.
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When you check the Master Text Frame option while creating a new document, the resulting
master page text frame will be sized and placed according to the margin guides. When you're
autoflowing multipage placed text, new text frames will also be generated according to the area
defined by the margins. Other than that, their function is primarily as a visual guide to you. It’s the
automatic text frame sizing that also foils their use as live area guides. A live area should be, under
most conditions, 0.125 inches in from the trim edges all around. If you use automatic text frames,
though, that puts text flush with the live area guides. That’s not so much a problem for printing—
the live area guides define the minimum area that you can be sure will print and cut intact—but
more of a design issue. Copy running flush or too close to the edge looks bad. Readers need white
space along the edges of paper to grip the page or book as well as to give their eyes a place to rest.

So, what's the verdict? Margins as live area guides or not? If every page will be manually created
with individually placed frames, then you should be good to go using margin guides as live area
guides. If you're using any kind of automatic text frame creation (master text frame, autoflowing
text), then don’t use margins as live area guides. Instead, do this:

1. Select Ruler Guides from the Layout menu and change the color to something other than
the defaults: Cyan (guide color), Magenta (margin guides), Violet (column guides), Fiesta
(bleed guides), Grid Blue (slug guides), White, Light Gray, and Black (see Figure 7.11). Per-
sonally, I like green for my live area guides because it stands out against most colors with-
out being too similar to other types of guides.

FIGURE 7.11
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2. Go to the document master page(s) for the document and drag horizontal and vertical
guides from the rulers for each edge (four for nonfacing documents, eight guides for both
pages in the spread of a facing-pages document). Notice how they’re now green.

3. Unlock guides by unchecking the View > Grids & Guides > Lock Guides toggle command.

4. Using the Control or Transform panel, position unlocked guides 0.125 inches in from the
page edges on all outside edges; with bound documents, you'll probably want more space
on the bind edges. Those guides will define your live area.

5. Deselect all guides with Cmd+Shift+A /Ctrl+Shift+A and return new guides to their default
color (Cyan) with Layout > Ruler Guides again.

With separate live area guides, you can now use the margin guides for their intended pur-
pose—limiting content and enabling white space. As you design, keep all important elements
inside the green guides, extend all bleeding objects out to the bleed guide, and you'll be safe from
misaligned cuts.

Still, it seems like a lot of work to set up bleed, slug, and especially live area guides for every
new document, doesn’t it? Wouldn't it be cool if there were an easier way? There is.

Reusable Document Setups

This section is about efficiency. As I've said before, if you’ll do something more than once, do it
only once and automate it. InDesign has numerous automation-enabling facilities for many com-
mon tasks, including reusable page setups.
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DOCUMENT PRESETS

At the top of the New Document dialog (File > New > Document) is the Document Preset drop-
down menu (see Figure 7.12). By default, it contains only [Default] and [Custom]. The latter is
intended just to be a visual cue for you the InDesign user. Change anything below and the preset
becomes [Custom]; you do not need to preselect [Custom] in order to make any changes below it.
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If you more often than not have to change something from its default in the New Document
dialog,—maybe your typical document is tabloid sized, includes a standard-sized bleed, has
multiple columns, or needs something other than a half inch all around margin—set it up just
once and build a preset. Every subsequent document you create will then not require all the
manual settings; you'll be able to select it from the Document Preset menu and have all your
options applied. Just set the options once, click the Save Preset button, and give the preset a name
in the Save Preset dialog that pops up. Upon clicking OK, you'll find your customer preset below
[Default] in the list, ready for two-click setup of your next document. Build presets for all the
different types of documents you create at least once in a while.

PAGE S1ZE PRESETS
Hey! Is there a way to customize the Paper Size menu? Another common question, and the answer
is yes.

The Page Size list contains the most common paper sizes customers told Adobe they use. If they
aren’t inclusive of your most common page sizes, tell Adobe; maybe a future edition of InDesign
will include your typical page sizes. Until then, you can manually override them by changing the
width, height, and/or orientation below the drop-down menu, or you can add your own common
sizes to the Page Sizes list. Here’s how:

1. Quit out of InDesign.
2. Open this file in your text editor:

Windows: Program Files\Adobe\Adobe InDesign CS3\Presets\New Doc Sizes.txt
Mac 0S: Applications/Adobe InDesign CS3/Presets/New Doc Sizes.txt
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3. At the bottom of the file, insert each of your desired page size presets in the following format:
Name[tab]Width[tab]Height. Here’s an example:

Business Card 3.5" 2"

4. Save and close New Doc Sizes.txt. When you open InDesign next, your new options will be
in the Page Sizes list.

There are other examples in the New Doc Sizes. txt file right above the copyright notice. Remove
the semicolons and leading spaces to uncomment the examples and make them selectable page
sizes for new documents. The rest of the file contains additional instructions and information you
may find useful.

If your custom addition didn’t work, check that you inserted straight inch marks (") instead of
curly quote marks (7). If you're having trouble getting the inch marks (even some text editors do
automatic correction now) use i or in in their stead.

DOCUMENT TEMPLATES

Neither document presets nor page size presets can save your manually created live area guides, but
a template can. In fact, a template can save everything to do with a particular document—paragraph,
character, table, cell, and object styles as well as swatches, dictionary spelling and hyphenation excep-
tions, columns, and master pages, among other things. I always recommend templates for workflows
that frequently employ the same or similar document layouts and styles. Cumulatively, templates
can save a massive amount of time over setting up documents manually, and they can be passed
around the office or posted on a shared server for simultaneous use by everyone. Templates, in fact,
are the key to consistent style usage among workgroups (more on that in Chapter 11, “Efficiency”).

If you've set up trim area guides or any other document feature likely to be reused on the same
page size in the future, save it as a template. Just go to File > Save As, and change the Save As
Type drop-down to InDesign CS3 Template. The resulting file will have an .indt extension instead
of .indd and will have a slightly different icon. For all intents and purposes, it’s just a standard
InDesign document with the sole exception that the .indt extension triggers a slightly different
behavior when File > Open is used. Instead of opening the template itself, InDesign will create a
new, untitled document based on that template—a duplicate—and will not open the template
itself. In the new document you’ll have everything you had in the template—paragraph, character,
table, cell, and object styles as well as swatches, dictionary spelling and hyphenation exceptions,
columns, and master pages, among other things.

The trick is in the way the Open dialog works. Note the three Open As options at the bottom
(see Figure 7.13). Original opens the original file, whether an InDesign document, template, or
Interchange Format INX file. Copy generates on-the-fly an unsaved duplicate of the selected docu-
ment; the original is left untouched, but InDesign creates a new document faithful to the original
in every respect. Finally, Normal says to use whatever is default behavior for the specific docu-
ment type—INDD and INX documents open originals, INDTs create copies. Normal is the default,
which means that, when designers in your workgroup need to create new documents from your
template, they won't be editing the template itself. To do that, you must deliberately choose to
open the original. Note that when you're opening documents created in a previous version of
InDesign or created in a compatible version of PageMaker (6.0-7.0) or QuarkXPress (3.3-4.1 and
QuarkXPress Passport 4.1), a copy will be created regardless of the Open As choice.

A template-based workflow is the ideal for any periodical and is usually more efficient and
leads to fewer content-destroying mistakes than opening the previous issue’s files, resaving as the
next issue’s files, and then replacing content. I've seen few other workflows wherein at least one
document setup is reused that doesn’t also see a benefit from employing templates.
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If you choose the File > New > Document from Template command, it opens an Adobe Bridge
window focused on the Templates\InDesign folder created during InDesign or Creative Suite install.
Dozens of professionally designed, royalty-free templates are included with InDesign CS3, and
you can use them as is or, better, as learning aids. They’re all InDesign template INDT files, so
opening them by double-clicking in the Bridge view will have the same effect as opening a template
you created using the default Normal option—a new, untitled document based on the template.

Layout Adjustment

This isn’t strictly a master page thing, but layout adjustment is most often used in conjunction
with master pages, so it makes the most sense to bring it up here.

After initially creating the document, you can change its type—facing or nonfacing—as well as
the paper size and orientation with File > Document Setup. Using Layout > Margins and Columns,
you can also alter the margins, number of columns, and column gutter width. Finally, on master
pages, margin guides can be manually dragged to new positions (if unlocked). None of these
changes will adapt your page objects to the new conditions by default. If you want your text
frames to expand or contract to fit new margins, to automatically reduce or increase the number
of columns they contain according to changes you’ve made in Margins and Columns, or if you
want other objects to adjust to the new document layout without you having to do it all by hand,
turn to Layout Adjustment on the Layout menu (see Figure 7.14).
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Layout Adjustment does a decent job of reformatting page (and master page) objects to conform
to new document conditions such as new page sizes and orientations and margin and column
guide relocation. Frames will be moved and resized as needed to adapt to the new layout if Enable
Layout Adjustment is activated prior to making the layout change. Here is what the options mean:

Snap Zone The maximum distance an object must be from one or more margin or column
guides or the page edge to be a candidate for repositioning or resizing with Layout Adjustment.
For instance, with a value of 0.25 inches, a master text frame directly on four margins will be
adjusted but a graphic frame 0.5 inches from the nearest guide will not be adjusted.

Allow Graphics and Groups to Resize Vector objects, frames, and groups of objects will be
repositioned by Layout Adjustment regardless of whether they fall within the snap zone. This
option determines whether they may also be scaled to better fit. For instance, if converting an
8.5X11-inch document from portrait to landscape, should a full-page background graphic frame
follow suit to become 11X8.5 inches with its content scaled accordingly?

Allow Ruler Guides to Move Manually created ruler guides—column center points, for
example—can be moved to maintain their relative position to margin and column guides with
this option checked.

Ignore Ruler Guide Alignments Throughout working on a document, we often create
numerous ruler guides that are not significantly related to the layout. Because layout adjust-
ment considers all guides in its calculations, these nonessential guides can cause it confusion,
leading to improperly adjusted layouts. Checking this option tells InDesign to ignore them,
factoring in only page edges and column and margin guides when repositioning and scaling
objects.

Ignore Object and Layer Locks This option is an easier alternative to unlocking locked layers
and combing through a document looking for any objects whose positions have been selectively
locked. Enabling this will reposition and/or scale objects regardless of their individual or layer
lock statuses.

Multiple Page Sizes

Since long before computers, there has always been a need to create documents that include multi-
ple page sizes or orientations. With the rise of VDP and digital-to-press output making high-quality,
one-off productions an affordable option, multiple page sizes and orientations in documents have
become more common and more desirable. But the software has never caught up with the need—
even in the cutting edge of page production, InDesign CS3. QuarkXPress, since version 6.0, has
done multiple page sizes in one “project,” but it’s not truly the same thing. You see, QuarkXPress
merely allows multiple, disconnected layouts to be saved in the same file—it’s an MDF, a multiple
document format, similar to the way Excel allows multiple spreadsheets to be saved in a single
Excel document. QuarkXPress, even in the latest version as of this writing, still won’t allow two or
more differently sized pages in a single, continuous layout.

In close to a hundred InDesign training, consulting, and speaking engagements, I'm hard-pressed
to recall a single one in which I wasn’t asked if InDesign could do multiple page sizes in one docu-
ment. There’s a lot of need for that feature in our field. Gatefold covers and ads in magazines are
still produced separately from surrounding pages and then inserted at bindery time. Maps, charts,
and spreadsheets in proposals and technical books are still separate InDesign documents. Landscape
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content in a portrait-orientation book still forces designers to work sideways, either trying to read
at 90 degrees or rotating their work for every change or onscreen copy proof—and that often requires
grouping and ungrouping for many edits just to retain object relational positions. Frankly, it’s
ridiculous. That’s why I did something about it.

First, let’s look at the workaround we—design, prepress, press professionals—have come to
accept as the “only” way of creating multiple page sizes or orientations in a single document.

BOOK PANEL

InDesign only allows a single page orientation and size per document. If most of the document is
to be 8.5X11 inches portrait (tall), then it’s all going to be 8.5X11 inches portrait. The workaround to
this limitation has been “booking” multiple documents together to (somewhat) behave as one.
This isn’t just InDesign, by the way. Print pros have been using this same workaround for two
decades in QuarkXPress, PageMaker, and other layout applications.

We'll look at the functionality of InDesign Book documents and the Book panel in Chapter 9,
“Documents,” but in essence, an InDesign Book document (INDB) is a paperclip that links mul-
tiple, otherwise completely self-contained InDesign documents together. Via the Book panel,
page and section numbers, styles, indexes, and tables of contents can be synchronized among
all the booked files. They can also be preflighted, packaged, exported to PDF, and printed simul-
taneously as if they were a single document. That is very cool and powerful, as are the synchro-
nizing functions. The Book panel, though, was developed for the purpose of managing longer
documents. It enables, for instance, this book to be written in chapters. As I'm writing this chap-
ter, others are with my editors Sam and Karen, some are already with the compositor being
poured into the layout template, and still other chapters are on their way back to me for final
layout proof. When all the chapters are done, the fact that they’re booked will keep page numbers,
the TOC, and the index correct, ensuring that Chapter 2 begins numbering where Chapter 1
leaves off and so on.

Because the Book panel has all these features, it can be used to insert an oversized or rotated
page into the middle of a long document. For instance, if page 26 is a fold-out tabloid diagram
among 47 other 8.5X11-inch pages, the Book panel can insert the tabloid as page 26 and keep the
rest of the page numbers in synch. The catch is that they must all be separate documents. Pages 1
through 25 must be one 8.5X11-inch InDesign document, page 26 a single 11X17-inch page docu-
ment, and then pages 27 through 48 have to be a third document because they’re 8.5X11 inches. If
editorial says the tabloid diagram belongs two pages previous, you'll have to pull two pages out
of the first document and insert them in the third to make it work. Of course, that’s only the sim-
plest of scenarios. Many longer documents have several charts, diagrams, fold-outs, or other over-
sized pages. Everywhere that the page size differs requires a new InDesign document. Beginning
to see how this can get ugly? Add in the fact that each of those documents has its own localized
paragraph, character, object, table, and cell styles as well as hyphenation exceptions, swatches, ink
settings, master pages, and a whole lot more and every document exponentially increases the risk
of mistakes making it to press. All of these can be synchronized via the Book panel, but that must
be done deliberately and correctly. Someone forgets or doesn’t synch correctly, and.... Well, I'm
sure you can imagine—or maybe you don’t have to imagine.

If you need to deal with two or three different booked documents as a result of page size or
orientation differences only once in a while, use the Book panel method. If you need it more
often, or just don’t want to add another layer of complication to your workflow, there’s another
option.
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@ Real World Scenario

REDUCING 87 DOCUMENTS TO 6

Not long ago I was hired, in my capacity as workflow consultant, to redefine and optimize the proposal
book design workflow of a major commercial land developer, Omni Industrial Environs. Omni annually
produces three to six 500- to 700-page, hardcover book proposals for development projects averaging
$200 million in gross revenue. Each of the four-color proposals is for a different project, so the primary
page size varies per book, but they all include numerous oversized fold-out charts, diagrams, maps, sur-
veys, blueprints, and spreadsheets. On average, 1in every 10 pages was an oversized sheet.

When1arrived, Omni’s designers were creating upwards of 100 separate InDesign documents per book just
like the Book panel workaround method described in this chapter, but without using a Book file. The design
department—which consisted of four dedicated proposal designers, one part-time freelancer, and a pro-
duction manager—revisited each page of a given book an average of five times. Much of their time was
spent manually numbering and renumbering pages across all those documents, documents that grew and
shrank frequently as copy, financial data, and other information changed leading up to the proposal sub-
mission deadline. Adding a single page early in the book meant manually renumbering every other page
across all 100-odd documents. Needless to say, this was a very inefficient workflow, and despite best efforts,
page arrangement and numbering errors did slip through to press.

By creating a Book file to link all the different InDesign documents together, they all but eliminated page
numbering mistakes. In each separate InDesign document, regardless of its dimensions, the pages are
automatically renumbered in response to page re-ordering and the increase or decrease of page count in
any of the other documents in the book file. Exploiting the other advantages of the Book panel—style
usage consistency, soft-proofing via PDF, hard-proof printing, and readying the entire book for delivery
to press—transformed hours-long manual tasks to nothing more than a couple of clicks of the mouse.

1 wish I could tell you how many work hours were saved by introducing a Book file to the workflow, but
that isn’t possible. In addition to optimizing page handling, numerous other areas of the proposal produc-
tion workflow were optimized and streamlined, including using anchored objects to force illustrations
and figures to automatically follow their referencing text without manual repositioning, centralizing
font management with Extensis Suitcase Server, and replacing Microsoft Word with InCopy on editorial
and data analysis desktops, thus slashing the number of times a designer worked on the average page, fol-
lowing initial design, from five to less than one. Omni hadn’t broken down work hours into individual
tasks such as page handling or renumbering prior to the optimization, so there was nothing to use for a
comparison with post-workflow optimization times.

At the time 1 helped Omni, the best I could do to alleviate the complications of dealing with multiple page
sizes in one publication was to bring in the Book panel. In my mind, it wasn’t enough. Although the produc-
tion manager estimated that that step alone would save more than 100 work hours per publication, there was
still more time that could be saved and, more importantly, a lot less menial work in file management if
only InDesign could include multiple page sizes in the same document. For Omni, the problem was so large
in fact that, if QuarkXPress had offered the feature (it doesn’t), | would have recommended they convert back
to that application despite other advantages using InDesign and InCopy brought to the workflow.

Omni became the final straw for me. For years I’d been lobbying in vain for InDesign—and, before it,
QuarkXPress and PageMaker—to handle multiple page sizes in a single, continuous page document.
Because no one else was going to solve the problem, I decided to do it myself—with the help of the tal-
ented programmers at DTP Tools.
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Ayear after my initial visit, [ returned to Omni Industrial Environs with my Page Control plug-in in hand.
Putting it to use on their next proposal, the list of files on the horribly deep Book panel suddenly shrank
from 87 to 6.

Page Control allows InDesign to mix multiple page sizes and/or orientations in a single document. Omni no
longer had to create three separate InDesign documents just to accommodate a single oversized page (one
document for the pages leading up to the odd-sized page, the odd-sized page itself in a document alone,
and the third for standard-sized pages following it). All their fold-out charts, maps, spreadsheets, diagrams,
blueprints, and so on were able to be created in-line in the same document containing the pages leading up
to, and following, the fold-out. They still employed a Book file and the Book panel, but now they used it for
its intended purpose—to coordinate the six, chapter-like documents created and edited one each by the six
designers. Now each designer has one document to worry about—not 10, 20, or 30 as before.

PAGE CONTROL PLUG-IN

Until November 2006, the Book panel option was the only workaround to managing multiple page
sizes or orientations in a single document created in InDesign. Then DTP Tools and I released the
Page Control plug-in, which works in InDesign CS, CS2, and CS3. With it, you can resize any or all
pages—singly or in spreads—change from landscape to portrait, change the vertical alignment of
pages within a spread, resize master pages, set document pages to automatically resize according to
their assigned masters, and change the size of the pasteboard for more working room—and all of
this in one, single InDesign document that can be packaged, printed, exported to PDF, and so on
without risky or inconvenient workarounds (see Figure 7.15). And, it prints. Prior to releasing Page
Control, we held a public beta period in which we asked printers in the U.S., Australia, and Europe,
among other places and groups of professionals, to test it out thoroughly. Whether printed natively
from InDesign, printed from an InDesign-exported PDF, or printed first to PostScript, documents
containing a full range of different page sizes sailed through RIPs without complaint. As of this writ-
ing, Page Control has been available and selling to design and prepress professionals all over the
world for several months; I have yet to hear a complaint from anywhere within the for-print process.

FIGURE 7.15
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We even created a free Page Control Reader plug-in that enables anyone without the full Page
Control plug-in to view, edit, save, and output InDesign documents containing multiple page
sizes. (Hint, hint, you service bureaus and printers.)

If you create documents with different page sizes in a single document, or just want to enlarge
your pasteboard, there’s a 14-day try-out version of Page Control included on this book’s download
page in the Chapter 7 folder. The BIN file is for Mac installs and the MSI for Windows. Upon
installation, the Page Control commands will appear on the Pages panel’s flyout menu. The same
installers will also set up Page Control Reader.

Managing Pages

Once you have a document created and have begun laying out the design, you'll need to insert,
delete, duplicate, rearrange, and even import the occasional page. In addition to new page man-
agement features, InDesign CS3 has put some spit and polish on many of the familiar ones.

Pages Panel

The hub of page management activity is the Pages panel, which, in CS3, includes some much
needed updates (see Figure 7.16).
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The first thing you'll notice is that each page icon in the panel is now a thumbnail of the actual
content of the page—master pages, too. You'll spend a lot less time guessing on which page you
placed that picture last week. Because icons are no longer generic, the master page indicators (the
little As in the figure), no longer fill the icon; instead they move to the outer top corner on facing
pages and top center for nonfacing pages. The trade-off for the page thumbnails is that the master
page indicators got smaller and less obvious, although they still stand out when a page is selected
in the panel. Previously, if a page contained transparency, the entire icon would display the patented
checkerboard background instead of a white background. Now it’s a little rectangle beside the
page number. You should recognize the symbol from the Photoshop Layers panel. Also gone are
the down-turned corners denoting facing pages. Now, if the document pages are facing, they
have the spine representation between them. Single and spread master pages show no difference
in their icons other the single or double pages.



MANAGING PAGES

Customizing the Pages Panel

In its default view, the Pages panel shows masters at the top in small icons and documents in
medium icons at the bottom. Both grow vertically, which, especially in the lower section, leaves a
lot of wasted horizontal space. There’s a lot of customization possible, though, as you can see
from just a few possible configurations in Figure 7.17. You can change the size of pages and master
icons, show them horizontally or vertically, and change which is on the top. Those sentimental for
PageMaker can tear the panel away from the dock, align it across the bottom of the InDesign win-
dow, and set pages to show horizontally rather than vertically.
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All this customization is available in the Panel Options dialog (see Figure 7.18), which is the last
option on the Pages panel flyout menu. The last option, a drop-down menu titled Resize, defines
which section, if either, is fixed height. When one is chosen as fixed, resizing the panel alters the
other section. Setting both to Proportional will resize them equally. If you long for the good old
days when master page identifiers were easy to read and pages were just plain white (and, when
selected, blue) icons, or if rendering page thumbnails slows down your system, uncheck Show
Thumbnails for pages and/or masters.

FIGURE 7. 18 Panel Optons
Pages Panel Options v |
dialog Iron Sire: | Madium -

v Show Verlicaly

+ Show Thumbnals

Cancel

Masters
Teon Siee: | Sinall -
v Show Vertically
+ Show Thumbnals

Panel | ayout

Pagus un Tog
= Masters.on Top

Restze:  Masters Mxed

231



232 | CHAPTER7 PAGES

Inserting Pages

Here is a refresher on the familiar ways to add pages to a document:

¢ At the bottom of the Pages panel, the Create New Page button adds one page at a time to
the end of the document. New pages adopt the master assigned to the last page—for
instance, if page 5 of a five-page document is assigned to master page A (and includes
the A indicator), new pages will also be assigned to master page A.

Cmd+Shift+P/Ctrl+Shift+P has the same effect as the Create New Page button.

Layout > Pages > Add Page also adds one new page at the end of the document, assigning
the same master page as the last in the document.

¢ The Insert Pages command on both the Pages panel flyout menu and the Layout > Pages
menu offers insertion of multiple pages at once at a specific location in the document (e.g.,
before or after page X) and choice of the master page to which to assign inserted pages (see

Figure 7.19).
FIGURE 7.19
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Although not new, this method demands more explanation than a quick bullet point. Dragging
either the name or icon(s) of a master page down into the Pages panel has two possible effects.
Dropping it on top of an existing page w